14:29:58 <bizhang> #startmeeting Pulp Triage 2017-03-24
14:29:58 <pulpbot> Meeting started Fri Mar 24 14:29:58 2017 UTC and is due to finish in 60 minutes.  The chair is bizhang. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:29:58 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:29:58 <pulpbot> The meeting name has been set to 'pulp_triage_2017_03_24'
14:29:58 <bizhang> #info bizhang has joined triage
14:29:58 <pulpbot> bizhang has joined triage
14:30:02 <smyers> !here
14:30:02 <smyers> #info smyers has joined triage
14:30:02 <pulpbot> smyers has joined triage
14:30:08 <ipanova> !here
14:30:08 <ipanova> #info ipanova has joined triage
14:30:08 <pulpbot> ipanova has joined triage
14:30:13 <ttereshc> !here
14:30:13 <ttereshc> #info ttereshc has joined triage
14:30:14 <pulpbot> ttereshc has joined triage
14:30:20 <mhrivnak> !here
14:30:20 <mhrivnak> #info mhrivnak has joined triage
14:30:20 <pulpbot> mhrivnak has joined triage
14:30:24 <bizhang> !next
14:30:25 <bizhang> #topic Broker reconnect support broken - http://pulp.plan.io/issues/2613
14:30:26 <pulpbot> 6 issues left to triage: 2613, 2642, 2654, 2655, 2657, 2659
14:30:27 <pulpbot> Pulp Issue #2613 [ASSIGNED] (dalley) - Priority: Normal | Severity: Medium
14:30:28 <pulpbot> Broker reconnect support broken - http://pulp.plan.io/issues/2613
14:30:41 <bmbouter> !here
14:30:41 <bmbouter> #info bmbouter has joined triage
14:30:42 <pulpbot> bmbouter has joined triage
14:31:16 <smyers> ASSIGNED and already on the sprint
14:31:31 <bizhang> I think it was untriaged to discuss if it should be a 2.13 blocker
14:31:32 <dalley_> !here
14:31:32 <dalley_> #info dalley_ has joined triage
14:31:32 <pulpbot> dalley_ has joined triage
14:31:40 <dalley_> correct bizhang
14:32:38 <bizhang> !propose other triage high/normal keep 2.13 blocker status
14:32:38 <bizhang> #idea Proposed for #2613: triage high/normal keep 2.13 blocker status
14:32:39 <smyers> I have no reason to change ichimonji10's decision in #9
14:32:39 <pulpbot> Proposed for #2613: triage high/normal keep 2.13 blocker status
14:32:43 <smyers> =1
14:32:46 <smyers> also +1
14:32:46 <dalley_> +1
14:32:49 <mhrivnak> Is there anything specific to discuss?
14:32:50 <ipanova> thomasmckay: not for now
14:32:53 <mhrivnak> I'm not sure what changed.
14:33:20 <bizhang> !accept
14:33:20 <bizhang> #agreed triage high/normal keep 2.13 blocker status
14:33:20 <pulpbot> Current proposal accepted: triage high/normal keep 2.13 blocker status
14:33:21 <bizhang> #topic --auth-ca parameter on repo creation not working - http://pulp.plan.io/issues/2642
14:33:22 <pulpbot> 5 issues left to triage: 2642, 2654, 2655, 2657, 2659
14:33:23 <pulpbot> RPM Support Issue #2642 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:33:24 <pulpbot> --auth-ca parameter on repo creation not working - http://pulp.plan.io/issues/2642
14:33:29 <dalley_> mhrivnak, when the issue was first discussed it was completely different than it is now
14:33:39 <dalley_> it was thought to be an issue only w/ Celery 4
14:34:10 <dalley_> the actual issue is that some new celery functionality we're using in 2.13 has a defect to where broker reconnect support is broken with both Celery 3 & 4
14:34:31 <dalley_> it was untriaged also because I rewrote the issue with that new info
14:34:42 <mhrivnak> Gotcha, ok.
14:35:13 <smyers> #2642 looks rough, can anyone tell for sure if it's broken, or just a super confusing workflow that's easy to mess up (and got messed up)?
14:35:35 <mhrivnak> bizhang has looked at this one a lot.
14:35:44 <mhrivnak> Looks like it might be a legit bug.
14:35:55 <smyers> Yeah, that's the sense I'm getting
14:36:38 <bizhang> Yeah I think it's our pulp_content.conf's sslverifyclient not checking the client cert
14:37:02 <bizhang> setting it to optional_no_ca fixes the issues
14:37:03 <mhrivnak> !propose accept
14:37:03 <mhrivnak> #idea Proposed for #2642: Leave the issue as-is, accepting its current state.
14:37:03 <pulpbot> Proposed for #2642: Leave the issue as-is, accepting its current state.
14:37:43 <bizhang> but I'm not sure if that's the correct resolution, anyways +1 accept
14:38:23 <bizhang> !accept
14:38:23 <bizhang> #agreed Leave the issue as-is, accepting its current state.
14:38:23 <pulpbot> Current proposal accepted: Leave the issue as-is, accepting its current state.
14:38:24 <pulpbot> 4 issues left to triage: 2654, 2655, 2657, 2659
14:38:25 <smyers> I don't think they're mutually exclusive, maybe get on the mailing list to ofer that as a workaround, but still fix the bug :)
14:38:25 <bizhang> #topic Pulp3 isn't logging the first 8 characters of a task id in every log statement emitted from a running task - http://pulp.plan.io/issues/2654
14:38:26 <pulpbot> Pulp Issue #2654 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:38:27 <pulpbot> Pulp3 isn't logging the first 8 characters of a task id in every log statement emitted from a running task - http://pulp.plan.io/issues/2654
14:38:35 <smyers> heh
14:38:42 <bizhang> smyers, that sounds like a good plan :)
14:39:04 <bizhang> This one is a fix made in pulp2 that was not merged forward to pulp3
14:39:07 <bizhang> !propose accept
14:39:07 <bizhang> #idea Proposed for #2654: Leave the issue as-is, accepting its current state.
14:39:08 <pulpbot> Proposed for #2654: Leave the issue as-is, accepting its current state.
14:39:10 <smyers> That's not a bug, imo
14:39:14 <mhrivnak> agreed.
14:39:38 <smyers> Convert to story, "pulp 2 does this, pulp 3 should too, merging forward didn't work so we have to do it the hard way"
14:39:45 <mhrivnak> I'm glad we have something in redmine to track it, but I wouldn't call it a bug.
14:39:52 <ipanova> agree
14:39:56 <bizhang> !propose other convert to story
14:39:56 <bizhang> #idea Proposed for #2654: convert to story
14:39:57 <pulpbot> Proposed for #2654: convert to story
14:40:05 <mhrivnak> +1
14:40:06 <ttereshc> +1
14:40:09 <bizhang> !accept
14:40:09 <bizhang> #agreed convert to story
14:40:09 <pulpbot> Current proposal accepted: convert to story
14:40:11 <bizhang> #topic units_successful is empty for successful ISO assocaiting task - http://pulp.plan.io/issues/2655
14:40:11 <pulpbot> 3 issues left to triage: 2655, 2657, 2659
14:40:12 <pulpbot> RPM Support Issue #2655 [ASSIGNED] (ipanova@redhat.com) - Priority: Normal | Severity: High
14:40:13 <pulpbot> units_successful is empty for successful ISO assocaiting task - http://pulp.plan.io/issues/2655
14:40:34 <ipanova> while i was looking into it i found the issue and the fix
14:40:54 <ipanova> mind triaging it and adding to the sprint?
14:41:01 <mhrivnak> +1
14:41:17 <smyers> I question the high severity...
14:41:29 <smyers> !propose other normal/medium add to sprint 17
14:41:29 <smyers> #idea Proposed for #2655: normal/medium add to sprint 17
14:41:29 <pulpbot> Proposed for #2655: normal/medium add to sprint 17
14:41:49 <bizhang> +1
14:41:56 <mhrivnak> This is a blocker to upgrade for a key user, because they depend on that field being populated.
14:42:13 <mhrivnak> So I suppose they consider it "severe" since it blocks them.
14:42:29 <mhrivnak> But otherwise I agree that medium seems appropriate.
14:42:37 <ipanova> +1
14:42:50 <ipanova> the fix is 1 line, let's move ^_^
14:42:54 <bizhang> !accept
14:42:54 <bizhang> #agreed normal/medium add to sprint 17
14:42:54 <pulpbot> Current proposal accepted: normal/medium add to sprint 17
14:42:56 <bizhang> #topic Publishing iso_rsync_distributor fails when iso_distributor is published with serve_https==False - http://pulp.plan.io/issues/2657
14:42:56 <pulpbot> 2 issues left to triage: 2657, 2659
14:42:57 <pulpbot> RPM Support Issue #2657 [ASSIGNED] (ipanova@redhat.com) - Priority: Normal | Severity: Medium
14:42:58 <pulpbot> Publishing iso_rsync_distributor fails when iso_distributor is published with serve_https==False - http://pulp.plan.io/issues/2657
14:43:04 <mhrivnak> ipanova++
14:43:04 <pulpbot> ipanova's karma is now 34
14:43:05 <ipanova> same here
14:43:22 <smyers> prio and sev are used by QE, for example, after the bug is fixed. They still matter even after we fix the bug.
14:43:57 <bizhang> !propose other accept and add to sprint
14:43:57 <bizhang> #idea Proposed for #2657: accept and add to sprint
14:43:57 <pulpbot> Proposed for #2657: accept and add to sprint
14:44:26 <mhrivnak> +1
14:44:31 <ipanova> +1
14:44:38 <bizhang> !accept
14:44:38 <bizhang> #agreed accept and add to sprint
14:44:38 <pulpbot> Current proposal accepted: accept and add to sprint
14:44:39 <smyers> +1
14:44:41 <pulpbot> 1 issues left to triage: 2659
14:44:41 <bizhang> #topic Stale worker documents present in the db for Pulp3 - http://pulp.plan.io/issues/2659
14:44:42 <pulpbot> Pulp Issue #2659 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:44:43 <pulpbot> Stale worker documents present in the db for Pulp3 - http://pulp.plan.io/issues/2659
14:44:48 <bizhang> !propose other convert to story
14:44:48 <bizhang> #idea Proposed for #2659: convert to story
14:44:49 <pulpbot> Proposed for #2659: convert to story
14:44:54 <mhrivnak> +1
14:44:58 <bizhang> this is another pulp2->3 merge issue
14:45:08 <bizhang> !accept
14:45:08 <bizhang> #agreed convert to story
14:45:08 <pulpbot> Current proposal accepted: convert to story
14:45:10 <pulpbot> No issues to triage.
14:45:15 <bizhang> !end
14:45:15 <bizhang> #endmeeting