14:30:19 <ttereshc> #startmeeting Pulp Triage 2017-03-28
14:30:19 <ttereshc> #info ttereshc has joined triage
14:30:19 <pulpbot> Meeting started Tue Mar 28 14:30:19 2017 UTC and is due to finish in 60 minutes.  The chair is ttereshc. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:30:19 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:30:19 <pulpbot> The meeting name has been set to 'pulp_triage_2017_03_28'
14:30:19 <pulpbot> ttereshc has joined triage
14:30:29 <bmbouter> smyers: maybe a specific proposal of where to store the file
14:30:30 <ipanova> !here
14:30:30 <ipanova> #info ipanova has joined triage
14:30:30 <pulpbot> ipanova has joined triage
14:30:33 <bmbouter> and format
14:30:35 <bmbouter> !here
14:30:35 <bmbouter> #info bmbouter has joined triage
14:30:36 <pulpbot> bmbouter has joined triage
14:30:37 <bmbouter> ok triage
14:30:37 <bizhang> !here
14:30:37 <bizhang> #info bizhang has joined triage
14:30:37 <pulpbot> bizhang has joined triage
14:30:39 <mhrivnak> !here
14:30:39 <mhrivnak> #info mhrivnak has joined triage
14:30:40 <pulpbot> mhrivnak has joined triage
14:30:43 <ttereshc> !next
14:30:45 <daviddavis> !here
14:30:45 <pulpbot> 7 issues left to triage: 2664, 2665, 2666, 2667, 2669, 2670, 2671
14:30:45 <ttereshc> #topic Workers Canceling Tasks on Startup Fail if the Broker is Down - http://pulp.plan.io/issues/2664
14:30:45 <daviddavis> #info daviddavis has joined triage
14:30:46 <pulpbot> Pulp Issue #2664 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:30:47 <pulpbot> Workers Canceling Tasks on Startup Fail if the Broker is Down - http://pulp.plan.io/issues/2664
14:30:48 <pulpbot> daviddavis has joined triage
14:30:49 <dalley> !here
14:30:49 <dalley> #info dalley has joined triage
14:30:49 <pulpbot> dalley has joined triage
14:31:10 <ichimonji10> elyezer: Yes, I will
14:31:18 <ichimonji10> I'm just putting out a (figurative) fire right now
14:31:35 <bmbouter> I plan to propose this for the next sprint but not this one
14:31:39 <dalley> bmbouter: I will note that it is the exact same traceback (it seems) as I get with the broker reconnect issue
14:31:40 <mhrivnak> Is this a reasonable workaround? 1) start the broker 2) try starting the workers again
14:31:41 <bmbouter> I'll reraise it at sprint planning
14:31:50 <bmbouter> interesting
14:32:05 <dalley> the 2nd half is the same, at least
14:32:07 <bmbouter> yes that is the workaround
14:32:25 <ttereshc> !propose accept
14:32:25 <ttereshc> #idea Proposed for #2664: Leave the issue as-is, accepting its current state.
14:32:26 <pulpbot> Proposed for #2664: Leave the issue as-is, accepting its current state.
14:32:27 <dalley> once it gets inside Kombu / Qpid
14:32:28 <elyezer> ichimonji10: no need to rush, look it when you are "relaxing" :)
14:32:30 <mhrivnak> +1 accept
14:32:49 <smyers> +1
14:33:08 <ttereshc> !accept
14:33:08 <ttereshc> #agreed Leave the issue as-is, accepting its current state.
14:33:08 <pulpbot> Current proposal accepted: Leave the issue as-is, accepting its current state.
14:33:10 <ttereshc> #topic API documentation doesn't explain how to manage tags - http://pulp.plan.io/issues/2665
14:33:10 <pulpbot> 6 issues left to triage: 2665, 2666, 2667, 2669, 2670, 2671
14:33:11 <pulpbot> Docker Support Issue #2665 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:33:12 <pulpbot> API documentation doesn't explain how to manage tags - http://pulp.plan.io/issues/2665
14:34:18 <ttereshc> add to current sprint?
14:34:34 <daviddavis> +1
14:34:44 <ipanova> +1
14:34:46 <ttereshc> qe is somewhat blocked on that, right?
14:34:49 <mhrivnak> I'm hesitant to add anything, but this is blocking QE testing, so I'm good with that.
14:35:06 <jortel> !here
14:35:06 <jortel> #info jortel has joined triage
14:35:07 <pulpbot> jortel has joined triage
14:35:08 <bmbouter> is it blocking QE?
14:35:09 <ttereshc> !propose other normal/medium add to sprint
14:35:09 <ttereshc> #idea Proposed for #2665: normal/medium add to sprint
14:35:09 <pulpbot> Proposed for #2665: normal/medium add to sprint
14:35:13 <smyers> I doesn't seem to be blocking, just super annoying
14:35:17 <smyers> I'm -1 for adding to sprint
14:35:19 <preethi> ttereshc: yes that is blocking docker tests passiing
14:35:49 <mhrivnak> Is this not blocking QE?
14:35:55 <preethi> it is
14:36:03 <smyers> There's this little guy, though: "It's also hard to fix the tests that have broken in 2.13 (due to an backwards-incompatible change - is that OK?)" < Nope
14:36:10 <smyers> Is there a bug for that change coming up? :)
14:36:39 <smyers> Pardon the digression, though
14:36:49 <ttereshc> we can decide later if we want to add it to sprint or not
14:36:53 <ttereshc> !propose accept
14:36:54 <ttereshc> #idea Proposed for #2665: Leave the issue as-is, accepting its current state.
14:36:55 <pulpbot> Proposed for #2665: Leave the issue as-is, accepting its current state.
14:37:12 <mhrivnak> I think we want QE testing before we do a beta if we can get it.
14:37:26 <mhrivnak> And that's currently scheduled about 2 weeks from now, at the beginning of the next sprint.
14:37:47 <bmbouter> preethi says yes its blocking but it still seems unclear with what smyers says
14:37:49 <mhrivnak> So I think our options are: produce docs ASAP so they can test it, or wait and accept that it won't get tested.
14:37:56 <bmbouter> agreed
14:38:20 <mhrivnak> I think we should get the docs done ASAP, since we really should have done them with the original work anyway.
14:38:36 <smyers> But the workaround in issue seems to be "steal what pulp-admin -vv shows and do that in a testing client"
14:38:50 <ipanova> mhrivnak: i don't this it blocks qe
14:38:56 <ipanova> they can proceed to test
14:38:57 <smyers> Crappy? Yep. Urgent to fix? Eeehhhhh
14:39:13 <bmbouter> ichimonji10, elyezer: ^?
14:39:19 <ipanova> this rfe was written for cli usage abd it was tested against cli usage
14:39:28 <ipanova> daviddavis: can tell more about this ^
14:39:47 <mhrivnak> We could work around the problem by spending time explaining it through other means to QE.
14:39:48 <ipanova> i understand that cli is based on api, but at this point testing is not blocked
14:39:49 <ipanova> imho
14:40:29 <daviddavis> it would be nice to address the point about passing the tag name twice before the release
14:40:39 <ttereshc> !propose other normal/medium add to sprint
14:40:39 <ttereshc> #idea Proposed for #2665: normal/medium add to sprint
14:40:39 <ipanova> so i kinda agree with smyers
14:40:39 <pulpbot> Proposed for #2665: normal/medium add to sprint
14:40:45 <daviddavis> I don't know if it's possible to only pass the tag name once but it's worth investigating
14:40:57 <ttereshc> let's add to sprint and see if we have time to address it
14:41:13 <bmbouter> the challenge is that pulp3 is the priority
14:41:13 <daviddavis> +1
14:41:31 <ichimonji10> I can write tests for this issue if some dev(s) can sit down with me and answer some questions as I write tests.
14:41:44 <ichimonji10> About the backwards-incompatible change: basically, files are now served at different locations.
14:42:03 <ichimonji10> So any code that tries to fetch e.g. manifests will break.
14:42:11 <mhrivnak> ichimonji10, I'm not sure that's actually backwards-incompatible, but we can talk about it.
14:42:20 <ichimonji10> Well, there's no _href paths.
14:42:32 <ichimonji10> So there's no way for code that currently works with the docker plugin to still work.
14:42:35 <mhrivnak> better to discuss that aspect post-triage.
14:42:38 <ichimonji10> Sure.
14:42:45 <ttereshc> everyone agree on normal/medium?
14:43:06 <bizhang> +1
14:43:07 <mhrivnak> If we don't either 1) document it, or 2) explain it in-person, QE won't be able to test this as far as I'm understanding. Is that right?
14:43:11 <ipanova> agree on normal/medium
14:43:58 <ttereshc> !propose other normal/medium explain to qe or add to sprint
14:43:58 <ttereshc> #idea Proposed for #2665: normal/medium explain to qe or add to sprint
14:43:58 <pulpbot> Proposed for #2665: normal/medium explain to qe or add to sprint
14:44:12 <ttereshc> !accept
14:44:12 <ttereshc> #agreed normal/medium explain to qe or add to sprint
14:44:12 <pulpbot> Current proposal accepted: normal/medium explain to qe or add to sprint
14:44:14 <pulpbot> 5 issues left to triage: 2666, 2667, 2669, 2670, 2671
14:44:14 <ttereshc> #topic Rsync publish for RPM repo fails to run in fast forward mode - http://pulp.plan.io/issues/2666
14:44:15 <pulpbot> RPM Support Issue #2666 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:44:16 <pulpbot> Rsync publish for RPM repo fails to run in fast forward mode - http://pulp.plan.io/issues/2666
14:45:14 <ichimonji10> mhrivnak: You're right.
14:45:24 <ichimonji10> And I'm happy with either solution.
14:45:31 <mhrivnak> ichimonji10, thanks.
14:45:46 <ichimonji10> Thank *you*.
14:45:57 <bmbouter> we should accept 2666 as is and add to sprint
14:46:09 <ipanova> agree
14:46:11 <bmbouter> we need 2666 on sprint so that RCM can consumer Pulp
14:46:16 <bmbouter> s/consumer/consume/
14:46:33 <ttereshc> !propose other normal/medium add to sprint
14:46:33 <ttereshc> #idea Proposed for #2666: normal/medium add to sprint
14:46:34 <pulpbot> Proposed for #2666: normal/medium add to sprint
14:47:12 <mhrivnak> I'm not understanding the bug.
14:47:31 <ttereshc> publish is full instead of being incremental
14:47:34 <ttereshc> I think
14:48:15 <dkliban> yeah
14:48:18 <mhrivnak> Ah. So it just takes longer than it should?
14:48:21 <dkliban> yes
14:48:37 <ttereshc> and RCM marked it as blocker for them
14:48:54 <dkliban> i think we should add it to the sprint
14:48:58 <dkliban> or at least next sprint
14:49:09 <mhrivnak> If it landed in 2.13.1 instead of 2.13.0, would that still be acceptable?
14:49:16 <dkliban> mhrivnak: yes
14:49:21 <dkliban> i just want us to fix it soon
14:49:26 <mhrivnak> Given that, I'd wait for next sprint.
14:49:33 <mhrivnak> and prioritize it there.
14:49:33 <dkliban> bmbouter: do you care?
14:49:39 <ttereshc> it's probably an easy fix...
14:49:54 <bmbouter> I +1 to adding to the current sprint but that's just me
14:50:07 <bmbouter> I +0 adding to next sprint
14:50:17 <ipanova> bmbouter:  haha
14:50:38 <ipanova> i love this +0 and -0
14:50:41 <bmbouter> I just think of RCM tasks as preempting pulp3 work
14:50:56 <ipanova> +1 for current sprint
14:51:02 <bmbouter> mhrivnak I defer to your decision
14:51:22 <ipanova> i guess we need already to finish this long task to enable rcm to upgrade to vanilla pulp, it's been too long
14:51:27 <mhrivnak> I think there's nothing exceptional or urgent about this circumstance, so we should wait.
14:51:36 <ttereshc> !propose other normal/medium add to next sprint
14:51:36 <ttereshc> #idea Proposed for #2666: normal/medium add to next sprint
14:51:36 <pulpbot> Proposed for #2666: normal/medium add to next sprint
14:51:40 <smyers> I agree with waiting
14:51:59 <ttereshc> !accept
14:51:59 <ttereshc> #agreed normal/medium add to next sprint
14:51:59 <pulpbot> Current proposal accepted: normal/medium add to next sprint
14:52:00 <pulpbot> 4 issues left to triage: 2667, 2669, 2670, 2671
14:52:01 <ttereshc> #topic Pulp 2.13 RHEL6 Builds Fail on Koji with Error - http://pulp.plan.io/issues/2667
14:52:01 <pulpbot> Pulp Issue #2667 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:52:02 <pulpbot> Pulp 2.13 RHEL6 Builds Fail on Koji with Error - http://pulp.plan.io/issues/2667
14:53:09 <smyers> Yeah. I have no idea what to do with this one. Easy fix is stop building el6 in nightlies. Unknown difficulty of fix is get them working again.
14:53:50 <bmbouter> upstream doesn't need them so +1 to stopping building
14:54:34 <mhrivnak> Can we stop building just 2.13+ specifically?
14:54:44 <smyers> I can open a task specifically for that that refs this issue and put a PR up today.
14:54:57 <smyers> mhrivnak, stop building nightlies for master?
14:55:15 <mhrivnak> for el6
14:55:17 <mhrivnak> yes
14:55:29 <smyers> Still confused
14:55:42 <smyers> Stop building *all* master nightlies, or just el6 nightlies?
14:55:43 <mhrivnak> Can we continue doing nightlies for 2.12 on el6, but not 2.13 on el6?
14:55:59 <smyers> Maybe!
14:56:18 <ttereshc> maybe skip this issue for now and decide later what we want to do with nightlies?
14:56:31 <dkliban> +1 to ttereshc
14:56:40 <mhrivnak> Seems reasonable.
14:56:44 <ttereshc> !skip
14:56:46 <ttereshc> #topic Scheduled calls support needs to be patched in F26 and rawhide - http://pulp.plan.io/issues/2669
14:56:46 <pulpbot> 3 issues left to triage: 2669, 2670, 2671
14:56:47 <pulpbot> External Issue #2669 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:56:48 <pulpbot> Scheduled calls support needs to be patched in F26 and rawhide - http://pulp.plan.io/issues/2669
14:57:00 <bizhang> Should this be a task instead?
14:57:12 <mhrivnak> yes.
14:57:19 <ttereshc> +1 to task
14:57:28 <ttereshc> !propose other convert to task
14:57:28 <ttereshc> #idea Proposed for #2669: convert to task
14:57:29 <pulpbot> Proposed for #2669: convert to task
14:57:46 <ttereshc> next sprint? not the current one?
14:58:11 <bmbouter> not the current
14:58:20 <ttereshc> good :)
14:58:22 <mhrivnak> Sounds good.
14:58:24 <ttereshc> !accept
14:58:24 <ttereshc> #agreed convert to task
14:58:24 <pulpbot> Current proposal accepted: convert to task
14:58:26 <ttereshc> #topic Broker Reconnect Support needs to be patched in F26 and Rawhide  - http://pulp.plan.io/issues/2670
14:58:26 <pulpbot> 2 issues left to triage: 2670, 2671
14:58:27 <pulpbot> External Issue #2670 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:58:28 <pulpbot> Broker Reconnect Support needs to be patched in F26 and Rawhide  - http://pulp.plan.io/issues/2670
14:58:28 <mhrivnak> same for remaining 2 issues?
14:58:40 <bmbouter> same for this one
14:58:52 <bmbouter> and the last one too I would say
14:58:58 <ttereshc> !propose other convert to task
14:58:58 <ttereshc> #idea Proposed for #2670: convert to task
14:58:59 <pulpbot> Proposed for #2670: convert to task
14:59:06 <ttereshc> !accept
14:59:06 <ttereshc> #agreed convert to task
14:59:06 <pulpbot> Current proposal accepted: convert to task
14:59:07 <pulpbot> No issues to triage.
14:59:15 <bizhang> I preempted the last one :)
14:59:22 <ttereshc> aha!
14:59:24 <ttereshc> :)
14:59:24 <smyers> heh
14:59:27 <smyers> sneaky!
14:59:29 <ttereshc> !end
14:59:29 <ttereshc> #endmeeting