14:30:03 <ttereshc> #startmeeting Pulp Triage 2017-03-31
14:30:03 <ttereshc> #info ttereshc has joined triage
14:30:04 <pulpbot> Meeting started Fri Mar 31 14:30:03 2017 UTC and is due to finish in 60 minutes.  The chair is ttereshc. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:30:04 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:30:04 <pulpbot> The meeting name has been set to 'pulp_triage_2017_03_31'
14:30:04 <pulpbot> ttereshc has joined triage
14:30:18 <bizhang> !here
14:30:18 <bizhang> #info bizhang has joined triage
14:30:19 <pulpbot> bizhang has joined triage
14:30:21 <fdobrovo> !here
14:30:21 <fdobrovo> #info fdobrovo has joined triage
14:30:22 <pulpbot> fdobrovo has joined triage
14:30:52 <ipanova> !here
14:30:52 <ipanova> #info ipanova has joined triage
14:30:52 <pulpbot> ipanova has joined triage
14:31:01 <mhrivnak> !here
14:31:01 <mhrivnak> #info mhrivnak has joined triage
14:31:01 <pulpbot> mhrivnak has joined triage
14:31:02 <ttereshc> !next
14:31:04 <ttereshc> #topic Pulp 2.13 RHEL6 Builds Fail on Koji with Error - http://pulp.plan.io/issues/2667
14:31:04 <pulpbot> 6 issues left to triage: 2667, 2677, 2678, 2681, 2684, 2687
14:31:05 <pulpbot> Pulp Issue #2667 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:31:06 <pulpbot> Pulp 2.13 RHEL6 Builds Fail on Koji with Error - http://pulp.plan.io/issues/2667
14:31:26 <ttereshc> we skipped this last time and afaik had no discussion
14:31:50 <ttereshc> skip again and add to agenda for qe meeting or team meeting?
14:32:09 <mhrivnak> smyers ?
14:33:14 <ttereshc> we can back to this one at the end of triage
14:33:19 <ttereshc> mhrivnak, ^
14:33:20 <mhrivnak> Sounds good.
14:33:23 <ttereshc> !defer
14:33:24 <pulpbot> 5 issues left to triage: 2677, 2678, 2681, 2684, 2687
14:33:24 <ttereshc> #topic Occasional HTTP 403 errors when downloading rpms from on_demand / lazy sync repositories - http://pulp.plan.io/issues/2677
14:33:25 <pulpbot> Pulp Issue #2677 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:33:26 <pulpbot> Occasional HTTP 403 errors when downloading rpms from on_demand / lazy sync repositories - http://pulp.plan.io/issues/2677
14:34:27 <mhrivnak> This is a big one. The fix is fairly involved, and we need to vet the design with the team.
14:35:01 <mhrivnak> but is also very high priority because it's impacting current users.
14:35:09 <ttereshc> oh yeah
14:35:30 <ttereshc> !propose triage h h
14:35:30 <ttereshc> #idea Proposed for #2677: Priority: High, Severity: High
14:35:30 <pulpbot> Proposed for #2677: Priority: High, Severity: High
14:35:42 <mhrivnak> oh, that's a nice shortcut.
14:36:09 <mhrivnak> I'm good with that, and then we can get more eyes on the proposed fix before pulling it onto the sprint, hopefully early next week.
14:36:16 <ipanova> +1
14:36:25 <ttereshc> !accept
14:36:25 <ttereshc> #agreed Priority: High, Severity: High
14:36:25 <pulpbot> Current proposal accepted: Priority: High, Severity: High
14:36:25 <fdobrovo> +1
14:36:26 <pulpbot> 4 issues left to triage: 2678, 2681, 2684, 2687
14:36:26 <ttereshc> #topic 'relative_repo_path' in docs should be 'repo_relative_path' - http://pulp.plan.io/issues/2678
14:36:27 <pulpbot> Docker Support Issue #2678 [NEW] (unassigned) - Priority: Normal | Severity: Low
14:36:28 <pulpbot> 'relative_repo_path' in docs should be 'repo_relative_path' - http://pulp.plan.io/issues/2678
14:36:46 <ipanova> that's a doc bug, let's accept it as it is
14:37:02 <mhrivnak> +1
14:37:08 <bizhang> +1
14:37:13 <ttereshc> !propose accept
14:37:13 <ttereshc> #idea Proposed for #2678: Leave the issue as-is, accepting its current state.
14:37:14 <pulpbot> Proposed for #2678: Leave the issue as-is, accepting its current state.
14:37:17 <smyers> ttereshc read the manual :)
14:37:18 <ttereshc> !accept
14:37:18 <ttereshc> #agreed Leave the issue as-is, accepting its current state.
14:37:19 <pulpbot> Current proposal accepted: Leave the issue as-is, accepting its current state.
14:37:19 <ttereshc> #topic Orphan cleanup does not handle errata package lists correctly  - http://pulp.plan.io/issues/2681
14:37:20 <pulpbot> 3 issues left to triage: 2681, 2684, 2687
14:37:21 <pulpbot> RPM Support Issue #2681 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:37:22 <pulpbot> Orphan cleanup does not handle errata package lists correctly  - http://pulp.plan.io/issues/2681
14:37:53 <ttereshc> maybe skip this one and get back to it after discussion?
14:38:10 <mhrivnak> works for me.
14:38:19 <ttereshc> !skip
14:38:20 <pulpbot> 2 issues left to triage: 2684, 2687
14:38:21 <ttereshc> #topic pulp-manage-db sometimes runs when it shouldn't - http://pulp.plan.io/issues/2684
14:38:21 <pulpbot> Pulp Issue #2684 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:38:22 <pulpbot> pulp-manage-db sometimes runs when it shouldn't - http://pulp.plan.io/issues/2684
14:38:32 <bizhang> I suspect this one is being caused by https://pulp.plan.io/issues/2613
14:38:34 <pulpbot> Title: Issue #2613: Worker Heartbeats Broken After Broker Reconnect - Pulp (at pulp.plan.io)
14:38:50 <bizhang> I can validate that claim and update the issue
14:39:14 <ttereshc> could we triage it now? bizhang
14:39:27 <ttereshc> or your validation will influence that
14:39:39 <ipanova> let's triage and after validation we can close it
14:39:52 <bizhang> yeah, let's triage it now
14:40:05 <ttereshc> hi/med?
14:40:58 <ipanova> +1
14:41:26 <ttereshc> !propose triage h m
14:41:26 <ttereshc> #idea Proposed for #2684: Priority: High, Severity: Medium
14:41:26 <pulpbot> Proposed for #2684: Priority: High, Severity: Medium
14:41:30 <ttereshc> bizhang, ^
14:41:34 <bizhang> +1
14:41:48 <ttereshc> !accept
14:41:48 <ttereshc> #agreed Priority: High, Severity: Medium
14:41:48 <pulpbot> Current proposal accepted: Priority: High, Severity: Medium
14:41:50 <ttereshc> #topic Rsync publish removes symlinks and replace them with directories - http://pulp.plan.io/issues/2687
14:41:50 <pulpbot> 1 issues left to triage: 2687
14:41:51 <pulpbot> RPM Support Issue #2687 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:41:52 <pulpbot> Rsync publish removes symlinks and replace them with directories - http://pulp.plan.io/issues/2687
14:42:06 <dalley_> bizhang, I'm reading through it (it's a long issue) but I'm not immediately convinced it's related to #2613
14:42:28 <bizhang> dalley_ let's chat after triage?
14:42:43 <dalley_> kk
14:43:02 <ipanova> let's triage it as it is and add to sprint?
14:43:05 <mhrivnak> dkliban, have you looked at this one?
14:43:19 <ipanova> i see that some solution was already suggested
14:44:41 <ttereshc> !propose accept
14:44:41 <ttereshc> #idea Proposed for #2687: Leave the issue as-is, accepting its current state.
14:44:41 <pulpbot> Proposed for #2687: Leave the issue as-is, accepting its current state.
14:44:56 <mhrivnak> It would be good to get dkliban 's perspective .
14:45:40 <ttereshc> !propose needinfo dkliban
14:45:41 <mhrivnak> If we add it to the sprint, let's assign to him for evaluation. :)
14:45:41 <pulpbot> propose needinfo Propose that the current issue cannot be triaged without more info.
14:45:50 <ipanova> mhrivnak: it is a blocker for rcm anyway
14:45:54 <ipanova> let's add to sprint
14:46:05 <ipanova> and dkliban can set priority and severety then
14:46:10 <ipanova> severity*
14:46:14 <mhrivnak> Sounds good to me.
14:46:37 <ttereshc> !propose other accept and add to sprint
14:46:37 <ttereshc> #idea Proposed for #2687: accept and add to sprint
14:46:37 <pulpbot> Proposed for #2687: accept and add to sprint
14:46:42 <ttereshc> !accept
14:46:42 <ttereshc> #agreed accept and add to sprint
14:46:42 <pulpbot> Current proposal accepted: accept and add to sprint
14:46:43 <pulpbot> No issues to triage.
14:46:58 <smyers> So I guess defer didn't work?
14:46:59 <ttereshc> !issue 2667
14:46:59 <ttereshc> #topic Pulp 2.13 RHEL6 Builds Fail on Koji with Error - http://pulp.plan.io/issues/2667
14:47:00 <pulpbot> Pulp Issue #2667 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:47:01 <pulpbot> Pulp 2.13 RHEL6 Builds Fail on Koji with Error - http://pulp.plan.io/issues/2667
14:47:03 <smyers> That stinks
14:47:03 <ttereshc> smyers, yep
14:47:12 <smyers> (
14:47:14 <smyers> :(
14:47:16 <ttereshc> yep == it didn't work
14:47:29 <ttereshc> there was a race condition :)
14:47:45 <smyers> So we've disabled el6 for 2.13 and later in nightlies for now (see the associated task)
14:48:06 <smyers> We can just close this, or, if we eventually want to see nightlies working on el6 again, triage it.
14:48:30 <smyers> I don't know what we want to do, long-term, so I'd default to low prio, low sev, fix it when it catches fire
14:48:40 <ttereshc> close as wontfix and re-open if needed?
14:48:49 <dkliban> mhrivnak: i looked at 2687
14:48:54 <smyers> That also works for me
14:49:29 <ttereshc> any proposal on low/low vs wontfix?
14:50:09 <dkliban> mhrivnak: in regard to 2687, i would like to add it to the sprint. this work is more important than pulp 3
14:50:18 <smyers> I can't decide :\
14:50:29 <ttereshc> dkliban, we decided to add it
14:50:37 <ttereshc> !propose triage l l
14:50:37 <ttereshc> #idea Proposed for #2667: Priority: Low, Severity: Low
14:50:38 <pulpbot> Proposed for #2667: Priority: Low, Severity: Low
14:50:52 <smyers> sure
14:50:58 <ttereshc> :)
14:51:21 <ttereshc> no more opinions? :(
14:51:25 <mhrivnak> wontfix
14:51:29 <mhrivnak> :)
14:51:39 <ttereshc> you propose then ;)
14:51:52 <mhrivnak> !propose other close wontfix
14:51:52 <mhrivnak> #idea Proposed for #2667: close wontfix
14:51:53 <pulpbot> Proposed for #2667: close wontfix
14:52:18 <ipanova> +1
14:52:19 <ttereshc> !accept
14:52:19 <ttereshc> #agreed close wontfix
14:52:19 <pulpbot> Current proposal accepted: close wontfix
14:52:21 <pulpbot> No issues to triage.
14:52:29 <ttereshc> !end
14:52:29 <ttereshc> #endmeeting