14:30:22 <ttereshc> #startmeeting Pulp Triage 2017-04-04
14:30:22 <pulpbot> Meeting started Tue Apr  4 14:30:22 2017 UTC and is due to finish in 60 minutes.  The chair is ttereshc. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:30:22 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:30:22 <pulpbot> The meeting name has been set to 'pulp_triage_2017_04_04'
14:30:22 <ttereshc> #info ttereshc has joined triage
14:30:22 <pulpbot> ttereshc has joined triage
14:30:37 <jortel> !here
14:30:37 <jortel> #info jortel has joined triage
14:30:37 <pulpbot> jortel has joined triage
14:31:11 <daviddavis> !here
14:31:11 <daviddavis> #info daviddavis has joined triage
14:31:12 <pulpbot> daviddavis has joined triage
14:32:13 * ttereshc thinks we need one more dev
14:32:41 <daviddavis> yea
14:33:15 <ttereshc> mhrivnak, bmbouter?^
14:33:25 <mhrivnak> sorry, I think I missed some history.
14:33:35 <mhrivnak> just reconnected because I wasn't seeing any activity. :)
14:33:36 <ttereshc> would you like to participate intriage?
14:33:45 <mhrivnak> !here
14:33:45 <mhrivnak> #info mhrivnak has joined triage
14:33:45 <pulpbot> mhrivnak has joined triage
14:33:49 <ttereshc> !next
14:33:51 <pulpbot> 2 issues left to triage: 2689, 2691
14:33:51 <ttereshc> #topic Don't use ssh connection sharing in rsync distributor - http://pulp.plan.io/issues/2689
14:33:52 <pulpbot> Pulp Issue #2689 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:33:53 <pulpbot> Don't use ssh connection sharing in rsync distributor - http://pulp.plan.io/issues/2689
14:33:53 <bmbouter> !here
14:33:53 <bmbouter> #info bmbouter has joined triage
14:33:53 <pulpbot> bmbouter has joined triage
14:34:20 <mhrivnak> !propose accept
14:34:20 <mhrivnak> #idea Proposed for #2689: Leave the issue as-is, accepting its current state.
14:34:20 <pulpbot> Proposed for #2689: Leave the issue as-is, accepting its current state.
14:34:26 <ttereshc> easyfix?
14:34:35 <bmbouter> I think so
14:34:35 <mhrivnak> yes, good point.
14:34:50 <ttereshc> !accept
14:34:50 <ttereshc> #agreed Leave the issue as-is, accepting its current state.
14:34:50 <pulpbot> Current proposal accepted: Leave the issue as-is, accepting its current state.
14:34:52 <pulpbot> 1 issues left to triage: 2691
14:34:53 <ttereshc> #topic Pulp should verify if source for link exists - http://pulp.plan.io/issues/2691
14:34:53 <pulpbot> Pulp Issue #2691 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:34:54 <pulpbot> Pulp should verify if source for link exists - http://pulp.plan.io/issues/2691
14:35:41 <ttereshc> broken symlinks can exist in case of on_demand, right?
14:35:48 <mhrivnak> yes.
14:35:54 <bmbouter> I think this issue is too broad to be accepted as is
14:36:02 <mhrivnak> I agree.
14:36:13 <jortel> agreed
14:36:13 <ttereshc> jluza 's suggestion is probably valid for immediate case
14:36:53 <bmbouter> in pulp2 the symlink publising it's a plugin by plugin behavior right?
14:36:53 <mhrivnak> Perhaps he's getting at a question of: should publish validate that expected files are on disk?
14:37:30 <ttereshc> !propose needinfo
14:37:30 <ttereshc> #idea Proposed for #2691: This issue cannot be triaged without more info.
14:37:30 <pulpbot> Proposed for #2691: This issue cannot be triaged without more info.
14:37:32 <mhrivnak> bmbouter, kinda? But not in a way that I think will necessarily change.
14:37:58 <jortel> actually, I think the suggested solution is wrong.  verification (when appropriate) is the responsibility of the publisher, not the util function.
14:38:07 <jluza> mhrivnak, he just thinks pulp shouldn't produce invalid data when publish task finished successfully
14:38:30 <bmbouter> I agree completely with that, but it's not specific enough for us to fix as written
14:38:59 <bmbouter> if it's publishing broken symlinks when they are expected to work we need to understand how to reproduce it so we can fix it
14:39:07 <bmbouter> so I would say this needs a reproducer
14:39:10 <mhrivnak> jluza, i see your point.
14:39:27 <jluza> for me it does make sense to do fix in util method, if for some reason is there a situation where you don't like to validate source, you can add option for that
14:39:53 <jluza> otherwise you would have to change every single occurrence of make_symlink in your codes
14:40:27 <mhrivnak> I think there's a reasonable discussion to be had of whether it's enough for a distributor/publisher to create references to content that should exist, or must it also validate that the content it references exists.
14:40:41 <mhrivnak> How paranoid should it be.
14:41:23 <bmbouter> that all sounds good, but how would QE verify this without a reproducer?
14:41:31 <mhrivnak> Our users tend to be performance sensitive, particularly with regard to publishing, so verifying the presence of files is something we haven't added to that workflow.
14:42:33 <ttereshc> it can possibly be an option and users will be aware that it can slow things down
14:42:35 <mhrivnak> I could see this as an RFE to verify the presence of files during publish, and then we could discuss its value.
14:42:47 <jluza> I see there's question of quality vs quantity
14:42:58 <mhrivnak> I don't see this as a bug.
14:43:37 <jluza> ttereshc, you mean in [server] section: paranoid = True ?
14:44:04 <daviddavis> jluza: yea that's one option. or perhaps on the publisher?
14:44:20 <ttereshc> yep, Ithought more about publisher
14:44:36 <ttereshc> jluza, what do you think about changing it to story?
14:44:39 <bmbouter> but if this feature compensates for a defect then we should fix the defect
14:44:44 <mhrivnak> Validation of content on disk in general is something a lot of people are interested in being able to do.
14:44:52 <mhrivnak> I'm not sure publish is the right time to do it.
14:45:04 <jortel> agreed
14:45:14 <bmbouter> can we turn it into a story and continue discussion on the bug?
14:45:23 <jortel> yes, let's do that
14:45:31 <jluza> mhrivnak, what should be good time then?
14:45:34 <mhrivnak> +1
14:45:39 <ttereshc> !propose other convert to story
14:45:39 <ttereshc> #idea Proposed for #2691: convert to story
14:45:40 <pulpbot> Proposed for #2691: convert to story
14:45:40 <mhrivnak> jluza, sync
14:45:51 <mhrivnak> or "download_repo" task
14:45:54 <jluza> mhrivnak, yeah, I already filled another story for that
14:45:55 <mhrivnak> or some new task we don't have yet.
14:46:06 <jluza> mhrivnak, hmm actually Ina did that, but we discussed that
14:47:44 <ttereshc> jluza, do you have link handy?
14:47:51 <ttereshc> I can't find it
14:48:21 <ttereshc> mhrivnak, so we will convert this bug to story or close it if it is a dup
14:48:23 <ttereshc> ok?
14:48:27 <jluza> ttereshc, https://pulp.plan.io/issues/2624
14:48:29 <pulpbot> Title: Story #2624: As a user, I can verify blobs checksum during sync - Docker Support - Pulp (at pulp.plan.io)
14:48:33 <mhrivnak> Either is fine with me.
14:48:44 <ttereshc> #agreed convert to story
14:48:45 <ttereshc> !accept
14:48:45 <pulpbot> Current proposal accepted: convert to story
14:48:47 <pulpbot> No issues to triage.
14:48:56 <ttereshc> !end
14:48:56 <ttereshc> #endmeeting