14:39:10 <ttereshc> #startmeeting Pulp Triage 2017-04-07
14:39:10 <ttereshc> #info ttereshc has joined triage
14:39:11 <pulpbot> Meeting started Fri Apr  7 14:39:10 2017 UTC and is due to finish in 60 minutes.  The chair is ttereshc. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:39:11 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:39:11 <pulpbot> The meeting name has been set to 'pulp_triage_2017_04_07'
14:39:11 <pulpbot> ttereshc has joined triage
14:39:26 <asmacdo> !here
14:39:26 <asmacdo> #info asmacdo has joined triage
14:39:27 <pulpbot> asmacdo has joined triage
14:40:07 <jortel> !here
14:40:07 <jortel> #info jortel has joined triage
14:40:08 <pulpbot> jortel has joined triage
14:40:17 <daviddavis> !here
14:40:17 <daviddavis> #info daviddavis has joined triage
14:40:17 <pulpbot> daviddavis has joined triage
14:40:20 <ttereshc> !next
14:40:20 <dalley> !here
14:40:21 <pulpbot> 1 issues left to triage: 2692
14:40:22 <ttereshc> #topic packages with non-canonical but valid names cannot be installed with pip >= 8.1.2 - http://pulp.plan.io/issues/2692
14:40:22 <dalley> #info dalley has joined triage
14:40:22 <pulpbot> Python Support Issue #2692 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:40:23 <pulpbot> packages with non-canonical but valid names cannot be installed with pip >= 8.1.2 - http://pulp.plan.io/issues/2692
14:40:24 <pulpbot> dalley has joined triage
14:40:53 <pcreech> !here
14:40:53 <pcreech> #info pcreech has joined triage
14:40:53 <pulpbot> pcreech has joined triage
14:42:32 <ttereshc> asmacdo, any thoughts on that? this issue was there for a while, right? so it is not that important to fix it before 2.0, though it would be good?
14:42:37 <asmacdo> so this one has been present since the python plugin was released
14:43:15 <asmacdo> agree with what you said
14:43:18 <fdobrovo|wfh> !here
14:43:18 <fdobrovo|wfh> #info fdobrovo|wfh has joined triage
14:43:19 <pulpbot> fdobrovo|wfh has joined triage
14:43:35 <asmacdo> it shouldnt block 2.0
14:43:41 <ttereshc> !propose accept
14:43:41 <ttereshc> #idea Proposed for #2692: Leave the issue as-is, accepting its current state.
14:43:42 <pulpbot> Proposed for #2692: Leave the issue as-is, accepting its current state.
14:43:47 <asmacdo> +1
14:44:00 <daviddavis> asmacdo: is it possible that two packages might collide?
14:44:14 <daviddavis> e.g. zope.interface and zope_interface
14:44:36 <asmacdo> daviddavis: I am not sure about that, but if that is possible, PyPI has the same issue
14:44:42 <daviddavis> I see
14:45:00 <asmacdo> PyPI would serve both of those *also* at zope-interface
14:45:11 <daviddavis> makes sense
14:45:16 <daviddavis> anyway, +1 to accept from me
14:45:18 <bmbouter> !here
14:45:18 <bmbouter> #info bmbouter has joined triage
14:45:19 <pulpbot> bmbouter has joined triage
14:45:45 <ttereshc> daviddavis, All comparisons of distribution names MUST be case insensitive, and MUST consider hyphens and underscores to be equivalent.  from pep 426
14:45:58 <ttereshc> nothing about dots though
14:46:05 <bmbouter> there is an old-style version
14:46:09 <bmbouter> which is pre 426
14:46:15 <asmacdo> pep 426 is not accepted
14:46:26 <daviddavis> ttereshc: thx
14:46:29 <bmbouter> the user who reported this indicated it was the "old style" version
14:46:29 <asmacdo> but that is an attempt to prevent that prioblem
14:46:49 <asmacdo> he was talking about pip versions
14:47:06 <asmacdo> older pip uses zope.interface, new pip looks at zope-interface
14:47:09 <asmacdo> we need to serve both
14:47:45 <ttereshc> I agree that it makes sense to mimic PyPI behavior
14:47:57 <asmacdo> I am pretty sure PEP 426 is intended for warehouse, not PyPI
14:48:01 <ttereshc> bmbouter, no objections from you?
14:48:23 <bmbouter> +1 to mimicing PyPI
14:48:26 <ttereshc> !accept
14:48:26 <ttereshc> #agreed Leave the issue as-is, accepting its current state.
14:48:26 <pulpbot> Current proposal accepted: Leave the issue as-is, accepting its current state.
14:48:27 <pulpbot> No issues to triage.
14:48:33 <ttereshc> !end
14:48:33 <ttereshc> #endmeeting