14:29:49 <ttereshc> #startmeeting Pulp Triage 2017-04-25
14:29:49 <ttereshc> #info ttereshc has joined triage
14:29:49 <pulpbot> Meeting started Tue Apr 25 14:29:49 2017 UTC and is due to finish in 60 minutes.  The chair is ttereshc. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:29:49 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:29:49 <pulpbot> The meeting name has been set to 'pulp_triage_2017_04_25'
14:29:49 <pulpbot> ttereshc has joined triage
14:31:07 <daviddavis> !here
14:31:07 <daviddavis> #info daviddavis has joined triage
14:31:07 <pulpbot> daviddavis has joined triage
14:32:30 <ttereshc> jortel, bmbouter, asmacdo, ipanova, dalley, any takers for triage?
14:32:45 <asmacdo> !here
14:32:45 <asmacdo> #info asmacdo has joined triage
14:32:46 <pulpbot> asmacdo has joined triage
14:32:55 <ipanova> !here
14:32:55 <ipanova> #info ipanova has joined triage
14:32:55 <pulpbot> ipanova has joined triage
14:32:59 <ttereshc> !next
14:33:01 <ttereshc> #topic Pulp Gets Stuck On A Particular Mirror - http://pulp.plan.io/issues/2588
14:33:01 <pulpbot> 3 issues left to triage: 2588, 2724, 2725
14:33:01 <pulpbot> Pulp Issue #2588 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:33:02 <pulpbot> Pulp Gets Stuck On A Particular Mirror - http://pulp.plan.io/issues/2588
14:33:28 <ipanova> jortel: ^
14:33:43 <dalley> !here
14:33:43 <dalley> #info dalley has joined triage
14:33:43 <pulpbot> dalley has joined triage
14:34:14 <asmacdo> sounds like a wontfix to me
14:34:15 <ttereshc> it looks like suggestion by jortel is wontfix in pulp2
14:34:43 <ttereshc> but it was the same last time and we decided to re-triage it
14:35:24 <ttereshc> !propose other close as wontfix
14:35:24 <ttereshc> #idea Proposed for #2588: close as wontfix
14:35:24 <pulpbot> Proposed for #2588: close as wontfix
14:35:26 <ipanova> +
14:35:27 <ipanova> 1
14:35:34 <asmacdo> +1
14:35:35 <dalley> +1
14:35:46 <ttereshc> !accept
14:35:46 <ttereshc> #agreed close as wontfix
14:35:46 <pulpbot> Current proposal accepted: close as wontfix
14:35:48 <ttereshc> #topic `pulp-admin docker repo create --help` states v1 content is synced by default - http://pulp.plan.io/issues/2724
14:35:48 <pulpbot> 2 issues left to triage: 2724, 2725
14:35:49 <pulpbot> Docker Support Issue #2724 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:35:50 <pulpbot> `pulp-admin docker repo create --help` states v1 content is synced by default - http://pulp.plan.io/issues/2724
14:36:24 <ttereshc> this looks like an error in help text
14:36:28 <ipanova> let's triage it as it is + easy fix
14:36:30 <daviddavis> seems trivial but easy
14:36:32 <daviddavis> +1
14:36:44 <asmacdo> v1 isnt used by default anymore?
14:36:44 <ttereshc> !propose other triage nornal medium easyfix
14:36:44 <ttereshc> #idea Proposed for #2724: triage nornal medium easyfix
14:36:44 <pulpbot> Proposed for #2724: triage nornal medium easyfix
14:37:00 <jortel> !here
14:37:00 <jortel> #info jortel has joined triage
14:37:01 <pulpbot> jortel has joined triage
14:37:14 <asmacdo> Since it used to be the only thing we did, we left v1 True by default for backwards compatibility
14:37:24 <dalley> *normal
14:37:27 <ipanova> asmacdo: it is not, the code was changed
14:37:39 <dalley> s/nornal/normal
14:38:37 <ttereshc> asmacdo, any objections or you agree with this fix?
14:39:09 <asmacdo> well, I don't understand why the code was changed, but I can chat about that with ipanova
14:39:14 <asmacdo> go ahead
14:39:20 <ttereshc> !accept
14:39:20 <ttereshc> #agreed triage nornal medium easyfix
14:39:20 <pulpbot> Current proposal accepted: triage nornal medium easyfix
14:39:21 <pulpbot> 1 issues left to triage: 2725
14:39:22 <ttereshc> #topic Celery killed during applicability regeneration due to out of memory condition - http://pulp.plan.io/issues/2725
14:39:22 <pulpbot> Pulp Issue #2725 [NEW] (daviddavis@redhat.com) - Priority: Normal | Severity: Medium
14:39:23 <pulpbot> Celery killed during applicability regeneration due to out of memory condition - http://pulp.plan.io/issues/2725
14:41:13 <ttereshc> daviddavis, any hints to reproduce it?
14:41:19 <jortel> the bugzilla is urgent/urgent
14:41:42 <jortel> daviddavis: has the bugzialla been triaged by downstream?
14:41:43 <daviddavis> ttereshc: I'm currently trying to reproduce it in my pulp dev env
14:41:46 <ttereshc> oh, it was updated very recently, Isee
14:41:49 <bmbouter> !here
14:41:49 <bmbouter> #info bmbouter has joined triage
14:41:50 <pulpbot> bmbouter has joined triage
14:41:54 <ttereshc> now I see BZ
14:41:58 <daviddavis> jortel: not that I know of
14:42:05 <asmacdo> could they reduce the number of workers?
14:42:20 <daviddavis> asmacdo: I can ask them
14:42:24 <jortel> my first reaction is for user to get more memory but 5G / worker seems like too much
14:42:25 <daviddavis> 5 seems reasonable though
14:42:37 <asmacdo> I'm not sure how much memory we expect workers to use while calculating applicability, that seems like a difficult problem
14:42:39 <bmbouter> you would think that is too much but in practice it's common
14:42:53 <bmbouter> some tasks go to 10G of ram during usage
14:42:54 <jortel> okay.
14:43:02 <ipanova> asmacdo: https://github.com/pulp/pulp_docker/blob/master/plugins/pulp_docker/plugins/importers/sync.py#L75
14:43:02 <daviddavis> ok, I can ask
14:43:03 <pulpbot> Title: pulp_docker/sync.py at master · pulp/pulp_docker · GitHub (at github.com)
14:43:31 <ipanova> asmacdo: actuall you can blame yourself for this change ;)
14:43:33 <asmacdo> lol ipanova I changed it!
14:43:39 <ipanova> asmacdo: looking at git blame :D
14:43:40 <bmbouter> as in the fix for this will be a focused memory improvement issue versus "oh look the huge leak is here"
14:43:49 <ipanova> asmacdo: lol
14:44:04 <ttereshc> waiting for info or should we triage it as high/high for investigation?
14:44:31 <daviddavis> I'm happy with either. I don't have a preference.
14:44:55 <bmbouter> daviddavis: if this never was fixed what would happen?
14:45:29 <bmbouter> I'm asking because trying to fix it while also using mongodb may be challenging
14:45:54 <jortel> we could triage as is and rely on the bz to drive it further ..
14:46:00 <daviddavis> uh good question
14:46:45 <daviddavis> let me ask if they can increase memory/decrease pulp workers and see if that fixes it for them
14:46:55 <ttereshc> !propose needinfo
14:46:55 <ttereshc> #idea Proposed for #2725: This issue cannot be triaged without more info.
14:46:56 <pulpbot> Proposed for #2725: This issue cannot be triaged without more info.
14:47:00 <bmbouter> sounds good
14:47:07 <daviddavis> maybe we can draw a line in the sand in terms of memory usage (10GB) and only address it if it's above that?
14:47:08 <bmbouter> can we go back to 2588
14:47:18 <ttereshc> sure
14:47:26 <ttereshc> !accept
14:47:26 <ttereshc> #agreed This issue cannot be triaged without more info.
14:47:26 <pulpbot> Current proposal accepted: This issue cannot be triaged without more info.
14:47:28 <pulpbot> No issues to triage.
14:47:30 <ttereshc> !issue 2588
14:47:31 <ttereshc> #topic Pulp Gets Stuck On A Particular Mirror - http://pulp.plan.io/issues/2588
14:47:31 <pulpbot> Pulp Issue #2588 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:47:31 <pulpbot> Pulp Gets Stuck On A Particular Mirror - http://pulp.plan.io/issues/2588
14:48:05 <bmbouter> it is going back through triage due to a community request
14:48:41 <bmbouter> https://www.redhat.com/archives/pulp-list/2017-April/msg00004.html
14:49:09 <bmbouter> I won't propose that we put it on the sprint
14:49:49 <bmbouter> but with community interest in it it's possible someone non-core could fix it
14:50:29 <asmacdo> from what jortel said, I don't know that we could accept a patch that did that
14:51:17 <asmacdo> at least, it sounds like a high risk patch
14:51:36 <bmbouter> it sounded not easy but it could be done
14:51:42 <jortel> I'm fine with traged as mormal/high and if community want to fix then ...
14:52:23 <asmacdo> if we do accept it for the purpose of letting a community person do it, then it might be nice if we gave a little more detail
14:52:31 <bmbouter> yes and we should please
14:53:03 <asmacdo> !propose triage normal high
14:53:03 <asmacdo> #idea Proposed for #2588: Priority: Normal, Severity: High
14:53:04 <pulpbot> Proposed for #2588: Priority: Normal, Severity: High
14:53:23 <bmbouter> jortel I think you know the most about this, how would you feel about writing a short note giving some idea of how it could be fixed
14:54:59 <jortel> bmbouter: honestly, that write up would take a good bit of time because it would require rewriting significant parts of the importer.
14:55:33 <ipanova> bmbouter: i think before investing time in this we should understand if there are some community volunteers to work on this
14:56:03 <bmbouter> no one will fix this unless we share knowledge
14:56:11 <bmbouter> so right now the blocker on this is us
14:56:47 <asmacdo> I would be satisfied with a "if you are interested in working on this, please chat with us in #pulp-dev"
14:56:48 <bmbouter> we know the community wants it fixed, but they don't know how to so we should remedy that
14:57:03 <ttereshc> let's triage it as suggested and we can later decide how much time and when we will invest, sounds good?
14:57:16 <bmbouter> well without a note I don't think it can be triaged
14:57:18 <jortel> fair enough.  I'll add a comment.
14:57:42 <bmbouter> that kind of note sounds good
14:58:03 <ttereshc> !propose other triage normal/high, jortel will add a note
14:58:03 <ttereshc> #idea Proposed for #2588: triage normal/high, jortel will add a note
14:58:04 <pulpbot> Proposed for #2588: triage normal/high, jortel will add a note
14:58:39 <ttereshc> !accept
14:58:39 <ttereshc> #agreed triage normal/high, jortel will add a note
14:58:40 <pulpbot> Current proposal accepted: triage normal/high, jortel will add a note
14:58:44 <pulpbot> No issues to triage.
14:58:46 <asmacdo> thanks ttereshc :)
14:58:49 <ttereshc> !end
14:58:49 <ttereshc> #endmeeting