14:32:20 <ttereshc> #startmeeting Pulp Triage 2017-04-28
14:32:20 <ttereshc> #info ttereshc has joined triage
14:32:21 <pulpbot> Meeting started Fri Apr 28 14:32:20 2017 UTC and is due to finish in 60 minutes.  The chair is ttereshc. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:32:21 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:32:21 <pulpbot> The meeting name has been set to 'pulp_triage_2017_04_28'
14:32:21 <pulpbot> ttereshc has joined triage
14:32:30 <asmacdo> !here
14:32:30 <asmacdo> #info asmacdo has joined triage
14:32:30 <pulpbot> asmacdo has joined triage
14:32:37 <jortel> !here
14:32:37 <jortel> #info jortel has joined triage
14:32:37 <pulpbot> jortel has joined triage
14:32:54 <bmbouter> !here
14:32:54 <bmbouter> #info bmbouter has joined triage
14:32:54 <pulpbot> bmbouter has joined triage
14:32:57 <ttereshc> !next
14:32:59 <pulpbot> 11 issues left to triage: 2639, 2725, 2727, 2729, 2730, 2732, 2734, 2735, 2736, 2737, 2739
14:32:59 <ttereshc> #topic Upgrade fails on Fedora - http://pulp.plan.io/issues/2639
14:33:00 <pulpbot> Pulp Issue #2639 [ASSIGNED] (pcreech) - Priority: Normal | Severity: Medium
14:33:00 <pulpbot> Upgrade fails on Fedora - http://pulp.plan.io/issues/2639
14:33:30 <pcreech> !here
14:33:30 <pcreech> #info pcreech has joined triage
14:33:30 <pulpbot> pcreech has joined triage
14:33:44 <ipanova> !here
14:33:44 <ipanova> #info ipanova has joined triage
14:33:44 <pulpbot> ipanova has joined triage
14:33:55 <pcreech> So, this one isn't fixed, and preethi marked it as un-triaged so we can re prioritize it
14:34:21 <asmacdo> do you have a recommendation pcreech?
14:34:25 <ttereshc> it looks like high prio to me
14:34:31 <dalley> !here
14:34:31 <dalley> #info dalley has joined triage
14:34:32 <pulpbot> dalley has joined triage
14:34:55 <pcreech> I do not, as I do not know how important it is to be able to upgrade from pulp in fedora to pulp upstream
14:35:46 <jortel> our rpms should upgrade cleanly regardless of which dist they come from
14:36:17 <ttereshc> !propose triage h h
14:36:17 <ttereshc> #idea Proposed for #2639: Priority: High, Severity: High
14:36:17 <pulpbot> Proposed for #2639: Priority: High, Severity: High
14:36:45 <pcreech> the fix at this point will probably be re-naming all our python-* packages for fedora to match the pulp in fedora spec file namings
14:36:54 <pcreech> well, python-pulp*
14:37:07 <ipanova> shall we add this to sprint as well?
14:37:14 <asmacdo> can you elaborate on that pcreech?
14:37:14 <ttereshc> it is on the sprint
14:37:26 <ipanova> oh blind me
14:37:27 <asmacdo> python-pulp becomes what?
14:37:44 <pcreech> asmacdo: this is probably not teh best venue, but form python-pulp to python2-pulp wiht a provides python-pulp
14:37:49 <pcreech> just mirrornign what we do in fedora better
14:37:53 <asmacdo> oh ok
14:38:08 <pcreech> so the upgrade path is followed when we have a superceeding update
14:38:12 <asmacdo> didn't mean to get into the weeds, I just didnt understand
14:38:17 <pcreech> np
14:38:21 <asmacdo> +1 hh
14:38:25 <pcreech> +1 h, h, keeping it on sprint
14:38:32 <ttereshc> !accept
14:38:32 <ttereshc> #agreed Priority: High, Severity: High
14:38:32 <pulpbot> Current proposal accepted: Priority: High, Severity: High
14:38:34 <ttereshc> #topic Celery killed during applicability regeneration due to out of memory condition - http://pulp.plan.io/issues/2725
14:38:34 <pulpbot> 10 issues left to triage: 2725, 2727, 2729, 2730, 2732, 2734, 2735, 2736, 2737, 2739
14:38:34 <pulpbot> Pulp Issue #2725 [NEW] (daviddavis@redhat.com) - Priority: Normal | Severity: Medium
14:38:35 <pulpbot> Celery killed during applicability regeneration due to out of memory condition - http://pulp.plan.io/issues/2725
14:38:48 <ttereshc> !propose skip
14:38:48 <ttereshc> #idea Proposed for #2725: Skip this issue for this triage session.
14:38:49 <pulpbot> Proposed for #2725: Skip this issue for this triage session.
14:38:52 <ttereshc> waiting for info
14:39:19 <asmacdo> if no update: propose skip
14:39:31 <ttereshc> I checked with daviddavis
14:39:35 <jortel> +1 skip
14:39:36 <ttereshc> !accept
14:39:36 <ttereshc> #agreed Skip this issue for this triage session.
14:39:36 <pulpbot> Current proposal accepted: Skip this issue for this triage session.
14:39:38 <ttereshc> #topic Updating importer with ssl_* options along with other options fails "Cannot update 'config.remove_missing' and 'config' at the same time" - http://pulp.plan.io/issues/2727
14:39:38 <pulpbot> 9 issues left to triage: 2727, 2729, 2730, 2732, 2734, 2735, 2736, 2737, 2739
14:39:38 <pulpbot> RPM Support Issue #2727 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:39:39 <pulpbot> Updating importer with ssl_* options along with other options fails "Cannot update 'config.remove_missing' and 'config' at the same time" - http://pulp.plan.io/issues/2727
14:40:01 <asmacdo> this one looks kind of fun :)
14:40:33 <ttereshc> I hit similar issue with errata pkglists once
14:40:56 <ttereshc> there is a workaround to do updates one by one but we better solve this soon
14:41:33 <ttereshc> !propose accept
14:41:33 <ttereshc> #idea Proposed for #2727: Leave the issue as-is, accepting its current state.
14:41:34 <pulpbot> Proposed for #2727: Leave the issue as-is, accepting its current state.
14:41:55 <jortel> normal/high
14:42:09 <asmacdo> this is probably a regression from mongoengine
14:42:11 * pcreech brb's
14:42:19 <asmacdo> +1 normal/high
14:42:27 <ttereshc> !propose triage n h
14:42:27 <ttereshc> #idea Proposed for #2727: Priority: Normal, Severity: High
14:42:27 <pulpbot> Proposed for #2727: Priority: Normal, Severity: High
14:42:37 <ttereshc> !accept
14:42:37 <ttereshc> #agreed Priority: Normal, Severity: High
14:42:37 <pulpbot> Current proposal accepted: Priority: Normal, Severity: High
14:42:39 <pulpbot> 8 issues left to triage: 2729, 2730, 2732, 2734, 2735, 2736, 2737, 2739
14:42:39 <ttereshc> #topic pulp_user_metadata is ignored during ISO import - http://pulp.plan.io/issues/2729
14:42:40 <pulpbot> RPM Support Issue #2729 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:42:40 <pulpbot> pulp_user_metadata is ignored during ISO import - http://pulp.plan.io/issues/2729
14:44:47 <ttereshc> so it looks like a regression from 2.7, as for the rcm comment
14:44:51 <ipanova> it looks like a regression
14:45:15 <asmacdo> http://docs.pulpproject.org/dev-guide/integration/rest-api/content/upload.html#creating-an-upload-request
14:45:16 <pulpbot> Title: Uploading Content — Pulp Project 2.13 documentation (at docs.pulpproject.org)
14:45:17 <jortel> maybe h/m since it fails silently but dont put on sprint
14:45:32 <jortel> since there is a work around
14:45:42 <asmacdo> oh whoops, wrong upload
14:45:57 <bmbouter> jortel: I agree
14:46:05 <ttereshc> !propose triage h m
14:46:05 <ttereshc> #idea Proposed for #2729: Priority: High, Severity: Medium
14:46:06 <pulpbot> Proposed for #2729: Priority: High, Severity: Medium
14:46:06 <bmbouter> if they aren't calling it a blocker
14:46:11 <bmbouter> +1
14:46:15 <ttereshc> they are not
14:46:16 <ipanova> +1
14:46:20 <ttereshc> !accept
14:46:20 <ttereshc> #agreed Priority: High, Severity: Medium
14:46:21 <pulpbot> Current proposal accepted: Priority: High, Severity: Medium
14:46:21 <ttereshc> #topic As user I want to be able to provide custom rsync arguments to rsync distributor - http://pulp.plan.io/issues/2730
14:46:22 <pulpbot> 8 issues left to triage: 2730, 2732, 2734, 2735, 2736, 2737, 2739, 2741
14:46:22 <pulpbot> RPM Support Issue #2730 [NEW] (unassigned) - Priority: High | Severity: Medium
14:46:23 <pulpbot> As user I want to be able to provide custom rsync arguments to rsync distributor - http://pulp.plan.io/issues/2730
14:46:43 <jortel> should be a story?
14:46:53 <ttereshc> +1 to story
14:47:04 <ttereshc> !propose other convert to a story
14:47:04 <ttereshc> #idea Proposed for #2730: convert to a story
14:47:05 <pulpbot> Proposed for #2730: convert to a story
14:47:17 <pcreech> +1
14:47:21 <ipanova> +1
14:47:24 <ttereshc> !accept
14:47:24 <ttereshc> #agreed convert to a story
14:47:24 <pulpbot> Current proposal accepted: convert to a story
14:47:26 <pulpbot> 7 issues left to triage: 2732, 2734, 2735, 2736, 2737, 2739, 2741
14:47:26 <ttereshc> #topic Syncing from one pulp instance to another is slow - http://pulp.plan.io/issues/2732
14:47:27 <pulpbot> Puppet Support Issue #2732 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:47:27 <pulpbot> Syncing from one pulp instance to another is slow - http://pulp.plan.io/issues/2732
14:47:50 <fdobrovo> !here
14:47:50 <fdobrovo> #info fdobrovo has joined triage
14:47:51 <pulpbot> fdobrovo has joined triage
14:49:33 <ttereshc> there is a bit more info on BZ and lzap reproduced the issue, so it looks to me that at least it is worth investigating
14:49:45 <jortel> need more information ... what does "slow" mean?
14:50:11 <bmbouter> whenever these types of issues come in I want to retitled them for example
14:50:15 <jortel> n/m issue has metrics
14:50:16 <ttereshc> 2 hours pulp-to-pulp vs 10 mins forge-to-pulp
14:50:21 <bmbouter> 'puppet sync is slow'
14:50:43 <jortel> propose h/m
14:51:06 <bmbouter> given those numbers the current title does seem right
14:51:17 <ttereshc> that's what I got from BZ
14:51:23 <ipanova> agree with ttereshc let's investigate
14:51:40 <ttereshc> !propose triage h m
14:51:40 <ttereshc> #idea Proposed for #2732: Priority: High, Severity: Medium
14:51:40 <pulpbot> Proposed for #2732: Priority: High, Severity: Medium
14:52:51 <ttereshc> no objections?
14:53:08 <ttereshc> !accept
14:53:08 <ttereshc> #agreed Priority: High, Severity: Medium
14:53:08 <pulpbot> Current proposal accepted: Priority: High, Severity: Medium
14:53:10 <ttereshc> #topic cancelling task does not update task group - http://pulp.plan.io/issues/2734
14:53:10 <pulpbot> 6 issues left to triage: 2734, 2735, 2736, 2737, 2739, 2741
14:53:11 <pulpbot> Pulp Issue #2734 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:53:12 <pulpbot> cancelling task does not update task group - http://pulp.plan.io/issues/2734
14:54:35 <jortel> i think we need more info since not reproduced w/ just pulp;
14:55:22 <bmbouter> I was working w/ him on this
14:55:46 <bmbouter> I also want it reproduced on only Pulp but beav nor I had time to do it
14:56:12 <jortel> skip?
14:56:44 <bmbouter> unless someone is going to take an AI to reproduce it I'm not sure anything will be different next time
14:56:57 <ttereshc> !propose other skip and find volunteer to reproduce
14:56:57 <ttereshc> #idea Proposed for #2734: skip and find volunteer to reproduce
14:56:57 <pulpbot> Proposed for #2734: skip and find volunteer to reproduce
14:56:59 <jortel> good point :)
14:57:30 <bmbouter> what if we skip and put a note on it asking for a pulp-only reproducer to be posted on it?
14:57:35 <jortel> can we ask the reporter to reproduce?
14:57:43 <ipanova> i like this idea more
14:57:59 <bmbouter> we can definitly ask
14:58:08 <jortel> +1 to bmbouter proposal
14:58:28 <ttereshc> !propose other skip, put a not on issue and find a volunteer
14:58:28 <ttereshc> #idea Proposed for #2734: skip, put a not on issue and find a volunteer
14:58:28 <pulpbot> Proposed for #2734: skip, put a not on issue and find a volunteer
14:58:34 <ttereshc> !accept
14:58:34 <ttereshc> #agreed skip, put a not on issue and find a volunteer
14:58:34 <pulpbot> Current proposal accepted: skip, put a not on issue and find a volunteer
14:58:36 <pulpbot> 5 issues left to triage: 2735, 2736, 2737, 2739, 2741
14:58:36 <ttereshc> #topic Add support for failover to v1 protocol - http://pulp.plan.io/issues/2735
14:58:37 <pulpbot> Docker Support Issue #2735 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:58:37 <pulpbot> Add support for failover to v1 protocol - http://pulp.plan.io/issues/2735
14:59:27 <ttereshc> !propose other convert to a story
14:59:27 <ttereshc> #idea Proposed for #2735: convert to a story
14:59:27 <pulpbot> Proposed for #2735: convert to a story
15:00:16 <ipanova> i am not sure if it a story or bug but with current situation it is impossible to docker pull v1 from pulp
15:00:31 <ipanova> addition of failover support would fix this issue
15:00:47 <asmacdo> i think story is correct because this is a new feature we never had
15:00:57 <bmbouter> but we used to be able to do that?
15:01:09 <ttereshc> my understanding is no
15:01:11 <ipanova> bmbouter:  yes, but docker client changed its behaviour
15:01:20 <asmacdo> this bug only occurs if the client tries to use v2 api but we only serve v1 api
15:01:21 <bmbouter> oic
15:02:03 <daviddavis> !here
15:02:03 <daviddavis> #info daviddavis has joined triage
15:02:04 <pulpbot> daviddavis has joined triage
15:02:08 <ttereshc> everyone agree on converting it to story?
15:02:13 <asmacdo> +1
15:02:16 <fdobrovo> +1
15:02:18 <jortel> I /think/ so
15:02:22 <ttereshc> !accept
15:02:22 <ttereshc> #agreed convert to a story
15:02:22 <pulpbot> Current proposal accepted: convert to a story
15:02:24 <pulpbot> 4 issues left to triage: 2736, 2737, 2739, 2741
15:02:24 <ttereshc> #topic pulp_rpm.yum_plugin.utils.generate_listing_files should move in the platform - http://pulp.plan.io/issues/2736
15:02:25 <pulpbot> Pulp Issue #2736 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:02:25 <pulpbot> pulp_rpm.yum_plugin.utils.generate_listing_files should move in the platform - http://pulp.plan.io/issues/2736
15:02:58 <ttereshc> we are out of time, do we continue triage? (I am all for it) what others think
15:03:09 <asmacdo> i dont mind
15:03:13 <bmbouter> I don't mind
15:03:13 <daviddavis> i dont mind either
15:03:25 <ttereshc> good we have quorum
15:03:26 <ttereshc> ok
15:03:27 <daviddavis> this seems more like a refactor?
15:03:34 <bmbouter> definitly
15:03:46 <ttereshc> !propose other convert to refactor
15:03:46 <ttereshc> #idea Proposed for #2736: convert to refactor
15:03:47 <pulpbot> Proposed for #2736: convert to refactor
15:03:47 <asmacdo> !propose low low
15:03:47 <pulpbot> Error: "propose" is not a valid command.
15:04:03 <bmbouter> +1
15:04:16 <asmacdo> this would be nice, but it doesn't actually change anything in our code
15:04:22 <ipanova> +1
15:04:29 <ttereshc> !accept
15:04:29 <ttereshc> #agreed convert to refactor
15:04:29 <pulpbot> Current proposal accepted: convert to refactor
15:04:30 <pcreech> +1
15:04:31 <pulpbot> 3 issues left to triage: 2737, 2739, 2741
15:04:31 <ttereshc> #topic pulp_rpm.common.version_utils has some functionality that seems useful for the platform - http://pulp.plan.io/issues/2737
15:04:32 <pulpbot> Pulp Issue #2737 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:04:32 <pulpbot> pulp_rpm.common.version_utils has some functionality that seems useful for the platform - http://pulp.plan.io/issues/2737
15:04:37 <ttereshc> !propose other convert to refactor
15:04:37 <ttereshc> #idea Proposed for #2737: convert to refactor
15:04:38 <pulpbot> Proposed for #2737: convert to refactor
15:04:43 <bmbouter> yeah same here
15:04:44 <asmacdo> same deal, but i dont think we should accept this one
15:04:44 <bmbouter> +1
15:04:47 <asmacdo> -1
15:04:52 <jortel> +1
15:05:00 <asmacdo> those version_utils look very specific to rpm
15:05:12 <asmacdo> i think those should stay there
15:05:38 <bmbouter> I see what you are saying
15:05:40 <ipanova> what about adding this to pulp_deb as well instead of moving to platform
15:06:14 <pcreech> I'm +1 to ina's idea for the short term, but -1 for long term due to DRY
15:06:24 <asmacdo> well, if debian and rpm actually do use the same versioning scheme, then this could be renmaed and moved
15:06:28 <jortel> oh, if only rpm/deb specific then -1 to moving to platform.
15:06:35 <bmbouter> it is only rpm/deb specific
15:06:42 <bmbouter> is my understanding
15:07:01 <bmbouter> I think both of these issues are an attempt to have the pulp_deb plugin not depend on pulp_rpm
15:07:18 <bmbouter> so I don't think either of these will actually be done
15:07:20 <jortel> in either case, this should be a task/refactor not an issue.
15:07:24 <bmbouter> definitly
15:07:39 <asmacdo> i think this should be to implement this type of thing in pulp_deb
15:07:51 <ttereshc> asmacdo, would you mind putting comment on the issue with your thoughts on that, to start a conversation in the issue maybe?
15:08:03 <bmbouter> asmacdo: you're point is still valid I'm just pointing out some context
15:08:03 <asmacdo> sure
15:08:07 <bmbouter> yeah that would be good
15:08:11 <jortel> yep
15:08:13 <bmbouter> can we skip w/ asmacdo leaving a note?
15:08:25 <asmacdo> +1
15:08:25 <bmbouter> if we switch it to a refactor now we won't rediscuss it next triage3
15:08:32 <ttereshc> !propose skip and asmacdo will comment on it
15:08:32 <pulpbot> propose skip Propose skipping the current issue for this triage session.
15:08:46 <ttereshc> !propose other skip and asmacdo will comment on it
15:08:46 <ttereshc> #idea Proposed for #2737: skip and asmacdo will comment on it
15:08:46 <pulpbot> Proposed for #2737: skip and asmacdo will comment on it
15:08:55 <ttereshc> !accept
15:08:55 <ttereshc> #agreed skip and asmacdo will comment on it
15:08:55 <pulpbot> Current proposal accepted: skip and asmacdo will comment on it
15:08:56 <ttereshc> #topic Cannot see downloaded content units durinf sync of the repo in repo details - http://pulp.plan.io/issues/2739
15:08:57 <pulpbot> 2 issues left to triage: 2739, 2741
15:08:57 <pulpbot> RPM Support Issue #2739 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:08:58 <pulpbot> Cannot see downloaded content units durinf sync of the repo in repo details - http://pulp.plan.io/issues/2739
15:10:02 <asmacdo> arent the content unit numbers generated at the end of a sync?
15:10:10 <ipanova> not sure now important it is just noticed change in behavior
15:10:30 <ipanova> asmacdo: it was possible to see unit numbers during sync
15:10:51 <asmacdo> hmm ok
15:10:52 <ttereshc> does anyone remember when we had such possibility?
15:11:01 <asmacdo> yeah i think this changed with the mongoengine conversion also
15:11:13 <ttereshc> so since 2.7
15:11:14 <asmacdo> the content units were updated by the conduits as they were importerd
15:11:36 <asmacdo> but now, iirc that didnt work for some reason, so we had to do it all at once after the sync was done
15:11:41 <asmacdo> jortel: does that ring a bell?
15:12:39 <jortel> iirc, the counts are managed by the conduit but the plugin is responsible for reporting it
15:12:55 <bmbouter> conduits aren't used post mongoengine in manyplaces
15:13:09 <jortel> if nobody is complaining, let's leave it as m/m
15:13:27 <ipanova> works for me
15:13:31 <asmacdo> +1
15:13:43 <ttereshc> !propose accept
15:13:43 <ttereshc> #idea Proposed for #2739: Leave the issue as-is, accepting its current state.
15:13:43 <pulpbot> Proposed for #2739: Leave the issue as-is, accepting its current state.
15:13:53 <ttereshc> !accept
15:13:53 <ttereshc> #agreed Leave the issue as-is, accepting its current state.
15:13:53 <pulpbot> Current proposal accepted: Leave the issue as-is, accepting its current state.
15:13:54 <pulpbot> 1 issues left to triage: 2741
15:13:55 <ttereshc> #topic Pulp is not compatible with Django 1.10 - http://pulp.plan.io/issues/2741
15:13:55 <pulpbot> Pulp Issue #2741 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:13:55 <pulpbot> Pulp is not compatible with Django 1.10 - http://pulp.plan.io/issues/2741
15:15:01 <asmacdo> i think we changed our urlpatterns stuff for django forward compatibility
15:15:05 <pcreech> I took a quick look here, and it's in one place
15:15:24 <pcreech> a minor overlooked point for something including "content"
15:15:51 <ttereshc> !propose other triage high/high and add to sprint
15:15:51 <ttereshc> #idea Proposed for #2741: triage high/high and add to sprint
15:15:51 <pulpbot> Proposed for #2741: triage high/high and add to sprint
15:15:54 <pcreech> ./server/pulp/server/content/web/urls.py:urlpatterns = patterns(
15:16:00 <pcreech> +1
15:16:02 <bmbouter> +1
15:16:12 <ttereshc> !accept
15:16:12 <ttereshc> #agreed triage high/high and add to sprint
15:16:12 <pulpbot> Current proposal accepted: triage high/high and add to sprint
15:16:13 <jortel> +1
15:16:14 <pulpbot> No issues to triage.
15:16:19 <ttereshc> !end
15:16:19 <ttereshc> #endmeeting