14:29:59 <ttereshc> #startmeeting Pulp Triage 2017-05-05
14:29:59 <ttereshc> #info ttereshc has joined triage
14:29:59 <pulpbot> Meeting started Fri May  5 14:29:59 2017 UTC and is due to finish in 60 minutes.  The chair is ttereshc. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:29:59 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:29:59 <pulpbot> The meeting name has been set to 'pulp_triage_2017_05_05'
14:29:59 <pulpbot> ttereshc has joined triage
14:30:33 <ipanova> !here
14:30:33 <ipanova> #info ipanova has joined triage
14:30:34 <pulpbot> ipanova has joined triage
14:32:13 <ttereshc> any takers for triage? we need two more people, bmbouter dkliban pcreech asmacdo
14:33:27 <ttereshc> I think the rest of devs are out today
14:33:34 <ipanova> they are
14:33:36 <bmbouter> !here
14:33:36 <bmbouter> #info bmbouter has joined triage
14:33:36 <pulpbot> bmbouter has joined triage
14:34:02 <ipanova> let's wait another couple of minutes to reach the quorum
14:34:03 <bmbouter> elyezer: np we can triage that issue later
14:34:06 <bmbouter> ok
14:34:12 <elyezer> thank you!
14:34:24 <asmacdo> !here
14:34:24 <asmacdo> #info asmacdo has joined triage
14:34:24 <pulpbot> asmacdo has joined triage
14:34:34 <ttereshc> !next
14:34:35 <pulpbot> 5 issues left to triage: 2725, 2734, 2737, 2745, 2746
14:34:36 <ttereshc> #topic Celery killed during applicability regeneration due to out of memory condition - http://pulp.plan.io/issues/2725
14:34:36 <pulpbot> Pulp Issue #2725 [NEW] (daviddavis@redhat.com) - Priority: Normal | Severity: Medium
14:34:36 <pulpbot> Celery killed during applicability regeneration due to out of memory condition - http://pulp.plan.io/issues/2725
14:34:48 <ttereshc> !propose skip
14:34:48 <ttereshc> #idea Proposed for #2725: Skip this issue for this triage session.
14:34:49 <pulpbot> Proposed for #2725: Skip this issue for this triage session.
14:35:02 <asmacdo> +1
14:35:09 <ipanova> +1
14:35:13 <ttereshc> daviddavis proposed to close it in a week if there will be no info
14:35:17 <ttereshc> !accept
14:35:17 <ttereshc> #agreed Skip this issue for this triage session.
14:35:17 <pulpbot> Current proposal accepted: Skip this issue for this triage session.
14:35:18 <pulpbot> 4 issues left to triage: 2734, 2737, 2745, 2746
14:35:19 <ttereshc> #topic cancelling task does not update task group - http://pulp.plan.io/issues/2734
14:35:19 <pulpbot> Pulp Issue #2734 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:35:19 <pulpbot> cancelling task does not update task group - http://pulp.plan.io/issues/2734
14:36:00 <ttereshc> bmbouter, it works for me ^ if I did what expected :)
14:36:17 * bmbouter is reading
14:36:19 <ttereshc> does it make sense to try to reproduce it with 2.8?
14:36:34 <ttereshc> to fix it downstream in case there is an issue
14:37:31 <bmbouter> that is an idea
14:37:45 <bmbouter> I would like to hear from the reporter given that you can't reproduce
14:37:46 <bmbouter> also
14:38:00 <asmacdo> I don't think we should be responsible for determining if its a bug in our stuff or the downstream stuff.
14:38:21 <bmbouter> agreed, but I think the question is, is it a bug at all
14:38:29 <ttereshc> !propose other needinfo from beav and/or ttereshc will try to reproduce with 2.8
14:38:29 <ttereshc> #idea Proposed for #2734: needinfo from beav and/or ttereshc will try to reproduce with 2.8
14:38:29 <pulpbot> Proposed for #2734: needinfo from beav and/or ttereshc will try to reproduce with 2.8
14:38:37 <ipanova> let's skip until next triage and ask from feedback from cduryee
14:38:46 <ipanova> and then close
14:38:46 <bmbouter> yes
14:38:51 <bmbouter> beav: fyi ^
14:39:02 <ttereshc> !accept
14:39:02 <ttereshc> #agreed needinfo from beav and/or ttereshc will try to reproduce with 2.8
14:39:02 <pulpbot> Current proposal accepted: needinfo from beav and/or ttereshc will try to reproduce with 2.8
14:39:03 <pulpbot> 3 issues left to triage: 2737, 2745, 2746
14:39:03 <ttereshc> #topic pulp_rpm.common.version_utils has some functionality that seems useful for the platform - http://pulp.plan.io/issues/2737
14:39:04 <pulpbot> Pulp Issue #2737 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:39:04 <pulpbot> pulp_rpm.common.version_utils has some functionality that seems useful for the platform - http://pulp.plan.io/issues/2737
14:39:43 <asmacdo> I recommend that we close this one
14:39:59 <ttereshc> yeah, I agree
14:40:12 <ttereshc> !propose other close as wontfix
14:40:12 <ttereshc> #idea Proposed for #2737: close as wontfix
14:40:13 <pulpbot> Proposed for #2737: close as wontfix
14:40:27 <bmbouter> with a comment please
14:40:40 <ttereshc> bmbouter, there is already one from asmacdo
14:40:52 <asmacdo> misa:  ^ please reopen if you think we missed something
14:41:11 <bmbouter> ok then +1 to close wontfix
14:41:14 <bmbouter> ty
14:41:21 <ttereshc> !accept
14:41:21 <ttereshc> #agreed close as wontfix
14:41:21 <pulpbot> Current proposal accepted: close as wontfix
14:41:23 <ttereshc> #topic DocumentTooLarge when syncing repo with on_demand policy - http://pulp.plan.io/issues/2745
14:41:23 <pulpbot> 2 issues left to triage: 2745, 2746
14:41:23 <pulpbot> RPM Support Issue #2745 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:41:24 <pulpbot> DocumentTooLarge when syncing repo with on_demand policy - http://pulp.plan.io/issues/2745
14:42:51 <ttereshc> I think there are 2 different issues as I mentioned in the comment https://pulp.plan.io/issues/2745#note-3
14:42:53 <pulpbot> Title: Issue #2745: DocumentTooLarge when syncing repo with on_demand policy - RPM Support - Pulp (at pulp.plan.io)
14:42:54 <ipanova> ttereshc: i think the error handling should be the same in both cases
14:43:15 <ttereshc> I suggest to re-name and fix this one as error handling issue
14:43:24 <ipanova> ttereshc: maybe with immediate policy not to silently skip the rpm but put it among failed ones?
14:43:37 <ttereshc> and create new issue or story to see how we can improve huge filelist handling
14:43:49 <ttereshc> ipanova, I agree this should be fixed
14:44:15 <ttereshc> I just do not want to mix up DocumentTooLarge issue itself and general error handling issue
14:44:24 <ipanova> ttereshc: i agree
14:44:53 <ttereshc> bmbouter, do you have any thoughts on all this?
14:45:10 <ipanova> ttereshc:  but i guess more important is to fix the DocumentTooLarge issue
14:46:40 <ipanova> asmacdo: ^
14:46:48 <ipanova> guys, concentrate ;)
14:46:55 <bmbouter> I think two issues is good
14:47:09 <bmbouter> +1 to all discussed ^
14:47:10 <ttereshc> ipanova, yes and no. First we have to decide how far we should go with DocumentTooLarge fix becasue to fix the issue for any RPM is a lot of changes and we did not want to do it last time
14:47:18 <ttereshc> thanks for the feedback
14:47:29 <asmacdo> im confused if immediate is just swallowing the exception?
14:47:34 <ipanova> ttereshc: makes sense
14:47:39 <ipanova> asmacdo: yes it does
14:47:44 <ttereshc> !propose other ttereshc will rename current issue and create new one to track to different issues
14:47:44 <ttereshc> #idea Proposed for #2745: ttereshc will rename current issue and create new one to track to different issues
14:47:44 <pulpbot> Proposed for #2745: ttereshc will rename current issue and create new one to track to different issues
14:47:54 <ipanova> +1
14:47:55 <ttereshc> !propose other ttereshc will rename current issue and create new one to track two different issues
14:47:55 <ttereshc> #idea Proposed for #2745: ttereshc will rename current issue and create new one to track two different issues
14:47:55 <bmbouter> yeah that is a good plan
14:47:55 <pulpbot> Proposed for #2745: ttereshc will rename current issue and create new one to track two different issues
14:48:00 <ttereshc> !accept
14:48:00 <ttereshc> #agreed ttereshc will rename current issue and create new one to track two different issues
14:48:00 <pulpbot> Current proposal accepted: ttereshc will rename current issue and create new one to track two different issues
14:48:01 <pulpbot> 1 issues left to triage: 2746
14:48:02 <ttereshc> #topic Add documentation about Transparent Huge Pages - http://pulp.plan.io/issues/2746
14:48:02 <pulpbot> Pulp Issue #2746 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:48:02 <pulpbot> Add documentation about Transparent Huge Pages - http://pulp.plan.io/issues/2746
14:48:31 <ttereshc> I am not sure if it is a story or issue but +1 for that anyway
14:48:43 <ttereshc> I read your discussion yesterday, bmbouter
14:49:01 <bmbouter> yeah I'm hoping to keep it as a bug so it can land in z stream
14:49:09 <bmbouter> I can also see both issue and story
14:49:14 <ttereshc> good point!
14:49:22 <ttereshc> !propose accept
14:49:22 <ttereshc> #idea Proposed for #2746: Leave the issue as-is, accepting its current state.
14:49:23 <pulpbot> Proposed for #2746: Leave the issue as-is, accepting its current state.
14:49:27 <ipanova> +1
14:49:33 <asmacdo> +1
14:49:41 <ttereshc> do we want to add it to sprint?
14:49:51 <bmbouter> I would like to
14:49:59 <ttereshc> it is a small doc issue but it will help customers a lot
14:49:59 <bmbouter> but I also put it down on mylist for sprint planning
14:50:04 <ipanova> no objections
14:50:30 <ttereshc> !propose other accept as-is and add to sprint
14:50:30 <ttereshc> #idea Proposed for #2746: accept as-is and add to sprint
14:50:30 <pulpbot> Proposed for #2746: accept as-is and add to sprint
14:50:51 <ttereshc> !accept
14:50:51 <ttereshc> #agreed accept as-is and add to sprint
14:50:51 <pulpbot> Current proposal accepted: accept as-is and add to sprint
14:50:52 <pulpbot> No issues to triage.
14:50:59 <ttereshc> !end
14:50:59 <ttereshc> #endmeeting