14:29:28 <asmacdo> #startmeeting Pulp Triage 2017-05-12
14:29:28 <asmacdo> #info asmacdo has joined triage
14:29:29 <pulpbot> Meeting started Fri May 12 14:29:28 2017 UTC and is due to finish in 60 minutes.  The chair is asmacdo. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:29:29 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:29:29 <pulpbot> The meeting name has been set to 'pulp_triage_2017_05_12'
14:29:29 <pulpbot> asmacdo has joined triage
14:29:36 <daviddavis> !here
14:29:36 <daviddavis> #info daviddavis has joined triage
14:29:37 <pulpbot> daviddavis has joined triage
14:30:14 <bizhang> !here
14:30:14 <bizhang> #info bizhang has joined triage
14:30:14 <pulpbot> bizhang has joined triage
14:30:38 <asmacdo> !next
14:30:39 <pulpbot> 6 issues left to triage: 2734, 2748, 2749, 2750, 2751, 2754
14:30:39 <asmacdo> #topic cancelling task does not update task group - http://pulp.plan.io/issues/2734
14:30:40 <pulpbot> Pulp Issue #2734 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:30:40 <pulpbot> cancelling task does not update task group - http://pulp.plan.io/issues/2734
14:31:08 <jortel> !here
14:31:08 <jortel> #info jortel has joined triage
14:31:08 <pulpbot> jortel has joined triage
14:31:19 <ipanova> !here
14:31:19 <ipanova> #info ipanova has joined triage
14:31:20 <pulpbot> ipanova has joined triage
14:31:48 <dkliban> !heer
14:31:48 <pulpbot> Error: "heer" is not a valid command.
14:31:52 <ipanova> let's skip it?
14:31:52 <dkliban> !here
14:31:52 <dkliban> #info dkliban has joined triage
14:31:53 <pulpbot> dkliban has joined triage
14:32:00 <asmacdo> !propose skip
14:32:00 <asmacdo> #idea Proposed for #2734: Skip this issue for this triage session.
14:32:01 <pulpbot> Proposed for #2734: Skip this issue for this triage session.
14:32:07 <ipanova> dkliban: sounds almost like !beer
14:32:10 <dkliban> lol
14:32:13 <asmacdo> !cheers
14:32:13 <pulpbot> Error: "cheers" is not a valid command.
14:32:22 <ipanova> dkliban: it's friday, you know ;)
14:32:26 <ipanova> +1
14:32:26 <pulpbot> ipanova: That's Numberwang!
14:32:36 <ipanova> beav: any updates?^
14:33:25 <daviddavis> let's give him another week and skip for now?
14:33:30 <jortel> +1
14:33:31 <asmacdo> !skip
14:33:32 <pulpbot> 5 issues left to triage: 2748, 2749, 2750, 2751, 2754
14:33:33 <asmacdo> #topic Complex/Strange Upstream Yum URL Results In Incorrect Upstream Package URLs - http://pulp.plan.io/issues/2748
14:33:33 <pulpbot> Pulp Issue #2748 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:33:33 <pulpbot> Complex/Strange Upstream Yum URL Results In Incorrect Upstream Package URLs - http://pulp.plan.io/issues/2748
14:33:58 <beav> ipanova:  not yet :( i have another issue to look into first related to pulp-rpm before that one, i havent created a redmine for it yet
14:34:07 <dralley> !here
14:34:07 <dralley> #info dralley has joined triage
14:34:08 <pulpbot> dralley has joined triage
14:34:24 <ipanova> beav: ok we skipped it again to give you some more time
14:34:34 <fdobrovo> !here
14:34:34 <fdobrovo> #info fdobrovo has joined triage
14:34:35 <pulpbot> fdobrovo has joined triage
14:35:10 <ipanova> looks like we have some issue in parsing the feed itseld
14:35:14 <ipanova> itself
14:35:15 <beav> ok thx. if someone is interested in the pulp-rpm packaging issue it would be helpful. it is easy to reproduce
14:35:36 <asmacdo> is this one a mirror list issue? I'm not sure
14:35:47 <dkliban> it's not
14:35:58 <daviddavis> no I think pulp is just having trouble with the url since the relative path is a get parameter
14:36:07 <dkliban> yeah
14:36:09 <daviddavis> seems like an RFE almost
14:36:09 <mhrivnak> I'm just glancing at this, but it's real weird to have the path in the query parameter.
14:36:14 <daviddavis> yea
14:36:17 <jortel> agreed
14:36:27 <ipanova> asmacdo: mirrorlist do not have primary, so it is a feed
14:36:33 <dkliban> it's definitely weird but i would like us to be able to support taht
14:36:34 <mhrivnak> I wonder if this layout is even an RFC violation.
14:36:41 <ipanova> mhrivnak: i agree
14:37:29 <ipanova> let's investigate this and see whether it is a valid path or rfc violation?
14:37:35 <asmacdo> i wonder if this same thing works with dnf
14:37:50 <daviddavis> "Using a yum configuration to hit the upstream repo directly works.
14:38:37 <asmacdo> i interpreted that to mean it worked with yum, not necessarily dnf
14:38:55 <daviddavis> ah yea, maybe it doesn't work with dnf
14:39:06 <ipanova> daviddavis: with dnf work many things because it forgives many issues, but it does not that those are correct
14:39:20 <daviddavis> agreed
14:39:20 <ipanova> does not mean*
14:39:27 * mhrivnak isn't able to focus on triage but wanted to comment on this one in particular
14:39:28 <asmacdo> !propose accept
14:39:28 <asmacdo> #idea Proposed for #2748: Leave the issue as-is, accepting its current state.
14:39:28 <pulpbot> Proposed for #2748: Leave the issue as-is, accepting its current state.
14:39:42 <asmacdo> ipanova: will you add a comment?
14:40:03 <ipanova> asmacdo: before adding a comment we need to make an investigation
14:40:18 <daviddavis> +1
14:40:18 <ipanova> if the stuff is valid as pointed out mhrivnak
14:40:32 <asmacdo> I was thinking the comment would just ask the question to investigate
14:40:38 <mhrivnak> It may be hard to know without having an example repo to poke.
14:40:43 <asmacdo> ipanova: are you suggesting we skip?
14:42:13 <asmacdo> !propose skip
14:42:13 <asmacdo> #idea Proposed for #2748: Skip this issue for this triage session.
14:42:13 <pulpbot> Proposed for #2748: Skip this issue for this triage session.
14:42:50 <ipanova> asmacdo: yeah
14:43:01 <asmacdo> !accept
14:43:01 <asmacdo> #agreed Skip this issue for this triage session.
14:43:01 <pulpbot> Current proposal accepted: Skip this issue for this triage session.
14:43:02 <asmacdo> #topic _release_resource should be acks_late and idempotent - http://pulp.plan.io/issues/2749
14:43:03 <pulpbot> 4 issues left to triage: 2749, 2750, 2751, 2754
14:43:03 <pulpbot> Pulp Issue #2749 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:43:04 <pulpbot> _release_resource should be acks_late and idempotent - http://pulp.plan.io/issues/2749
14:44:28 <ipanova> looks like the conversation is still, ongoing, let's skip it until the reporter will asnwer the questions?
14:45:16 <asmacdo> !propose skip
14:45:16 <asmacdo> #idea Proposed for #2749: Skip this issue for this triage session.
14:45:16 <pulpbot> Proposed for #2749: Skip this issue for this triage session.
14:45:44 <jortel> +1
14:46:00 <fdobrovo> +1
14:46:06 <dralley> +1
14:46:08 <asmacdo> !accept
14:46:08 <asmacdo> #agreed Skip this issue for this triage session.
14:46:08 <pulpbot> Current proposal accepted: Skip this issue for this triage session.
14:46:09 <pulpbot> 3 issues left to triage: 2750, 2751, 2754
14:46:10 <asmacdo> #topic pulp_puppet is not compatible with django 1.10 - http://pulp.plan.io/issues/2750
14:46:10 <pulpbot> Puppet Support Issue #2750 [ASSIGNED] (daviddavis@redhat.com) - Priority: Normal | Severity: Medium
14:46:11 <pulpbot> pulp_puppet is not compatible with django 1.10 - http://pulp.plan.io/issues/2750
14:46:35 <asmacdo> daviddavis: accept?
14:46:37 <daviddavis> yes
14:46:49 <daviddavis> and add to sprint preferrably since 2741 is on the sprint
14:47:09 <ipanova> +1
14:47:15 <dralley> +1
14:47:15 <asmacdo> !propose accept add to sprint
14:47:16 <pulpbot> propose accept Propose accepting the current issue in its current state.
14:47:21 <bizhang> +1
14:47:45 <asmacdo> ah, already on the sprint.
14:47:47 <asmacdo> !accept
14:47:47 <pulpbot> No action proposed, nothing to accept.
14:47:55 <asmacdo> hmm
14:48:03 <asmacdo> !propose accept
14:48:03 <asmacdo> #idea Proposed for #2750: Leave the issue as-is, accepting its current state.
14:48:04 <pulpbot> Proposed for #2750: Leave the issue as-is, accepting its current state.
14:48:06 <asmacdo> !accept
14:48:06 <asmacdo> #agreed Leave the issue as-is, accepting its current state.
14:48:06 <pulpbot> Current proposal accepted: Leave the issue as-is, accepting its current state.
14:48:07 <pulpbot> 2 issues left to triage: 2751, 2754
14:48:08 <asmacdo> #topic Unittest builder for plugins fails if the minimum required platform version is unavailable  - http://pulp.plan.io/issues/2751
14:48:08 <pulpbot> Packaging Issue #2751 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:48:08 <pulpbot> Unittest builder for plugins fails if the minimum required platform version is unavailable  - http://pulp.plan.io/issues/2751
14:50:03 <dkliban> we should accept as is
14:50:13 <dkliban> and we can add it to the next sprint at sprint planning
14:50:16 <dralley> +1
14:50:17 <asmacdo> dkliban: i was thinking this one needed discussion
14:50:34 <dkliban> asmacdo: what questions do you have?
14:50:35 <asmacdo> it looks like a change in our release process right?
14:51:20 <asmacdo> i'm not sure that I agree that we should build pulp 2.10 for fedora just because pulp_ostree only requires 2.10 on fedora
14:51:43 <dkliban> asmacdo: i think it's just a change in our PR builder job. it looks at the spec file to see what the minimum platform version is needed. it only tries that minimum. if that minimum is not available it should try to install teh next version
14:52:32 <asmacdo> the bug as written doesnt look like it is asking for failover
14:52:52 <asmacdo> it looks like it wants all platform versions to be installable by the plugins
14:53:23 <ipanova> i think we should triage it and the discussion should happen in the tracker
14:53:50 <pcreech> +1
14:53:53 <asmacdo> thats fine by me. dkliban do you have a prio suggestion?
14:54:07 <dkliban> as is
14:54:12 <asmacdo> !propose accept
14:54:12 <asmacdo> #idea Proposed for #2751: Leave the issue as-is, accepting its current state.
14:54:13 <pulpbot> Proposed for #2751: Leave the issue as-is, accepting its current state.
14:54:17 <ipanova> +1
14:54:24 <asmacdo> !accept
14:54:24 <asmacdo> #agreed Leave the issue as-is, accepting its current state.
14:54:24 <pulpbot> Current proposal accepted: Leave the issue as-is, accepting its current state.
14:54:25 <asmacdo> #topic RPM uploads appear to be missing metadata information - http://pulp.plan.io/issues/2754
14:54:26 <pulpbot> 1 issues left to triage: 2754
14:54:26 <pulpbot> Pulp Issue #2754 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:54:27 <pulpbot> RPM uploads appear to be missing metadata information - http://pulp.plan.io/issues/2754
14:55:35 <daviddavis> so syncing seems to fill out these fields (Size, Summary, Source RPM, and Group) but uploading does not
14:56:04 <asmacdo> daviddavis: do those fields exist on the unit or in the repo metadata?
14:56:30 <daviddavis> asmacdo: the metadata - https://pulp.plan.io/issues/2754#note-2
14:56:32 <pulpbot> Title: Issue #2754: RPM uploads appear to be missing metadata information - Pulp (at pulp.plan.io)
14:57:45 <ipanova> daviddavis: this sounds familiar to me
14:58:07 <mhrivnak> Me too, at least a little.
14:58:14 * daviddavis googles
14:58:25 <mhrivnak> I recall at some point that uploaded rpms weren't getting all the right fields populated.
14:58:40 <ipanova> daviddavis: we can extract just those info which is in package headers
14:58:59 <daviddavis> "rpm -qip" can so I believe so
14:59:46 <asmacdo> cool
14:59:51 <asmacdo> !propose accept
14:59:51 <asmacdo> #idea Proposed for #2754: Leave the issue as-is, accepting its current state.
14:59:52 <pulpbot> Proposed for #2754: Leave the issue as-is, accepting its current state.
15:00:26 <mhrivnak> daviddavis, do you have a sense of how big the impact is of this bug?
15:02:21 <daviddavis> mhrivnak: minimal unless the user wants this information at some later time
15:02:27 <daviddavis> they'll have to reupload the package
15:02:38 <mhrivnak> This is the similar one I was thinking of: https://pulp.plan.io/issues/2365
15:02:40 <pulpbot> Title: Issue #2365: rpm upload fails to populate "files" field on model - RPM Support - Pulp (at pulp.plan.io)
15:02:57 <daviddavis> mhrivnak: yes! I was looking for that
15:03:12 <ipanova> daviddavis: so i've just uploaded one rpm, all data is there
15:03:47 <daviddavis> weird, it's not for me
15:04:04 <mhrivnak> What versions of pulp are you each trying/
15:04:05 <mhrivnak> ?
15:04:44 <daviddavis> I'm on master
15:04:49 <daviddavis> pulp 2
15:05:07 <mhrivnak> hm, interesting.
15:05:40 <mhrivnak> I wonder if there's a smash test similar to this use case already.
15:05:48 <mhrivnak> Where we might be able to just add some assertions about these fields?
15:05:49 <ipanova> let's triage it and then continue the discussion
15:06:01 <mhrivnak> Sounds reasonable.
15:06:09 <asmacdo> as is?
15:06:28 <daviddavis> +1
15:06:36 <asmacdo> !accept
15:06:36 <asmacdo> #agreed Leave the issue as-is, accepting its current state.
15:06:36 <pulpbot> Current proposal accepted: Leave the issue as-is, accepting its current state.
15:06:38 <pulpbot> No issues to triage.
15:06:42 <asmacdo> !end
15:06:42 <asmacdo> #endmeeting