14:29:42 <ttereshc> #startmeeting Pulp Triage 2017-05-23
14:29:42 <ttereshc> #info ttereshc has joined triage
14:29:42 <pulpbot> Meeting started Tue May 23 14:29:42 2017 UTC and is due to finish in 60 minutes.  The chair is ttereshc. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:29:42 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:29:42 <pulpbot> The meeting name has been set to 'pulp_triage_2017_05_23'
14:29:42 <pulpbot> ttereshc has joined triage
14:29:48 <daviddavis> !here
14:29:48 <daviddavis> #info daviddavis has joined triage
14:29:48 <pulpbot> daviddavis has joined triage
14:29:53 <bizhang> !here
14:29:53 <bizhang> #info bizhang has joined triage
14:29:54 <pulpbot> bizhang has joined triage
14:29:56 <dkliban> !here
14:29:56 <dkliban> #info dkliban has joined triage
14:29:56 <pulpbot> dkliban has joined triage
14:30:01 <dralley> !here
14:30:01 <dralley> #info dralley has joined triage
14:30:02 <pulpbot> dralley has joined triage
14:30:06 <ipanova> !here
14:30:06 <ipanova> #info ipanova has joined triage
14:30:06 <pulpbot> ipanova has joined triage
14:30:09 <bmbouter> !here
14:30:09 <bmbouter> #info bmbouter has joined triage
14:30:10 <pulpbot> bmbouter has joined triage
14:30:22 <asmacdo> !here
14:30:22 <asmacdo> #info asmacdo has joined triage
14:30:23 <pulpbot> asmacdo has joined triage
14:30:29 <ttereshc> !next
14:30:30 <pulpbot> 5 issues left to triage: 2749, 2758, 2772, 2773, 2774
14:30:31 <ttereshc> #topic _release_resource should be acks_late and idempotent - http://pulp.plan.io/issues/2749
14:30:31 <pulpbot> Pulp Issue #2749 [NEW] (unassigned) - Priority: Normal | Severity: Low
14:30:32 <pulpbot> _release_resource should be acks_late and idempotent - http://pulp.plan.io/issues/2749
14:30:40 <pcreech> !here
14:30:40 <pcreech> #info pcreech has joined triage
14:30:41 <pulpbot> pcreech has joined triage
14:31:26 <ttereshc> bmbouter, any thoughts on this one?
14:32:10 <bmbouter> I think we should triage it
14:32:24 <bmbouter> and I can take an action item to touch up the checklist based on the latest discussion
14:32:48 <ttereshc> sounds good, what about prio? normal?
14:33:01 <bmbouter> I think low
14:33:03 <bmbouter> low/low
14:33:26 <ttereshc> !propose triage l l
14:33:26 <ttereshc> #idea Proposed for #2749: Priority: Low, Severity: Low
14:33:26 <pulpbot> Proposed for #2749: Priority: Low, Severity: Low
14:33:32 <ttereshc> !accept
14:33:32 <ttereshc> #agreed Priority: Low, Severity: Low
14:33:32 <pulpbot> Current proposal accepted: Priority: Low, Severity: Low
14:33:34 <ttereshc> #topic Documentation on Pulp's storage logic - http://pulp.plan.io/issues/2758
14:33:34 <pulpbot> 4 issues left to triage: 2758, 2772, 2773, 2774
14:33:35 <pulpbot> Pulp Issue #2758 [NEW] (unassigned) - Priority: Normal | Severity: Low
14:33:36 <pulpbot> Documentation on Pulp's storage logic - http://pulp.plan.io/issues/2758
14:33:49 <jortel> !here
14:33:49 <jortel> #info jortel has joined triage
14:33:49 <pulpbot> jortel has joined triage
14:33:50 <dkliban> i updated this issue after my discussion with Ashton
14:34:14 <dkliban> the description now has 4 specific things that we should add documentation about
14:34:24 <ttereshc> dkliban, I think we have documented unit_key fields for every unit
14:34:24 <dkliban> i propose accepting as is and adding it to the sprint
14:34:52 <ttereshc> isn't it the first item on the list?
14:34:54 <ttereshc> dkliban,
14:35:34 <dkliban> ttereshc: that's good ... we should create a page in our docs that links to each plugins unit key ... and has some explanations abou tit
14:35:55 <ttereshc> ok
14:36:15 <ttereshc> !propose triage normal/low and add to sprint
14:36:15 <pulpbot> (propose triage <priority> <severity> [target_release]) -- Propose triage values including priority, severity, and an optional target release.
14:36:23 <ttereshc> !propose other triage normal/low and add to sprint
14:36:23 <ttereshc> #idea Proposed for #2758: triage normal/low and add to sprint
14:36:23 <pulpbot> Proposed for #2758: triage normal/low and add to sprint
14:36:25 <dkliban> +1
14:36:28 <dralley> +1
14:36:37 <ipanova> +1
14:36:46 <ttereshc> !accept
14:36:46 <ttereshc> #agreed triage normal/low and add to sprint
14:36:46 <pulpbot> Current proposal accepted: triage normal/low and add to sprint
14:36:48 <ttereshc> #topic Unable to Sync with upstream Redhat repo in AWS - http://pulp.plan.io/issues/2772
14:36:48 <pulpbot> 3 issues left to triage: 2772, 2773, 2774
14:36:49 <pulpbot> Pulp Issue #2772 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:36:50 <pulpbot> Unable to Sync with upstream Redhat repo in AWS - http://pulp.plan.io/issues/2772
14:36:58 <dkliban> i don't think this is a bug
14:37:03 <dkliban> let's skip it for now though
14:37:07 <bmbouter> yeah I think it's a feature
14:37:23 <bmbouter> and it needs to be rewritten to be like its related issue
14:37:32 <bmbouter> let's not skip, just convert to  a story and give me action item to rewrite
14:37:44 <ttereshc> any volunteers to rewrite it?
14:37:58 <bmbouter> I will
14:37:59 <dkliban> bmbouter
14:38:14 <bmbouter> I'll do both of those rewrites soon this morning
14:38:21 <ttereshc> !propose other convert to story and bmbouter will rewrite it
14:38:21 <ttereshc> #idea Proposed for #2772: convert to story and bmbouter will rewrite it
14:38:22 <pulpbot> Proposed for #2772: convert to story and bmbouter will rewrite it
14:38:29 <bmbouter> +1
14:38:30 <ttereshc> !accept
14:38:30 <ttereshc> #agreed convert to story and bmbouter will rewrite it
14:38:31 <pulpbot> Current proposal accepted: convert to story and bmbouter will rewrite it
14:38:31 <ttereshc> #topic ISO repo does not handle updates to files on manifest during re-sync correctly - http://pulp.plan.io/issues/2773
14:38:32 <pulpbot> 2 issues left to triage: 2773, 2774
14:38:33 <pulpbot> RPM Support Issue #2773 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:38:33 <ttereshc> thanks, bmbouter
14:38:33 <pulpbot> ISO repo does not handle updates to files on manifest during re-sync correctly - http://pulp.plan.io/issues/2773
14:40:08 <dkliban> this sounds like a major bug
14:40:32 <ttereshc> yeah... I agree
14:40:48 <ttereshc> and it is there at least from 2.9
14:41:25 <ttereshc> high/high?
14:41:45 <dkliban> i think so
14:41:55 <dralley> +1
14:42:05 <ttereshc> !propose triage h h
14:42:05 <ttereshc> #idea Proposed for #2773: Priority: High, Severity: High
14:42:05 <pulpbot> Proposed for #2773: Priority: High, Severity: High
14:42:35 <ttereshc> seems like no objections
14:42:38 <ttereshc> !accept
14:42:38 <ttereshc> #agreed Priority: High, Severity: High
14:42:38 <pulpbot> Current proposal accepted: Priority: High, Severity: High
14:42:40 <ttereshc> #topic Inconsistent Checksum and Checksumtype when uploading with --checksum-type - http://pulp.plan.io/issues/2774
14:42:40 <pulpbot> 1 issues left to triage: 2774
14:42:41 <pulpbot> RPM Support Issue #2774 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:42:42 <pulpbot> Inconsistent Checksum and Checksumtype when uploading with --checksum-type - http://pulp.plan.io/issues/2774
14:43:01 <bmbouter> we need a comment from RCM if this is a blocker for their upgrade to vanilla or not
14:43:18 <ipanova> oh i checked this one
14:43:31 <ipanova> https://github.com/pulp/pulp_rpm/blame/master/extensions_admin/pulp_rpm/extensions/admin/upload/package.py#L220
14:43:32 <pulpbot> Title: pulp_rpm/extensions_admin/pulp_rpm/extensions/admin/upload/package.py at master · pulp/pulp_rpm · GitHub (at github.com)
14:43:35 <bmbouter> ipanova: should I comment on it asking RCM if it is a blocker from them?
14:43:42 <ipanova> looks like we hardcoded the checksumtype
14:43:45 <bmbouter> or if you want to
14:44:14 <ipanova> bmbouter:  i can add the comment
14:45:20 <ttereshc> if it is a pulp-admin issue then it is not that severe
14:45:36 <ttereshc> !propose accept
14:45:36 <ttereshc> #idea Proposed for #2774: Leave the issue as-is, accepting its current state.
14:45:37 <pulpbot> Proposed for #2774: Leave the issue as-is, accepting its current state.
14:45:48 <ttereshc> assuming that it works correctly via API
14:45:56 <ipanova> ttereshc: i am not sure about this
14:46:01 <bmbouter> ipanova: ty, if it is labeled as blocker then we should add to sprint
14:46:09 <ipanova> ttereshc: i think via api you would get same result
14:46:09 <bmbouter> maybe we should not triage until it's known?
14:46:26 <bmbouter> If its a blocker for them I don't want to triage and forget
14:46:27 <ipanova> bmbouter: gotcha, i will get the info from rcm
14:46:33 <ttereshc> bmbouter, that's a good point, we also can try to reproduce
14:46:45 <ttereshc> !propose skip
14:46:45 <ttereshc> #idea Proposed for #2774: Skip this issue for this triage session.
14:46:46 <pulpbot> Proposed for #2774: Skip this issue for this triage session.
14:47:13 <bmbouter> +1 to skip
14:47:17 <dkliban> +1
14:47:19 <bmbouter> and ipanova to comment asking for blocker status
14:47:30 <bmbouter> I think we need to know that for any RCM issue pre-triage
14:47:38 <ttereshc> !propose other skip and ipanova to comment asking for blocker status
14:47:38 <ttereshc> #idea Proposed for #2774: skip and ipanova to comment asking for blocker status
14:47:38 <pulpbot> Proposed for #2774: skip and ipanova to comment asking for blocker status
14:47:41 <ipanova> +1
14:47:42 <ttereshc> !accept
14:47:42 <ttereshc> #agreed skip and ipanova to comment asking for blocker status
14:47:42 <pulpbot> Current proposal accepted: skip and ipanova to comment asking for blocker status
14:47:43 <pulpbot> No issues to triage.
14:47:46 <bmbouter> s/pre-triage/in order to triage/
14:47:51 <ttereshc> !end
14:47:51 <ttereshc> #endmeeting