14:29:29 <ttereshc> #startmeeting Pulp Triage 2017-06-02
14:29:29 <ttereshc> #info ttereshc has joined triage
14:29:30 <pulpbot> Meeting started Fri Jun  2 14:29:29 2017 UTC and is due to finish in 60 minutes.  The chair is ttereshc. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:29:30 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:29:30 <pulpbot> The meeting name has been set to 'pulp_triage_2017_06_02'
14:29:30 <pulpbot> ttereshc has joined triage
14:29:41 <fdobrovo> bmbouter Yes I think so
14:29:44 <pcreech> !here
14:29:44 <pcreech> #info pcreech has joined triage
14:29:44 <pulpbot> pcreech has joined triage
14:29:52 <mhrivnak> !here
14:29:52 <mhrivnak> #info mhrivnak has joined triage
14:29:52 <pulpbot> mhrivnak has joined triage
14:29:53 <daviddavis> !here
14:29:53 <daviddavis> #info daviddavis has joined triage
14:29:53 <pulpbot> daviddavis has joined triage
14:29:56 <bizhang> !here
14:29:56 <bizhang> #info bizhang has joined triage
14:29:57 <pulpbot> bizhang has joined triage
14:29:57 <fdobrovo> bmbouter, And I just updated the https://github.com/pulp/pulp/pull/3002
14:29:58 <pulpbot> Title: Update apply_async and apply_async_with_reservations signatures by BrnoPCmaniak · Pull Request #3002 · pulp/pulp · GitHub (at github.com)
14:29:59 <ttereshc> !next
14:30:00 <pulpbot> 5 issues left to triage: 2783, 2784, 2785, 2786, 2788
14:30:00 <ttereshc> #topic CopyDirectoryStep should copy mtime - http://pulp.plan.io/issues/2783
14:30:01 <pulpbot> RPM Support Issue #2783 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:30:02 <pulpbot> CopyDirectoryStep should copy mtime - http://pulp.plan.io/issues/2783
14:30:09 <dkliban> !here
14:30:09 <dkliban> #info dkliban has joined triage
14:30:09 <ipanova> !here
14:30:09 <ipanova> #info ipanova has joined triage
14:30:09 <pulpbot> dkliban has joined triage
14:30:10 <pulpbot> ipanova has joined triage
14:30:40 <fdobrovo> !here
14:30:40 <fdobrovo> #info fdobrovo has joined triage
14:30:40 <pulpbot> fdobrovo has joined triage
14:31:03 <ipanova> i think we should fix this one from proposed options to unblock rcm
14:31:06 <dkliban> looks important to me
14:31:10 <dralley> !here
14:31:10 <dralley> #info dralley has joined triage
14:31:11 <mhrivnak> agreed
14:31:11 <pulpbot> dralley has joined triage
14:31:31 <ttereshc> I agree with ipanova that this one is a good candidate and it also will be helpful for troubleshooting purposes for gss
14:31:48 <ttereshc> !propose accept
14:31:48 <ttereshc> #idea Proposed for #2783: Leave the issue as-is, accepting its current state.
14:31:48 <pulpbot> Proposed for #2783: Leave the issue as-is, accepting its current state.
14:32:12 <mhrivnak> and mark as sprint candidate so we consider it for the next sprint
14:32:13 <daviddavis> +1
14:32:16 <fdobrovo> +1
14:32:20 <ipanova> +1 mhrivnak
14:32:22 <bmbouter> !here
14:32:22 <bmbouter> #info bmbouter has joined triage
14:32:22 <ttereshc> will do , mhrivnak
14:32:22 <pulpbot> bmbouter has joined triage
14:32:26 <ttereshc> !accept
14:32:26 <ttereshc> #agreed Leave the issue as-is, accepting its current state.
14:32:26 <pulpbot> Current proposal accepted: Leave the issue as-is, accepting its current state.
14:32:27 <pulpbot> 4 issues left to triage: 2784, 2785, 2786, 2788
14:32:27 <ttereshc> #topic Pulp spec file does not contain a proper Source0 - http://pulp.plan.io/issues/2784
14:32:28 <pulpbot> Pulp Issue #2784 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:32:29 <pulpbot> Pulp spec file does not contain a proper Source0 - http://pulp.plan.io/issues/2784
14:32:41 <bmbouter> this probably should be in POST
14:32:52 <pcreech> Yup, should be POST
14:33:05 <ttereshc> #idea Proposed for #2784: Leave the issue as-is, accepting its current state.
14:33:05 <ttereshc> !propose accept
14:33:05 <pulpbot> Proposed for #2784: Leave the issue as-is, accepting its current state.
14:33:07 <ipanova> +1
14:33:12 <pcreech> +1
14:33:14 <ttereshc> !accept
14:33:14 <ttereshc> #agreed Leave the issue as-is, accepting its current state.
14:33:14 <pulpbot> Current proposal accepted: Leave the issue as-is, accepting its current state.
14:33:15 <pulpbot> 3 issues left to triage: 2785, 2786, 2788
14:33:16 <ttereshc> #topic pulp-admin rpm repo create with --retain-old-count option does not seem to work - http://pulp.plan.io/issues/2785
14:33:16 <pulpbot> Pulp Issue #2785 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:33:18 <pulpbot> pulp-admin rpm repo create with --retain-old-count option does not seem to work - http://pulp.plan.io/issues/2785
14:33:56 <mhrivnak> Maybe ask the user to list the packages they saw, and the ones they expected to see?
14:34:11 <dkliban> do we have pulp-smash tests for this?
14:34:39 <ipanova> mhrivnak: i asked, he probably forgot or did not understand what i meant
14:34:52 <mhrivnak> dkliban good question. We certainly should.
14:35:02 <ttereshc> ipanova, would you like to follow up with your favorite user? ^ and skip it for now?
14:35:32 <mhrivnak> yes there is a smash test
14:35:42 <ttereshc> !propose needinfo
14:35:42 <ttereshc> #idea Proposed for #2785: This issue cannot be triaged without more info.
14:35:43 <ipanova> mhrivnak:  we already have smash test for this options, maybe just to extend the test
14:35:43 <pulpbot> Proposed for #2785: This issue cannot be triaged without more info.
14:35:43 <mhrivnak> pulp_smash/tests/rpm/api_v2/test_retain_old_count.py
14:36:12 <ipanova> ttereshc: i can ping him when i see him online, yes
14:36:26 <ttereshc> ipanova, maybe put a comment onthe issue itself?
14:36:38 <mhrivnak> +1
14:36:43 <bmbouter> +1
14:36:44 <dkliban> +1
14:36:51 <ttereshc> !accept
14:36:51 <ttereshc> #agreed This issue cannot be triaged without more info.
14:36:51 <pulpbot> Current proposal accepted: This issue cannot be triaged without more info.
14:36:52 <pulpbot> 2 issues left to triage: 2786, 2788
14:36:53 <ttereshc> #topic The content wsgi does not respect logging configuration - http://pulp.plan.io/issues/2786
14:36:53 <pulpbot> Pulp Issue #2786 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:36:55 <pulpbot> The content wsgi does not respect logging configuration - http://pulp.plan.io/issues/2786
14:36:58 <ipanova> i will
14:37:11 <ttereshc> post? and accept?
14:38:00 <bmbouter> yes I think so
14:38:13 <ipanova> +1
14:38:17 <bmbouter> ehelms: I didn't realize you put in a PR for this issue also, nice  https://github.com/pulp/pulp/pull/3041/files
14:38:17 <ttereshc> !propose accept
14:38:17 <ttereshc> #idea Proposed for #2786: Leave the issue as-is, accepting its current state.
14:38:17 <pulpbot> Proposed for #2786: Leave the issue as-is, accepting its current state.
14:38:18 <pulpbot> Title: fixes #2786: Allow content application to use console logging by ehelms · Pull Request #3041 · pulp/pulp · GitHub (at github.com)
14:38:24 <mhrivnak> +1
14:38:26 <ttereshc> !accept
14:38:26 <ttereshc> #agreed Leave the issue as-is, accepting its current state.
14:38:26 <pulpbot> Current proposal accepted: Leave the issue as-is, accepting its current state.
14:38:27 <pulpbot> 1 issues left to triage: 2788
14:38:28 <ttereshc> #topic sqlite files are retained indefinitely - http://pulp.plan.io/issues/2788
14:38:28 <pulpbot> RPM Support Issue #2788 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:38:29 <pulpbot> sqlite files are retained indefinitely - http://pulp.plan.io/issues/2788
14:39:16 <ttereshc> I think it is not a must but nice to have one
14:39:17 <ehelms> bmbouter: trying to do my part :)
14:39:22 <mhrivnak> This is definitely surprising.
14:39:41 <ttereshc> and as ipanova mentioned slows down rsync publish
14:39:54 <ipanova> i  suggest not fix this if we fix the mtime
14:40:21 <mhrivnak> Seems reasonable. We can accept the bug in case someone else would like to fix it.
14:40:25 <ipanova> i suggest ti put this as related, and check if mtime would fix the slowdown issue of publish, in case it is - then not fix it
14:40:39 <ttereshc> repodata will be more sane if we fix this, we don't keep any other
14:41:02 <ipanova> also jluza_ is considering to submit a patch in case we gonna fix that eventually
14:41:06 <ttereshc> !propose accept
14:41:06 <ttereshc> #idea Proposed for #2788: Leave the issue as-is, accepting its current state.
14:41:08 <pulpbot> Proposed for #2788: Leave the issue as-is, accepting its current state.
14:41:14 <mhrivnak> Yep. It's also worth noting that these files may be going out of style. DNF does not use them and has no plans to.
14:41:45 <mhrivnak> +1
14:41:47 <ipanova> +1
14:41:47 <pulpbot> ipanova: That's Numberwang!
14:41:58 <ttereshc> !accept
14:41:58 <ttereshc> #agreed Leave the issue as-is, accepting its current state.
14:41:58 <pulpbot> Current proposal accepted: Leave the issue as-is, accepting its current state.
14:42:00 <pulpbot> No issues to triage.
14:42:05 <ttereshc> !end
14:42:05 <ttereshc> #endmeeting