14:29:17 <ttereshc> #startmeeting Pulp Triage 2017-06-13
14:29:17 <ttereshc> #info ttereshc has joined triage
14:29:18 <pulpbot> Meeting started Tue Jun 13 14:29:17 2017 UTC and is due to finish in 60 minutes.  The chair is ttereshc. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:29:18 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:29:18 <pulpbot> The meeting name has been set to 'pulp_triage_2017_06_13'
14:29:18 <pulpbot> ttereshc has joined triage
14:29:36 <ipanova> i feel like https://www.youtube.com/watch?v=BuB20drdeeY
14:29:41 <daviddavis> !here
14:29:41 <daviddavis> #info daviddavis has joined triage
14:29:42 <pulpbot> daviddavis has joined triage
14:29:42 <mhrivnak> !here
14:29:42 <mhrivnak> #info mhrivnak has joined triage
14:29:43 <pulpbot> mhrivnak has joined triage
14:29:45 <ttereshc> !next
14:29:46 <pulpbot> 4 issues left to triage: 2808, 2809, 2811, 2814
14:29:47 <ttereshc> #topic Clarify use of `pulp-consumer` - http://pulp.plan.io/issues/2808
14:29:47 <pulpbot> Pulp Issue #2808 [POST] (kdelee@redhat.com) - Priority: Normal | Severity: Low
14:29:48 <pulpbot> Clarify use of `pulp-consumer` - http://pulp.plan.io/issues/2808
14:29:51 <bizhang> !here
14:29:51 <bizhang> #info bizhang has joined triage
14:29:51 <pulpbot> bizhang has joined triage
14:29:57 <ttereshc> !propose accept
14:29:57 <ttereshc> #idea Proposed for #2808: Leave the issue as-is, accepting its current state.
14:29:58 <pulpbot> Proposed for #2808: Leave the issue as-is, accepting its current state.
14:29:59 <mhrivnak> +1
14:30:14 <ttereshc> !accept
14:30:14 <ttereshc> #agreed Leave the issue as-is, accepting its current state.
14:30:14 <pulpbot> Current proposal accepted: Leave the issue as-is, accepting its current state.
14:30:16 <ttereshc> #topic getting an error "'ascii' codec can't decode byte 0xc3 in position 48: ordinal not in range(128)" when syncing a repository  - http://pulp.plan.io/issues/2809
14:30:16 <pulpbot> 3 issues left to triage: 2809, 2811, 2814
14:30:17 <pulpbot> Pulp Issue #2809 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:30:18 <pulpbot> getting an error "'ascii' codec can't decode byte 0xc3 in position 48: ordinal not in range(128)" when syncing a repository  - http://pulp.plan.io/issues/2809
14:30:34 <ttereshc> !propose other close as NOTABUG
14:30:34 <ttereshc> #idea Proposed for #2809: close as NOTABUG
14:30:35 <pulpbot> Proposed for #2809: close as NOTABUG
14:30:40 <ipanova> +1
14:30:45 <bizhang> +1
14:31:02 <mhrivnak> hang on
14:31:06 <dkliban> !here
14:31:06 <dkliban> #info dkliban has joined triage
14:31:06 <pulpbot> dkliban has joined triage
14:31:19 <pcreech> +1
14:31:25 <mhrivnak> Might be user error in this case, but is it valid generally to have non-ascii in a URL?
14:31:45 <bmbouter> !here
14:31:45 <bmbouter> #info bmbouter has joined triage
14:31:45 <jortel> +1
14:31:45 <pulpbot> bmbouter has joined triage
14:31:59 <dalley> !here
14:31:59 <dalley> #info dalley has joined triage
14:32:00 <pulpbot> dalley has joined triage
14:32:21 <ttereshc> mhrivnak, I think such symbols should be escaped
14:32:24 <bmbouter> I'm not sure what the url spec encoding is
14:32:30 <pcreech> mhrivnak: i don't think so without standard percent encodings
14:32:45 <mhrivnak> gotcha.
14:32:58 <pcreech> per rfc it's ascii (i'm pretty sure)
14:33:09 <mhrivnak> Quick googling suggests the same, that spelling out the utf8 with percent-encoding is the way to go.
14:33:18 <daviddavis> "No, they are not allowed. Just check the ABNF in RFC 3986.
14:33:20 <daviddavis> "
14:33:44 <mhrivnak> That said, I think there's still a bug here.
14:33:52 <mhrivnak> Our logging shouldn't explode. :)
14:34:01 <mhrivnak> low-priority perhaps, but a bug none the less.
14:34:15 <daviddavis> I concur
14:34:24 <dalley> +1
14:34:38 <ttereshc> !propose other convert to logging bug and triage as low/low
14:34:38 <ttereshc> #idea Proposed for #2809: convert to logging bug and triage as low/low
14:34:39 <pulpbot> Proposed for #2809: convert to logging bug and triage as low/low
14:34:46 <mhrivnak> +1
14:34:56 <ipanova> +1
14:35:04 <ttereshc> !accept
14:35:04 <ttereshc> #agreed convert to logging bug and triage as low/low
14:35:04 <pulpbot> Current proposal accepted: convert to logging bug and triage as low/low
14:35:05 <pulpbot> 2 issues left to triage: 2811, 2814
14:35:06 <ttereshc> #topic importers URL no longer available in the pulp 3 API - http://pulp.plan.io/issues/2811
14:35:06 <pulpbot> Pulp Issue #2811 [POST] (dkliban@redhat.com) - Priority: Normal | Severity: Medium
14:35:07 <pulpbot> importers URL no longer available in the pulp 3 API - http://pulp.plan.io/issues/2811
14:35:22 <ttereshc> !propose accept
14:35:22 <ttereshc> #idea Proposed for #2811: Leave the issue as-is, accepting its current state.
14:35:22 <pulpbot> Proposed for #2811: Leave the issue as-is, accepting its current state.
14:35:23 <dkliban> this should be at modified
14:35:47 <mhrivnak> and on this sprint I assume?
14:35:50 <bmbouter> andyup
14:35:50 <ipanova> +1
14:35:52 <bmbouter> yup
14:35:52 <dkliban> the pulp_file plugin needs to be configured with redmine ... the issue should be at modified
14:36:01 <ipanova> dkliban: maybe you to manually associate the commit
14:36:03 <bmbouter> I can configure that
14:36:11 <ipanova> oh i see
14:36:16 <bmbouter> but dkliban can you manually associate the commit?
14:36:21 <ttereshc> !propose other triage as-is and add to sprint
14:36:21 <ttereshc> #idea Proposed for #2811: triage as-is and add to sprint
14:36:21 <pulpbot> Proposed for #2811: triage as-is and add to sprint
14:36:26 <dkliban> ipanova: bmbouter : i will manually associate it
14:36:34 <ipanova> dkliban: thank you
14:36:35 <ipanova> +1
14:36:39 <ttereshc> !accept
14:36:39 <ttereshc> #agreed triage as-is and add to sprint
14:36:39 <pulpbot> Current proposal accepted: triage as-is and add to sprint
14:36:40 <pulpbot> 1 issues left to triage: 2814
14:36:41 <ttereshc> #topic API for resources that use HyperlinkedRelatedFields in serializers require full URL of related resource - http://pulp.plan.io/issues/2814
14:36:41 <pulpbot> Pulp Issue #2814 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:36:42 <pulpbot> API for resources that use HyperlinkedRelatedFields in serializers require full URL of related resource - http://pulp.plan.io/issues/2814
14:36:56 <dkliban> another 3.0 bug
14:37:09 <mhrivnak> A complicated one at that.
14:37:30 <dkliban> mhrivnak: yeah ... i've started digging into a solution ... but it's not comlete yet
14:37:45 <dkliban> i decided to just file the issue for now so we can all discuss
14:37:52 <mhrivnak> dkliban I'm interested to hear about what you have in mind.
14:38:03 <mhrivnak> after triage of course. :)
14:38:10 <dkliban> mhrivnak: i'll add more infor to the ticket
14:38:43 <ttereshc> any suggestions for prio/sev?
14:38:59 <dkliban> normal/mediu,
14:39:04 <mhrivnak> +1
14:39:04 <ttereshc> !propose accept
14:39:04 <ttereshc> #idea Proposed for #2814: Leave the issue as-is, accepting its current state.
14:39:05 <pulpbot> Proposed for #2814: Leave the issue as-is, accepting its current state.
14:39:10 <ttereshc> !accept
14:39:10 <ttereshc> #agreed Leave the issue as-is, accepting its current state.
14:39:11 <pulpbot> Current proposal accepted: Leave the issue as-is, accepting its current state.
14:39:12 <pulpbot> No issues to triage.
14:39:17 <ttereshc> !end
14:39:17 <ttereshc> #endmeeting