14:39:10 <asmacdo> #startmeeting Pulp Triage 2017-06-20
14:39:10 <asmacdo> #info asmacdo has joined triage
14:39:11 <pulpbot> Meeting started Tue Jun 20 14:39:10 2017 UTC and is due to finish in 60 minutes.  The chair is asmacdo. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:39:11 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:39:11 <pulpbot> The meeting name has been set to 'pulp_triage_2017_06_20'
14:39:11 <pulpbot> asmacdo has joined triage
14:39:17 <asmacdo> yeah!
14:39:22 <mhrivnak> Maybe we need to introduce pulpbot to coffeebot.
14:39:34 <mhrivnak> So pulpbot can get to work on time.
14:39:37 <asmacdo> wanna join up?
14:39:47 <mhrivnak> !here
14:39:47 <mhrivnak> #info mhrivnak has joined triage
14:39:47 <pulpbot> mhrivnak has joined triage
14:39:57 <dalley> !here
14:39:57 <dalley> #info dalley has joined triage
14:39:58 <pulpbot> dalley has joined triage
14:39:59 <asmacdo> !next
14:40:00 <pulpbot> 3 issues left to triage: 2821, 2824, 2825
14:40:00 <asmacdo> #topic sles12 updates repo fails sync - http://pulp.plan.io/issues/2821
14:40:00 <mansari> !here
14:40:00 <mansari> #info mansari has joined triage
14:40:00 <pulpbot> Pulp Issue #2821 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:40:01 <pulpbot> sles12 updates repo fails sync - http://pulp.plan.io/issues/2821
14:40:02 <pulpbot> mansari has joined triage
14:40:13 <asmacdo> !propose accept
14:40:13 <asmacdo> #idea Proposed for #2821: Leave the issue as-is, accepting its current state.
14:40:14 <pulpbot> Proposed for #2821: Leave the issue as-is, accepting its current state.
14:40:25 <daviddavis> !here
14:40:25 <daviddavis> #info daviddavis has joined triage
14:40:26 <pulpbot> daviddavis has joined triage
14:40:27 <asmacdo> mhrivnak: would you mind leaving the comment asking for metdata?
14:40:34 <mhrivnak> will do
14:40:41 <asmacdo> !accept
14:40:41 <asmacdo> #agreed Leave the issue as-is, accepting its current state.
14:40:41 <pulpbot> Current proposal accepted: Leave the issue as-is, accepting its current state.
14:40:42 <pulpbot> 2 issues left to triage: 2824, 2825
14:40:42 <asmacdo> #topic Name isn't returned when querying repos - http://pulp.plan.io/issues/2824
14:40:43 <pulpbot> Pulp Issue #2824 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:40:44 <pulpbot> Name isn't returned when querying repos - http://pulp.plan.io/issues/2824
14:42:06 <mhrivnak> !propose accept
14:42:06 <mhrivnak> #idea Proposed for #2824: Leave the issue as-is, accepting its current state.
14:42:06 <pulpbot> Proposed for #2824: Leave the issue as-is, accepting its current state.
14:42:26 <mhrivnak> and add to sprint if anyone wants to grab it. Should be a very easy fix.
14:42:38 <asmacdo> i dont think we have enough info
14:42:48 <asmacdo> do we want name to be returned?
14:43:08 <mhrivnak> It's the natural key, so I think we do.
14:43:25 <mhrivnak> It's also the only thing the user has to supply when creating a repo.
14:43:37 <mhrivnak> So it would be weird for it to not be returned in the representation.
14:43:49 <mhrivnak> or be searchable.
14:44:10 <asmacdo> it should be searchable
14:44:28 <asmacdo> the reason i'm holding out here is that we had talked about some other ideas
14:44:39 <mhrivnak> It would be real weird for an invisible field to be searchable.
14:44:43 <asmacdo> like [(name, href)]
14:45:15 <mhrivnak> what would ^ be?
14:45:27 <asmacdo> we had talked about that for nested urls
14:45:34 <asmacdo> v3/repositories/
14:45:52 <asmacdo> returns a list of k,v names and hrefs
14:46:42 <mhrivnak> That's interesting, but seems separate.
14:46:58 <asmacdo> ok
14:47:09 <asmacdo> !propose other convert to story
14:47:09 <asmacdo> #idea Proposed for #2824: convert to story
14:47:10 <pulpbot> Proposed for #2824: convert to story
14:47:40 <mhrivnak> what would the story be?
14:48:09 <asmacdo> as a user i can see the name of repositories
14:48:59 <mhrivnak> I could go with that, but it sure seems like a big ole bug that the representation for an object omits the unique identifier, and the only part of the representation the user must supply.
14:49:07 <mhrivnak> It's an incomplete representation.
14:49:26 <asmacdo> its not a bug, it was a choice to represent repositories by their hyperlink. we will probably need to create a second serializer
14:49:43 <mhrivnak> Hm, ok. Story is fine with me then.
14:50:01 <asmacdo> !accept
14:50:01 <asmacdo> #agreed convert to story
14:50:01 <pulpbot> Current proposal accepted: convert to story
14:50:02 <asmacdo> #topic pulp-admin client improperly base64 encode (very long) user credentials for basic auth - http://pulp.plan.io/issues/2825
14:50:03 <pulpbot> 1 issues left to triage: 2825
14:50:04 <pulpbot> Pulp Issue #2825 [NEW] (unassigned) - Priority: Normal | Severity: High
14:50:05 <pulpbot> pulp-admin client improperly base64 encode (very long) user credentials for basic auth - http://pulp.plan.io/issues/2825
14:52:11 <mhrivnak> oh, a PR!
14:52:32 <asmacdo> i just saw that too!
14:52:49 <mhrivnak> !propose accept
14:52:49 <mhrivnak> #idea Proposed for #2825: Leave the issue as-is, accepting its current state.
14:52:49 <pulpbot> Proposed for #2825: Leave the issue as-is, accepting its current state.
14:52:58 <dalley> encodestring is deprecated also, bonus reason to change
14:53:12 <asmacdo> this is great
14:53:23 <asmacdo> !accept
14:53:23 <asmacdo> #agreed Leave the issue as-is, accepting its current state.
14:53:23 <pulpbot> Current proposal accepted: Leave the issue as-is, accepting its current state.
14:53:24 <pulpbot> No issues to triage.
14:53:42 <asmacdo> !end
14:53:42 <asmacdo> #endmeeting