14:29:27 <ttereshc> #startmeeting Pulp Triage 2017-06-23
14:29:27 <ttereshc> #info ttereshc has joined triage
14:29:28 <pulpbot> Meeting started Fri Jun 23 14:29:27 2017 UTC and is due to finish in 60 minutes.  The chair is ttereshc. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:29:28 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:29:28 <pulpbot> The meeting name has been set to 'pulp_triage_2017_06_23'
14:29:28 <pulpbot> ttereshc has joined triage
14:29:30 <daviddavis> !here
14:29:30 <daviddavis> #info daviddavis has joined triage
14:29:30 <pulpbot> daviddavis has joined triage
14:29:37 <pcreech> !here
14:29:37 <pcreech> #info pcreech has joined triage
14:29:37 <pulpbot> pcreech has joined triage
14:29:46 <bmbouter> !here
14:29:46 <bmbouter> #info bmbouter has joined triage
14:29:47 <pulpbot> bmbouter has joined triage
14:29:54 <mansari> !here
14:29:54 <mansari> #info mansari has joined triage
14:29:54 <pulpbot> mansari has joined triage
14:29:55 <ttereshc> !next
14:29:56 <pulpbot> 9 issues left to triage: 2826, 2827, 2828, 2830, 2831, 2832, 2834, 2835, 2836
14:29:56 <ttereshc> #topic Repository deletion fails with no such file for a repositories listing file - http://pulp.plan.io/issues/2826
14:29:57 <pulpbot> Pulp Issue #2826 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:29:58 <pulpbot> Repository deletion fails with no such file for a repositories listing file - http://pulp.plan.io/issues/2826
14:31:14 <dalley> !here
14:31:14 <dalley> #info dalley has joined triage
14:31:15 <pulpbot> dalley has joined triage
14:31:19 <dkliban> i think this is a specific bug with how katello uses pulp
14:31:22 <dkliban> !here
14:31:22 <dkliban> #info dkliban has joined triage
14:31:23 <pulpbot> dkliban has joined triage
14:31:33 <ttereshc> yeah, dkliban I also think so
14:31:41 <ttereshc> I suggest to find more info to triage later
14:31:42 <dkliban> we should try to reproduce this
14:31:57 <dkliban> i think i know how to reproduce it
14:32:13 <dkliban> i'll add a note to the issue, but we can accept as is
14:32:39 <ttereshc> !propose accept and dkliban will leave a comment how to reproduce
14:32:39 <pulpbot> propose accept Propose accepting the current issue in its current state.
14:32:51 <ttereshc> !propose other accept and dkliban will leave a comment how to reproduce
14:32:51 <ttereshc> #idea Proposed for #2826: accept and dkliban will leave a comment how to reproduce
14:32:52 <pulpbot> Proposed for #2826: accept and dkliban will leave a comment how to reproduce
14:32:55 <ttereshc> !accept
14:32:55 <ttereshc> #agreed accept and dkliban will leave a comment how to reproduce
14:32:55 <pulpbot> Current proposal accepted: accept and dkliban will leave a comment how to reproduce
14:32:57 <ttereshc> #topic Pulp resource lock mechanism is not working correctly - http://pulp.plan.io/issues/2827
14:32:57 <pulpbot> 8 issues left to triage: 2827, 2828, 2830, 2831, 2832, 2834, 2835, 2836
14:32:59 <pulpbot> Pulp Issue #2827 [NEW] (unassigned) - Priority: High | Severity: Medium
14:33:00 <pulpbot> Pulp resource lock mechanism is not working correctly - http://pulp.plan.io/issues/2827
14:33:42 <dkliban> i think we decided to close this as not a bug
14:33:56 <dkliban> since the issue was reported on a fork of Pulp
14:34:03 <dalley> yeah, RCM's fork..
14:34:04 <asmacdo> 2 celerybeats
14:34:17 <ttereshc> !propose other close as notabug
14:34:17 <ttereshc> #idea Proposed for #2827: close as notabug
14:34:17 <pulpbot> Proposed for #2827: close as notabug
14:34:23 <dkliban> asmacdo: we support that now .
14:34:38 <bmbouter> yeah that is supported now :)
14:34:59 <asmacdo> are they on the version that supports that?
14:34:59 <ttereshc> !accept
14:34:59 <ttereshc> #agreed close as notabug
14:34:59 <pulpbot> Current proposal accepted: close as notabug
14:35:00 <pulpbot> 7 issues left to triage: 2828, 2830, 2831, 2832, 2834, 2835, 2836
14:35:00 <ttereshc> #topic yum plugin documentation states that ssl_client_cert is looking for a file and not certificate data - http://pulp.plan.io/issues/2828
14:35:01 <pulpbot> Pulp Issue #2828 [NEW] (unassigned) - Priority: Normal | Severity: Low
14:35:02 <pulpbot> yum plugin documentation states that ssl_client_cert is looking for a file and not certificate data - http://pulp.plan.io/issues/2828
14:35:10 <bmbouter> asmacdo: they are not yet
14:35:39 <ttereshc> !propose triage low low
14:35:39 <ttereshc> #idea Proposed for #2828: Priority: Low, Severity: Low
14:35:40 <pulpbot> Proposed for #2828: Priority: Low, Severity: Low
14:37:15 <daviddavis> +1
14:37:23 <asmacdo> i was thinking a higher prio
14:37:35 <bmbouter> med would be fine I think
14:37:39 <asmacdo> esp since its just a little docs fix
14:37:42 <daviddavis> should that be under pulp_rpm
14:37:56 <ttereshc> !propose triage n l
14:37:56 <ttereshc> #idea Proposed for #2828: Priority: Normal, Severity: Low
14:37:56 <pulpbot> Proposed for #2828: Priority: Normal, Severity: Low
14:37:56 <bmbouter> maybe easy_fix?
14:38:05 <asmacdo> already easy fix
14:38:06 <bmbouter> oh it has that
14:38:12 * bmbouter misread the Category
14:38:13 <asmacdo> +1
14:38:22 <ttereshc> !accept
14:38:22 <ttereshc> #agreed Priority: Normal, Severity: Low
14:38:22 <pulpbot> Current proposal accepted: Priority: Normal, Severity: Low
14:38:23 <pulpbot> 6 issues left to triage: 2830, 2831, 2832, 2834, 2835, 2836
14:38:24 <ttereshc> #topic pulp-server installation - http://pulp.plan.io/issues/2830
14:38:24 <bmbouter> are we sure that pulp really onlly works this way?
14:38:24 <pulpbot> Pulp Issue #2830 [NEW] (unassigned) - Priority: Normal | Severity: Urgent
14:38:25 <pulpbot> pulp-server installation - http://pulp.plan.io/issues/2830
14:38:34 <daviddavis> skip
14:38:41 <pcreech> this should be fixed, verified by PSI-jack, wating on response from guy
14:38:44 <pcreech> will probably close in a few days
14:38:50 <bmbouter> I can post a comment on 2828 asking that question so ignore my question
14:39:01 <ttereshc> !propose skip
14:39:01 <ttereshc> #idea Proposed for #2830: Skip this issue for this triage session.
14:39:01 <pulpbot> Proposed for #2830: Skip this issue for this triage session.
14:39:35 <pcreech> +1
14:39:41 <ttereshc> !accept
14:39:41 <ttereshc> #agreed Skip this issue for this triage session.
14:39:41 <pulpbot> Current proposal accepted: Skip this issue for this triage session.
14:39:43 <ttereshc> #topic RFE: Changes to pulp_docker and crane metadata structure - http://pulp.plan.io/issues/2831
14:39:43 <pulpbot> 5 issues left to triage: 2831, 2832, 2834, 2835, 2836
14:39:45 <pulpbot> Crane Issue #2831 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:39:46 <pulpbot> RFE: Changes to pulp_docker and crane metadata structure - http://pulp.plan.io/issues/2831
14:40:08 <ttereshc> !propose other convert to story
14:40:08 <ttereshc> #idea Proposed for #2831: convert to story
14:40:09 <pulpbot> Proposed for #2831: convert to story
14:40:23 <asmacdo> this sounds like docker push
14:40:27 <bmbouter> yup
14:41:27 <ttereshc> !accept
14:41:27 <ttereshc> #agreed convert to story
14:41:28 <pulpbot> Current proposal accepted: convert to story
14:41:28 <daviddavis> why are they working on a registry vs patching crane?
14:41:29 <ttereshc> #topic jenkins unittest pr job failing for some plugins - http://pulp.plan.io/issues/2832
14:41:30 <pulpbot> 4 issues left to triage: 2832, 2834, 2835, 2836
14:41:31 <pulpbot> Pulp Issue #2832 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:41:32 <pulpbot> jenkins unittest pr job failing for some plugins - http://pulp.plan.io/issues/2832
14:41:34 <asmacdo> i agree this should be a story, but I'm not sure we can accept that
14:41:51 <bmbouter> making it a story just sends it to storyland
14:42:01 <asmacdo> i guess its not groomed
14:42:03 <ttereshc> !issue 2831
14:42:04 <ttereshc> #topic RFE: Changes to pulp_docker and crane metadata structure - http://pulp.plan.io/issues/2831
14:42:04 <asmacdo> +1 move on
14:42:04 <pulpbot> Crane Issue #2831 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:42:04 <daviddavis> my favorite amusement park
14:42:04 <pulpbot> RFE: Changes to pulp_docker and crane metadata structure - http://pulp.plan.io/issues/2831
14:42:28 <ttereshc> do we want to come back at some grooming session or discuss on pulp-dev?
14:42:41 <bmbouter> can we get a comment on it?
14:43:04 <bmbouter> maybe we can talk a bit more after this and convert to a story during triage?
14:43:22 <asmacdo> +1
14:43:25 <ttereshc> bmbouter, sure
14:43:29 <ttereshc> !next
14:43:30 <pulpbot> 4 issues left to triage: 2832, 2834, 2835, 2836
14:43:30 <ttereshc> #topic jenkins unittest pr job failing for some plugins - http://pulp.plan.io/issues/2832
14:43:31 <pulpbot> Pulp Issue #2832 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:43:32 <pulpbot> jenkins unittest pr job failing for some plugins - http://pulp.plan.io/issues/2832
14:44:19 <asmacdo> !propose accept
14:44:19 <asmacdo> #idea Proposed for #2832: Leave the issue as-is, accepting its current state.
14:44:19 <asmacdo> #info asmacdo has joined triage
14:44:19 <pulpbot> asmacdo has joined triage
14:44:20 <pulpbot> Proposed for #2832: Leave the issue as-is, accepting its current state.
14:44:23 <dkliban> bizhang: does this happen consistently or from time to time?
14:44:54 <bizhang> dkliban, I have not tested extensively, but it happens on 3 different plugins...
14:45:00 <dkliban> bizhang: i think i see the problem
14:45:10 <dkliban> let's talk after triage
14:45:18 <bmbouter> can this be puton the sprint
14:45:20 <ttereshc> I am not sure about prio/sev but it's better to fix it sooner rather than later
14:45:30 <dkliban> yeah ... let's add to the sprint
14:45:31 <bmbouter> it's a followup of work that is already on this sprint
14:45:47 <ttereshc> !propose other accept and add to sprint
14:45:47 <ttereshc> #idea Proposed for #2832: accept and add to sprint
14:45:48 <pulpbot> Proposed for #2832: accept and add to sprint
14:45:51 <bizhang> +1
14:46:04 <ttereshc> !accept
14:46:04 <ttereshc> #agreed accept and add to sprint
14:46:04 <pulpbot> Current proposal accepted: accept and add to sprint
14:46:06 <ttereshc> #topic Can't sync the RHEL 6.7 ISO repo from cdn due to failure parsing PULP_MANIFEST - http://pulp.plan.io/issues/2834
14:46:06 <pulpbot> 3 issues left to triage: 2834, 2835, 2836
14:46:07 <pulpbot> Pulp Issue #2834 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:46:08 <pulpbot> Can't sync the RHEL 6.7 ISO repo from cdn due to failure parsing PULP_MANIFEST - http://pulp.plan.io/issues/2834
14:46:58 <ttereshc> pcreech, any additional info? you mentioned that you filed issue against rcm as well
14:47:09 <pcreech> Baically, it appears the importer chockes on the manifest if it has a newline in the file.  Reproduced by mhrivnak on 2.10.3
14:47:21 <pcreech> s/in the/at the end of the/
14:47:44 <daviddavis> accept, easyfix
14:48:01 <asmacdo> -1 easyfix
14:48:18 <pcreech> the RCM ticket is to see if they can remove the newline, but we could probably also help by filtering out blank lines somehow
14:48:26 <daviddavis> it should be easy to make the code ignore empty lines no?
14:48:41 <asmacdo> the fix might be easy, but the newline sounds like a guess
14:48:55 <daviddavis> true
14:48:57 <pcreech> educated guess duing reproducer by mhrivnak
14:49:05 <pcreech> he has better info than I do
14:49:13 <ttereshc> !propose accept
14:49:13 <ttereshc> #idea Proposed for #2834: Leave the issue as-is, accepting its current state.
14:49:13 <pulpbot> Proposed for #2834: Leave the issue as-is, accepting its current state.
14:50:04 <pcreech> +1
14:50:10 <ttereshc> !accept
14:50:10 <ttereshc> #agreed Leave the issue as-is, accepting its current state.
14:50:10 <pulpbot> Current proposal accepted: Leave the issue as-is, accepting its current state.
14:50:12 <pulpbot> 2 issues left to triage: 2835, 2836
14:50:12 <ttereshc> #topic Tasks stuck in waiting after restart of pulp services - http://pulp.plan.io/issues/2835
14:50:13 <pulpbot> Pulp Issue #2835 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:50:14 <pulpbot> Tasks stuck in waiting after restart of pulp services - http://pulp.plan.io/issues/2835
14:50:37 <bmbouter> so this issue is really three issues, I think we should break it out into three
14:50:44 <bmbouter> but I didn't have time since I just finished this investigation
14:50:58 <asmacdo> !propose skip
14:50:58 <asmacdo> #idea Proposed for #2835: Skip this issue for this triage session.
14:50:59 <pulpbot> Proposed for #2835: Skip this issue for this triage session.
14:51:09 <bmbouter> one thing though
14:51:18 <bmbouter> we need to do some work on this I think now
14:52:08 <bmbouter> but we can do this work pre-triage on this issue
14:52:35 <ttereshc> bmbouter, we can discuss all three issues and when whoever splits them will set proper sev/prio or ping me for ninja-triage :)
14:52:35 <bmbouter> dalley: I think you and I need to look at this
14:52:42 <dalley> yup
14:52:43 <bmbouter> sounds fine
14:52:49 <bmbouter> +1 skip
14:53:00 <ttereshc> !accept
14:53:00 <ttereshc> #agreed Skip this issue for this triage session.
14:53:00 <pulpbot> Current proposal accepted: Skip this issue for this triage session.
14:53:01 <pulpbot> 1 issues left to triage: 2836
14:53:01 <ttereshc> #topic Pulp makes a wall of logs during sync - http://pulp.plan.io/issues/2836
14:53:02 <pulpbot> Pulp Issue #2836 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:53:03 <pulpbot> Pulp makes a wall of logs during sync - http://pulp.plan.io/issues/2836
14:53:04 <asmacdo> ninja-triage++
14:53:15 <daviddavis> accept, easy fix?
14:53:27 <ttereshc> maybe more info needed
14:53:29 <bmbouter> I think we need to wait to check with others
14:53:38 <ttereshc> !propose skip
14:53:38 <ttereshc> #idea Proposed for #2836: Skip this issue for this triage session.
14:53:39 <pulpbot> Proposed for #2836: Skip this issue for this triage session.
14:53:45 <bmbouter> we do need to change this but we need to check w/ the users requesting it
14:53:59 <asmacdo> +1
14:54:01 <daviddavis> +1
14:54:06 <bmbouter> +1
14:54:07 <ttereshc> !accept
14:54:07 <ttereshc> #agreed Skip this issue for this triage session.
14:54:07 <pulpbot> Current proposal accepted: Skip this issue for this triage session.
14:54:08 <pulpbot> No issues to triage.
14:54:18 <ttereshc> !end
14:54:18 <ttereshc> #endmeeting