14:29:10 <ttereshc> #startmeeting Pulp Triage 2017-06-27
14:29:10 <ttereshc> #info ttereshc has joined triage
14:29:10 <pulpbot> Meeting started Tue Jun 27 14:29:10 2017 UTC and is due to finish in 60 minutes.  The chair is ttereshc. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:29:10 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:29:10 <pulpbot> The meeting name has been set to 'pulp_triage_2017_06_27'
14:29:10 <pulpbot> ttereshc has joined triage
14:29:23 <dralley> !here
14:29:23 <dralley> #info dralley has joined triage
14:29:23 <pulpbot> dralley has joined triage
14:29:35 <mansari> !here
14:29:35 <mansari> #info mansari has joined triage
14:29:36 <pulpbot> mansari has joined triage
14:30:03 <dkliban> !here
14:30:03 <dkliban> #info dkliban has joined triage
14:30:04 <pulpbot> dkliban has joined triage
14:30:11 <ttereshc> !next
14:30:12 <pulpbot> 5 issues left to triage: 2831, 2835, 2837, 2838, 2844
14:30:12 <ttereshc> #topic RFE: Changes to pulp_docker and crane metadata structure - http://pulp.plan.io/issues/2831
14:30:13 <pulpbot> Crane Issue #2831 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:30:14 <pulpbot> RFE: Changes to pulp_docker and crane metadata structure - http://pulp.plan.io/issues/2831
14:30:34 <ttereshc> I suggest to skip it again, I'll reach mhrivnak or ipanova before next triage
14:30:37 <ttereshc> #idea Proposed for #2831: Skip this issue for this triage session.
14:30:37 <ttereshc> !propose skip
14:30:37 <pulpbot> Proposed for #2831: Skip this issue for this triage session.
14:30:38 <jortel> #info jortel has joined triage
14:30:38 <jortel> !here
14:30:38 <pulpbot> jortel has joined triage
14:31:17 <ttereshc> any objections?
14:31:22 <ipanova> ttereshc: since dralley did the last changes that aread i asked him to take a look
14:31:29 <ipanova> in that area*
14:31:37 <ipanova> ah sorry
14:31:43 <ipanova> i am on another bug
14:31:47 <ipanova> ignore me
14:31:49 <ttereshc> you mean rsync, I know :)
14:31:59 <bmbouter> !here
14:31:59 <bmbouter> #info bmbouter has joined triage
14:32:00 <pulpbot> bmbouter has joined triage
14:32:16 <dralley> 2844, yeah
14:32:26 <bmbouter> +1 ttereshc
14:32:31 <daviddavis> !here
14:32:31 <daviddavis> #info daviddavis has joined triage
14:32:31 <pulpbot> daviddavis has joined triage
14:32:40 <ttereshc> !accept
14:32:40 <ttereshc> #agreed Skip this issue for this triage session.
14:32:40 <pulpbot> Current proposal accepted: Skip this issue for this triage session.
14:32:42 <ttereshc> #topic Tasks stuck in waiting after restart of pulp services - http://pulp.plan.io/issues/2835
14:32:42 <pulpbot> 4 issues left to triage: 2835, 2837, 2838, 2844
14:32:43 <pulpbot> Pulp Issue #2835 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:32:44 <pulpbot> Tasks stuck in waiting after restart of pulp services - http://pulp.plan.io/issues/2835
14:32:50 <ttereshc> thanks bmbouter :)
14:33:14 <bmbouter> so now this issue is just "Issue B"
14:34:02 <dralley> correct
14:34:05 <bmbouter> I think this needs to go on the sprint, it's a serious reliability issue
14:34:10 <dralley> +1
14:34:16 <ttereshc> but we still need to create issue for A, right?
14:34:18 <jortel> +1
14:34:30 <dralley> ttereshc, yes
14:34:30 <bmbouter> yes we still need an Issue A
14:34:49 <bmbouter> dralley: are you going to file Issue A?
14:35:04 <ttereshc> !propose other triage high/high, add to sprint, dralley will create a redmine issue for "IssueA"
14:35:04 <ttereshc> #idea Proposed for #2835: triage high/high, add to sprint, dralley will create a redmine issue for IssueA
14:35:05 <pulpbot> Proposed for #2835: triage high/high, add to sprint, dralley will create a redmine issue for IssueA
14:35:09 <dralley> bmbouter: planning on it yes.  I ran out of time on Friday because I had to pack up
14:35:16 <bmbouter> dralley: ty and np
14:35:18 <bmbouter> +1
14:35:21 <asmacdo> do we feel comfortable marking Issue A triaged also when dralley makes it?
14:35:22 <dralley> yesterday and today are technically PTO but I'm making up some hours
14:35:46 <bmbouter> let's traige together on friday
14:36:15 <asmacdo> +1
14:36:18 <ttereshc> !accept
14:36:18 <ttereshc> #agreed triage high/high, add to sprint, dralley will create a redmine issue for IssueA
14:36:18 <pulpbot> Current proposal accepted: triage high/high, add to sprint, dralley will create a redmine issue for IssueA
14:36:19 <pulpbot> 3 issues left to triage: 2837, 2838, 2844
14:36:19 <bmbouter> we're going to file an upstream issue this week I think either way
14:36:19 <ttereshc> #topic The systemd file for pulp_workers will not start the workers if they have been killed without using the pulp_workers unit - http://pulp.plan.io/issues/2837
14:36:20 <pulpbot> Pulp Issue #2837 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:36:21 <pulpbot> The systemd file for pulp_workers will not start the workers if they have been killed without using the pulp_workers unit - http://pulp.plan.io/issues/2837
14:36:36 <bmbouter> this issue has been with us a long time
14:36:39 <dralley> yup
14:36:40 <bmbouter> I think
14:36:46 <bmbouter> ever since the systemd units were implemented
14:36:57 <bmbouter> so I think just put this on the backlog
14:37:06 <ttereshc> !propose accept
14:37:06 <ttereshc> #idea Proposed for #2837: Leave the issue as-is, accepting its current state.
14:37:06 <pulpbot> Proposed for #2837: Leave the issue as-is, accepting its current state.
14:37:15 <daviddavis> is there a workaround?
14:37:26 <bmbouter> yes you gratuitously stop pulp_workers
14:37:32 <dralley> or using restart instead of start
14:37:36 <daviddavis> ah ok
14:37:38 <bmbouter> that too
14:37:51 <daviddavis> sounds good then
14:38:05 <ttereshc> prio/sev is ok?
14:38:10 <asmacdo> !propose triage n low
14:38:10 <asmacdo> #idea Proposed for #2837: Priority: Normal, Severity: Low
14:38:10 <asmacdo> #info asmacdo has joined triage
14:38:11 <pulpbot> asmacdo has joined triage
14:38:12 <pulpbot> Proposed for #2837: Priority: Normal, Severity: Low
14:39:02 <bmbouter> that is fine
14:39:03 <dralley> sounds fine to me
14:39:10 <ttereshc> !accept
14:39:10 <ttereshc> #agreed Priority: Normal, Severity: Low
14:39:10 <pulpbot> Current proposal accepted: Priority: Normal, Severity: Low
14:39:12 <ttereshc> #topic Updating/Adding a sync schedule does not trigger an immediate sync - http://pulp.plan.io/issues/2838
14:39:12 <pulpbot> 2 issues left to triage: 2838, 2844
14:39:13 <pulpbot> Python Support Issue #2838 [NEW] (unassigned) - Priority: Normal | Severity: Low
14:39:14 <pulpbot> Updating/Adding a sync schedule does not trigger an immediate sync - http://pulp.plan.io/issues/2838
14:39:56 <daviddavis> 978023
14:40:33 <dralley> hello daviddavis' yubikey
14:40:38 <daviddavis> lol
14:40:50 <asmacdo> hahahaha
14:41:07 <bmbouter> I don't think we can put any effort into this
14:41:14 <jortel> agreed
14:41:17 <bmbouter> sync schedules are going away in pulp3
14:41:29 <asmacdo> Thats true, but is this a bug?
14:41:43 <ttereshc> it's inconsistency
14:42:00 <bmbouter> true but we never guaranteed consistency
14:42:10 <asmacdo> Is this a missing feature or is it core code that is broken with python?
14:42:27 <bmbouter> I thought this was an all platform feature
14:43:12 <asmacdo> Me too, which makes me think we should accept low/low
14:43:39 <asmacdo> IMO if the code is there and it isnt working, its a bug
14:43:49 <bmbouter> that sounds fine
14:44:05 <ttereshc> !propose triage l l
14:44:05 <ttereshc> #idea Proposed for #2838: Priority: Low, Severity: Low
14:44:05 <pulpbot> Proposed for #2838: Priority: Low, Severity: Low
14:44:23 <ttereshc> workaround is to specify start time
14:44:54 <ttereshc> !accept
14:44:54 <ttereshc> #agreed Priority: Low, Severity: Low
14:44:54 <pulpbot> Current proposal accepted: Priority: Low, Severity: Low
14:44:55 <pulpbot> 1 issues left to triage: 2844
14:44:55 <ttereshc> #topic Rsync publish for RPM repo fails to run in fast forward mode - http://pulp.plan.io/issues/2844
14:44:56 <pulpbot> RPM Support Issue #2844 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:44:57 <pulpbot> Rsync publish for RPM repo fails to run in fast forward mode - http://pulp.plan.io/issues/2844
14:45:41 <ttereshc> regression, high/medium, add to sprint?
14:46:40 <dralley> you can assign me as well
14:47:57 <ttereshc> !propose other triage high/medium, add to sprint
14:47:57 <ttereshc> #idea Proposed for #2844: triage high/medium, add to sprint
14:47:58 <pulpbot> Proposed for #2844: triage high/medium, add to sprint
14:48:04 <ttereshc> any objections or thoughts?
14:48:50 <daviddavis> no objection from me
14:49:01 <dralley> same
14:49:07 <ttereshc> #agreed triage high/medium, add to sprint
14:49:07 <ttereshc> !accept
14:49:07 <pulpbot> Current proposal accepted: triage high/medium, add to sprint
14:49:09 <pulpbot> No issues to triage.
14:49:21 <ttereshc> !end
14:49:21 <ttereshc> #endmeeting