14:29:27 <ttereshc> #startmeeting Pulp Triage 2017-06-30
14:29:27 <ttereshc> #info ttereshc has joined triage
14:29:28 <pulpbot> Meeting started Fri Jun 30 14:29:27 2017 UTC and is due to finish in 60 minutes.  The chair is ttereshc. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:29:28 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:29:28 <pulpbot> The meeting name has been set to 'pulp_triage_2017_06_30'
14:29:28 <pulpbot> ttereshc has joined triage
14:29:36 <elijah_d> !here
14:29:36 <elijah_d> #info elijah_d has joined triage
14:29:36 <pulpbot> elijah_d has joined triage
14:29:38 <asmacdo> !here
14:29:38 <asmacdo> #info asmacdo has joined triage
14:29:38 <pulpbot> asmacdo has joined triage
14:29:47 <bizhang> !here
14:29:47 <bizhang> #info bizhang has joined triage
14:29:47 <pulpbot> bizhang has joined triage
14:29:49 <dalley> !here
14:29:49 <dalley> #info dalley has joined triage
14:29:50 <pulpbot> dalley has joined triage
14:29:53 <ttereshc> !next
14:29:54 <pulpbot> 8 issues left to triage: 2831, 2846, 2847, 2848, 2849, 2850, 2860, 2861
14:29:55 <ttereshc> #topic RFE: Changes to pulp_docker and crane metadata structure - http://pulp.plan.io/issues/2831
14:29:55 <pulpbot> Crane Issue #2831 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:29:56 <pulpbot> RFE: Changes to pulp_docker and crane metadata structure - http://pulp.plan.io/issues/2831
14:30:27 <mhrivnak> !here
14:30:27 <mhrivnak> #info mhrivnak has joined triage
14:30:28 <pulpbot> mhrivnak has joined triage
14:30:37 <jortel> !here
14:30:37 <jortel> #info jortel has joined triage
14:30:37 <pulpbot> jortel has joined triage
14:30:45 <asmacdo> lets switch to a story, but not groom it
14:30:50 <ttereshc> as per mhrivnak comment, convert to two stories?
14:30:59 <mhrivnak> !propose other convert to 2 stories
14:30:59 <mhrivnak> #idea Proposed for #2831: convert to 2 stories
14:30:59 <pulpbot> Proposed for #2831: convert to 2 stories
14:31:04 <jortel> +1
14:31:10 <dkliban> !here
14:31:10 <dkliban> #info dkliban has joined triage
14:31:11 <pulpbot> dkliban has joined triage
14:31:14 <ttereshc> !accept
14:31:14 <ttereshc> #agreed convert to 2 stories
14:31:14 <pulpbot> Current proposal accepted: convert to 2 stories
14:31:15 <pulpbot> 7 issues left to triage: 2846, 2847, 2848, 2849, 2850, 2860, 2861
14:31:16 <ttereshc> #topic Pulp Yum Repo doesn't support include or exclude features - http://pulp.plan.io/issues/2846
14:31:16 <pulpbot> RPM Support Issue #2846 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:31:17 <pulpbot> Pulp Yum Repo doesn't support include or exclude features - http://pulp.plan.io/issues/2846
14:31:26 <daviddavis> !here
14:31:26 <daviddavis> #info daviddavis has joined triage
14:31:27 <pulpbot> daviddavis has joined triage
14:31:38 <dkliban> i asked this user to file this issue
14:31:44 <dkliban> it should be converted to a story
14:32:05 <dkliban> and we should probably implement it with pulp 3.1+
14:32:25 <mhrivnak> Sounds good.
14:32:30 <ttereshc> there is a rm 206 which is about whitelists and blacklists (in the comments)
14:32:31 <pulpbot> RPM Support Story #206 [NEW] (unassigned) - Priority: Normal
14:32:32 <pulpbot> As a user, I can specify a whitelist of packages for sync - http://pulp.plan.io/issues/206
14:32:41 <ttereshc> as bmbouter mentioned
14:32:50 <asmacdo> this should focus on "exclude" since whitelist =include
14:32:53 <dkliban> oh yeah ... this is exactly the same thing
14:33:18 <dkliban> not exactly, but the same concept. do we want to keep both open?
14:33:50 <mhrivnak> We'll may implement in pulp 3 something more general than either of these.
14:33:53 <asmacdo> does 206 talk about exlude or blacklist?
14:34:03 <mhrivnak> So I'd combine them somehow and not worry too much about the details.
14:34:12 <ttereshc> asmacdo, only in comments
14:34:24 <mansari> !here
14:34:24 <mansari> #info mansari has joined triage
14:34:25 <pulpbot> mansari has joined triage
14:34:34 <ttereshc> !propose other update rm 206 to include "exclude" :P
14:34:34 <ttereshc> #idea Proposed for #2846: update rm 206 to include exclude :P
14:34:34 <pulpbot> Proposed for #2846: update rm 206 to include exclude :P
14:34:35 <jortel> agreed to mhrivnak comment.  and, I don't think we should do this for pulp2
14:35:05 <asmacdo> +1 mhrivnak
14:35:29 <ttereshc> !propose other combine with rm 206
14:35:29 <ttereshc> #idea Proposed for #2846: combine with rm 206
14:35:29 <pulpbot> Proposed for #2846: combine with rm 206
14:35:31 <ttereshc> !accept
14:35:31 <ttereshc> #agreed combine with rm 206
14:35:31 <pulpbot> Current proposal accepted: combine with rm 206
14:35:32 <pulpbot> 6 issues left to triage: 2847, 2848, 2849, 2850, 2860, 2861
14:35:33 <ttereshc> #topic Skip download of blobs with foreign mediatype. - http://pulp.plan.io/issues/2847
14:35:33 <pulpbot> Docker Support Issue #2847 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:35:34 <pulpbot> Skip download of blobs with foreign mediatype. - http://pulp.plan.io/issues/2847
14:35:46 <mhrivnak> !propose triage high high
14:35:46 <mhrivnak> #idea Proposed for #2847: Priority: High, Severity: High
14:35:46 <pulpbot> Proposed for #2847: Priority: High, Severity: High
14:36:00 <mhrivnak> We talked about this yesterday and put it on the next sprint.
14:36:04 <ttereshc> +1
14:36:08 <asmacdo> "violate the license" is not good
14:36:15 <asmacdo> +1
14:36:16 <bizhang> +1
14:36:24 <jortel> +1
14:36:25 <ttereshc> !accept
14:36:25 <ttereshc> #agreed Priority: High, Severity: High
14:36:25 <pulpbot> Current proposal accepted: Priority: High, Severity: High
14:36:26 <ttereshc> #topic remove tag and name field on the Manifest model - http://pulp.plan.io/issues/2848
14:36:27 <pulpbot> 5 issues left to triage: 2848, 2849, 2850, 2860, 2861
14:36:28 <pulpbot> Docker Support Issue #2848 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:36:29 <pulpbot> remove tag and name field on the Manifest model - http://pulp.plan.io/issues/2848
14:37:18 <mhrivnak> !propose other convert to task
14:37:18 <mhrivnak> #idea Proposed for #2848: convert to task
14:37:19 <pulpbot> Proposed for #2848: convert to task
14:37:36 <jortel> +1
14:37:44 <mansari> +1
14:37:51 <asmacdo> is this backwards compatible?
14:37:56 <mhrivnak> This is related to limitations of schema 1 manifests FWIW
14:38:11 <bmbouter> !here
14:38:11 <bmbouter> #info bmbouter has joined triage
14:38:11 <pulpbot> bmbouter has joined triage
14:38:16 <mhrivnak> asmacdo I suggest discussing that on the issue.
14:38:27 <dkliban> asmacdo: it's not, but it's also broken
14:38:35 <dkliban> and has always been
14:38:54 <asmacdo> ok. +1 covert to task
14:38:57 <ttereshc> !accept
14:38:57 <ttereshc> #agreed convert to task
14:38:57 <pulpbot> Current proposal accepted: convert to task
14:38:58 <dalley> +1
14:38:59 <pulpbot> 4 issues left to triage: 2849, 2850, 2860, 2861
14:38:59 <ttereshc> #topic Worker terminates abnormally while processing task - http://pulp.plan.io/issues/2849
14:39:00 <pulpbot> Docker Support Issue #2849 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:39:01 <pulpbot> Worker terminates abnormally while processing task - http://pulp.plan.io/issues/2849
14:39:55 <mhrivnak> !propose triage high high
14:39:55 <mhrivnak> #idea Proposed for #2849: Priority: High, Severity: High
14:39:55 <pulpbot> Proposed for #2849: Priority: High, Severity: High
14:40:01 <bmbouter> if it's not the OOM it must be a segfault
14:40:19 <bmbouter> +1 to h/h
14:40:26 <dkliban> +1
14:40:28 <jortel> +1
14:40:32 <ttereshc> !accept
14:40:32 <ttereshc> #agreed Priority: High, Severity: High
14:40:32 <pulpbot> Current proposal accepted: Priority: High, Severity: High
14:40:34 <ttereshc> #topic Ensure that users can reach the status api even if the db is down - http://pulp.plan.io/issues/2850
14:40:34 <pulpbot> 3 issues left to triage: 2850, 2860, 2861
14:40:35 <pulpbot> Pulp Issue #2850 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:40:36 <pulpbot> Ensure that users can reach the status api even if the db is down - http://pulp.plan.io/issues/2850
14:40:51 <pcreech> !here
14:40:51 <pcreech> #info pcreech has joined triage
14:40:52 <pulpbot> pcreech has joined triage
14:40:54 <pcreech> late :(
14:40:57 <asmacdo> +tag Pulp 3
14:41:03 <dkliban> yes
14:41:03 <mhrivnak> !propose other convert to story
14:41:03 <mhrivnak> #idea Proposed for #2850: convert to story
14:41:03 <pulpbot> Proposed for #2850: convert to story
14:41:05 <daviddavis> it's tagged pulp 3 already
14:41:30 <mhrivnak> As a user I can use the status endpoint when the DB is down
14:41:38 <bizhang> +1
14:41:43 <daviddavis> +1
14:41:44 <asmacdo> +1
14:41:44 <dkliban> +1
14:41:46 <jortel> +1
14:41:47 <bmbouter> +1
14:41:51 <daviddavis> +1
14:41:55 <ttereshc> !accept
14:41:55 <ttereshc> #agreed convert to story
14:41:55 <pulpbot> Current proposal accepted: convert to story
14:41:56 <mhrivnak> Look at all that participation! ;)
14:41:56 <pulpbot> 2 issues left to triage: 2860, 2861
14:41:57 <pcreech> +1 (semi-related) we should connect to the db early and disconnect late as a best practice
14:41:57 <ttereshc> #topic Python3 weakref tracebacks in the log - http://pulp.plan.io/issues/2860
14:41:58 <pulpbot> Pulp Issue #2860 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:41:59 <pulpbot> Python3 weakref tracebacks in the log - http://pulp.plan.io/issues/2860
14:42:11 <pcreech> er.. switch late/early in my last stament
14:42:11 <ttereshc> :) well done, guys
14:42:55 <dalley> upstream python issue
14:43:07 <mhrivnak> this is in F25, right?
14:43:16 <asmacdo> yes
14:43:24 <dalley> specifically python 3.5.3
14:43:29 <asmacdo> its been fixed upstream
14:43:47 <asmacdo> not sure if its been released yet
14:43:48 <mhrivnak> Gotcha. So we just wait for it to land in Fedora?
14:43:55 <asmacdo> yes
14:44:01 <asmacdo> probably
14:44:09 <asmacdo> it was fixed in 3.6, i dont know about 3.5
14:44:36 <bmbouter> yes
14:44:50 <ttereshc> should we close it as wontfix on our side with comment about upstream fix?
14:44:57 <bmbouter> I not sure if we need to rebuild after that lands or not, but that is fine
14:45:21 <bmbouter> that's why I want to figure out if we need to rebuild
14:45:21 <asmacdo> thats fine with me. mostly wanted it to be searchable
14:45:28 <mhrivnak> I'd go for notabug
14:45:33 <mhrivnak> It's not a pulp bug.
14:45:35 <jortel> +1
14:45:37 <bmbouter> if we have to take an action though then we probably should leave it open
14:45:43 <mhrivnak> I don't think we take any action.
14:45:51 <asmacdo> task to figure out what to do with it?
14:45:58 <bmbouter> don't we have to 'rebuild our stuff on the new scl'
14:46:01 <mhrivnak> If there is an action to take, we could make an issue to do that action.
14:46:03 * bmbouter doesn't know and is guessing
14:46:08 <mhrivnak> I don't think there's an SCL involved.
14:46:09 <pcreech> bmbouter: rebuild our stuff:  no
14:46:18 <ttereshc> !propose other close as NOTABUG
14:46:18 <ttereshc> #idea Proposed for #2860: close as NOTABUG
14:46:19 <pulpbot> Proposed for #2860: close as NOTABUG
14:46:20 <bmbouter> thx, +1 closing as NOTABUG
14:46:21 <pcreech> er... untill python36
14:46:25 <pcreech> but hten... maybe
14:46:32 <ttereshc> !accept
14:46:32 <ttereshc> #agreed close as NOTABUG
14:46:32 <pulpbot> Current proposal accepted: close as NOTABUG
14:46:33 <pulpbot> 1 issues left to triage: 2861
14:46:33 <ttereshc> #topic Queued tasks will be lost if the resource manager is restarted via systemctl - http://pulp.plan.io/issues/2861
14:46:34 <pulpbot> Pulp Issue #2861 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:46:35 <pulpbot> Queued tasks will be lost if the resource manager is restarted via systemctl - http://pulp.plan.io/issues/2861
14:46:36 <bmbouter> well we can open a rebuild task later anyway
14:46:44 <dalley> I think it was fixed in py 3.5.4
14:46:54 <bmbouter> this is "Issue A" from last Friday's report
14:47:13 <bmbouter> we should put this on the sprint b/c it affects both pulp2 and pulp3
14:47:27 <bmbouter> and high/med is my suggestion
14:47:45 <ttereshc> !propose other triage high/med, add to sprint
14:47:45 <ttereshc> #idea Proposed for #2861: triage high/med, add to sprint
14:47:46 <pulpbot> Proposed for #2861: triage high/med, add to sprint
14:47:50 <dkliban> +1
14:47:50 <mhrivnak> +1
14:47:52 <asmacdo> is this a bug to fix upstream?
14:48:20 <bmbouter> yes it's going to be another upstream celery activity
14:48:31 <bmbouter> this will reproduce outside of pulp easy
14:49:02 <dalley> +1
14:49:10 <bmbouter> dalley: I'm hoping you can file the upstream celery reproducer
14:49:18 <mhrivnak> Should we move it to the External tracker?
14:49:23 <asmacdo> im unclear about  when we track upstream bugs
14:49:35 <mhrivnak> I think we do if we're planning to fix them. :)
14:49:48 <bmbouter> let's keep it on pulp
14:50:05 <asmacdo> im ok with whatever jortel decides
14:50:06 <bmbouter> the root cause is upstream, but it's affecting pulp users in specific ways
14:50:20 <mhrivnak> good point.
14:50:34 <dalley> bmbouter: I'll look at it, I've also get the rsync regression fixed first though
14:50:34 <ttereshc> !accept
14:50:34 <ttereshc> #agreed triage high/med, add to sprint
14:50:34 <pulpbot> Current proposal accepted: triage high/med, add to sprint
14:50:36 <pulpbot> No issues to triage.
14:50:40 <bmbouter> dalley: ty!
14:50:42 <ttereshc> !end
14:50:42 <ttereshc> #endmeeting