14:29:20 <ttereshc> #startmeeting Pulp Triage 2017-07-07
14:29:20 <pulpbot> Meeting started Fri Jul  7 14:29:20 2017 UTC and is due to finish in 60 minutes.  The chair is ttereshc. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:29:20 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:29:20 <pulpbot> The meeting name has been set to 'pulp_triage_2017_07_07'
14:29:20 <ttereshc> #info ttereshc has joined triage
14:29:20 <pulpbot> ttereshc has joined triage
14:29:24 <mhrivnak> !here
14:29:24 <mhrivnak> #info mhrivnak has joined triage
14:29:24 <pulpbot> mhrivnak has joined triage
14:29:25 <dalley> !here
14:29:25 <dalley> #info dalley has joined triage
14:29:25 <pulpbot> dalley has joined triage
14:29:30 <mansari> !here
14:29:30 <mansari> #info mansari has joined triage
14:29:31 <pulpbot> mansari has joined triage
14:29:41 <bizhang> !here
14:29:41 <bizhang> #info bizhang has joined triage
14:29:42 <pulpbot> bizhang has joined triage
14:29:43 <ttereshc> !next
14:29:44 <ttereshc> #topic task group never quite finishes if pulp is restarted in the middle of task run - http://pulp.plan.io/issues/2734
14:29:45 <pulpbot> 5 issues left to triage: 2734, 2867, 2871, 2874, 2875
14:29:46 <pulpbot> Pulp Issue #2734 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:29:47 <pulpbot> task group never quite finishes if pulp is restarted in the middle of task run - http://pulp.plan.io/issues/2734
14:30:37 <dkliban> !here
14:30:37 <dkliban> #info dkliban has joined triage
14:30:38 <daviddavis> !here
14:30:38 <daviddavis> #info daviddavis has joined triage
14:30:38 <pulpbot> dkliban has joined triage
14:30:39 <pulpbot> daviddavis has joined triage
14:31:00 <mhrivnak> !propose triage high medium
14:31:00 <mhrivnak> #idea Proposed for #2734: Priority: High, Severity: Medium
14:31:01 <pulpbot> Proposed for #2734: Priority: High, Severity: Medium
14:31:12 <dkliban> +1
14:31:27 <mhrivnak> Good candidate for next sprint.
14:31:31 <bizhang> +1
14:31:33 <ttereshc> !accept
14:31:33 <ttereshc> #agreed Priority: High, Severity: Medium
14:31:33 <pulpbot> Current proposal accepted: Priority: High, Severity: Medium
14:31:34 <ttereshc> #topic As a user I can view plugin versions via the status API - http://pulp.plan.io/issues/2867
14:31:35 <pulpbot> 4 issues left to triage: 2867, 2871, 2874, 2875
14:31:36 <pulpbot> Pulp Issue #2867 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:31:36 <bmbouter> !here
14:31:36 <bmbouter> #info bmbouter has joined triage
14:31:36 <pulpbot> As a user I can view plugin versions via the status API - http://pulp.plan.io/issues/2867
14:31:37 <pulpbot> bmbouter has joined triage
14:31:41 <mhrivnak> story
14:31:55 <daviddavis> +1
14:31:59 <mhrivnak> !propose other convert to story
14:31:59 <mhrivnak> #idea Proposed for #2867: convert to story
14:31:59 <pulpbot> Proposed for #2867: convert to story
14:32:13 <daviddavis> the author needs to remember to open stories when it's a story
14:32:19 <ttereshc> :)
14:32:23 <ttereshc> !accept
14:32:23 <ttereshc> #agreed convert to story
14:32:23 <pulpbot> Current proposal accepted: convert to story
14:32:24 <pulpbot> 3 issues left to triage: 2871, 2874, 2875
14:32:25 <ttereshc> #topic Old references to checksum_type need to be updated to checksumtype - http://pulp.plan.io/issues/2871
14:32:25 <pulpbot> RPM Support Issue #2871 [NEW] (kdelee@redhat.com) - Priority: Normal | Severity: Medium
14:32:26 <pulpbot> Old references to checksum_type need to be updated to checksumtype - http://pulp.plan.io/issues/2871
14:32:48 <bmbouter> so there is a lot of history w/ this checksum_type and checksumtype
14:33:15 <bmbouter> and a lot of special transform code to allow it to internally be one way and externally be another due to semver
14:33:32 <bmbouter> I wasn't sure if the filer understood alkl that and I didn't want to start writing a history of pulp on the ticket
14:34:14 <bizhang> bmbouter, I looked at it yesterday and I think it's filed correctly
14:34:40 <mhrivnak> So the docs don't match the behavior?
14:34:44 <bizhang> I don't know the history but the way it is on the docs does not work
14:34:51 <bizhang> right
14:35:17 <bizhang> !propose triage l l
14:35:17 <bizhang> #idea Proposed for #2871: Priority: Low, Severity: Low
14:35:18 <pulpbot> Proposed for #2871: Priority: Low, Severity: Low
14:35:26 <mhrivnak> +1
14:35:39 <bmbouter> my point is that whoever works on this needs to be really careful, it's very complicated
14:35:58 <bmbouter> I can leave a cautioning comment on it to capture that
14:36:03 <mhrivnak> Sounds good.
14:36:08 <ttereshc> !accept
14:36:08 <ttereshc> #agreed Priority: Low, Severity: Low
14:36:08 <pulpbot> Current proposal accepted: Priority: Low, Severity: Low
14:36:09 <pulpbot> 2 issues left to triage: 2874, 2875
14:36:09 <ttereshc> #topic Race condition during applicability regeneration for consumers with same profile - http://pulp.plan.io/issues/2874
14:36:10 <pulpbot> Pulp Issue #2874 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:36:11 <pulpbot> Race condition during applicability regeneration for consumers with same profile - http://pulp.plan.io/issues/2874
14:36:54 <mhrivnak> another good candidate for next sprint.
14:37:24 <ttereshc> yeah it will be good to fix it
14:37:25 <mhrivnak> !propose triage high medium
14:37:25 <mhrivnak> #idea Proposed for #2874: Priority: High, Severity: Medium
14:37:25 <pulpbot> Proposed for #2874: Priority: High, Severity: Medium
14:37:31 <ttereshc> +1
14:37:52 <ttereshc> !accept
14:37:52 <ttereshc> #agreed Priority: High, Severity: Medium
14:37:53 <pulpbot> Current proposal accepted: Priority: High, Severity: Medium
14:37:54 <ttereshc> #topic Removing agents / consumers gets stuck - http://pulp.plan.io/issues/2875
14:37:54 <pulpbot> 1 issues left to triage: 2875
14:37:55 <pulpbot> Pulp Issue #2875 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:37:56 <pulpbot> Removing agents / consumers gets stuck - http://pulp.plan.io/issues/2875
14:38:54 <bmbouter> so 3 users have talked to me about this
14:39:17 <bmbouter> actually two of them, but the third posted on SO or similar I saw (but couldn't easily find the link again)
14:39:32 <bmbouter> We can accept as-is or accept and put on sprint
14:39:42 <bmbouter> I'm 50/50 on those
14:39:56 <bmbouter> probably not put it on the sprint since there is a workaround and now it's written on the ticket...
14:40:19 <mhrivnak> I would not prioritize this on a sprint.
14:40:28 <ttereshc> !propose accept
14:40:28 <ttereshc> #idea Proposed for #2875: Leave the issue as-is, accepting its current state.
14:40:28 <pulpbot> Proposed for #2875: Leave the issue as-is, accepting its current state.
14:40:38 <mhrivnak> I'd change to low severity I think.
14:40:57 <mhrivnak> The stale tasks are annoying, but I don't think they break anything.
14:41:03 <bmbouter> I agree
14:41:05 <ttereshc> !propose triage m l
14:41:05 <pulpbot> Error: Unknown Priority
14:41:13 <ttereshc> !propose triage n l
14:41:13 <ttereshc> #idea Proposed for #2875: Priority: Normal, Severity: Low
14:41:14 <pulpbot> Proposed for #2875: Priority: Normal, Severity: Low
14:41:18 <mhrivnak> +1
14:41:19 <bmbouter> +1
14:41:21 <ttereshc> !accept
14:41:21 <ttereshc> #agreed Priority: Normal, Severity: Low
14:41:21 <pulpbot> Current proposal accepted: Priority: Normal, Severity: Low
14:41:23 <pulpbot> No issues to triage.
14:41:26 <ttereshc> !end
14:41:26 <ttereshc> #endmeeting