14:29:18 <ttereshc> #startmeeting Pulp Triage 2017-07-25
14:29:18 <ttereshc> #info ttereshc has joined triage
14:29:18 <pulpbot> Meeting started Tue Jul 25 14:29:18 2017 UTC and is due to finish in 60 minutes.  The chair is ttereshc. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:29:18 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:29:18 <pulpbot> The meeting name has been set to 'pulp_triage_2017_07_25'
14:29:18 <pulpbot> ttereshc has joined triage
14:29:32 <bizhang> !here
14:29:32 <bizhang> #info bizhang has joined triage
14:29:32 <pulpbot> bizhang has joined triage
14:29:35 <daviddavis> !here
14:29:35 <daviddavis> #info daviddavis has joined triage
14:29:36 <pulpbot> daviddavis has joined triage
14:29:38 <bmbouter> !here
14:29:38 <bmbouter> #info bmbouter has joined triage
14:29:38 <pulpbot> bmbouter has joined triage
14:29:47 <ttereshc> !next
14:29:48 <pulpbot> 5 issues left to triage: 2927, 2929, 2930, 2939, 2941
14:29:49 <ttereshc> #topic Messages in resource manager queue are not persisted after restarting Qpid and cause tasks never start - http://pulp.plan.io/issues/2927
14:29:49 <pulpbot> Pulp Issue #2927 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:29:50 <pulpbot> Messages in resource manager queue are not persisted after restarting Qpid and cause tasks never start - http://pulp.plan.io/issues/2927
14:30:32 <dkliban> !here
14:30:32 <dkliban> #info dkliban has joined triage
14:30:33 <pulpbot> dkliban has joined triage
14:30:47 <bmbouter> fwiw, daviddavis and I are discussing this in 30 min
14:30:56 <bmbouter> I kind of think skip for now
14:31:07 <bmbouter> daviddavis what do you think?
14:31:13 <ttereshc> is it pulp bug?
14:31:39 <bmbouter> very likely not, but it affects pulp so I'm not sure how to track
14:31:46 <dkliban> ttereshc: it's probably not ... i have experienced the same thing on pulp 3
14:31:55 <bmbouter> if anything it will be a change in celery/kombu
14:31:59 <daviddavis> +1
14:32:07 <dalley> !here
14:32:07 <dalley> #info dalley has joined triage
14:32:07 <pulpbot> dalley has joined triage
14:32:23 <ttereshc> then maybe skip it for now and if you confirm that it's not a pulp bug, change to External project?
14:32:37 <dkliban> ttereshc: +1 to skip for nwo
14:32:37 <bmbouter> we could change to External now and skip
14:32:53 <ttereshc> !propose other skip and change to External
14:32:53 <ttereshc> #idea Proposed for #2927: skip and change to External
14:32:54 <pulpbot> Proposed for #2927: skip and change to External
14:32:56 <bmbouter> +1
14:32:58 <ttereshc> !accept
14:32:58 <ttereshc> #agreed skip and change to External
14:32:58 <pulpbot> Current proposal accepted: skip and change to External
14:33:00 <ttereshc> #topic Node sync is failing with unexpected error repo_id=None - http://pulp.plan.io/issues/2929
14:33:00 <pulpbot> 4 issues left to triage: 2929, 2930, 2939, 2941
14:33:01 <pulpbot> Pulp Issue #2929 [NEW] (unassigned) - Priority: Normal | Severity: High
14:33:02 <pulpbot> Node sync is failing with unexpected error repo_id=None - http://pulp.plan.io/issues/2929
14:34:28 <dkliban> is this just a configuration problem?
14:35:32 <bmbouter> I suspect it is because nodes doesn't have any big regressions that I know of
14:35:54 <bmbouter> but maybe it is a bug that we just haven't seen before
14:36:42 <ttereshc> yeah, maybe... I'm not sure if nodes are used much nowadays
14:37:14 <ttereshc> so we need a reproducer for that to triage?
14:38:16 <bizhang> I think we should get their configuration files, I can follow up and ask
14:38:27 <dkliban> bizhang: thank you
14:38:35 <ttereshc> !propose needinfo
14:38:35 <ttereshc> #idea Proposed for #2929: This issue cannot be triaged without more info.
14:38:36 <dkliban> bizhang: should we skip for now?
14:38:36 <pulpbot> Proposed for #2929: This issue cannot be triaged without more info.
14:38:53 <bizhang> +1 needinfo
14:38:59 <ttereshc> I don't think we can triage it with the info we have
14:39:00 <dkliban> +1
14:39:04 <ttereshc> !accept
14:39:04 <ttereshc> #agreed This issue cannot be triaged without more info.
14:39:04 <pulpbot> Current proposal accepted: This issue cannot be triaged without more info.
14:39:06 <ttereshc> #topic pulp_celerybeat keeps going offline - http://pulp.plan.io/issues/2930
14:39:06 <pulpbot> 3 issues left to triage: 2930, 2939, 2941
14:39:07 <pulpbot> Pulp Issue #2930 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:39:08 <pulpbot> pulp_celerybeat keeps going offline - http://pulp.plan.io/issues/2930
14:39:40 <dkliban> i am not sure what is going on here ... but when i leave my pulp 3 environment running for a while i see these messages
14:39:55 <bmbouter> dkliban: so this could be pulp3 specific?
14:40:00 <dkliban> bmbouter: i think so
14:40:28 <bmbouter> should we accept and put on sprint to investigate?
14:40:37 <dkliban> yeah
14:40:47 <dalley> hmm
14:40:57 <dkliban> dalley: you arethe most familiar with this
14:41:30 <ttereshc> is it important for alpha release?
14:41:59 <dkliban> it could be ... we really should investigate some more
14:42:07 <dalley> yeah. I will look into it because I'm stuck with the current one I'm working on and bored to tears
14:42:34 <ttereshc> !propose other accept and add to sprint
14:42:34 <ttereshc> #idea Proposed for #2930: accept and add to sprint
14:42:34 <pulpbot> Proposed for #2930: accept and add to sprint
14:42:38 <dkliban> +1
14:42:48 <ttereshc> !accept
14:42:48 <ttereshc> #agreed accept and add to sprint
14:42:48 <pulpbot> Current proposal accepted: accept and add to sprint
14:42:50 <ttereshc> #topic Add pep8speaks - http://pulp.plan.io/issues/2939
14:42:50 <pulpbot> 2 issues left to triage: 2939, 2941
14:42:51 <pulpbot> Nectar Issue #2939 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:42:52 <pulpbot> Add pep8speaks - http://pulp.plan.io/issues/2939
14:43:17 <ttereshc> I guess daviddavis just forgot to swith it to task
14:43:24 <ttereshc> !propose other convert to task
14:43:24 <ttereshc> #idea Proposed for #2939: convert to task
14:43:24 <pulpbot> Proposed for #2939: convert to task
14:43:26 <daviddavis> :)
14:43:28 <bmbouter> yeah I think so. +1
14:43:31 <daviddavis> daviddavis--
14:43:31 <pulpbot> daviddavis's karma is now 22
14:43:34 <dkliban> lol
14:43:44 <ttereshc> I don't want accept that :)
14:43:47 <ttereshc> daviddavis++
14:43:47 <pulpbot> daviddavis's karma is now 23
14:43:49 <ttereshc> !accept
14:43:49 <ttereshc> #agreed convert to task
14:43:49 <pulpbot> Current proposal accepted: convert to task
14:43:50 <pulpbot> 1 issues left to triage: 2941
14:43:51 <ttereshc> #topic download failure produces long traceback - http://pulp.plan.io/issues/2941
14:43:51 <pulpbot> Pulp Issue #2941 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:43:52 <pulpbot> download failure produces long traceback - http://pulp.plan.io/issues/2941
14:44:23 <dkliban> this only happens outside of changeset .... i believe that the changeset properly handles download errors
14:44:45 <bmbouter> this could be better but I'm not 100% sure how
14:45:28 <dkliban> we shouldn't log the traceback. just the error and the URL it's occuring with
14:45:52 <bmbouter> it's hard though in many cases we do want to log the traceback
14:46:01 <dkliban> lol
14:46:14 <dkliban> can we just accept and have more discussion on the issue?
14:46:27 <ttereshc> !propose accept
14:46:27 <ttereshc> #idea Proposed for #2941: Leave the issue as-is, accepting its current state.
14:46:27 <pulpbot> Proposed for #2941: Leave the issue as-is, accepting its current state.
14:47:00 <bmbouter> sounds good
14:47:12 <ttereshc> !accept
14:47:12 <ttereshc> #agreed Leave the issue as-is, accepting its current state.
14:47:12 <pulpbot> Current proposal accepted: Leave the issue as-is, accepting its current state.
14:47:13 <pulpbot> No issues to triage.
14:47:17 <ttereshc> !end
14:47:17 <ttereshc> #endmeeting