14:30:15 <ttereshc> #startmeeting Pulp Triage 2017-08-04
14:30:15 <ttereshc> #info ttereshc has joined triage
14:30:15 <pulpbot> Meeting started Fri Aug 4 14:30:15 2017 UTC and is due to finish in 60 minutes. The chair is ttereshc. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:30:15 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:30:15 <pulpbot> The meeting name has been set to 'pulp_triage_2017_08_04'
14:30:15 <pulpbot> ttereshc: ttereshc has joined triage
14:30:22 <ttereshc> pulpbot \o/
14:30:22 <pulpbot> ttereshc: Error: "\o/" is not a valid command.
14:30:28 <mansari> !here
14:30:28 <mansari> #info mansari has joined triage
14:30:28 <pulpbot> mansari: mansari has joined triage
14:30:29 <mhrivnak> heh
14:30:31 <pcreech> !here
14:30:31 <pcreech> #info pcreech has joined triage
14:30:31 <pulpbot> pcreech: pcreech has joined triage
14:30:33 <mhrivnak> !here
14:30:33 <mhrivnak> #info mhrivnak has joined triage
14:30:33 <pulpbot> mhrivnak: mhrivnak has joined triage
14:30:43 <ttereshc> !next
14:30:44 <pulpbot> ttereshc: 3 issues left to triage: 2927, 2952, 2954
14:30:45 <ttereshc> #topic Messages in resource manager queue are not persisted after restarting Qpid and cause tasks never start - http://pulp.plan.io/issues/2927
14:30:46 <pulpbot> Issue #2927 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:30:47 <pulpbot> Messages in resource manager queue are not persisted after restarting Qpid and cause tasks never start - http://pulp.plan.io/issues/2927
14:31:27 <bmbouter> !here
14:31:27 <bmbouter> #info bmbouter has joined triage
14:31:27 <pulpbot> bmbouter: bmbouter has joined triage
14:31:34 <daviddavis> !here
14:31:34 <daviddavis> #info daviddavis has joined triage
14:31:35 <pulpbot> daviddavis: daviddavis has joined triage
14:31:46 <bmbouter> daviddavis should we skip again?
14:31:53 <ttereshc> so it's important one to fix but it's not a pulp bug, is that correct?
14:32:04 <mhrivnak> seems like we need to dig into kombu to find the bug?
14:32:37 <bmbouter> yeah that is right but all of the celery capacity has been going to another bug
14:32:37 <daviddavis> I'm not 100% sure it's not pulp
14:32:50 <bmbouter> so that is why this just keeps getting bumped
14:33:09 <mhrivnak> I think this is ready to accept and get assigned to someone to work on.
14:33:20 <daviddavis> +1 from me
14:33:24 <bmbouter> that sounds fine
14:33:33 <dalley> +1
14:33:40 <ttereshc> what about prio/sev?
14:33:41 <mhrivnak> !propose other high high add to sprint
14:33:41 <mhrivnak> #idea Proposed for #2927: high high add to sprint
14:33:41 <pulpbot> mhrivnak: Proposed for #2927: high high add to sprint
14:33:43 <ttereshc> hign?
14:33:46 <ttereshc> ah :)
14:33:59 <ttereshc> !accept
14:33:59 <ttereshc> #agreed high high add to sprint
14:33:59 <pulpbot> ttereshc: Current proposal accepted: high high add to sprint
14:34:00 <pulpbot> ttereshc: 2 issues left to triage: 2952, 2954
14:34:01 <ttereshc> #topic Use 'endpoint' in /etc/crane.conf in all response headers - http://pulp.plan.io/issues/2952
14:34:01 <pulpbot> Issue #2952 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:34:02 <pulpbot> Use 'endpoint' in /etc/crane.conf in all response headers - http://pulp.plan.io/issues/2952
14:34:53 <mhrivnak> I don't think this is the right change to make.
14:34:55 <daviddavis> I think this bug/rfe is no longer needed
14:35:01 <mhrivnak> Agreed.
14:35:17 <daviddavis> thomasmckay fixed his problem by seting the url on the distributor
14:35:19 <mhrivnak> I suspect Tom agrees it was based on a misunderstanding, but we can confirm.
14:35:27 <daviddavis> +1
14:35:33 <mhrivnak> !propose skip
14:35:33 <mhrivnak> #idea Proposed for #2952: Skip this issue for this triage session.
14:35:33 <pulpbot> mhrivnak: Proposed for #2952: Skip this issue for this triage session.
14:35:34 <daviddavis> I'll update the bug
14:35:40 <mhrivnak> +1
14:35:42 <ttereshc> thanks daviddavis
14:35:49 <ttereshc> !accept
14:35:49 <ttereshc> #agreed Skip this issue for this triage session.
14:35:49 <pulpbot> ttereshc: Current proposal accepted: Skip this issue for this triage session.
14:35:50 <pulpbot> ttereshc: 1 issues left to triage: 2954
14:35:50 <ttereshc> #topic Ensure that queued tasks are not lost by enabling task_reject_on_worker_lost for Celery 4 - http://pulp.plan.io/issues/2954
14:35:51 <pulpbot> Issue #2954 [ASSIGNED] (daviddavis@redhat.com) - Priority: Normal | Severity: Medium
14:35:52 <pulpbot> Ensure that queued tasks are not lost by enabling task_reject_on_worker_lost for Celery 4 - http://pulp.plan.io/issues/2954
14:37:08 <bmbouter> daviddavis: is this the issue we are currently working on?
14:37:08 <ttereshc> assigned already, should it be on the sprint?
14:37:18 <bmbouter> yeah it should be
14:37:23 <daviddavis> yes please. it's a clone of 2861
14:37:25 <bmbouter> this was split out from an existing bug
14:37:27 <bmbouter> yeah
14:37:29 <daviddavis> but with celery 4
14:37:46 <mhrivnak> is it not a bug with celery 3?
14:38:00 <daviddavis> 2861 is for celery 3
14:38:09 <daviddavis> 2954 is for celery 4
14:38:12 <mhrivnak> but wontfix...
14:38:13 * mhrivnak reads
14:38:23 <daviddavis> yea, we'd have to monkeypatch celery 3 to fix it
14:38:29 <daviddavis> celery 4 has an option to fix it
14:38:39 <mhrivnak> Gotcha.
14:38:49 <daviddavis> happy to revisit 2861 if anyone thinks it's worth monkeypatching celery 3
14:39:22 <daviddavis> or we could try to backport the feature from celery 4 ourselves
14:39:46 <ttereshc> !propose other triage normal/med, add to sprint
14:39:46 <ttereshc> #idea Proposed for #2954: triage normal/med, add to sprint
14:39:46 <pulpbot> ttereshc: Proposed for #2954: triage normal/med, add to sprint
14:40:04 <mhrivnak> works for me.
14:40:24 <ttereshc> !accept
14:40:24 <ttereshc> #agreed triage normal/med, add to sprint
14:40:24 <pulpbot> ttereshc: Current proposal accepted: triage normal/med, add to sprint
14:40:26 <pulpbot> ttereshc: No issues to triage.
14:40:28 <ttereshc> !end
14:40:28 <ttereshc> #endmeeting