14:30:25 <ttereshc> #startmeeting Pulp Triage 2017-08-08
14:30:25 <ttereshc> #info ttereshc has joined triage
14:30:25 <ttereshc> !start
14:30:25 <pulpbot> Meeting started Tue Aug 8 14:30:25 2017 UTC and is due to finish in 60 minutes. The chair is ttereshc. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:30:25 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:30:25 <pulpbot> The meeting name has been set to 'pulp_triage_2017_08_08'
14:30:25 <pulpbot> ttereshc: ttereshc has joined triage
14:30:34 <mhrivnak> #info mhrivnak has joined triage
14:30:34 <mhrivnak> !here
14:30:34 <pulpbot> mhrivnak: mhrivnak has joined triage
14:30:58 <ichimonji10> pcreech, Let's talk about this after triage.
14:31:04 <mansari> !here
14:31:04 <mansari> #info mansari has joined triage
14:31:05 <pulpbot> mansari: mansari has joined triage
14:31:09 <pcreech> ichimonji10: ack, didn't realize triage was coming up :)
14:31:11 <pcreech> !here
14:31:11 <pcreech> #info pcreech has joined triage
14:31:12 <pulpbot> pcreech: pcreech has joined triage
14:31:14 <ttereshc> !next
14:31:15 <pulpbot> ttereshc: 6 issues left to triage: 2956, 2957, 2959, 2960, 2961, 2963
14:31:15 <ichimonji10> (:
14:31:15 <ttereshc> #topic Pulp docker ignores basic auth credentials - http://pulp.plan.io/issues/2956
14:31:16 <pulpbot> Issue #2956 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:31:17 <pulpbot> Pulp docker ignores basic auth credentials - http://pulp.plan.io/issues/2956
14:31:33 <ipanova> #info ipanova has joined triage
14:31:33 <ipanova> !here
14:31:33 <pulpbot> ipanova: ipanova has joined triage
14:32:05 <mhrivnak> !propose accept
14:32:05 <mhrivnak> #idea Proposed for #2956: Leave the issue as-is, accepting its current state.
14:32:06 <pulpbot> mhrivnak: Proposed for #2956: Leave the issue as-is, accepting its current state.
14:32:08 <bmbouter> #info bmbouter has joined triage
14:32:08 <bmbouter> !here
14:32:08 <pulpbot> bmbouter: bmbouter has joined triage
14:32:13 <jortel> !here
14:32:13 <jortel> #info jortel has joined triage
14:32:14 <pulpbot> jortel: jortel has joined triage
14:32:14 <mhrivnak> good candidate to talk about during sprint planning.
14:32:22 <ipanova> agree
14:32:24 <preethi> !here
14:32:24 <preethi> #info preethi has joined triage
14:32:25 <pulpbot> preethi: preethi has joined triage
14:32:29 <ipanova> it should converted to to story
14:32:46 <ipanova> we will describe and groom with asmacdo
14:32:54 <dkliban> !here
14:32:54 <dkliban> #info dkliban has joined triage
14:32:55 <pulpbot> dkliban: dkliban has joined triage
14:33:14 <mhrivnak> ipanova sounds fine.
14:33:21 <ttereshc> #idea Proposed for #2956: convert to story
14:33:21 <ttereshc> !propose other convert to story
14:33:21 <pulpbot> ttereshc: Proposed for #2956: convert to story
14:33:27 <ipanova> +1
14:33:30 <ttereshc> !accept
14:33:30 <ttereshc> #agreed convert to story
14:33:30 <pulpbot> ttereshc: Current proposal accepted: convert to story
14:33:32 <ttereshc> #topic pulp-admin auth user create allows creation of duplicate userid - http://pulp.plan.io/issues/2957
14:33:32 <pulpbot> ttereshc: 5 issues left to triage: 2957, 2959, 2960, 2961, 2963
14:33:34 <pulpbot> Issue #2957 [NEW] (unassigned) - Priority: Normal | Severity: High
14:33:35 <pulpbot> pulp-admin auth user create allows creation of duplicate userid - http://pulp.plan.io/issues/2957
14:33:42 * asmacdo is too slow, just https://pulp.plan.io/issues/2956#note-5
14:34:23 <mhrivnak> well that's weird.
14:34:49 <ipanova> btw i was not able to reproduce this
14:35:00 <ipanova> at leas it was always asking for the password
14:36:00 <mhrivnak> ipanova aside from that, did it allow you to create two users with the same id?
14:36:06 <daviddavis> #info daviddavis has joined triage
14:36:06 <daviddavis> !here
14:36:06 <pulpbot> daviddavis: daviddavis has joined triage
14:36:06 <ipanova> no
14:36:32 <asmacdo> looks like it is unique for [user, name]
14:37:03 <ipanova> can it be that he had the DB screwed up?
14:37:08 <mhrivnak> ipanova want to close it WORKSFORME and paste in what you saw?
14:37:17 <asmacdo> https://github.com/pulp/pulp/blob/master/server/pulp/server/db/model/__init__.py#L1163
14:37:18 <mhrivnak> I would guess that person was missing an index.
14:37:22 <ipanova> mhrivnak: will do
14:37:26 <jortel> +1
14:37:50 <ttereshc> #idea Proposed for #2957: close as WORKSFORME, ipanova will comment
14:37:50 <ttereshc> !propose other close as WORKSFORME, ipanova will comment
14:37:51 <pulpbot> ttereshc: Proposed for #2957: close as WORKSFORME, ipanova will comment
14:38:03 <ttereshc> #agreed close as WORKSFORME, ipanova will comment
14:38:03 <ttereshc> !accept
14:38:03 <pulpbot> ttereshc: Current proposal accepted: close as WORKSFORME, ipanova will comment
14:38:04 <pulpbot> ttereshc: 4 issues left to triage: 2959, 2960, 2961, 2963
14:38:05 <ttereshc> #topic Task results can be lost due to race condition - http://pulp.plan.io/issues/2959
14:38:05 <pulpbot> Issue #2959 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:38:07 <pulpbot> Task results can be lost due to race condition - http://pulp.plan.io/issues/2959
14:38:09 <mhrivnak> ipanova actually let's follow up on that later.
14:38:22 <daviddavis> bmbouter and I were just discussing this
14:38:23 <bmbouter> daviddavis and I looked at this filing, and we agree it's a bug
14:38:36 <ipanova> mhrivnak: ok
14:38:38 <bmbouter> our only question is if it should go on a sprint or not
14:38:41 <daviddavis> fwiw, it's pulp 2 only
14:38:56 <bmbouter> oh yeah, it's pulp2 only this was fixed during the tasking system transition to pulp3
14:39:24 <daviddavis> we could ask RCM if it's a blocker for them?
14:39:31 <ipanova> bmbouter: we can discuss this at spring planning
14:39:38 <bmbouter> cool but it's not on my list
14:39:45 <mhrivnak> agreed, we should discuss that in sprint planning.
14:40:03 <bmbouter> who will bring it back up then?
14:40:05 <ipanova> daviddavis: it should not be a blocker for them, but let's ask on the issue
14:40:18 <ttereshc> !propose accept, ask RCM if it's a blocker
14:40:18 <pulpbot> ttereshc: Error: "propose" is not a valid command.
14:40:22 <ipanova> bmbouter: in case it is a blocker i will bring this up
14:40:23 <ttereshc> #idea Proposed for #2959: accept, ask RCM if it's a blocker
14:40:23 <ttereshc> !propose other accept, ask RCM if it's a blocker
14:40:23 <pulpbot> ttereshc: Proposed for #2959: accept, ask RCM if it's a blocker
14:40:28 <bmbouter> thank you ipanova
14:40:45 <ttereshc> pulpbot you were out for too long, I forgot everything :)
14:40:45 <pulpbot> ttereshc: Error: "you" is not a valid command.
14:40:52 <dalley> !here
14:40:52 <dalley> #info dalley has joined triage
14:40:53 <pulpbot> dalley: dalley has joined triage
14:40:53 <ttereshc> !accept
14:40:53 <ttereshc> #agreed accept, ask RCM if it's a blocker
14:40:54 <pulpbot> ttereshc: Current proposal accepted: accept, ask RCM if it's a blocker
14:40:54 <ttereshc> #topic UnicodeEncodeError in case of a non-ASCII character in comments provided with SSL cert/key/CA - http://pulp.plan.io/issues/2960
14:40:55 <pulpbot> ttereshc: 3 issues left to triage: 2960, 2961, 2963
14:40:56 <pulpbot> Issue #2960 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:40:57 <pulpbot> UnicodeEncodeError in case of a non-ASCII character in comments provided with SSL cert/key/CA - http://pulp.plan.io/issues/2960
14:41:40 <mhrivnak> !propose accept
14:41:40 <mhrivnak> #idea Proposed for #2960: Leave the issue as-is, accepting its current state.
14:41:41 <pulpbot> mhrivnak: Proposed for #2960: Leave the issue as-is, accepting its current state.
14:41:59 <jortel> +1
14:41:59 <pcreech> +1
14:42:01 <mhrivnak> There's a reasonable work-around at least.
14:42:01 <ttereshc> maybe low priority? workaround is easy
14:42:03 <ttereshc> no?
14:42:07 <mhrivnak> heh
14:42:09 <ttereshc> :)
14:42:35 <ttereshc> but I'm ok with normal/medium as well
14:42:42 <ttereshc> #agreed Leave the issue as-is, accepting its current state.
14:42:42 <ttereshc> !accept
14:42:42 <pulpbot> ttereshc: Current proposal accepted: Leave the issue as-is, accepting its current state.
14:42:43 <pulpbot> ttereshc: 2 issues left to triage: 2961, 2963
14:42:44 <ttereshc> #topic Pulp 2.14 broken on Fedora 26 - http://pulp.plan.io/issues/2961
14:42:44 <pulpbot> Issue #2961 [NEW] (unassigned) - Priority: Normal | Severity: High
14:42:45 <pulpbot> Pulp 2.14 broken on Fedora 26 - http://pulp.plan.io/issues/2961
14:43:19 <mhrivnak> !propose other high high add to sprint
14:43:19 <mhrivnak> #idea Proposed for #2961: high high add to sprint
14:43:20 <pulpbot> mhrivnak: Proposed for #2961: high high add to sprint
14:43:32 <mhrivnak> I'm happy to be talked out of that if it's overkill. :)
14:43:51 <pcreech> based on what i've seen so far, I can +1
14:43:59 <daviddavis> +1
14:44:08 <bmbouter> +1
14:44:14 <ttereshc> is it an issue with pulp_packaging way of installation?
14:44:21 <pcreech> (to be clear, we are saying this isn't a blocker)
14:44:24 <ttereshc> or in general
14:44:25 <pcreech> no?
14:44:36 <pcreech> some of it is pulp_packaging, but the bulk is selinux issues on f26
14:44:45 <ttereshc> ah ok
14:45:12 <mhrivnak> I suppose the immediate priority is to figure out exactly what's going on and ensure next steps are clear to get it resolved.
14:45:20 <mhrivnak> whether that's on our side, Fedora's side, or both.
14:46:02 <ttereshc> so we can make it a blocker later?
14:46:06 <ttereshc> if needed
14:47:07 <ttereshc> it looks like a blocker if it can poentially be the one
14:47:30 <mhrivnak> I'm not up-to-speed on the blocker conversation, but it does seem like we should get all the facts out and assessed before deciding to release.
14:47:47 <mhrivnak> I know a lot of that's happened, so maybe we just need to summarize on the issue.
14:48:03 <pcreech> Yeah, i'm finishing up some reasearch now via manual installs
14:48:21 <ttereshc> ok, everyone agree on high/high + add to sprint?
14:48:52 <bmbouter> I believe if we can install on all distros with selinux enabled then it should block
14:49:17 <bmbouter> but we can wait until we have all the facts to make the call
14:49:44 <ttereshc> ok, seems like no objections
14:49:46 <ttereshc> #agreed high high add to sprint
14:49:46 <ttereshc> !accept
14:49:46 <pulpbot> ttereshc: Current proposal accepted: high high add to sprint
14:49:47 <pulpbot> ttereshc: 1 issues left to triage: 2963
14:49:47 <ttereshc> #topic Use the new lower case celery config settings - http://pulp.plan.io/issues/2963
14:49:48 <pulpbot> Issue #2963 [NEW] (unassigned) - Priority: Low | Severity: Medium
14:49:49 <pulpbot> Use the new lower case celery config settings - http://pulp.plan.io/issues/2963
14:50:01 <dkliban> story?
14:50:02 <mhrivnak> Oh good, no more yelling. :)
14:50:08 <mhrivnak> or a refactor?
14:50:35 <bmbouter> +1 refactor
14:50:39 <daviddavis> +1
14:50:43 <daviddavis> also, low/low
14:50:47 <bmbouter> +1
14:50:56 <mhrivnak> Sounds good.
14:50:57 <ttereshc> #idea Proposed for #2963: Priority: Low, Severity: Low
14:50:57 <ttereshc> !propose triage l l
14:50:57 <pulpbot> ttereshc: Proposed for #2963: Priority: Low, Severity: Low
14:51:03 <ttereshc> !accept
14:51:03 <ttereshc> #agreed Priority: Low, Severity: Low
14:51:03 <pulpbot> ttereshc: Current proposal accepted: Priority: Low, Severity: Low
14:51:05 <pulpbot> ttereshc: No issues to triage.
14:51:08 <ttereshc> !end
14:51:08 <ttereshc> #endmeeting