14:30:22 <ttereshc> #startmeeting Pulp Triage 2017-08-11
14:30:22 <ttereshc> #info ttereshc has joined triage
14:30:23 <pulpbot> Meeting started Fri Aug 11 14:30:22 2017 UTC and is due to finish in 60 minutes. The chair is ttereshc. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:30:23 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:30:23 <pulpbot> The meeting name has been set to 'pulp_triage_2017_08_11'
14:30:23 <pulpbot> ttereshc: ttereshc has joined triage
14:30:30 <daviddavis> !here
14:30:30 <daviddavis> #info daviddavis has joined triage
14:30:30 <pulpbot> daviddavis: daviddavis has joined triage
14:30:31 <ipanova> i also did not hadtest it yet mhrivnak
14:30:34 <ipanova> !here
14:30:34 <ipanova> #info ipanova has joined triage
14:30:35 <mansari> !here
14:30:35 <mansari> #info mansari has joined triage
14:30:35 <pulpbot> ipanova: ipanova has joined triage
14:30:36 <pulpbot> mansari: mansari has joined triage
14:30:52 <mhrivnak> !here
14:30:52 <mhrivnak> #info mhrivnak has joined triage
14:30:52 <pulpbot> mhrivnak: mhrivnak has joined triage
14:30:53 <ttereshc> !next
14:30:54 <pulpbot> ttereshc: 8 issues left to triage: 2957, 2964, 2966, 2967, 2968, 2969, 2970, 2973
14:30:54 <ttereshc> #topic pulp-admin auth user create allows creation of duplicate userid - http://pulp.plan.io/issues/2957
14:30:55 <pulpbot> Issue #2957 [NEW] (unassigned) - Priority: Normal | Severity: High
14:30:56 <pulpbot> pulp-admin auth user create allows creation of duplicate userid - http://pulp.plan.io/issues/2957
14:31:28 <mhrivnak> asmacdo what do you think?
14:32:22 <mhrivnak> !propose accept
14:32:22 <mhrivnak> #idea Proposed for #2957: Leave the issue as-is, accepting its current state.
14:32:22 <pulpbot> mhrivnak: Proposed for #2957: Leave the issue as-is, accepting its current state.
14:32:28 <ipanova> +1
14:32:35 <ttereshc> the fix to it will require migration, right?
14:33:04 <mhrivnak> It will require adding a uniqueness constraint.
14:33:05 <ttereshc> And I'm not sure how the collisions should be solved
14:33:23 <ttereshc> yeah, but if the duplicates are there
14:33:42 <mhrivnak> It would be interesting to test a system with collisions to see if that alone would break it.
14:33:51 <ttereshc> anyway, I agree it's a bug +1 to accept
14:33:57 <ttereshc> ok' I'll leave a comment
14:34:07 <ttereshc> !accept
14:34:07 <ttereshc> #agreed Leave the issue as-is, accepting its current state.
14:34:07 <pulpbot> ttereshc: Current proposal accepted: Leave the issue as-is, accepting its current state.
14:34:08 <ttereshc> #topic Too easy for user to create empy python repo when syncing from feed - http://pulp.plan.io/issues/2964
14:34:09 <pulpbot> ttereshc: 7 issues left to triage: 2964, 2966, 2967, 2968, 2969, 2970, 2973
14:34:10 <pulpbot> Issue #2964 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:34:11 <pulpbot> Too easy for user to create empy python repo when syncing from feed - http://pulp.plan.io/issues/2964
14:34:57 <mhrivnak> !propose triage normal low
14:34:57 <mhrivnak> #idea Proposed for #2964: Priority: Normal, Severity: Low
14:34:57 <pulpbot> mhrivnak: Proposed for #2964: Priority: Normal, Severity: Low
14:35:04 <daviddavis> +1
14:35:12 <ttereshc> is it doc bug?
14:35:30 <mhrivnak> The task should maybe refuse to run without that set.
14:35:47 <ttereshc> ah, so it's an API change
14:35:51 <mhrivnak> I'd call it a usability bug for sure.
14:36:05 <mhrivnak> I'm not sure that makes it an API change.
14:36:17 <mhrivnak> But it would be a change in that task's behavior.
14:36:34 <ttereshc> !accept
14:36:34 <ttereshc> #agreed Priority: Normal, Severity: Low
14:36:34 <pulpbot> ttereshc: Current proposal accepted: Priority: Normal, Severity: Low
14:36:35 <pulpbot> ttereshc: 6 issues left to triage: 2966, 2967, 2968, 2969, 2970, 2973
14:36:36 <ttereshc> #topic Unable to sync docker repo because worker dies - http://pulp.plan.io/issues/2966
14:36:36 <pulpbot> Issue #2966 [NEW] (unassigned) - Priority: Normal | Severity: High
14:36:37 <pulpbot> Unable to sync docker repo because worker dies - http://pulp.plan.io/issues/2966
14:37:39 <ipanova> i wanted the team to take a look so we can confirm it is the same root cause which needs to be investigated, just manifests in different cases
14:37:51 <ipanova> in case we all agree it should be closed as dup
14:38:22 <mhrivnak> it "manifests" in different cases you say...
14:38:41 <mhrivnak> ;)
14:39:04 <mhrivnak> how easy is it to reproduce this?
14:39:24 <ipanova> haha, manifests like a verb not a noun :D
14:39:34 <ipanova> the 2966 i was not able to reproduce
14:39:49 <ipanova> but the one which was reported earlier is 100% reproducible
14:40:06 <ipanova> without the fix for foreign blobs
14:41:05 <mhrivnak> Oh. After adding foreign blob fix, it goes away?
14:41:20 <ipanova> yes it does
14:41:26 <mhrivnak> ugh
14:41:39 <ipanova> but we risk to hit again the killed worker
14:41:45 <ipanova> if we do not find the root cause
14:42:03 <ipanova> my guess is something with prematurely closed connection from the registry
14:42:42 <ipanova> here it dies after:
14:42:43 <ipanova> Skipping requests to index.docker.io due to repeated connection failures: HTTPSConnectionPool(host='dseasb33srnrn.cloudfront.net', port=443): Read timed out.
14:43:10 <mhrivnak> WHOA hang on
14:43:19 <mhrivnak> from the log attached: "signal 9 (SIGKILL)"
14:43:36 <mhrivnak> So that's the kernel actively yanking the rug out from under it.
14:43:51 <mhrivnak> what is initiating that is less clear.
14:44:05 <ipanova> yes, in both bug reports it is sigkill
14:44:33 <ttereshc> so how about setting those issues related and if the root cause would be the same, we can close this one as a dup?
14:44:35 <ipanova> we are trying to figure out here if it is a dup of #2849
14:44:41 <ttereshc> and continue discussion on the issue
14:45:03 <mhrivnak> Sounds good.
14:45:08 <ttereshc> I suggest to move on and if it requires investigation skip it
14:45:28 <ttereshc> !propose other skip and set related to #2849
14:45:28 <ttereshc> #idea Proposed for #2966: skip and set related to #2849
14:45:28 <pulpbot> ttereshc: Proposed for #2966: skip and set related to #2849
14:45:56 <mhrivnak> +1
14:46:12 <ttereshc> !accept
14:46:12 <ttereshc> #agreed skip and set related to #2849
14:46:12 <pulpbot> ttereshc: Current proposal accepted: skip and set related to #2849
14:46:13 <ttereshc> #topic Unable to sync debian repo using URL as feed - http://pulp.plan.io/issues/2967
14:46:14 <pulpbot> ttereshc: 5 issues left to triage: 2967, 2968, 2969, 2970, 2973
14:46:15 <pulpbot> Issue #2967 [NEW] (unassigned) - Priority: Normal | Severity: Low
14:46:16 <pulpbot> Unable to sync debian repo using URL as feed - http://pulp.plan.io/issues/2967
14:46:24 <daviddavis> dalley++
14:46:24 <pulpbot> daviddavis: dalley's karma is now 1
14:48:12 <mhrivnak> I don't understand the problem here.
14:48:48 <ttereshc> I think it may be the environmental problem, permissions maybe
14:49:03 <ttereshc> but I'm not sure how to reproduce it
14:49:39 <mhrivnak> kersom ^
14:49:39 <ttereshc> I can follow up with kersom on this after triage
14:49:44 <mhrivnak> Ya, that sounds good.
14:49:46 <ttereshc> !propose skip
14:49:46 <ttereshc> #idea Proposed for #2967: Skip this issue for this triage session.
14:49:46 <pulpbot> ttereshc: Proposed for #2967: Skip this issue for this triage session.
14:49:54 <ttereshc> !accept
14:49:54 <ttereshc> #agreed Skip this issue for this triage session.
14:49:54 <pulpbot> ttereshc: Current proposal accepted: Skip this issue for this triage session.
14:49:55 <pulpbot> ttereshc: 4 issues left to triage: 2968, 2969, 2970, 2973
14:49:55 <ttereshc> #topic Rename DeferredArtifact and remove DownloadCatalog. - http://pulp.plan.io/issues/2968
14:49:56 <pulpbot> Issue #2968 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:49:57 <pulpbot> Rename DeferredArtifact and remove DownloadCatalog. - http://pulp.plan.io/issues/2968
14:50:18 <kersom> ttereshc, sounds good
14:50:35 <ttereshc> is it a bug or task?
14:50:50 <mhrivnak> jortel ?
14:51:08 <mhrivnak> I think it looks more like a task now, if we're handling the missing constraint in a separate issue.
14:52:12 <ttereshc> I think renaming deferred artifact and removing catalog model is not that much of a work, so I guess we can triage it as a bug and just solve
14:52:36 <ttereshc> add to sprint?
14:53:15 <mhrivnak> Ok with me. We need agreement on the name, but that can be worked on during the sprint.
14:53:24 <ttereshc> yeah
14:53:27 <mhrivnak> We should definitely remove the unused catalog code.
14:53:44 <ttereshc> !propose other accept and add to sprint
14:53:44 <ttereshc> #idea Proposed for #2968: accept and add to sprint
14:53:44 <pulpbot> ttereshc: Proposed for #2968: accept and add to sprint
14:53:49 <ttereshc> normal/medium?
14:54:29 <mhrivnak> +1
14:54:39 <ttereshc> !accept
14:54:39 <ttereshc> #agreed accept and add to sprint
14:54:39 <pulpbot> ttereshc: Current proposal accepted: accept and add to sprint
14:54:40 <pulpbot> ttereshc: 3 issues left to triage: 2969, 2970, 2973
14:54:40 <ttereshc> #topic progress reports omitted by task API - http://pulp.plan.io/issues/2969
14:54:41 <pulpbot> Issue #2969 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:54:42 <pulpbot> progress reports omitted by task API - http://pulp.plan.io/issues/2969
14:56:12 <mhrivnak> !propose other high high add to sprint
14:56:12 <mhrivnak> #idea Proposed for #2969: high high add to sprint
14:56:12 <pulpbot> mhrivnak: Proposed for #2969: high high add to sprint
14:56:32 <mhrivnak> Maybe this was just an oversight.
14:56:41 <ttereshc> yeah, +1 to solve it
14:56:51 <ttereshc> I think so, looks like an oversight
14:57:01 <ttereshc> !accept
14:57:01 <ttereshc> #agreed high high add to sprint
14:57:01 <pulpbot> ttereshc: Current proposal accepted: high high add to sprint
14:57:03 <ttereshc> #topic REST API silently ignores object attributes that don't exist on the serializer - http://pulp.plan.io/issues/2970
14:57:03 <pulpbot> ttereshc: 2 issues left to triage: 2970, 2973
14:57:04 <pulpbot> Issue #2970 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:57:05 <pulpbot> REST API silently ignores object attributes that don't exist on the serializer - http://pulp.plan.io/issues/2970
14:57:26 <ttereshc> +many to fix this one as well
14:57:30 <ttereshc> very confusing
14:57:50 <ttereshc> though it's not urgent or important for alpha I guess
14:57:51 <mhrivnak> Agreed. I don't think it has to be on this sprint necessarily, but is high priority.
14:57:57 <ttereshc> :)
14:58:10 <mhrivnak> !propose triage high medium
14:58:10 <mhrivnak> #idea Proposed for #2970: Priority: High, Severity: Medium
14:58:10 <pulpbot> mhrivnak: Proposed for #2970: Priority: High, Severity: Medium
14:58:20 <ttereshc> !accept
14:58:20 <ttereshc> #agreed Priority: High, Severity: Medium
14:58:20 <pulpbot> ttereshc: Current proposal accepted: Priority: High, Severity: Medium
14:58:21 <pulpbot> ttereshc: 1 issues left to triage: 2973
14:58:21 <ttereshc> #topic Tasking scheduler trace on startup. - http://pulp.plan.io/issues/2973
14:58:22 <pulpbot> Issue #2973 [NEW] (unassigned) - Priority: High | Severity: Medium
14:58:23 <pulpbot> Tasking scheduler trace on startup. - http://pulp.plan.io/issues/2973
14:58:46 <mhrivnak> https://github.com/pulp/pulp/pull/3118
14:58:49 <mhrivnak> already fixed
14:58:58 <ttereshc> nice
14:59:01 <mhrivnak> I'll just take the issue and mark it modified.
14:59:12 <ttereshc> ty!
14:59:24 <ttereshc> !propose other solved :)
14:59:24 <ttereshc> #idea Proposed for #2973: solved :)
14:59:24 <pulpbot> ttereshc: Proposed for #2973: solved :)
14:59:31 <ttereshc> !accept
14:59:31 <ttereshc> #agreed solved :)
14:59:31 <pulpbot> ttereshc: Current proposal accepted: solved :)
14:59:32 <pulpbot> ttereshc: No issues to triage.
14:59:38 <ttereshc> !end
14:59:38 <ttereshc> #endmeeting