14:30:33 <ttereshc> #startmeeting Pulp Triage 2017-08-15
14:30:33 <ttereshc> #info ttereshc has joined triage
14:30:34 <pulpbot> Meeting started Tue Aug 15 14:30:33 2017 UTC and is due to finish in 60 minutes.  The chair is ttereshc. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:30:34 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:30:34 <pulpbot> The meeting name has been set to 'pulp_triage_2017_08_15'
14:30:34 <pulpbot> ttereshc: ttereshc has joined triage
14:30:43 <bizhang> #info bizhang has joined triage
14:30:43 <bizhang> !here
14:30:43 <pulpbot> bizhang: bizhang has joined triage
14:30:44 <mansari> !here
14:30:44 <mansari> #info mansari has joined triage
14:30:45 <pulpbot> mansari: mansari has joined triage
14:30:51 <preethi> #info preethi has joined triage
14:30:51 <preethi> !here
14:30:51 <pulpbot> preethi: preethi has joined triage
14:30:52 <asmacdo> here
14:31:02 <mhrivnak> !here
14:31:02 <mhrivnak> #info mhrivnak has joined triage
14:31:03 <pulpbot> mhrivnak: mhrivnak has joined triage
14:31:04 <ttereshc> !next
14:31:05 <pulpbot> ttereshc: 8 issues left to triage: 2966, 2974, 2975, 2976, 2977, 2978, 2979, 2983
14:31:06 <ttereshc> #topic Unable to sync docker repo because worker dies - http://pulp.plan.io/issues/2966
14:31:06 <pulpbot> Issue #2966 [NEW] (unassigned) - Priority: Normal | Severity: High
14:31:08 <pulpbot> Unable to sync docker repo because worker dies - http://pulp.plan.io/issues/2966
14:31:11 <dkliban> !here
14:31:11 <dkliban> #info dkliban has joined triage
14:31:12 <pulpbot> dkliban: dkliban has joined triage
14:31:16 <daviddavis> #info daviddavis has joined triage
14:31:16 <daviddavis> !here
14:31:16 <pulpbot> daviddavis: daviddavis has joined triage
14:31:33 <dalley> #info dalley has joined triage
14:31:33 <dalley> !here
14:31:33 <pulpbot> dalley: dalley has joined triage
14:31:46 <mhrivnak> elijah_d what do you think?
14:32:16 <ipanova> !here
14:32:16 <ipanova> #info ipanova has joined triage
14:32:17 <pulpbot> ipanova: ipanova has joined triage
14:32:31 <mhrivnak> !propose skip
14:32:31 <mhrivnak> #idea Proposed for #2966: Skip this issue for this triage session.
14:32:32 <pulpbot> mhrivnak: Proposed for #2966: Skip this issue for this triage session.
14:32:37 <ttereshc> let's come back to this one at the end if elijah_d has something to add
14:32:42 <daviddavis> +1
14:32:48 <ttereshc> !next
14:32:49 <pulpbot> ttereshc: 7 issues left to triage: 2974, 2975, 2976, 2977, 2978, 2979, 2983
14:32:50 <ttereshc> #topic Error when attempting to create two repos with the same name - http://pulp.plan.io/issues/2974
14:32:50 <pulpbot> Issue #2974 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:32:51 <pulpbot> Error when attempting to create two repos with the same name - http://pulp.plan.io/issues/2974
14:33:18 <dkliban> accept as is and add to sprint
14:33:20 <mhrivnak> #idea Proposed for #2974: Leave the issue as-is, accepting its current state.
14:33:20 <mhrivnak> !propose accept
14:33:20 <pulpbot> mhrivnak: Proposed for #2974: Leave the issue as-is, accepting its current state.
14:33:26 <elijah_d> ttereshc, I can recreate #2966 and post logs before the next triage
14:33:27 <mhrivnak> I would not add it to this sprint.
14:33:38 <dkliban> ok
14:33:38 <mhrivnak> I suspect we have the same issue on other models.
14:33:47 <ttereshc> elijah_d, sounds good,thank you
14:33:48 <mhrivnak> And I don't think this blocks plugin writers.
14:33:49 <jortel> #info jortel has joined triage
14:33:49 <jortel> !here
14:33:49 <pulpbot> jortel: jortel has joined triage
14:33:51 <bmbouter> #info bmbouter has joined triage
14:33:51 <bmbouter> !here
14:33:51 <pulpbot> bmbouter: bmbouter has joined triage
14:34:14 <dkliban> i don't feel strongly about adding to the sprint
14:34:18 <dkliban> so we can move on
14:34:21 <daviddavis> some of the other models handle this already but I agree that it doesn't block plugin writers
14:34:25 <ttereshc> !accept
14:34:25 <ttereshc> #agreed Leave the issue as-is, accepting its current state.
14:34:25 <pulpbot> ttereshc: Current proposal accepted: Leave the issue as-is, accepting its current state.
14:34:26 <pulpbot> ttereshc: 6 issues left to triage: 2975, 2976, 2977, 2978, 2979, 2983
14:34:27 <ttereshc> #topic Username field doesn't validate characters - http://pulp.plan.io/issues/2975
14:34:27 <pulpbot> Issue #2975 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:34:28 <pulpbot> Username field doesn't validate characters - http://pulp.plan.io/issues/2975
14:34:43 <daviddavis> accept as is?
14:34:53 <mhrivnak> #idea Proposed for #2975: Leave the issue as-is, accepting its current state.
14:34:53 <mhrivnak> !propose accept
14:34:53 <pulpbot> mhrivnak: Proposed for #2975: Leave the issue as-is, accepting its current state.
14:35:00 <bizhang> +1
14:35:00 <asmacdo> +1
14:35:00 <dalley> +1
14:35:07 <asmacdo> we are going to have a lot of validation things
14:35:08 <ttereshc> I think it's more important than previous one, no?
14:35:20 <ttereshc> users can end up with weird things in db
14:35:23 <asmacdo> maybe we should treat these as stories rather than bugs
14:35:53 <jortel> I think adding a story to scrub all the field validation would be good instead of doing piecemeal
14:35:55 <mhrivnak> Does this one actually add anything to the DB?
14:36:15 <mhrivnak> I agree we would benefit from a top-to-bottom validation effort.
14:36:20 <daviddavis> +1
14:36:23 <ttereshc> isn't it a user creation?
14:36:43 <mhrivnak> Yes, but I think it's failing.
14:37:04 <dalley> is it?
14:37:06 <mhrivnak> oh wait, I moved on to the wrong one.
14:37:07 <ttereshc> Ah ok, I don't see it on the issue
14:37:08 <daviddavis> it works but it should not work
14:37:09 <dalley> issue doesn't specify
14:37:17 <mhrivnak> You're right!
14:37:21 <mhrivnak> Sorry about that. :)
14:37:34 <daviddavis> no worries
14:37:42 <daviddavis> I can add a story to add validation how about
14:37:46 <daviddavis> and then close these tasks out?
14:37:52 <daviddavis> and add them as checklist items?
14:37:56 <mhrivnak> That sounds reasonable.
14:38:03 <daviddavis> !propose skip
14:38:03 <daviddavis> #idea Proposed for #2975: Skip this issue for this triage session.
14:38:04 <pulpbot> daviddavis: Proposed for #2975: Skip this issue for this triage session.
14:38:18 <ttereshc> ty daviddavis
14:38:19 <dalley> Or rewrite them as tasks
14:38:32 <ttereshc> #agreed Skip this issue for this triage session.
14:38:32 <ttereshc> !accept
14:38:32 <pulpbot> ttereshc: Current proposal accepted: Skip this issue for this triage session.
14:38:33 <pulpbot> ttereshc: 5 issues left to triage: 2976, 2977, 2978, 2979, 2983
14:38:33 <ttereshc> #topic 500 error when I try to create a username with more than 150 chars - http://pulp.plan.io/issues/2976
14:38:34 <pulpbot> Issue #2976 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:38:35 <pulpbot> 500 error when I try to create a username with more than 150 chars - http://pulp.plan.io/issues/2976
14:38:41 <daviddavis> #idea Proposed for #2976: Skip this issue for this triage session.
14:38:41 <daviddavis> !propose skip
14:38:42 <pulpbot> daviddavis: Proposed for #2976: Skip this issue for this triage session.
14:38:51 <ttereshc> +1
14:38:52 <asmacdo> that might be different
14:39:00 <asmacdo> the validator is set to 150
14:39:11 <asmacdo> but it looks like it isnt being caught right
14:39:26 <daviddavis> where do you see that?
14:39:40 <mhrivnak> I glanced at this and really hoped the username was "daviddaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaavis". ;)
14:39:47 <asmacdo> models/auth.py #45
14:39:48 <daviddavis> haha
14:39:49 <ttereshc> :)
14:39:52 <asmacdo> lol daviddavis
14:40:21 <asmacdo> probably the validator should be on the serialzier not the model
14:40:24 <daviddavis> asmacdo: I think max_length has to be set in the serializer
14:40:30 <daviddavis> yea
14:40:38 <daviddavis> that just sets the size on the db field in auth.py
14:40:39 <asmacdo> but the point is this one is a bug, not part of the top to bottom validation stuff
14:41:00 <mhrivnak> From a user standpoint, I think they're all bugs.
14:41:22 <daviddavis> agreed
14:41:32 <asmacdo> ok, but it seems different to have a broken validator than to not have one at all
14:41:52 <daviddavis> I don't think the max_length setting in the model is a validator
14:41:59 <mhrivnak> Agreed. Two different types of bugs.
14:42:00 <daviddavis> it determines the max length of the db field
14:42:14 <asmacdo> you are right
14:42:21 <mhrivnak> There's no harm done to the user except they're subjected to a 500 error instead of a 4xx.
14:42:43 <mhrivnak> So I'm good with doing this as part of the validation sweep.
14:42:55 <asmacdo> ok, im convinced
14:43:04 <ttereshc> yay :)
14:43:06 <ttereshc> !accept
14:43:06 <ttereshc> #agreed Skip this issue for this triage session.
14:43:06 <pulpbot> ttereshc: Current proposal accepted: Skip this issue for this triage session.
14:43:08 <ttereshc> #topic Attributes on KeyValueRelatedFields are not used by DRF - http://pulp.plan.io/issues/2977
14:43:08 <pulpbot> ttereshc: 4 issues left to triage: 2977, 2978, 2979, 2983
14:43:09 <pulpbot> Issue #2977 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:43:10 <pulpbot> Attributes on KeyValueRelatedFields are not used by DRF - http://pulp.plan.io/issues/2977
14:43:50 <daviddavis> accept and add to sprint
14:44:26 <mhrivnak> +1
14:44:38 <asmacdo> +1
14:44:40 <ttereshc> #idea Proposed for #2977: accept and add to sprint
14:44:40 <ttereshc> !propose other accept and add to sprint
14:44:40 <pulpbot> ttereshc: Proposed for #2977: accept and add to sprint
14:44:43 <ttereshc> !accept
14:44:43 <ttereshc> #agreed accept and add to sprint
14:44:43 <pulpbot> ttereshc: Current proposal accepted: accept and add to sprint
14:44:44 <pulpbot> ttereshc: 3 issues left to triage: 2978, 2979, 2983
14:44:44 <ttereshc> #topic Make task-group tasks visible - http://pulp.plan.io/issues/2978
14:44:46 <pulpbot> Issue #2978 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:44:47 <pulpbot> Make task-group tasks visible - http://pulp.plan.io/issues/2978
14:45:44 <mhrivnak> This could become a story.
14:45:57 <asmacdo> i think we could probably just do this with filtering
14:46:10 <ttereshc> #idea Proposed for #2978: convert to story
14:46:10 <ttereshc> !propose other convert to story
14:46:10 <pulpbot> ttereshc: Proposed for #2978: convert to story
14:46:16 <mhrivnak> As a user, XXX type of task is visible in the task list.
14:46:46 <ttereshc> #agreed convert to story
14:46:46 <ttereshc> !accept
14:46:46 <pulpbot> ttereshc: Current proposal accepted: convert to story
14:46:47 <pulpbot> ttereshc: 2 issues left to triage: 2979, 2983
14:46:47 <mhrivnak> asmacdo I suspect this task type is just missing the decorator that would make it user-facing.
14:46:47 <ttereshc> #topic Celery workers may deadlock when PULP_MAX_TASKS_PER_CHILD and mongo replica set are used - http://pulp.plan.io/issues/2979
14:46:48 <pulpbot> Issue #2979 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:46:49 <pulpbot> Celery workers may deadlock when PULP_MAX_TASKS_PER_CHILD and mongo replica set are used - http://pulp.plan.io/issues/2979
14:46:55 * daviddavis does the celery bug dance
14:47:00 * bmbouter ducks
14:47:43 <bmbouter> for triage purposes I think this should be accepted
14:48:11 <bmbouter> but in terms of fixing it, celery's forking behavior and pymongo's threading behavior are just incompatible
14:48:24 <mhrivnak> Have they been using replica sets all along?
14:48:34 <bmbouter> yeah I think so
14:48:45 <bmbouter> but this issue isn't unique to replica sets even though they think it is
14:48:52 <bmbouter> I was going to comment w/ that
14:48:57 <mhrivnak> Gotcha.
14:49:11 <mhrivnak> #idea Proposed for #2979: Priority: Low, Severity: Low
14:49:11 <mhrivnak> !propose triage low low
14:49:11 <pulpbot> mhrivnak: Proposed for #2979: Priority: Low, Severity: Low
14:49:19 <ttereshc> or wontfix?
14:49:30 <mhrivnak> ^ especially since we recommend against using replica sets.
14:49:40 <mhrivnak> wontfix would also be good.
14:49:42 <bmbouter> so this will affect sat
14:49:53 <asmacdo> closed-cantfix
14:50:05 <bmbouter> it's not unique to replica sets, so any pulp user who enables that option could experience this
14:50:15 <bmbouter> without enabling that option it only forks once
14:50:24 <bmbouter> but with that option enabled it forks often
14:50:27 <mhrivnak> bmbouter which option?
14:50:33 <bmbouter> MAX_TASKS_PER_CHILD
14:50:36 <mhrivnak> ah.
14:51:02 <mhrivnak> Has this always been a bug since we added support for that option?
14:51:05 <bmbouter> by introducing that feature we've created this problem (well really we significantly increased it's probability of occurance)
14:51:08 <mhrivnak> Or is there something new?
14:51:17 <bmbouter> it's new because it forks a lot with that option set
14:51:47 <mhrivnak> #idea Proposed for #2979: wait for bmbouter to write this all up and triage on Friday
14:51:47 <mhrivnak> !propose other wait for bmbouter to write this all up and triage on Friday
14:51:47 <pulpbot> mhrivnak: Proposed for #2979: wait for bmbouter to write this all up and triage on Friday
14:52:03 <bmbouter> +1
14:52:08 <dalley> +1
14:52:10 <ttereshc> !accept
14:52:10 <ttereshc> #agreed wait for bmbouter to write this all up and triage on Friday
14:52:10 <pulpbot> ttereshc: Current proposal accepted: wait for bmbouter to write this all up and triage on Friday
14:52:11 <pulpbot> ttereshc: 1 issues left to triage: 2983
14:52:12 <ttereshc> #topic Default httpd configuration makes directory listings hard - http://pulp.plan.io/issues/2983
14:52:12 <pulpbot> Issue #2983 [NEW] (unassigned) - Priority: Normal | Severity: Low
14:52:14 <pulpbot> Default httpd configuration makes directory listings hard - http://pulp.plan.io/issues/2983
14:53:45 <ttereshc> I'm not sure I get the issue but it sounds like a story? :)
14:54:09 <mhrivnak> !propose triage low low
14:54:09 <mhrivnak> #idea Proposed for #2983: Priority: Low, Severity: Low
14:54:10 <pulpbot> mhrivnak: Proposed for #2983: Priority: Low, Severity: Low
14:54:33 <mhrivnak> I could see it as a bug. We did a thing that makes directory listings weird only in that particular place.
14:54:53 <ttereshc> ok with me
14:55:08 <ttereshc> no objections? anyone
14:55:17 <mhrivnak> A reasonable observation, but it's not really intended for human eyes. :)
14:55:26 <ttereshc> :)
14:55:31 <ttereshc> #agreed Priority: Low, Severity: Low
14:55:31 <ttereshc> !accept
14:55:31 <pulpbot> ttereshc: Current proposal accepted: Priority: Low, Severity: Low
14:55:33 <pulpbot> ttereshc: No issues to triage.
14:55:40 <ttereshc> !end
14:55:40 <ttereshc> #endmeeting