14:30:10 <asmacdo> #startmeeting Pulp Triage 2017-08-25
14:30:10 <asmacdo> #info asmacdo has joined triage
14:30:11 <pulpbot> Meeting started Fri Aug 25 14:30:10 2017 UTC and is due to finish in 60 minutes.  The chair is asmacdo. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:30:11 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:30:11 <pulpbot> The meeting name has been set to 'pulp_triage_2017_08_25'
14:30:11 <pulpbot> asmacdo: asmacdo has joined triage
14:30:18 <daviddavis> !here
14:30:18 <daviddavis> #info daviddavis has joined triage
14:30:19 <pulpbot> daviddavis: daviddavis has joined triage
14:30:20 <asmacdo> woohoo triage!
14:30:23 <bizhang> !here
14:30:23 <bizhang> #info bizhang has joined triage
14:30:23 <pulpbot> bizhang: bizhang has joined triage
14:30:31 <mhrivnak> thanks!
14:30:34 <mhrivnak> !here
14:30:34 <mhrivnak> #info mhrivnak has joined triage
14:30:34 <pulpbot> mhrivnak: mhrivnak has joined triage
14:30:41 <asmacdo> !next
14:30:42 <pulpbot> asmacdo: 2 issues left to triage: 2988, 2990
14:30:42 <asmacdo> #topic Exception when raising a user-Defined Exception that has a custom __init__ signature - http://pulp.plan.io/issues/2988
14:30:43 <pulpbot> Issue #2988 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:30:44 <pulpbot> Exception when raising a user-Defined Exception that has a custom __init__ signature - http://pulp.plan.io/issues/2988
14:31:43 <daviddavis> how would a user experience this?
14:32:20 <daviddavis> where's bmbouter
14:32:32 <asmacdo> hes changing locations
14:32:37 <daviddavis> ah
14:32:39 <mhrivnak> I think the worker would end up with an unhandled exception.
14:32:46 <daviddavis> I see
14:32:49 <asmacdo> ^ yes that was my impression
14:32:54 <mhrivnak> a MaybeEncodingError
14:33:32 * mhrivnak doesn't like the word "maybe" in software
14:33:39 <dkliban> i think we need to investigate this and see if this a new problem in celery 4 or if the same beahvior is present in 3 also
14:33:49 <mhrivnak> I think we want to get away from pickling anyway, which is one factor.
14:33:57 <mhrivnak> That seems reasonable.
14:34:09 <asmacdo> !propose accept
14:34:09 <asmacdo> #idea Proposed for #2988: Leave the issue as-is, accepting its current state.
14:34:09 <pulpbot> asmacdo: Proposed for #2988: Leave the issue as-is, accepting its current state.
14:34:37 <mhrivnak> works for me. Someone can bring it up during sprint planning next week.
14:35:23 <asmacdo> !accept
14:35:23 <asmacdo> #agreed Leave the issue as-is, accepting its current state.
14:35:23 <pulpbot> asmacdo: Current proposal accepted: Leave the issue as-is, accepting its current state.
14:35:24 <pulpbot> asmacdo: 1 issues left to triage: 2990
14:35:25 <asmacdo> #topic Celery 4.x traceback upon restarting a worker while processing a task - http://pulp.plan.io/issues/2990
14:35:25 <pulpbot> Issue #2990 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:35:27 <pulpbot> Celery 4.x traceback upon restarting a worker while processing a task - http://pulp.plan.io/issues/2990
14:35:50 <dalley> !here
14:35:50 <dalley> #info dalley has joined triage
14:35:50 <pulpbot> dalley: dalley has joined triage
14:36:22 <asmacdo> I assume we are only using celery 4 in Pulp 3+?
14:36:37 <dalley> I think we technically support in on pulp2 now
14:36:38 <mhrivnak> That seems reasonable.
14:36:55 <mhrivnak> we use both on pulp2 depending on your OS.
14:36:56 <dalley> Fedora 26+ ships celery 4
14:37:36 <asmacdo> does fedora 26 ship celery 3?
14:37:46 <mhrivnak> just 4 I think.
14:38:23 <mhrivnak> confirmed
14:38:23 <dkliban> dalley: so do you think this is a celery bug that we need to report upstream?
14:38:30 <asmacdo> !propose triage high high
14:38:30 <asmacdo> #idea Proposed for #2990: Priority: High, Severity: High
14:38:30 <pulpbot> asmacdo: Proposed for #2990: Priority: High, Severity: High
14:39:14 <dalley> I don't consider it that high prio
14:39:20 <dalley> normal?
14:39:25 <dalley> dkliban: yes
14:39:48 <mhrivnak> I suppose it only happens when restarting the worker, in which case you expect the task to stop anyway.
14:40:13 <dkliban> let's do normal priority
14:40:16 <dalley> mhrivnak yes
14:40:19 <mhrivnak> The fact that it results in an unhandled exception is unfortunate, but doesn't cause much of a problem.
14:40:36 <asmacdo> dalley: are you blocked from restarting your workers?
14:40:49 <dalley> asmacdo, no, it restarts afterwards fine
14:40:53 <asmacdo> oh ok
14:40:53 <dalley> it's just a traceback
14:41:01 <asmacdo> !propose normal medium
14:41:01 <pulpbot> asmacdo: Error: "propose" is not a valid command.
14:41:06 <asmacdo> !propose triage normal medium
14:41:06 <asmacdo> #idea Proposed for #2990: Priority: Normal, Severity: Medium
14:41:06 <pulpbot> asmacdo: Proposed for #2990: Priority: Normal, Severity: Medium
14:41:15 <dalley> ..well, it doesn't restart fine, but not because of the traceback
14:41:17 <dalley> +1
14:41:19 <mansari_> !here
14:41:19 <mansari_> #info mansari_ has joined triage
14:41:19 <pulpbot> mansari_: mansari_ has joined triage
14:41:20 <dalley> separate issue
14:41:22 <asmacdo> haha ok
14:41:24 <mhrivnak> heh
14:41:27 <mhrivnak> +1
14:41:33 <asmacdo> !accept
14:41:33 <asmacdo> #agreed Priority: Normal, Severity: Medium
14:41:33 <pulpbot> asmacdo: Current proposal accepted: Priority: Normal, Severity: Medium
14:41:35 <pulpbot> asmacdo: No issues to triage.
14:41:37 <asmacdo> !end
14:41:37 <asmacdo> #endmeeting