14:30:10 <asmacdo> #startmeeting Pulp Triage 2017-09-08
14:30:10 <asmacdo> #info asmacdo has joined triage
14:30:10 <pulpbot> Meeting started Fri Sep  8 14:30:10 2017 UTC and is due to finish in 60 minutes.  The chair is asmacdo. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:30:10 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:30:10 <pulpbot> The meeting name has been set to 'pulp_triage_2017_09_08'
14:30:10 <pulpbot> asmacdo: asmacdo has joined triage
14:30:18 <asmacdo> mhrivnak: shes out
14:30:19 <mhrivnak> heh, I guess not.
14:30:28 <dalley> !here
14:30:28 <dalley> #info dalley has joined triage
14:30:28 <pulpbot> dalley: dalley has joined triage
14:30:33 <mhrivnak> !here
14:30:33 <mhrivnak> #info mhrivnak has joined triage
14:30:33 <pulpbot> mhrivnak: mhrivnak has joined triage
14:30:41 <bmbouter> !here
14:30:41 <bmbouter> #info bmbouter has joined triage
14:30:41 <pulpbot> bmbouter: bmbouter has joined triage
14:30:46 <asmacdo> !next
14:30:46 <ipanova> !here
14:30:47 <asmacdo> #topic Exception when raising a user-Defined Exception that has a custom __init__ signature - http://pulp.plan.io/issues/2988
14:30:47 <ipanova> #info ipanova has joined triage
14:30:47 <pulpbot> asmacdo: 5 issues left to triage: 2988, 2997, 2999, 3001, 3003
14:30:49 <pulpbot> Issue #2988 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:30:50 <pulpbot> Exception when raising a user-Defined Exception that has a custom __init__ signature - http://pulp.plan.io/issues/2988
14:30:51 <pulpbot> ipanova: ipanova has joined triage
14:31:02 <jortel> !here
14:31:02 <jortel> #info jortel has joined triage
14:31:02 <pulpbot> jortel: jortel has joined triage
14:31:13 <mansari> !here
14:31:13 <mansari> #info mansari has joined triage
14:31:13 <pulpbot> mansari: mansari has joined triage
14:31:18 <asmacdo> bmbouter, we've been skipping this one to see what you had to say
14:31:21 <dkliban> !here
14:31:21 <dkliban> #info dkliban has joined triage
14:31:21 <pulpbot> dkliban: dkliban has joined triage
14:32:31 <bmbouter> yeah I saw that but I'm not entirely sure of several aspects of it
14:32:49 <bmbouter> but without that being fixed concrete exceptions that have custom __init__ signatures won't work
14:33:55 <asmacdo> want to accept and investigate late?
14:34:16 <bmbouter> I'm ok with that or with more discussion
14:34:27 <bmbouter> I do have a proposal I could write on the issue
14:34:33 <bmbouter> and we could skip this one last time
14:34:41 <bmbouter> it's a shortie but I'll just put it on the issue instead of here
14:34:46 <asmacdo> k lets do that
14:34:56 <asmacdo> !skip
14:34:57 <pulpbot> asmacdo: 4 issues left to triage: 2997, 2999, 3001, 3003
14:34:57 <asmacdo> #topic download Factory references Artifacts instead of RemoteArtifacts - http://pulp.plan.io/issues/2997
14:34:58 <pulpbot> Issue #2997 [NEW] (unassigned) - Priority: High | Severity: Medium
14:34:59 <pulpbot> download Factory references Artifacts instead of RemoteArtifacts - http://pulp.plan.io/issues/2997
14:35:10 * mhrivnak gets his callback from Delta after 2 hours and really needs to take it... :(
14:35:22 <asmacdo> !propsoe accept
14:35:22 <pulpbot> asmacdo: Error: "propsoe" is not a valid command.
14:35:29 <asmacdo> !propose accept
14:35:29 <asmacdo> #idea Proposed for #2997: Leave the issue as-is, accepting its current state.
14:35:30 <pulpbot> asmacdo: Proposed for #2997: Leave the issue as-is, accepting its current state.
14:35:34 <asmacdo> lets also add to the sprint
14:35:58 <ipanova> i think it is already on the sprint
14:36:07 <asmacdo> so it is
14:36:44 <asmacdo> #agreed Leave the issue as-is, accepting its current state.
14:36:44 <asmacdo> !accept
14:36:44 <pulpbot> asmacdo: Current proposal accepted: Leave the issue as-is, accepting its current state.
14:36:45 <pulpbot> asmacdo: 3 issues left to triage: 2999, 3001, 3003
14:36:46 <asmacdo> #topic As user I can see when task was cancelled - http://pulp.plan.io/issues/2999
14:36:46 <pulpbot> Issue #2999 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:36:47 <pulpbot> As user I can see when task was cancelled - http://pulp.plan.io/issues/2999
14:37:15 <ipanova> this is a request from content delivery team
14:37:21 <ipanova> besides the 2 others
14:38:05 <bmbouter> that looks like a bugfix since that attribute should be set
14:38:11 <dkliban> yeah
14:38:22 <bmbouter> for all of these are they blockers for their upgrade?
14:38:35 <ipanova> no they are not
14:38:36 <bmbouter> if so we should add to sprint. if not, we should backlog and track w/ the RCM tag
14:38:47 <ipanova> it is for better task monitoring
14:39:01 <asmacdo> !propose accept
14:39:01 <asmacdo> #idea Proposed for #2999: Leave the issue as-is, accepting its current state.
14:39:01 <pulpbot> asmacdo: Proposed for #2999: Leave the issue as-is, accepting its current state.
14:39:08 <asmacdo> and add the tag
14:39:15 <bmbouter> btw I can rename RCM -> CDT later today
14:39:32 <ipanova> bmbouter: thanks
14:39:33 <asmacdo> ooh fancy
14:39:52 <ipanova> bmbouter: honestly saying i am not sure we should do these issues
14:40:22 <ipanova> we can have the discussion after the triage
14:40:54 <asmacdo> !accept
14:40:54 <asmacdo> #agreed Leave the issue as-is, accepting its current state.
14:40:54 <pulpbot> asmacdo: Current proposal accepted: Leave the issue as-is, accepting its current state.
14:40:56 <asmacdo> #topic Pulp 2.14 EL5/EL6 repo's do not contain gofer modules - http://pulp.plan.io/issues/3001
14:40:56 <pulpbot> asmacdo: 2 issues left to triage: 3001, 3003
14:40:58 <pulpbot> Issue #3001 [NEW] (unassigned) - Priority: Normal | Severity: High
14:40:59 <pulpbot> Pulp 2.14 EL5/EL6 repo's do not contain gofer modules - http://pulp.plan.io/issues/3001
14:41:13 <bmbouter> this was discussed on pulp-list w/ several notes
14:41:22 <dkliban> we should add this to the sprint
14:41:36 <bmbouter> yes and I think we need to fix with the upcoming 2.13 and 2.14 z releases
14:41:42 <bmbouter> as in release blocker (imo)
14:41:48 <dkliban> i agree
14:42:13 <mhrivnak> +1 accept and add to sprint
14:42:20 <jortel> +1
14:42:33 <asmacdo> is normal/high enough?
14:42:50 <bmbouter> and will we set release blocker?
14:42:53 <jortel> does the build team need to fix this?  or, us?
14:43:01 <bmbouter> build team
14:43:06 <bmbouter> I think it's a mash issue at build time
14:43:14 <dkliban> yah
14:43:16 <bmbouter> the packages are already built in koji they just need to be included
14:43:36 <jortel> that's what I suspected
14:45:14 <asmacdo> ok adding to sprint, 2.14.z blocking
14:45:20 <asmacdo> !accept
14:45:20 <pulpbot> asmacdo: No action proposed, nothing to accept.
14:45:29 <asmacdo> !propose accept
14:45:29 <asmacdo> #idea Proposed for #3001: Leave the issue as-is, accepting its current state.
14:45:29 <pulpbot> asmacdo: Proposed for #3001: Leave the issue as-is, accepting its current state.
14:45:33 <asmacdo> !accept
14:45:33 <asmacdo> #agreed Leave the issue as-is, accepting its current state.
14:45:33 <pulpbot> asmacdo: Current proposal accepted: Leave the issue as-is, accepting its current state.
14:45:34 <pulpbot> asmacdo: 1 issues left to triage: 3003
14:45:34 <asmacdo> #topic sync progress only updates after first item and after all items are processed - http://pulp.plan.io/issues/3003
14:45:35 <pulpbot> Issue #3003 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:45:36 <pulpbot> sync progress only updates after first item and after all items are processed - http://pulp.plan.io/issues/3003
14:46:00 <dkliban> i don't think this is an alpha blocker but we should fix this soon
14:46:06 <mhrivnak> +1
14:46:53 <asmacdo> dkliban: is this pulp_example? or is this general to both sync apis
14:46:56 <ipanova> oh we need to triage this as well https://pulp.plan.io/issues/2998
14:47:11 <dkliban> asmacdo: i have not tested with pulp_example yet, just pulp_file
14:47:13 <ipanova> it was initially filled as story
14:47:50 <asmacdo> thanks ipanova
14:47:55 <ipanova> dkliban: do we want to add to sprint ?
14:47:59 <asmacdo> !propose accept
14:47:59 <asmacdo> #idea Proposed for #3003: Leave the issue as-is, accepting its current state.
14:47:59 <pulpbot> asmacdo: Proposed for #3003: Leave the issue as-is, accepting its current state.
14:48:16 <mhrivnak> I'd not add to sprint.
14:48:24 <dkliban> i don't think we need to
14:48:28 <dkliban> ipanova: ^
14:48:29 <ipanova> k
14:48:45 <asmacdo> !accept
14:48:45 <asmacdo> #agreed Leave the issue as-is, accepting its current state.
14:48:45 <pulpbot> asmacdo: Current proposal accepted: Leave the issue as-is, accepting its current state.
14:48:46 <pulpbot> asmacdo: No issues to triage.
14:48:55 <asmacdo> !issue 2998
14:48:56 <asmacdo> #topic As user I can see when each sync/publish step started and finished - http://pulp.plan.io/issues/2998
14:48:56 <pulpbot> Story #2998 [NEW] (unassigned) - Priority: Normal
14:48:57 <mhrivnak> If we run out of sprint work, that would be a good one to look at. :)
14:48:58 <pulpbot> As user I can see when each sync/publish step started and finished - http://pulp.plan.io/issues/2998
14:49:13 <mhrivnak> ipanova are you suggesting this should be a bug?
14:49:34 <ipanova> i suggest to close it right away if we do not plan to fix it in pulp2
14:50:07 <mhrivnak> It could become a pulp 3 feature.
14:50:20 <asmacdo> except sans steps :)
14:50:34 <ipanova> mhrivnak: fair enough, then accept and make a pulp3 tag?
14:50:44 <mhrivnak> Heh, well, I think "step" here doesn't necessarily refer to the step system.
14:51:16 <mhrivnak> ipanova ya I think we should just accept this for pulp 3.
14:51:25 <asmacdo> !propose accept
14:51:25 <asmacdo> #idea Proposed for #2998: Leave the issue as-is, accepting its current state.
14:51:25 <pulpbot> asmacdo: Proposed for #2998: Leave the issue as-is, accepting its current state.
14:51:31 <ipanova> agreed
14:51:33 <mhrivnak> And could comment on how big a pain it would be for pulp 2.
14:51:40 <asmacdo> +rcm tag
14:51:54 <ipanova> asmacdo: !punish, cdt tag
14:51:54 <jortel> the 1st cut of publishing does not have progress reporting.  let's add a story for file plugin to add progress reporting.
14:52:07 <mhrivnak> +1
14:52:10 <dkliban> jortel: +1
14:52:19 <ipanova> +1
14:52:32 <jortel> and do post-alpha
14:53:02 <jortel> I will add the story.
14:53:21 <asmacdo> !accept
14:53:21 <asmacdo> #agreed Leave the issue as-is, accepting its current state.
14:53:21 <pulpbot> asmacdo: Current proposal accepted: Leave the issue as-is, accepting its current state.
14:53:22 <pulpbot> asmacdo: No issues to triage.
14:54:34 <asmacdo> !end
14:54:34 <asmacdo> #endmeeting