14:30:40 <ttereshc> #startmeeting Pulp Triage 2017-09-12
14:30:40 <ttereshc> #info ttereshc has joined triage
14:30:41 <pulpbot> Meeting started Tue Sep 12 14:30:40 2017 UTC and is due to finish in 60 minutes.  The chair is ttereshc. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:30:41 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:30:41 <pulpbot> The meeting name has been set to 'pulp_triage_2017_09_12'
14:30:41 <pulpbot> ttereshc: ttereshc has joined triage
14:30:42 <daviddavis> !here
14:30:42 <daviddavis> #info daviddavis has joined triage
14:30:43 <pulpbot> daviddavis: daviddavis has joined triage
14:30:48 <dalley_> !here
14:30:48 <dalley_> #info dalley_ has joined triage
14:30:48 <pulpbot> dalley_: dalley_ has joined triage
14:31:10 <mansari> !here
14:31:10 <mansari> #info mansari has joined triage
14:31:10 <pulpbot> mansari: mansari has joined triage
14:31:14 <jortel> !here
14:31:14 <jortel> #info jortel has joined triage
14:31:14 <pulpbot> jortel: jortel has joined triage
14:31:16 <ttereshc> !next
14:31:17 <pulpbot> ttereshc: 3 issues left to triage: 2988, 3004, 3005
14:31:17 <ttereshc> #topic Exception when raising a user-Defined Exception that has a custom __init__ signature - http://pulp.plan.io/issues/2988
14:31:18 <pulpbot> Issue #2988 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:31:19 <pulpbot> Exception when raising a user-Defined Exception that has a custom __init__ signature - http://pulp.plan.io/issues/2988
14:32:22 <asmacdo> !here
14:32:22 <asmacdo> #info asmacdo has joined triage
14:32:22 <pulpbot> asmacdo: asmacdo has joined triage
14:32:24 <bmbouter> !here
14:32:24 <bmbouter> #info bmbouter has joined triage
14:32:24 <pulpbot> bmbouter: bmbouter has joined triage
14:32:32 <dkliban> !here
14:32:32 <dkliban> #info dkliban has joined triage
14:32:32 <pulpbot> dkliban: dkliban has joined triage
14:32:43 <bmbouter> I wrote my recommendation at the bottom in the last comment
14:32:43 <asmacdo> !propose notskip
14:32:43 <pulpbot> asmacdo: Error: "propose" is not a valid command.
14:33:06 <daviddavis> ha
14:33:15 <bmbouter> which is to accept and use non-concrete exceptions for now and switch them to concrete exceptions later (iirc)
14:34:30 <ttereshc> !propose accept
14:34:30 <ttereshc> #idea Proposed for #2988: Leave the issue as-is, accepting its current state.
14:34:30 <pulpbot> ttereshc: Proposed for #2988: Leave the issue as-is, accepting its current state.
14:35:02 <asmacdo> +1
14:35:30 <ttereshc> I think it's the issue which has to be solved post alpha and how we are going to solve it, we can decide later
14:36:05 <jortel> +1 to accept as is
14:36:08 <ttereshc> !accept
14:36:08 <ttereshc> #agreed Leave the issue as-is, accepting its current state.
14:36:08 <pulpbot> ttereshc: Current proposal accepted: Leave the issue as-is, accepting its current state.
14:36:09 <pulpbot> ttereshc: 2 issues left to triage: 3004, 3005
14:36:10 <ttereshc> #topic recursive errata copy does not copy rpms - http://pulp.plan.io/issues/3004
14:36:10 <pulpbot> Issue #3004 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:36:11 <pulpbot> recursive errata copy does not copy rpms - http://pulp.plan.io/issues/3004
14:37:28 <ttereshc> This is a regression in 6.2.11 and I guess it's becasue of my changes to errata handling, so likely a regression in 2.13.3
14:37:30 <jortel> bz has a pm score of 2100 seems important
14:37:43 <ttereshc> I think it is important
14:37:45 <daviddavis> high?
14:37:48 <daviddavis> add to sprint?
14:37:55 <ttereshc> I suggest high/high and ad to sprint
14:37:58 <ttereshc> yes :)
14:38:01 <daviddavis> +1
14:38:03 <jortel> +1
14:38:03 <asmacdo> sounds good
14:38:16 <ttereshc> !propose other triage h h, add to sprint
14:38:16 <ttereshc> #idea Proposed for #3004: triage h h, add to sprint
14:38:17 <pulpbot> ttereshc: Proposed for #3004: triage h h, add to sprint
14:38:21 <ttereshc> !accept
14:38:21 <ttereshc> #agreed triage h h, add to sprint
14:38:21 <pulpbot> ttereshc: Current proposal accepted: triage h h, add to sprint
14:38:22 <pulpbot> ttereshc: 1 issues left to triage: 3005
14:38:22 <ttereshc> #topic redmine_bugzilla script restores NEEDSINFO flag on developer after it has been removed - http://pulp.plan.io/issues/3005
14:38:24 <pulpbot> Issue #3005 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:38:24 <asmacdo> lol @ pulp-admin rpm repo sync --repo-id=foo2 and then pulp-admin rpm repo sync run --repo-id=foo2
14:38:25 <pulpbot> redmine_bugzilla script restores NEEDSINFO flag on developer after it has been removed - http://pulp.plan.io/issues/3005
14:38:28 <dalley_> low / low
14:38:45 <dalley_> just an annoyance
14:38:46 <daviddavis> asmacdo: ha
14:39:03 <asmacdo> daviddavis: ive done that so many (like every?) time
14:39:17 <daviddavis> dalley_: how do we fix it
14:39:25 <daviddavis> asmacdo: lol me too
14:39:37 <asmacdo> bmbouter wrote thae script iirc
14:39:51 <ttereshc> is it an issue at all? I think it probably makes sense to keep developer on the ticket. And the workflow currently is that if no more input from upstream is required, FailedQA should be unset as well
14:39:57 <ttereshc> along with needinfo
14:40:00 <dalley_> not sure, I haven't spent much time on it yet, I just recorded the bug when I came across it
14:40:29 <dalley_> ttereshc, that's a good point
14:40:38 <daviddavis> yea, I kinda agree too
14:40:42 <dalley_> but, once someone comments on the issue, don't they get emails anyway?
14:40:51 <dalley_> does needsinfo need to be set also
14:41:08 <dalley_> unless you mean for reference purposes
14:41:18 <dalley_> in which case... I agree with you, that sounds fine
14:41:36 <daviddavis> I don't see the harm in NEEDSINFO I guess. unless people start complaining.
14:41:40 <ttereshc> maybe they get into CC but you won't see as an upstream developer that you have needinfo flag, that something is still waiting on you
14:42:04 <daviddavis> +1
14:42:11 <dalley_> sounds fine to me
14:42:23 <ttereshc> maybe some feedback from bmbouter will be helpful and we can close it if needed after triage
14:42:23 <dalley_> NOTABUG ?
14:42:23 <ttereshc> _
14:42:25 <ttereshc> ?
14:42:39 <ttereshc> !propose skip
14:42:39 <ttereshc> #idea Proposed for #3005: Skip this issue for this triage session.
14:42:40 <pulpbot> ttereshc: Proposed for #3005: Skip this issue for this triage session.
14:42:43 <daviddavis> +1
14:42:43 <dalley_> +1
14:42:50 <ttereshc> !accept
14:42:50 <ttereshc> #agreed Skip this issue for this triage session.
14:42:50 <pulpbot> ttereshc: Current proposal accepted: Skip this issue for this triage session.
14:42:52 <pulpbot> ttereshc: No issues to triage.
14:42:56 <ttereshc> !end
14:42:56 <ttereshc> #endmeeting