14:30:09 <ttereshc> #startmeeting Pulp Triage 2017-09-15
14:30:09 <ttereshc> #info ttereshc has joined triage
14:30:10 <pulpbot> Meeting started Fri Sep 15 14:30:09 2017 UTC and is due to finish in 60 minutes.  The chair is ttereshc. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:30:10 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:30:10 <pulpbot> The meeting name has been set to 'pulp_triage_2017_09_15'
14:30:10 <pulpbot> ttereshc: ttereshc has joined triage
14:30:17 <dkliban> !here
14:30:17 <dkliban> #info dkliban has joined triage
14:30:17 <pulpbot> dkliban: dkliban has joined triage
14:30:39 <fdobrovo> !here
14:30:39 <fdobrovo> #info fdobrovo has joined triage
14:30:39 <pulpbot> fdobrovo: fdobrovo has joined triage
14:30:49 <mansari> !here
14:30:49 <mansari> #info mansari has joined triage
14:30:49 <pulpbot> mansari: mansari has joined triage
14:30:54 <ttereshc> !next
14:30:55 <pulpbot> ttereshc: 8 issues left to triage: 3010, 3011, 3012, 3013, 3014, 3015, 3016, 3017
14:30:56 <ttereshc> #topic Can't sync Docker images - http://pulp.plan.io/issues/3010
14:30:56 <pulpbot> Issue #3010 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:30:58 <pulpbot> Can't sync Docker images - http://pulp.plan.io/issues/3010
14:30:59 <dalley> !here
14:30:59 <dalley> #info dalley has joined triage
14:31:00 <pulpbot> dalley: dalley has joined triage
14:31:22 <bizhang> !here
14:31:22 <bizhang> #info bizhang has joined triage
14:31:22 <pulpbot> bizhang: bizhang has joined triage
14:31:30 <ttereshc> ipanova, shouldn't it be in modified with your yesterday's PR?
14:31:37 <bmbouter> #info bmbouter has joined triage
14:31:37 <bmbouter> !here
14:31:37 <pulpbot> bmbouter: bmbouter has joined triage
14:31:38 <ipanova> #info ipanova has joined triage
14:31:38 <ipanova> !here
14:31:38 <pulpbot> ipanova: ipanova has joined triage
14:31:52 <jortel> !here
14:31:52 <jortel> #info jortel has joined triage
14:31:52 <pulpbot> jortel: jortel has joined triage
14:32:19 <ipanova> ttereshc: yeah
14:32:30 <ttereshc> ipanova, will you take care of it?
14:32:51 <ipanova> yes
14:33:05 <ttereshc> !propose other ipanova will update the state
14:33:05 <ttereshc> #idea Proposed for #3010: ipanova will update the state
14:33:05 <pulpbot> ttereshc: Proposed for #3010: ipanova will update the state
14:33:09 <ttereshc> !accept
14:33:09 <ttereshc> #agreed ipanova will update the state
14:33:09 <pulpbot> ttereshc: Current proposal accepted: ipanova will update the state
14:33:10 <pulpbot> ttereshc: 7 issues left to triage: 3011, 3012, 3013, 3014, 3015, 3016, 3017
14:33:10 <ttereshc> #topic deleting a publisher via REST api produces a traceback - http://pulp.plan.io/issues/3011
14:33:11 <pulpbot> Issue #3011 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:33:12 <pulpbot> deleting a publisher via REST api produces a traceback - http://pulp.plan.io/issues/3011
14:33:12 <ttereshc> ty ipanova
14:33:36 <dkliban> i think we have a PR that is addressing the 'repository' part of the traceback
14:34:41 <ttereshc> alpha tag, add to sprint?
14:34:59 <dkliban> neither. but we should consider for next sprint
14:35:26 <ttereshc> how do you delete a publisher then?
14:35:38 <dkliban> you can't right now
14:36:01 <dkliban> we can add to sprint, but no alpha tag
14:36:21 <ttereshc> !propose accept
14:36:21 <ttereshc> #idea Proposed for #3011: Leave the issue as-is, accepting its current state.
14:36:21 <pulpbot> ttereshc: Proposed for #3011: Leave the issue as-is, accepting its current state.
14:36:37 <jortel> I'm on the fence but seems like for the alpha, the min is to create things.
14:36:53 <jortel> this should be high prio though
14:37:16 <ttereshc> !propose other triage high/med, mark as sprint candidate
14:37:16 <ttereshc> #idea Proposed for #3011: triage high/med, mark as sprint candidate
14:37:16 <pulpbot> ttereshc: Proposed for #3011: triage high/med, mark as sprint candidate
14:37:26 <dkliban> +1
14:37:35 <jortel> high/high
14:38:02 <ttereshc> !propose other triage high/high, mark as sprint candidate
14:38:02 <ttereshc> #idea Proposed for #3011: triage high/high, mark as sprint candidate
14:38:03 <pulpbot> ttereshc: Proposed for #3011: triage high/high, mark as sprint candidate
14:38:07 <ttereshc> !accept
14:38:07 <ttereshc> #agreed triage high/high, mark as sprint candidate
14:38:07 <pulpbot> ttereshc: Current proposal accepted: triage high/high, mark as sprint candidate
14:38:08 <pulpbot> ttereshc: 6 issues left to triage: 3012, 3013, 3014, 3015, 3016, 3017
14:38:09 <ttereshc> #topic db-reset script fails to migrate - http://pulp.plan.io/issues/3012
14:38:09 <pulpbot> Issue #3012 [POST] (amacdona@redhat.com) - Priority: Normal | Severity: Medium
14:38:10 <pulpbot> db-reset script fails to migrate - http://pulp.plan.io/issues/3012
14:38:45 <dkliban> already in POST
14:39:07 <jortel> asmacdo++
14:39:07 <pulpbot> jortel: asmacdo's karma is now 4
14:39:18 <ttereshc> !propose other accept, add to sprint
14:39:18 <ttereshc> #idea Proposed for #3012: accept, add to sprint
14:39:18 <pulpbot> ttereshc: Proposed for #3012: accept, add to sprint
14:39:39 <ttereshc> !accept
14:39:39 <ttereshc> #agreed accept, add to sprint
14:39:39 <pulpbot> ttereshc: Current proposal accepted: accept, add to sprint
14:39:40 <pulpbot> ttereshc: 5 issues left to triage: 3013, 3014, 3015, 3016, 3017
14:39:41 <ttereshc> #topic Content is not downloaded after switching from on_demand to immediate policy - http://pulp.plan.io/issues/3013
14:39:41 <pulpbot> Issue #3013 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:39:42 <pulpbot> Content is not downloaded after switching from on_demand to immediate policy - http://pulp.plan.io/issues/3013
14:41:27 <ttereshc> what are expectations for alpha? should this policy change work?
14:41:44 <ttereshc> I think, yes
14:41:53 <ttereshc> what do others think?
14:41:55 <dkliban> i don'tthink we have a streamer
14:42:05 <dkliban> so we don't have a way to really use the on demand policy
14:42:26 <jortel> no, we don't.  I think high/high and not aligned to alpha
14:42:37 <dkliban> +1
14:42:46 <dalley> +1
14:42:59 <ttereshc> so users will have ability to create a bunch of things which won't work :(
14:43:15 <ttereshc> !propose triage h h
14:43:15 <ttereshc> #idea Proposed for #3013: Priority: High, Severity: High
14:43:15 <pulpbot> ttereshc: Proposed for #3013: Priority: High, Severity: High
14:43:18 <dkliban> ttereshc: we will fix these very soon and re-release
14:43:26 <ttereshc> !accept
14:43:26 <ttereshc> #agreed Priority: High, Severity: High
14:43:26 <pulpbot> ttereshc: Current proposal accepted: Priority: High, Severity: High
14:43:28 <pulpbot> ttereshc: 4 issues left to triage: 3014, 3015, 3016, 3017
14:43:29 <ttereshc> #topic Counters for added content are incorrect in case of download failures - http://pulp.plan.io/issues/3014
14:43:29 <pulpbot> Issue #3014 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:43:30 <pulpbot> Counters for added content are incorrect in case of download failures - http://pulp.plan.io/issues/3014
14:44:35 <dkliban> same as the last?
14:44:44 <jortel> +1
14:44:47 <ttereshc> !propose triage h h
14:44:47 <ttereshc> #idea Proposed for #3014: Priority: High, Severity: High
14:44:47 <pulpbot> ttereshc: Proposed for #3014: Priority: High, Severity: High
14:44:59 <ttereshc> !accept
14:44:59 <ttereshc> #agreed Priority: High, Severity: High
14:44:59 <pulpbot> ttereshc: Current proposal accepted: Priority: High, Severity: High
14:45:00 <pulpbot> ttereshc: 3 issues left to triage: 3015, 3016, 3017
14:45:00 <ttereshc> #topic Sensitive data is visible in task results in case of download failures - http://pulp.plan.io/issues/3015
14:45:01 <pulpbot> Issue #3015 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:45:02 <pulpbot> Sensitive data is visible in task results in case of download failures - http://pulp.plan.io/issues/3015
14:45:50 <dkliban> jortel: if a password was provided, would it show up in the output or do you have something obfuscate it ?
14:46:05 <jortel> dkliban: it would show up here.
14:46:11 <jortel> er, in the log
14:46:17 <dkliban> gotcha
14:46:48 <jortel> er, in the task.
14:47:06 <dkliban> accept as is?
14:47:29 <ttereshc> it looks like an easyfix, maybe worth fixing right away? just remove several options from output
14:47:30 <jortel> +1
14:48:05 <jortel> post alpah
14:48:07 <jortel> not a blocker
14:48:34 <ttereshc> as a user I won't be happy, to be honest
14:48:41 <ttereshc> !propose accept
14:48:41 <ttereshc> #idea Proposed for #3015: Leave the issue as-is, accepting its current state.
14:48:41 <pulpbot> ttereshc: Proposed for #3015: Leave the issue as-is, accepting its current state.
14:48:47 <ttereshc> !accept
14:48:47 <ttereshc> #agreed Leave the issue as-is, accepting its current state.
14:48:47 <pulpbot> ttereshc: Current proposal accepted: Leave the issue as-is, accepting its current state.
14:48:48 <pulpbot> ttereshc: 2 issues left to triage: 3016, 3017
14:48:49 <ttereshc> #topic Removal of an Artifact leaves repo with associated artifactless Content forever - http://pulp.plan.io/issues/3016
14:48:49 <pulpbot> Issue #3016 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:48:50 <pulpbot> Removal of an Artifact leaves repo with associated artifactless Content forever - http://pulp.plan.io/issues/3016
14:50:35 <dkliban> we should not support removing artifacts associated with content that's in a repository that has an immediate download policy
14:50:43 <jortel> agreed.
14:51:01 <dkliban> i think this one is also high/high
14:51:30 <jortel> +1
14:51:32 <ttereshc> !propose triage h h
14:51:32 <ttereshc> #idea Proposed for #3016: Priority: High, Severity: High
14:51:32 <pulpbot> ttereshc: Proposed for #3016: Priority: High, Severity: High
14:51:36 <bmbouter> +1
14:51:39 <ttereshc> !accept
14:51:39 <ttereshc> #agreed Priority: High, Severity: High
14:51:39 <pulpbot> ttereshc: Current proposal accepted: Priority: High, Severity: High
14:51:40 <pulpbot> ttereshc: 1 issues left to triage: 3017
14:51:40 <ttereshc> #topic RemoteArtifact contains all the calculated hashes instead of only ones available in a remote repo - http://pulp.plan.io/issues/3017
14:51:41 <pulpbot> Issue #3017 [NEW] (unassigned) - Priority: Normal | Severity: Low
14:51:42 <pulpbot> RemoteArtifact contains all the calculated hashes instead of only ones available in a remote repo - http://pulp.plan.io/issues/3017
14:51:53 <ttereshc> the one we discussed earlier
14:51:59 <ttereshc> !propose accept
14:51:59 <ttereshc> #idea Proposed for #3017: Leave the issue as-is, accepting its current state.
14:51:59 <pulpbot> ttereshc: Proposed for #3017: Leave the issue as-is, accepting its current state.
14:52:18 <jortel> After thinking about it, I think this is a correctness prob.
14:52:33 <jortel> maybe h/m ?
14:52:40 <jortel> but not an alpha blocker
14:52:51 <ttereshc> #idea Proposed for #3017: Priority: High, Severity: Medium
14:52:51 <ttereshc> !propose triage h m
14:52:51 <pulpbot> ttereshc: Proposed for #3017: Priority: High, Severity: Medium
14:53:03 <dkliban> +1
14:53:07 <ttereshc> !accept
14:53:07 <ttereshc> #agreed Priority: High, Severity: Medium
14:53:07 <pulpbot> ttereshc: Current proposal accepted: Priority: High, Severity: Medium
14:53:08 <pulpbot> ttereshc: No issues to triage.
14:53:12 <ttereshc> !end
14:53:12 <ttereshc> #endmeeting