14:32:19 <ttereshc> #startmeeting Pulp Triage 2017-09-22
14:32:19 <ttereshc> #info ttereshc has joined triage
14:32:19 <pulpbot> Meeting started Fri Sep 22 14:32:19 2017 UTC and is due to finish in 60 minutes.  The chair is ttereshc. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:32:19 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:32:19 <pulpbot> The meeting name has been set to 'pulp_triage_2017_09_22'
14:32:19 <pulpbot> ttereshc: ttereshc has joined triage
14:32:20 <asmacdo> !here
14:32:21 <asmacdo> #info asmacdo has joined triage
14:32:21 <pulpbot> asmacdo: asmacdo has joined triage
14:32:25 <daviddavis> !here
14:32:25 <daviddavis> #info daviddavis has joined triage
14:32:25 <pulpbot> daviddavis: daviddavis has joined triage
14:32:50 <ipanova> !!!here
14:32:50 <pulpbot> ipanova: Error: "!!here" is not a valid command.
14:32:53 <ipanova> !here
14:32:53 <ipanova> #info ipanova has joined triage
14:32:53 <pulpbot> ipanova: ipanova has joined triage
14:32:54 <ttereshc> !next
14:32:55 <pulpbot> ttereshc: 4 issues left to triage: 3022, 3023, 3026, 3027
14:32:55 <ttereshc> #topic Tasks delete endpoint does not work if the optional parameter was not provided. - http://pulp.plan.io/issues/3022
14:32:56 <pulpbot> Issue #3022 [NEW] (unassigned) - Priority: Low | Severity: Low
14:32:57 <pulpbot> Tasks delete endpoint does not work if the optional parameter was not provided. - http://pulp.plan.io/issues/3022
14:32:57 <daviddavis> lol
14:33:22 <daviddavis> easy fix?
14:33:44 <mansari_> #info mansari_ has joined triage
14:33:44 <mansari_> !here
14:33:44 <pulpbot> mansari_: mansari_ has joined triage
14:33:44 <dalley> !here
14:33:44 <dalley> #info dalley has joined triage
14:33:45 <pulpbot> dalley: dalley has joined triage
14:34:02 <bmbouter> !here
14:34:02 <bmbouter> #info bmbouter has joined triage
14:34:02 <pulpbot> bmbouter: bmbouter has joined triage
14:34:06 <ttereshc> !propose accept
14:34:06 <ttereshc> #idea Proposed for #3022: Leave the issue as-is, accepting its current state.
14:34:06 <pulpbot> ttereshc: Proposed for #3022: Leave the issue as-is, accepting its current state.
14:34:08 <asmacdo> what behavior do we want there?
14:34:27 <asmacdo> should that return a 400? or should it delete all tasks
14:34:36 <mhrivnak> !here
14:34:36 <mhrivnak> #info mhrivnak has joined triage
14:34:36 <pulpbot> mhrivnak: mhrivnak has joined triage
14:34:44 <bizhang> #info bizhang has joined triage
14:34:44 <bizhang> !here
14:34:44 <pulpbot> bizhang: bizhang has joined triage
14:34:47 <daviddavis> so maybe make the parameter required?
14:35:04 <ipanova> i guess we need to update docs and change from optional to required
14:35:20 <mhrivnak> 403 is also a surprising response code for this case.
14:35:24 <bmbouter> agreed
14:35:34 <daviddavis> yes
14:35:50 <asmacdo> so i guess we really have 2 issues
14:36:12 <asmacdo> why in the world is that returning a 403 & make state non-optional
14:37:14 <ttereshc> what about prio?
14:37:25 <daviddavis> low seems fine to me
14:37:33 <asmacdo> I think more than low/low
14:37:33 <daviddavis> if it's just this one field
14:37:37 <mhrivnak> agreed. The workaround is easy.
14:37:53 <asmacdo> maybe low medium
14:38:12 <daviddavis> worx4me
14:38:21 <asmacdo> !propose triage l/m
14:38:21 <pulpbot> asmacdo: (propose triage <priority> <severity> [target_release]) -- Propose triage values including priority, severity, and an optional target release.
14:38:26 <ttereshc> asmacdo, could you also put a comment what the issues are ?
14:38:29 <mhrivnak> fine with me.
14:38:30 <asmacdo> !propose triage low medium
14:38:30 <asmacdo> #idea Proposed for #3022: Priority: Low, Severity: Medium
14:38:30 <pulpbot> asmacdo: Proposed for #3022: Priority: Low, Severity: Medium
14:38:45 <ttereshc> !accept
14:38:45 <ttereshc> #agreed Priority: Low, Severity: Medium
14:38:45 <pulpbot> ttereshc: Current proposal accepted: Priority: Low, Severity: Medium
14:38:45 <asmacdo> ttereshc: sure, ill change prio too while im in there
14:38:46 <pulpbot> ttereshc: 3 issues left to triage: 3023, 3026, 3027
14:38:47 <ttereshc> #topic Packages are published twice in a repo when synced from CentOS 7 Main repo - http://pulp.plan.io/issues/3023
14:38:47 <pulpbot> Issue #3023 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:38:48 <pulpbot> Packages are published twice in a repo when synced from CentOS 7 Main repo - http://pulp.plan.io/issues/3023
14:38:52 <mansari> !here
14:38:52 <mansari> #info mansari has joined triage
14:38:52 <pulpbot> mansari: mansari has joined triage
14:39:00 <ttereshc> asmacdo, ty
14:39:28 <dkliban> my guess is taht this only happens with packages that start wit ha number
14:39:36 <dkliban> and that's why we haven't noticed
14:39:41 <mhrivnak> This needs more info.
14:39:44 <mhrivnak> version of pulp
14:39:47 <mhrivnak> link to a repo
14:39:57 <dkliban> this happen with 2.13
14:40:10 <ttereshc> I think we need to investigate this, it was some recent katello installation I htink
14:40:16 <mhrivnak> ah
14:40:35 <dkliban> mhrivnak: 2.13.2 to be exact ... jsherrill reproduced it
14:40:48 <ttereshc> oh really?
14:41:02 <mhrivnak> Ah, interesting. Can you add that to the issue?
14:41:06 <dkliban> i will
14:41:09 <mhrivnak> Thanks.
14:41:27 <ttereshc> normal/med?
14:41:31 <mhrivnak> If we can get the url he used, that would be helpful also.
14:41:40 <dkliban> mhrivnak: i'll get the details
14:42:16 <mhrivnak> We could skip this and take another look when there are a few more details on Tuesday.
14:42:22 <asmacdo> +1 skip
14:42:24 <daviddavis> +1
14:42:34 <ttereshc> !skip
14:42:36 <ttereshc> #topic Getting an error with venv during vagrant up of pulp 3.0 dev environment - http://pulp.plan.io/issues/3026
14:42:36 <pulpbot> ttereshc: 2 issues left to triage: 3026, 3027
14:42:37 <pulpbot> Issue #3026 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:42:38 <pulpbot> Getting an error with venv during vagrant up of pulp 3.0 dev environment - http://pulp.plan.io/issues/3026
14:42:50 <daviddavis> so this one might be closed as wontfix
14:43:07 <daviddavis> basically if you use the version of ansible in epel7, you get an error when you vagrant up
14:43:15 <mansari> +1
14:43:23 <daviddavis> I'm on centos 7 so I had to rpm uninstall and then pip install ansible
14:43:27 <daviddavis> wasn't too hard
14:43:31 <mhrivnak> run ansible in a container. ;)
14:43:34 <daviddavis> ha
14:44:02 <daviddavis> another option: say we require ansible 2.3.2+ in the docs or something
14:44:04 <asmacdo> wait
14:44:07 <dkliban> yep
14:44:10 <dalley> +1
14:44:21 <asmacdo> also require ansible 2.3.2+ in the ansible version assertion
14:44:30 <daviddavis> +1
14:44:45 <bmbouter> +1
14:44:47 <mansari> +1
14:44:48 <ttereshc> !propose accept
14:44:48 <ttereshc> #idea Proposed for #3026: Leave the issue as-is, accepting its current state.
14:44:48 <pulpbot> ttereshc: Proposed for #3026: Leave the issue as-is, accepting its current state.
14:44:49 <daviddavis> I can update the bug
14:44:49 <asmacdo> ansible in a container lol
14:44:57 <mhrivnak> +1
14:44:59 <ttereshc> daviddavis, ty
14:45:06 <mhrivnak> seriously it's the future. :)
14:45:14 <ipanova> jeremy gave me this magical command and after iti was able to run with 2.3.1
14:45:15 <ipanova> ansible all -i localhost, -c local -m pip -a 'name=flake8 virtualenv=/tmp/env virtualenv_command="/usr/bin/python3 -m venv"'
14:45:25 <ttereshc> everyone is fine with normal/med?
14:45:34 <mhrivnak> +1
14:45:36 <bmbouter> don't we want to be able to run w/ the stock EL7 ansible?
14:45:54 <bmbouter> maybe now isn't the time for that convo but I think we do if possible
14:45:58 <ttereshc> !accept
14:45:58 <ttereshc> #agreed Leave the issue as-is, accepting its current state.
14:45:58 <pulpbot> ttereshc: Current proposal accepted: Leave the issue as-is, accepting its current state.
14:45:59 <pulpbot> ttereshc: 1 issues left to triage: 3027
14:46:00 <ttereshc> #topic Pulp doesn't generate prestodelta.xml - http://pulp.plan.io/issues/3027
14:46:00 <pulpbot> Issue #3027 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:46:01 <pulpbot> Pulp doesn't generate prestodelta.xml - http://pulp.plan.io/issues/3027
14:46:15 <asmacdo> we probably ought to work in EL7 bmbouter
14:46:24 <asmacdo> it will make debugging rhel easier for sure
14:46:33 <daviddavis> so rhel7 has ansible 2.3.2 in its repos
14:46:51 <ttereshc> ipanova, so you tried to reproduced it and it worked for you?
14:47:03 <ipanova> yes it worked for me
14:47:08 <ttereshc> hmm
14:47:12 <daviddavis> the problem is that I am on centos 7 which uses epel 7 and I am not subscribed to get the rhel7 repo
14:47:22 <ipanova> i was hoping user will provide more info in the bug report
14:47:25 <ipanova> then in the email
14:47:46 <mhrivnak> Having the feed url would help.
14:47:59 <daviddavis> +1
14:48:10 <ipanova> agreed
14:48:21 <ttereshc> !propose needinfo
14:48:21 <ttereshc> #idea Proposed for #3027: This issue cannot be triaged without more info.
14:48:21 <pulpbot> ttereshc: Proposed for #3027: This issue cannot be triaged without more info.
14:48:21 <mhrivnak> ipanova shall we skip for now and ask for specific details?
14:48:57 <ipanova> let's put the comment and ask the info we need/might be useful for us to debug
14:49:04 <ipanova> and leave for now untriaged
14:49:15 <mhrivnak> +1
14:49:17 <ttereshc> !accept
14:49:17 <ttereshc> #agreed This issue cannot be triaged without more info.
14:49:18 <pulpbot> ttereshc: Current proposal accepted: This issue cannot be triaged without more info.
14:49:19 <pulpbot> ttereshc: No issues to triage.
14:49:24 <ttereshc> !end
14:49:24 <ttereshc> #endmeeting