14:30:09 <ttereshc> #startmeeting Pulp Triage 2017-10-03
14:30:09 <ttereshc> #info ttereshc has joined triage
14:30:10 <pulpbot> Meeting started Tue Oct 3 14:30:09 2017 UTC and is due to finish in 60 minutes. The chair is ttereshc. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:30:10 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:30:10 <pulpbot> The meeting name has been set to 'pulp_triage_2017_10_03'
14:30:10 <pulpbot> ttereshc: ttereshc has joined triage
14:30:14 <mhrivnak> !here
14:30:14 <mhrivnak> #info mhrivnak has joined triage
14:30:14 <dalley> !here
14:30:14 <dalley> #info dalley has joined triage
14:30:14 <pulpbot> mhrivnak: mhrivnak has joined triage
14:30:15 <pulpbot> dalley: dalley has joined triage
14:30:20 <ttereshc> !next
14:30:21 <pulpbot> ttereshc: 5 issues left to triage: 3039, 3041, 3046, 3049, 3050
14:30:21 <ttereshc> #topic Uninstalling pulp-rpm-handlers removes /etc/yum.repos.d/pulp.repo - http://pulp.plan.io/issues/3039
14:30:22 <pulpbot> Issue #3039 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:30:23 <pulpbot> Uninstalling pulp-rpm-handlers removes /etc/yum.repos.d/pulp.repo - http://pulp.plan.io/issues/3039
14:30:30 <kersom> dalley, ichimonji10, I guess this is the https://pulp.plan.io/issues/3036
14:30:54 <mhrivnak> !propose accept
14:30:54 <mhrivnak> #idea Proposed for #3039: Leave the issue as-is, accepting its current state.
14:30:55 <pulpbot> mhrivnak: Proposed for #3039: Leave the issue as-is, accepting its current state.
14:30:55 <ichimonji10> Yup. What I posted in that issue is basically what I know.
14:30:59 <asmacdo> +1
14:31:05 <dalley> +1
14:31:25 <ttereshc> !accept
14:31:25 <ttereshc> #agreed Leave the issue as-is, accepting its current state.
14:31:25 <pulpbot> ttereshc: Current proposal accepted: Leave the issue as-is, accepting its current state.
14:31:26 <pulpbot> ttereshc: 4 issues left to triage: 3041, 3046, 3049, 3050
14:31:27 <ttereshc> #topic It's impossible to track the status of a scheduled task - http://pulp.plan.io/issues/3041
14:31:27 <pulpbot> Issue #3041 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:31:28 <pulpbot> It's impossible to track the status of a scheduled task - http://pulp.plan.io/issues/3041
14:31:55 <mhrivnak> I suspect this will be a WORKSFORME when #3042 gets fixed.
14:32:05 <daviddavis> !here
14:32:05 <daviddavis> #info daviddavis has joined triage
14:32:05 <pulpbot> daviddavis: daviddavis has joined triage
14:32:24 <mhrivnak> ichimonji10 think this could be a duplicate of 3042?
14:32:47 <ichimonji10> They're not the same.
14:32:57 <ttereshc> should we mark them as related and a comment to check after 3042 is complete?
14:33:35 <ichimonji10> 3041 describes how there's not any information that can be used to find out which async task describes the progress of a (running) scheduled task.
14:33:51 <bmbouter> !here
14:33:51 <bmbouter> #info bmbouter has joined triage
14:33:51 <pulpbot> bmbouter: bmbouter has joined triage
14:33:54 <ichimonji10> 3042 describes how the tasks API breaks when a scheduled task is running.
14:33:58 <dkliban> !here
14:33:58 <dkliban> #info dkliban has joined triage
14:33:58 <pulpbot> dkliban: dkliban has joined triage
14:34:03 <ipanova> ichimonji10: you can find it in tasks list
14:34:14 <ichimonji10> ipanova, see 3042.
14:34:17 <ichimonji10> You can't.
14:34:24 <ichimonji10> Also - that's non-deterministic.
14:34:34 <ichimonji10> What if several scheduled tasks are running?
14:34:47 <ichimonji10> SHould I just guess which task is related to my scheduled task?
14:34:54 <mhrivnak> ichimonji10 is it: As a user, I want to find task info for tasks related to a specific consumer?
14:34:55 <ipanova> ichimonji10: recently i was playing withc sched tasks and all was working
14:35:05 <ipanova> i mean the get at least
14:35:21 <mhrivnak> It sounds like you might be proposing that we have a feature gap.
14:35:25 <ichimonji10> ipanova, Yes, it does work. But if a scheduled task starts, then getting the list of tasks breaks.
14:35:30 <asmacdo> i don't think we create tasks when they are scheduled, so i dont think it can be deterministic
14:35:46 <asmacdo> the task is created (along with its id) when it starts
14:35:47 <ichimonji10> That's not what I'm asking for.
14:35:48 <ipanova> asmacdo: we do
14:35:50 <ichimonji10> Yeah.
14:36:05 <ichimonji10> Read 3041 and 3042, please?
14:36:12 <mhrivnak> I've read them.
14:36:16 <ichimonji10> mhrivnak, Thanks.
14:36:28 <ipanova> i did as well
14:36:44 <mhrivnak> I'm still not 100% certain what 3041 is getting at.
14:36:47 <asmacdo> so have i, does the timestamp prove that the task is created when its scheduled?
14:37:02 <asmacdo> because that doesn't fit with my understanding, given repeated tasks
14:37:10 <ipanova> ichimonji10: please specify version of pulp you're running issues into
14:37:21 <ichimonji10> 2.13 and 2.14
14:37:51 <ichimonji10> 3041 is saying "I know when a scheduled task starts, but not when it ends."
14:38:22 <mhrivnak> If we fix 3042, you'll be able to know both.
14:38:32 <mhrivnak> But you maybe won't be able to correlate the history entries with task entries.
14:38:39 <mhrivnak> So are you asking for a way to positively correlate those?
14:39:16 <ichimonji10> I'm asking for a way to correlate an event ("a package installation has started") with the tasks for that event.
14:39:48 <ichimonji10> There's no good way to do that right now. Timestamps are't suited for that purpose.
14:40:31 <mhrivnak> As a user viewing a consumer's history, I get a reference to the associated task?
14:40:36 <ichimonji10> Exactly.
14:40:44 <asmacdo> so, i agree that this is a feature gap, but I don't hink we will fix this.
14:40:50 <mhrivnak> Great! Let's convert it to a story then. :)
14:41:15 <asmacdo> AFAIK we are not planning to include scheduled tasks in pulp3
14:41:32 <mhrivnak> !propose other convert to story with title "As a user viewing a consumer's history, I get a reference to the associated task."
14:41:32 <mhrivnak> #idea Proposed for #3041: convert to story with title As a user viewing a consumer's history, I get a reference to the associated task.
14:41:33 <pulpbot> mhrivnak: Proposed for #3041: convert to story with title As a user viewing a consumer's history, I get a reference to the associated task.
14:41:38 <ichimonji10> Works for me. Knowing whether or not this will be addressed helps us decide what tests to write.
14:42:20 <ipanova> +1 for converting
14:42:20 <ttereshc> it does not look like a priority task for pulp 2, imo
14:42:26 <ttereshc> ichimonji10, ^
14:42:30 <mhrivnak> agreed.
14:42:30 <ipanova> ttereshc: +2
14:42:42 <ttereshc> !accept
14:42:42 <ttereshc> #agreed convert to story with title As a user viewing a consumer's history, I get a reference to the associated task.
14:42:42 <pulpbot> ttereshc: Current proposal accepted: convert to story with title As a user viewing a consumer's history, I get a reference to the associated task.
14:42:44 <ttereshc> #topic pulp-rpm Merging Errata fails with KeyError exception - http://pulp.plan.io/issues/3046
14:42:44 <pulpbot> ttereshc: 3 issues left to triage: 3046, 3049, 3050
14:42:45 <pulpbot> Issue #3046 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:42:46 <pulpbot> pulp-rpm Merging Errata fails with KeyError exception - http://pulp.plan.io/issues/3046
14:42:58 <ttereshc> I'm still on it, let's skip, I'll comment
14:43:02 <ttereshc> !propose skip
14:43:02 <ttereshc> #idea Proposed for #3046: Skip this issue for this triage session.
14:43:02 <pulpbot> ttereshc: Proposed for #3046: Skip this issue for this triage session.
14:43:11 <mhrivnak> +1
14:43:14 <dkliban> +1
14:43:16 <ttereshc> !accept
14:43:16 <ttereshc> #agreed Skip this issue for this triage session.
14:43:16 <pulpbot> ttereshc: Current proposal accepted: Skip this issue for this triage session.
14:43:17 <pulpbot> ttereshc: 2 issues left to triage: 3049, 3050
14:43:17 <ttereshc> #topic Sync Task hangs forever if wrong proxy setting provided - http://pulp.plan.io/issues/3049
14:43:18 <pulpbot> Issue #3049 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:43:19 <pulpbot> Sync Task hangs forever if wrong proxy setting provided - http://pulp.plan.io/issues/3049
14:44:01 <ipanova> skip until we get more info?
14:44:04 <mhrivnak> I just worry that this would be a lot of work to reproduce without a bit more information.
14:44:12 <dkliban> +1 to skip
14:44:13 <mhrivnak> Yeah.
14:44:16 <mhrivnak> +1
14:44:22 <ttereshc> !propose needsinfo
14:44:22 <pulpbot> ttereshc: Error: "propose" is not a valid command.
14:44:25 <ttereshc> !propose needinfo
14:44:25 <ttereshc> #idea Proposed for #3049: This issue cannot be triaged without more info.
14:44:25 <pulpbot> ttereshc: Proposed for #3049: This issue cannot be triaged without more info.
14:44:30 <ttereshc> !accept
14:44:30 <ttereshc> #agreed This issue cannot be triaged without more info.
14:44:30 <pulpbot> ttereshc: Current proposal accepted: This issue cannot be triaged without more info.
14:44:31 <asmacdo> do we know what plugin this is?
14:44:32 <pulpbot> ttereshc: 1 issues left to triage: 3050
14:44:32 <ttereshc> #topic "apache" user used in dev environment, "pulp" user used by ansible galaxy - http://pulp.plan.io/issues/3050
14:44:33 <pulpbot> Issue #3050 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:44:34 <pulpbot> "apache" user used in dev environment, "pulp" user used by ansible galaxy - http://pulp.plan.io/issues/3050
14:44:48 <ttereshc> asmacdo, let me know if you want to go back
14:45:06 <dkliban> we should add this one to the sprint
14:45:35 <ttereshc> +1
14:45:36 <asmacdo> ttereshc: its fine, its probably rpm, could you confirm that in your comment?
14:45:42 <ttereshc> asmacdo, ok
14:45:48 <ipanova> +1
14:45:58 <ttereshc> !propose other accept and add to sprint
14:45:58 <ttereshc> #idea Proposed for #3050: accept and add to sprint
14:45:58 <pulpbot> ttereshc: Proposed for #3050: accept and add to sprint
14:45:59 <bmbouter> +1
14:46:02 <ipanova> also vagrant file should be updated, it points to non existent plybook
14:46:05 <bmbouter> yes
14:46:07 <ipanova> in dev
14:46:19 <mhrivnak> Is this high-priority for this sprint?
14:46:22 <mhrivnak> Or should we wait for the next one?
14:46:28 <dkliban> ipanova: are you sure? perhaps you just need to update your vagrantfile from Vagrantfile.example
14:46:29 <ipanova> mhrivnak: it is a 10 mins work
14:46:33 <bmbouter> I think soon to get our environment right
14:46:39 <mhrivnak> Keeping in mind that next week we won't get much sprint work done.
14:46:49 <asmacdo> vagrantfile isnt checked into git, I'm pretty sure the vagrantfile.example is up to date
14:46:59 <bmbouter> its so quick to fix I think it's worht adding to sprint
14:47:20 <ipanova> asmacdo: yup you're right
14:47:23 <mhrivnak> Gotcha. Works for me.
14:47:28 <ttereshc> !accept
14:47:28 <ttereshc> #agreed accept and add to sprint
14:47:28 <pulpbot> ttereshc: Current proposal accepted: accept and add to sprint
14:47:29 <pulpbot> ttereshc: No issues to triage.
14:47:32 <ttereshc> !end
14:47:32 <ttereshc> #endmeeting