14:30:01 <ttereshc> #startmeeting Pulp Triage 2017-10-06
14:30:01 <ttereshc> #info ttereshc has joined triage
14:30:02 <pulpbot> Meeting started Fri Oct  6 14:30:01 2017 UTC and is due to finish in 60 minutes.  The chair is ttereshc. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:30:02 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:30:02 <pulpbot> The meeting name has been set to 'pulp_triage_2017_10_06'
14:30:02 <pulpbot> ttereshc: ttereshc has joined triage
14:30:08 <dalley> !here
14:30:08 <dalley> #info dalley has joined triage
14:30:08 <pulpbot> dalley: dalley has joined triage
14:30:11 <ipanova> !here
14:30:11 <ipanova> #info ipanova has joined triage
14:30:11 <pulpbot> ipanova: ipanova has joined triage
14:30:13 <daviddavis> !here
14:30:13 <daviddavis> #info daviddavis has joined triage
14:30:13 <pulpbot> daviddavis: daviddavis has joined triage
14:30:17 <ttereshc> !next
14:30:18 <pulpbot> ttereshc: 5 issues left to triage: 3042, 3049, 3052, 3053, 3056
14:30:18 <ttereshc> #topic Scheduled tasks break GET calls to /pulp/api/v2/tasks/ - http://pulp.plan.io/issues/3042
14:30:19 <pulpbot> Issue #3042 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:30:20 <pulpbot> Scheduled tasks break GET calls to /pulp/api/v2/tasks/ - http://pulp.plan.io/issues/3042
14:30:24 <jortel> !here
14:30:24 <jortel> #info jortel has joined triage
14:30:25 <pulpbot> jortel: jortel has joined triage
14:31:04 <dkliban> !here
14:31:04 <dkliban> #info dkliban has joined triage
14:31:04 <pulpbot> dkliban: dkliban has joined triage
14:31:19 <ipanova> i think we should re-define the understaning of what 'blocker' is :) anyone tried to reproduce this?
14:31:30 <bmbouter> !here
14:31:30 <bmbouter> #info bmbouter has joined triage
14:31:30 <pulpbot> bmbouter: bmbouter has joined triage
14:31:49 <mhrivnak> !here
14:31:49 <mhrivnak> #info mhrivnak has joined triage
14:31:49 <pulpbot> mhrivnak: mhrivnak has joined triage
14:32:11 <mansari> !here
14:32:11 <mansari> #info mansari has joined triage
14:32:11 <pulpbot> mansari: mansari has joined triage
14:32:24 <dkliban> so i am not sure that this is an area of pulp is worth improving
14:32:57 <mhrivnak> Agreed.
14:32:57 <ttereshc> +1
14:33:02 <bmbouter> I also agree
14:33:24 <bmbouter> I also acknowledge what QE is saying here
14:33:35 <ttereshc> Should we discuss priorities in general with QE at some point? So we are on the same page
14:33:41 <mhrivnak> We can take this as a known issue.
14:33:47 <bmbouter> +1 as known issue
14:33:58 <mhrivnak> And yes, we should discuss priorities with them especially around this area.
14:34:01 <bmbouter> agreed
14:34:06 <jortel> agreed
14:34:19 <ipanova> i think what he tries to point out is that once you schedule a task then you are not able to list tasks in general
14:34:33 <ttereshc> !propose other accept + tterashc will put a comment
14:34:33 <ttereshc> #idea Proposed for #3042: accept + tterashc will put a comment
14:34:33 <pulpbot> ttereshc: Proposed for #3042: accept + tterashc will put a comment
14:34:36 <dalley> that seems problematic
14:35:21 <ttereshc> ipanova, any objections to accept?
14:35:27 <mhrivnak> That is a good point. It would be nice to make sure this isn't a regression.
14:35:27 <ipanova> nope
14:35:33 <mhrivnak> If it is, it could impact katello and others.
14:35:45 <ipanova> let me reproduce this and then close?
14:35:59 <ttereshc> !propose other accept + ipanova will try to reproduce
14:35:59 <ttereshc> #idea Proposed for #3042: accept + ipanova will try to reproduce
14:35:59 <pulpbot> ttereshc: Proposed for #3042: accept + ipanova will try to reproduce
14:36:03 <ttereshc> !accept
14:36:03 <ttereshc> #agreed accept + ipanova will try to reproduce
14:36:03 <pulpbot> ttereshc: Current proposal accepted: accept + ipanova will try to reproduce
14:36:04 <mhrivnak> Otherwise I wonder if it's a very specific circumstance causing something unexpected to be in the TaskStatus object that isn't serializable.
14:36:05 <ttereshc> #topic Sync Task hangs forever if wrong proxy setting provided - http://pulp.plan.io/issues/3049
14:36:05 <pulpbot> ttereshc: 4 issues left to triage: 3049, 3052, 3053, 3056
14:36:06 <pulpbot> Issue #3049 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:36:07 <pulpbot> Sync Task hangs forever if wrong proxy setting provided - http://pulp.plan.io/issues/3049
14:37:42 <daviddavis> accept as is?
14:37:57 <mhrivnak> That seems reasonable.
14:38:04 <jortel> +1
14:38:06 <dalley> +1
14:38:08 <mansari> +1
14:38:09 <ttereshc> !propose accept
14:38:09 <ttereshc> #idea Proposed for #3049: Leave the issue as-is, accepting its current state.
14:38:09 <pulpbot> ttereshc: Proposed for #3049: Leave the issue as-is, accepting its current state.
14:38:12 <mhrivnak> I'm interested to reproduce it to figure out what part of the connection process is hanging.
14:38:21 <mhrivnak> But not interested enough to make it a big priority. :)
14:38:29 <ttereshc> !accept
14:38:29 <ttereshc> #agreed Leave the issue as-is, accepting its current state.
14:38:29 <pulpbot> ttereshc: Current proposal accepted: Leave the issue as-is, accepting its current state.
14:38:30 <pulpbot> ttereshc: 3 issues left to triage: 3052, 3053, 3056
14:38:31 <ttereshc> #topic Default fields download_policy and sync_mode on importer create - http://pulp.plan.io/issues/3052
14:38:31 <pulpbot> Issue #3052 [NEW] (unassigned) - Priority: Normal | Severity: Low
14:38:32 <pulpbot> Default fields download_policy and sync_mode on importer create - http://pulp.plan.io/issues/3052
14:39:10 <mhrivnak> rewrite as a story?
14:39:14 <daviddavis> +1
14:39:29 <asmacdo> sure. i also suggested that sync_mode should not have a default
14:39:35 <ttereshc> !propose other convert to a story
14:39:35 <ttereshc> #idea Proposed for #3052: convert to a story
14:39:35 <pulpbot> ttereshc: Proposed for #3052: convert to a story
14:39:45 <ttereshc> I think we can discuss it before grooming
14:39:47 <bmbouter> +1 rewrite as story
14:39:50 <ttereshc> on the issue
14:39:54 <mhrivnak> Sounds good.
14:39:59 <ttereshc> !accept
14:39:59 <ttereshc> #agreed convert to a story
14:39:59 <pulpbot> ttereshc: Current proposal accepted: convert to a story
14:40:01 <ttereshc> #topic pclean does not remove migrations in the pulp_app or plugin projects - http://pulp.plan.io/issues/3053
14:40:01 <pulpbot> ttereshc: 2 issues left to triage: 3053, 3056
14:40:02 <pulpbot> Issue #3053 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:40:03 <pulpbot> pclean does not remove migrations in the pulp_app or plugin projects - http://pulp.plan.io/issues/3053
14:40:17 <bmbouter> oh man this happened to me 3 times!
14:40:50 <asmacdo> so, pclean just runs migrations, but doesnt make them
14:40:53 <bmbouter> doesn't pclean make migrations currently?
14:41:01 <daviddavis> I don't think so
14:41:09 <bmbouter> I'm not really sure it's what I remembered
14:41:14 <asmacdo> there isnt a nice way to make migrations since we have to specify each app
14:41:29 <asmacdo> and aliases cant know which plugins to do
14:41:45 <bmbouter> oh right
14:42:06 <dkliban> it can be smart and figure out which plugins are installed
14:42:11 <mhrivnak> Is a core problem here that if you change the data model and forget about migrations, your running code won't match the DB's schema?
14:42:33 <daviddavis> I believe so
14:42:35 <dkliban> mhrivnak: yeah
14:42:36 <daviddavis> we should consider just checking in migrations into source code to fix this. would be good to get in the habit of updating migrations when we update models.
14:42:40 <bmbouter> no it's that after you vagrant up it was broken for me
14:42:52 <bmbouter> I think it's from changing a git branch and the migrations are leftover
14:43:00 <mhrivnak> Or I guess since we don't have migrations checked in, if *anyone* changes the data layer then everyone has to worry about migrations?
14:43:08 <mhrivnak> Yeah ok, that makes sense.
14:43:13 <daviddavis> mhrivnak: yes exactly
14:43:19 <bmbouter> I know how to work around it so it's not a big one for me
14:43:21 <daviddavis> bmbouter: you sure you didn't do a git pull?
14:43:27 <bmbouter> I did git pull
14:43:37 <bmbouter> then changed the branch
14:43:37 <daviddavis> it's possible that the git pull changed your models then
14:43:48 <bmbouter> yeah that is def what happened
14:43:51 <asmacdo> bmbouter: how about a new dev alias to remove and recreate migrations
14:44:05 <asmacdo> s/function/alias
14:44:08 <bmbouter> yeah but it also can't know about the plugins
14:44:19 <bmbouter> I had to remove both the pulp_app and pulp_example migrations
14:44:42 <asmacdo> if it took args, you could list any plugins installed
14:44:58 <bmbouter> so even though its a bit annoying I can fix this in a few seconds now and since it's temporary I think we should close WONTFIX and identify the workaround
14:45:08 <asmacdo> pulp-manager remakemigrations pulp_app pulp_file pulp_example
14:45:18 <bmbouter> I would also be ok w/ that
14:45:18 <asmacdo> thats fine by me also
14:45:20 <bmbouter> haha
14:45:23 <bmbouter> what asmacdo said
14:45:33 <bmbouter> would that be helpful later on?
14:45:37 <bmbouter> if so then that would be best
14:45:44 <asmacdo> it would be helpful until we GA
14:45:57 <bmbouter> can we get some input on others on this?
14:46:18 <asmacdo> even after we commit migrations, we will probably want to blow them away and start over so we have 1 set of initial migrations
14:46:30 <ttereshc> it's not that annoying for me personally, I'm fine with workaround as well
14:46:48 <daviddavis> I don't think we'll be redoing migrations after we commit them or at least I hope not
14:47:08 <asmacdo> +1 WONT FIX +1/2 new dev functions
14:47:19 <daviddavis> +1 WONTFIX from me
14:47:29 <dalley> +1
14:47:33 <jortel> +1
14:47:34 <ttereshc> any volunteers to provide workaround in comments?
14:47:47 <asmacdo> I'll do it
14:47:51 <bmbouter> +1 to all this
14:48:00 <ttereshc> !propose other close as wontfix and asmacdo will provide workaround
14:48:00 <ttereshc> #idea Proposed for #3053: close as wontfix and asmacdo will provide workaround
14:48:00 <pulpbot> ttereshc: Proposed for #3053: close as wontfix and asmacdo will provide workaround
14:48:02 <bmbouter> yeah it's also not annoying to me after the first time it happened
14:48:08 <ttereshc> !accept
14:48:08 <ttereshc> #agreed close as wontfix and asmacdo will provide workaround
14:48:08 <pulpbot> ttereshc: Current proposal accepted: close as wontfix and asmacdo will provide workaround
14:48:09 <pulpbot> ttereshc: 1 issues left to triage: 3056
14:48:10 <ttereshc> #topic rapidly dispatching sync of the same repo causes resource manager to print traceback - http://pulp.plan.io/issues/3056
14:48:10 <pulpbot> Issue #3056 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:48:11 <ttereshc> thanks asmacdo
14:48:12 <pulpbot> rapidly dispatching sync of the same repo causes resource manager to print traceback - http://pulp.plan.io/issues/3056
14:48:29 <mhrivnak> It looks like we're missing a uniqueness constraint on the model.
14:49:38 <mhrivnak> Might be an easy fix, but might also require a quick audit to make sure all code that creates them is prepared for a dup key error.
14:50:01 <bmbouter> agreed
14:50:04 <mhrivnak> In any case, it definitely needs to be fixed.
14:50:06 <bmbouter> I think we should take this onto the sprint
14:50:09 <ttereshc> +1
14:50:12 <dkliban> +1
14:50:25 <daviddavis> +1
14:50:26 <ttereshc> !propose other accept + add to sprint
14:50:26 <ttereshc> #idea Proposed for #3056: accept + add to sprint
14:50:26 <pulpbot> ttereshc: Proposed for #3056: accept + add to sprint
14:50:26 <mhrivnak> !propose other high high and add to sprint
14:50:35 <jortel> +1
14:50:35 <mhrivnak> heh
14:50:48 <ttereshc> let's try again
14:50:51 <ttereshc> !propose other high high and add to sprint
14:50:51 <ttereshc> #idea Proposed for #3056: high high and add to sprint
14:50:51 <pulpbot> ttereshc: Proposed for #3056: high high and add to sprint
14:50:55 <ttereshc> !accept
14:50:55 <ttereshc> #agreed high high and add to sprint
14:50:55 <pulpbot> ttereshc: Current proposal accepted: high high and add to sprint
14:50:56 <pulpbot> ttereshc: No issues to triage.
14:50:59 <ttereshc> !end
14:50:59 <ttereshc> #endmeeting