14:29:57 <asmacdo> #startmeeting Pulp Triage 2017-10-17
14:29:57 <asmacdo> #info asmacdo has joined triage
14:29:57 <asmacdo> !start
14:29:57 <pulpbot> Meeting started Tue Oct 17 14:29:57 2017 UTC and is due to finish in 60 minutes.  The chair is asmacdo. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:29:57 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:29:57 <pulpbot> The meeting name has been set to 'pulp_triage_2017_10_17'
14:29:57 <pulpbot> asmacdo: asmacdo has joined triage
14:30:02 <dkliban> !here
14:30:02 <dkliban> #info dkliban has joined triage
14:30:02 <pulpbot> dkliban: dkliban has joined triage
14:30:04 <dalley> !here
14:30:04 <dalley> #info dalley has joined triage
14:30:04 <pulpbot> dalley: dalley has joined triage
14:30:20 <bmbouter> !here
14:30:20 <bmbouter> #info bmbouter has joined triage
14:30:20 <pulpbot> bmbouter: bmbouter has joined triage
14:30:29 <daviddavis> !here
14:30:29 <daviddavis> #info daviddavis has joined triage
14:30:29 <pulpbot> daviddavis: daviddavis has joined triage
14:30:33 <bmbouter> asmacdo, dalley: ty!
14:30:58 <asmacdo> !next
14:30:59 <pulpbot> asmacdo: 8 issues left to triage: 3063, 3064, 3065, 3067, 3069, 3070, 3072, 3073
14:31:00 <asmacdo> #topic 406 returned when a 404 should be  - http://pulp.plan.io/issues/3063
14:31:00 <pulpbot> Issue #3063 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:31:01 <pulpbot> 406 returned when a 404 should be  - http://pulp.plan.io/issues/3063
14:31:03 <asmacdo> thanks bmbouter
14:32:02 <dkliban> i think this one is high priority ... it's something to do with the nested routers
14:32:20 <daviddavis> yea I hit this too
14:32:34 <asmacdo> oh, i thought it was because we switched filter backends
14:32:35 <jortel> +1 high
14:32:45 <asmacdo> !propose high high
14:32:45 <pulpbot> asmacdo: Error: "propose" is not a valid command.
14:32:51 <asmacdo> !propose triage  high high
14:32:51 <asmacdo> #idea Proposed for #3063: Priority: High, Severity: High
14:32:51 <pulpbot> asmacdo: Proposed for #3063: Priority: High, Severity: High
14:32:59 <dkliban> +1
14:33:05 <asmacdo> ill assign it to myself too
14:33:13 <dkliban> asmacdo: thank you
14:33:18 <asmacdo> !accept
14:33:18 <asmacdo> #agreed Priority: High, Severity: High
14:33:18 <pulpbot> asmacdo: Current proposal accepted: Priority: High, Severity: High
14:33:19 <pulpbot> asmacdo: 7 issues left to triage: 3064, 3065, 3067, 3069, 3070, 3072, 3073
14:33:19 <asmacdo> #topic Get unit tests running in pulp 3 and fix them - http://pulp.plan.io/issues/3064
14:33:20 <pulpbot> Issue #3064 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:33:21 <pulpbot> Get unit tests running in pulp 3 and fix them - http://pulp.plan.io/issues/3064
14:33:43 <daviddavis> I think med normal is fine on this
14:33:50 <jortel> agreed
14:34:08 <dkliban> +1
14:34:23 <dalley> +1
14:34:42 <asmacdo> lets make this a task
14:34:49 <asmacdo> !propose other switch to task
14:34:49 <asmacdo> #idea Proposed for #3064: switch to task
14:34:49 <pulpbot> asmacdo: Proposed for #3064: switch to task
14:34:55 <daviddavis> +1
14:35:21 <asmacdo> !accept
14:35:21 <asmacdo> #agreed switch to task
14:35:21 <pulpbot> asmacdo: Current proposal accepted: switch to task
14:35:22 <pulpbot> asmacdo: 6 issues left to triage: 3065, 3067, 3069, 3070, 3072, 3073
14:35:22 <asmacdo> #topic Replace the vagrant user with a user named 'pulp' - http://pulp.plan.io/issues/3065
14:35:23 <pulpbot> Issue #3065 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:35:24 <pulpbot> Replace the vagrant user with a user named 'pulp' - http://pulp.plan.io/issues/3065
14:35:47 <daviddavis> this is kind of low priority I think
14:35:53 <jortel> +1
14:36:01 <dkliban> i think this is also a task. and we won't do this until we start building our own vagrant boxes
14:36:28 <bmbouter> +1 to all that
14:36:36 <asmacdo> !propose other switch to task
14:36:36 <asmacdo> #idea Proposed for #3065: switch to task
14:36:36 <pulpbot> asmacdo: Proposed for #3065: switch to task
14:37:24 <asmacdo> !accept
14:37:24 <asmacdo> #agreed switch to task
14:37:24 <pulpbot> asmacdo: Current proposal accepted: switch to task
14:37:26 <asmacdo> #topic Document image manifest and manifest list peculiar behaviour during copy, remove and other actions - http://pulp.plan.io/issues/3067
14:37:26 <pulpbot> asmacdo: 5 issues left to triage: 3067, 3069, 3070, 3072, 3073
14:37:28 <pulpbot> Issue #3067 [NEW] (ipanova@redhat.com) - Priority: Normal | Severity: Medium
14:37:29 <pulpbot> Document image manifest and manifest list peculiar behaviour during copy, remove and other actions - http://pulp.plan.io/issues/3067
14:37:34 <asmacdo> ahhh daviddavis
14:37:40 <daviddavis> lol sorry :(
14:37:56 <asmacdo> no worries, lol
14:38:26 <asmacdo> !propose skip
14:38:26 <asmacdo> #idea Proposed for #3067: Skip this issue for this triage session.
14:38:26 <pulpbot> asmacdo: Proposed for #3067: Skip this issue for this triage session.
14:38:33 <daviddavis> +1
14:38:34 <bmbouter> +1
14:38:38 <jortel> +1
14:38:41 <asmacdo> We need some more info, this was a pulpcon-bug
14:38:52 <asmacdo> !skip
14:38:53 <pulpbot> asmacdo: 4 issues left to triage: 3069, 3070, 3072, 3073
14:38:54 <asmacdo> #topic NotFound exception if consumer is deleted when its queue is gone - http://pulp.plan.io/issues/3069
14:38:54 <pulpbot> Issue #3069 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:38:56 <pulpbot> NotFound exception if consumer is deleted when its queue is gone - http://pulp.plan.io/issues/3069
14:39:49 <dkliban> we should fix this for the next 2.14 release
14:39:59 <dkliban> 2.14.3
14:40:06 <jortel> This should be a few line fix in pulp.
14:40:12 <jortel> just adding try/catch
14:40:26 <jortel> just fyi
14:40:26 <asmacdo> !propose triage normal medium
14:40:26 <asmacdo> #idea Proposed for #3069: Priority: Normal, Severity: Medium
14:40:27 <pulpbot> asmacdo: Proposed for #3069: Priority: Normal, Severity: Medium
14:40:30 <asmacdo> and add to sprint
14:40:33 <dkliban> yeah
14:40:44 <jortel> +1
14:41:02 <asmacdo> !accept
14:41:02 <asmacdo> #agreed Priority: Normal, Severity: Medium
14:41:02 <pulpbot> asmacdo: Current proposal accepted: Priority: Normal, Severity: Medium
14:41:04 <asmacdo> #topic Pulp is not able to sync repositories. - http://pulp.plan.io/issues/3070
14:41:04 <pulpbot> asmacdo: 3 issues left to triage: 3070, 3072, 3073
14:41:05 <pulpbot> Issue #3070 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:41:06 <pulpbot> Pulp is not able to sync repositories. - http://pulp.plan.io/issues/3070
14:41:18 <asmacdo> sounds bad
14:41:57 <dalley> yup
14:42:29 <asmacdo> I don't think we can triage this yet, but I would like to change the name to something more specific and less scary
14:42:30 <jortel> If the repo has malformed metadata it /should/ fail.  right?
14:42:43 <daviddavis> I agree
14:42:59 <asmacdo> i think he is suggesting that it isnt malformed, but pulp thinks it is?
14:43:05 <dkliban> yeah
14:43:08 <jortel> ah
14:43:17 <dkliban> and it's hard for us to know since it's a repo he created.
14:43:35 <dkliban> i would recommend taht this user just upload packages to pulp instead of running createrepo and then syncing
14:43:51 <asmacdo> dkliban: would you add that as a comment, and we will skip for today?
14:43:56 <dkliban> asmacdo: i will
14:44:04 <asmacdo> thanks dkliban
14:44:06 <asmacdo> !skip
14:44:07 <pulpbot> asmacdo: 2 issues left to triage: 3072, 3073
14:44:07 <asmacdo> #topic Too generic "The importer yum_importer indicated a failed response" - http://pulp.plan.io/issues/3072
14:44:08 <pulpbot> Issue #3072 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:44:09 <pulpbot> Too generic "The importer yum_importer indicated a failed response" - http://pulp.plan.io/issues/3072
14:44:21 <asmacdo> :)
14:45:27 <daviddavis> haha
14:45:28 <jortel> we need for info as daviddavis suggested on the issue before we can triage.
14:45:40 <asmacdo> If he has a problem under this, we should figure out what it is. If this is just feedback on the error, +1000
14:45:56 <asmacdo> #idea Proposed for #3072: Skip this issue for this triage session.
14:45:56 <asmacdo> !propose skip
14:45:56 <pulpbot> asmacdo: Proposed for #3072: Skip this issue for this triage session.
14:46:29 <asmacdo> !skip
14:46:30 <pulpbot> asmacdo: 1 issues left to triage: 3073
14:46:30 <asmacdo> #topic Can't remove content from a repository - http://pulp.plan.io/issues/3073
14:46:31 <pulpbot> Issue #3073 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:46:32 <pulpbot> Can't remove content from a repository - http://pulp.plan.io/issues/3073
14:47:12 <dkliban> add to sprint
14:47:27 <jortel> +1
14:47:27 <daviddavis> yea, I was going to do this today
14:47:45 <asmacdo> just change the inheritance, i think
14:48:02 <asmacdo> !propose other accept and add to sprint
14:48:02 <asmacdo> #idea Proposed for #3073: accept and add to sprint
14:48:02 <pulpbot> asmacdo: Proposed for #3073: accept and add to sprint
14:48:12 <dalley> +1
14:48:46 <asmacdo> !accept
14:48:46 <asmacdo> #agreed accept and add to sprint
14:48:46 <pulpbot> asmacdo: Current proposal accepted: accept and add to sprint
14:48:48 <pulpbot> asmacdo: No issues to triage.
14:48:54 <asmacdo> !end
14:48:54 <asmacdo> #endmeeting