14:30:00 <dalley> #startmeeting Pulp Triage 2017-10-24
14:30:00 <dalley> #info dalley has joined triage
14:30:01 <pulpbot> Meeting started Tue Oct 24 14:30:00 2017 UTC and is due to finish in 60 minutes.  The chair is dalley. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:30:01 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:30:01 <pulpbot> The meeting name has been set to 'pulp_triage_2017_10_24'
14:30:01 <pulpbot> dalley: dalley has joined triage
14:30:08 <dkliban> !here
14:30:08 <dkliban> #info dkliban has joined triage
14:30:08 <pulpbot> dkliban: dkliban has joined triage
14:30:27 <mhrivnak> !here
14:30:27 <mhrivnak> #info mhrivnak has joined triage
14:30:27 <pulpbot> mhrivnak: mhrivnak has joined triage
14:31:05 <dalley> !next
14:31:06 <pulpbot> dalley: 4 issues left to triage: 3090, 3091, 3093, 3095
14:31:06 <dalley> #topic Uploading an invalid rpm produces an error message: "unexpected error occurred importing uploaded file: 'primary'" - http://pulp.plan.io/issues/3090
14:31:07 <pulpbot> Issue #3090 [NEW] (unassigned) - Priority: High | Severity: Medium
14:31:08 <pulpbot> Uploading an invalid rpm produces an error message: "unexpected error occurred importing uploaded file: 'primary'" - http://pulp.plan.io/issues/3090
14:31:14 <daviddavis> !here
14:31:14 <daviddavis> #info daviddavis has joined triage
14:31:14 <pulpbot> daviddavis: daviddavis has joined triage
14:31:31 <daviddavis> ok so this is a regression. it affects cli users and katello.
14:31:40 <asmacdo> !here
14:31:40 <asmacdo> #info asmacdo has joined triage
14:31:40 <pulpbot> asmacdo: asmacdo has joined triage
14:31:47 <daviddavis> there's no workaround really. even the logs are unhelpful
14:32:05 <dalley> !propose other accept and add to sprint
14:32:05 <dalley> #idea Proposed for #3090: accept and add to sprint
14:32:05 <pulpbot> dalley: Proposed for #3090: accept and add to sprint
14:32:10 <dkliban> +1
14:32:18 <mhrivnak> +1
14:32:22 <jortel> +1
14:32:25 <bmbouter> !here
14:32:25 <bmbouter> #info bmbouter has joined triage
14:32:25 <pulpbot> bmbouter: bmbouter has joined triage
14:32:27 <dalley> !accept
14:32:27 <dalley> #agreed accept and add to sprint
14:32:27 <pulpbot> dalley: Current proposal accepted: accept and add to sprint
14:32:28 <pulpbot> dalley: 3 issues left to triage: 3091, 3093, 3095
14:32:28 <dalley> #topic Add a command line utility to turn a directory into a file (iso) repository - http://pulp.plan.io/issues/3091
14:32:29 <pulpbot> Issue #3091 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:32:30 <pulpbot> Add a command line utility to turn a directory into a file (iso) repository - http://pulp.plan.io/issues/3091
14:32:46 <dkliban> this is a story
14:33:00 <mhrivnak> Yep.
14:33:04 <dalley> #idea Proposed for #3091: convert to story
14:33:04 <dalley> !propose other convert to story
14:33:04 <pulpbot> dalley: Proposed for #3091: convert to story
14:33:16 <mhrivnak> I'm happy to do the converting.
14:33:31 <dalley> sounds good to me
14:33:33 <asmacdo> could we mark as a sprint candidate?
14:33:45 <bmbouter> yeah but it needs more grooming
14:33:53 <asmacdo> agree
14:33:55 <bmbouter> what is it called, what are its features, use cases
14:33:56 <asmacdo> seems like a small thing that would make pulp3 actually sort of usable
14:34:01 <mhrivnak> Agreed, it definitely needs some grooming.
14:34:15 <mhrivnak> FWIW we have something sort of like this in our docs.
14:34:17 <bmbouter> +1 to convert to a story
14:34:23 <mhrivnak> But it doesn't meet all the use cases.
14:34:26 <dkliban> yeah ... the request is to ship an RPM
14:34:27 <asmacdo> but marking as a candidate would put it on the radar
14:35:04 <daviddavis> how do we ship the puppet module builder script?
14:35:35 <jortel> iirc, in puppet-tools rpm
14:35:40 <mhrivnak> daviddavis great question.
14:35:59 <mhrivnak> In any case, I can go either way on marking it as a sprint candidate.
14:36:04 <asmacdo> I think "shipping an rpm" should be a separate task though
14:36:54 <mhrivnak> All good thoughts, but let's groom it later.
14:37:25 <daviddavis> +1
14:37:31 <bmbouter> +1
14:37:38 <asmacdo> !propose other convert to story, mark as ungroomed sprint candidate
14:37:38 <asmacdo> #idea Proposed for #3091: convert to story, mark as ungroomed sprint candidate
14:37:38 <pulpbot> asmacdo: Proposed for #3091: convert to story, mark as ungroomed sprint candidate
14:37:48 <dalley> !accept
14:37:48 <dalley> #agreed convert to story, mark as ungroomed sprint candidate
14:37:48 <pulpbot> dalley: Current proposal accepted: convert to story, mark as ungroomed sprint candidate
14:37:48 <mhrivnak> +1
14:37:49 <pulpbot> dalley: 2 issues left to triage: 3093, 3095
14:37:50 <dalley> #topic Tons of extra params appear in the api schema - http://pulp.plan.io/issues/3093
14:37:50 <pulpbot> Issue #3093 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:37:51 <pulpbot> Tons of extra params appear in the api schema - http://pulp.plan.io/issues/3093
14:38:17 <asmacdo> i just updated comment 3 a couple minutes ago, so you might need to regfresh
14:38:52 <dalley> gnome shell crashed...
14:39:06 <dalley> that's what I get for using F27 beta
14:39:12 <daviddavis> heh
14:39:13 <mhrivnak> heh
14:39:30 <asmacdo> !propose skip
14:39:30 <asmacdo> #idea Proposed for #3093: Skip this issue for this triage session.
14:39:30 <pulpbot> asmacdo: Proposed for #3093: Skip this issue for this triage session.
14:39:54 <mhrivnak> What are we waiting on that will enable triage?
14:39:54 <jortel> why skip?  this seems important
14:40:12 <asmacdo> i'm not sure if this is a DRF upstream problem, a schema view problem, or a docs problem
14:40:12 <bmbouter> it's still being discussed on the issue I think
14:40:42 <asmacdo> +1 it is important, but i'd rather not "accept and figure it out later"
14:40:51 <mhrivnak> We don't need to find a root cause to triage a bug.
14:40:55 <asmacdo> unless we want to accept and put it on the sprint
14:41:05 <bmbouter> I think there is a question about what is the correct design we need
14:41:23 <bmbouter> like will this affect the clients or not... I'm not sure maybe others are to
14:41:23 <dalley> !propose high medium
14:41:23 <pulpbot> dalley: Error: "propose" is not a valid command.
14:41:24 <bmbouter> tho
14:41:42 <bmbouter> agreed, let's avoid accept and figure it out later
14:41:46 <asmacdo> my point is we should find the root cause soon, (maybe by friday's triage)
14:41:57 <bmbouter> agreed
14:42:18 <mhrivnak> If we're not sure what the expected behavior should be, then I could see skipping.
14:42:25 <dalley> !propose skip
14:42:25 <dalley> #idea Proposed for #3093: Skip this issue for this triage session.
14:42:26 <pulpbot> dalley: Proposed for #3093: Skip this issue for this triage session.
14:42:32 <bmbouter> this was filed like an hour ago I think that's where we're at
14:42:44 <asmacdo> +1, not  sure what this should be
14:42:51 <bmbouter> others know more tho I just saw the convo in irc
14:43:15 <daviddavis> who's going to work on this bug?
14:43:22 <daviddavis> to get it ready to be triaged?
14:43:51 <mhrivnak> daviddavis we could nominate the person who filed it? ;)
14:44:00 <daviddavis> ha, I'll pass
14:44:04 <daviddavis> not sure I am the right person
14:44:05 <mhrivnak> heh, fair enough.
14:44:22 <asmacdo> ill "champion" it, but it likely needs feedback from a few people
14:44:27 <daviddavis> +1
14:44:31 <mhrivnak> asmacdo thanks.
14:44:32 <jortel> +1
14:44:36 <daviddavis> asmacdo++
14:44:36 <pulpbot> daviddavis: asmacdo's karma is now 16
14:45:01 <dalley> !accept
14:45:01 <dalley> #agreed Skip this issue for this triage session.
14:45:01 <pulpbot> dalley: Current proposal accepted: Skip this issue for this triage session.
14:45:02 <dalley> #topic Unable to cancel pending unstarted tasks - http://pulp.plan.io/issues/3095
14:45:03 <pulpbot> dalley: 1 issues left to triage: 3095
14:45:04 <pulpbot> Issue #3095 [NEW] (unassigned) - Priority: Normal | Severity: Urgent
14:45:05 <pulpbot> Unable to cancel pending unstarted tasks - http://pulp.plan.io/issues/3095
14:45:18 <dalley> dkliban was discussing this one in #pulp
14:45:39 <dkliban> i think we just accept it
14:45:43 <asmacdo> as urgent?
14:45:43 <dkliban> i already left a comment on it
14:45:51 <dkliban> no ... low priority
14:46:04 <asmacdo> also, this is not "pulp-admin"
14:46:24 <bmbouter> dkliban's comment is a workaround so def not urgent sev
14:46:33 <mhrivnak> !propose triage normal medium
14:46:33 <mhrivnak> #idea Proposed for #3095: Priority: Normal, Severity: Medium
14:46:33 <pulpbot> mhrivnak: Proposed for #3095: Priority: Normal, Severity: Medium
14:46:40 <asmacdo> im not sure that workaround is ok
14:46:49 <daviddavis> should we close out https://pulp.plan.io/issues/3094 ?
14:46:54 <mhrivnak> or low priority
14:46:56 <asmacdo> is it a workaround if we require the user to manually touch the db?
14:47:21 <mhrivnak> workarounds are allowed to be ugly.
14:47:23 <bmbouter> it is, albeit a scary one
14:47:45 <bmbouter> another option would be to re-register the consumer w/ the same name and then delete, then unregister
14:47:48 <bmbouter> I can post that too
14:48:06 <asmacdo> +1, that one makes me less nervous
14:48:07 <mhrivnak> !propose triage low medium
14:48:07 <mhrivnak> #idea Proposed for #3095: Priority: Low, Severity: Medium
14:48:07 <pulpbot> mhrivnak: Proposed for #3095: Priority: Low, Severity: Medium
14:48:16 <bmbouter> +1
14:48:36 <asmacdo> !suggest remove blocks release and change category
14:48:36 <asmacdo> #idea remove blocks release and change category
14:48:49 <asmacdo> is !suggest not a thing anymore?
14:49:00 <mhrivnak> +1 to all that
14:49:04 <daviddavis> what's the different between !suggest and !propose?
14:49:36 <asmacdo> the !suggest action is like an add-on
14:50:01 <dalley> !propose other low, medium, remove release block, change category
14:50:01 <dalley> #idea Proposed for #3095: low, medium, remove release block, change category
14:50:01 <pulpbot> dalley: Proposed for #3095: low, medium, remove release block, change category
14:50:02 <bmbouter> yes we need to not have it block 2.14.z it's not a blocker
14:50:43 <mhrivnak> +1
14:50:51 <daviddavis> I'll leave a note I guess on https://pulp.plan.io/issues/3095 that it's probably a dupe of https://pulp.plan.io/issues/3094
14:51:12 <asmacdo> lets keep 3095 and close 3094
14:51:22 <bmbouter> can we finish 3095 first
14:51:39 <daviddavis> bmbouter: they're the same bug
14:51:43 <asmacdo> sure, i'm happy with current proposal
14:51:49 <daviddavis> looks like author filed it twice
14:51:59 <bmbouter> I agree
14:52:11 <daviddavis> ah sorry
14:52:22 <bmbouter> why isn't it being shown in thetriage list?
14:52:27 <daviddavis> bmbouter: it's in debian
14:52:47 <bmbouter> ohhhhhhh that explains it
14:53:02 <bmbouter> we should let misa handle the debian ones
14:53:04 <bmbouter> misa: ^
14:53:14 <daviddavis> yea, that';s why i was thinking of leaving a note
14:53:21 <bmbouter> I'm w/ you now. +1
14:53:21 <dalley> are we agreed on 3095?
14:53:25 <daviddavis> I think so
14:53:28 <asmacdo> +1
14:53:37 <bmbouter> to just leave a note?
14:53:38 <asmacdo> jwalterweatherman++
14:53:38 <pulpbot> asmacdo: jwalterweatherman's karma is now 1
14:53:44 <mhrivnak> +1
14:53:45 <daviddavis> bmbouter: yea, I'll do it
14:53:51 <bmbouter> cool, not to change it's state?
14:54:37 <dalley> I suppose that's a good clarification.  Are we leaving a note or are we changing the state, or both?.
14:54:43 <daviddavis> bmbouter: yea
14:54:44 <asmacdo> yeah, no state change, just daviddavis leaving a note on 3094, and accept proposal for 3095
14:54:49 <bmbouter> ty
14:54:51 <bmbouter> +1
14:54:57 <dalley> accept 3095 as is?
14:55:18 <bmbouter> we should stick to triaging one issue at a time I think
14:55:22 <dalley> yup
14:55:34 <asmacdo> no, proposal is low/medium, remove blocks and change category
14:55:35 <daviddavis> ha yea
14:55:38 <bmbouter> so which one are we triaging in our triage?
14:55:45 <daviddavis> #3095
14:55:47 <asmacdo> 3095
14:55:51 <bmbouter> and what's the proposal?
14:55:57 <daviddavis> low/medium, remove blocks and change category
14:56:04 <bmbouter> +1
14:56:12 <dalley> !accept
14:56:12 <dalley> #agreed low, medium, remove release block, change category
14:56:12 <pulpbot> dalley: Current proposal accepted: low, medium, remove release block, change category
14:56:14 <pulpbot> dalley: No issues to triage.
14:56:25 <dalley> #endmeeting
14:56:25 <dalley> !end