14:30:18 <dalley> #startmeeting Pulp Triage 2017-10-27
14:30:18 <dalley> #info dalley has joined triage
14:30:19 <pulpbot> Meeting started Fri Oct 27 14:30:18 2017 UTC and is due to finish in 60 minutes.  The chair is dalley. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:30:19 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:30:19 <pulpbot> The meeting name has been set to 'pulp_triage_2017_10_27'
14:30:19 <pulpbot> dalley: dalley has joined triage
14:30:33 <bizhang> !here
14:30:33 <bizhang> #info bizhang has joined triage
14:30:33 <pulpbot> bizhang: bizhang has joined triage
14:30:40 <asmacdo> !here
14:30:40 <asmacdo> #info asmacdo has joined triage
14:30:40 <pulpbot> asmacdo: asmacdo has joined triage
14:30:41 <mhrivnak> !here
14:30:41 <mhrivnak> #info mhrivnak has joined triage
14:30:42 <pulpbot> mhrivnak: mhrivnak has joined triage
14:30:43 <mansari> !here
14:30:43 <mansari> #info mansari has joined triage
14:30:43 <pulpbot> mansari: mansari has joined triage
14:30:57 <dalley> !next
14:30:58 <pulpbot> dalley: 5 issues left to triage: 3093, 3098, 3100, 3101, 3103
14:30:59 <dalley> #topic api schema includes the same params for all request types - http://pulp.plan.io/issues/3093
14:30:59 <pulpbot> Issue #3093 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:31:00 <pulpbot> api schema includes the same params for all request types - http://pulp.plan.io/issues/3093
14:31:04 <bmbouter> !here
14:31:04 <bmbouter> #info bmbouter has joined triage
14:31:04 <pulpbot> bmbouter: bmbouter has joined triage
14:31:12 <asmacdo> !propose accept
14:31:12 <asmacdo> #idea Proposed for #3093: Leave the issue as-is, accepting its current state.
14:31:12 <pulpbot> asmacdo: Proposed for #3093: Leave the issue as-is, accepting its current state.
14:31:16 <dalley> I believe we skipped this one last time pending more discussion
14:31:21 <bizhang> I think this is an issue with drf 3.7.0
14:31:41 <asmacdo> I don't know how we should handle it, but I think it is more of a documentation problem than a code problem
14:31:44 <mhrivnak> Did we resolve whatever it was we decided to wait on? (I don't recall what that was.)
14:31:56 <asmacdo> I looked into it
14:31:57 <bmbouter> yeah I think we got new comments
14:32:33 <fdobrovo> !here
14:32:33 <fdobrovo> #info fdobrovo has joined triage
14:32:33 <pulpbot> fdobrovo: fdobrovo has joined triage
14:33:04 <mhrivnak> This brings up an interesting side-note: maybe we should comment on an issue when we skip it, listing exactly why it was skipped and what needs to happen for it to be triagable.
14:33:12 <mhrivnak> But we can discuss that post-triage. :)
14:33:14 <asmacdo> Yeah, probably a good practice
14:33:19 <dalley> anyone object to accepting?
14:33:23 <bizhang> we should open this as an issue with upstream drf, since it's working as expected in 3.6.4
14:33:33 <mhrivnak> +1 accept
14:33:38 <asmacdo> bizhang: that is surprising to me
14:33:55 <bmbouter> +1
14:33:59 <bmbouter> should this go on the sprint?
14:34:10 <bizhang> asmacdo, If I revert to 3.6.4 the only params on DELETE is the name
14:34:14 <bizhang> I can comment on issue
14:34:39 <asmacdo> bizhang: oh wow, ok. I think i got it wrong then. Lets accept it, and put it on the sprint.
14:35:12 <dalley> !propose other accept and add to sprint
14:35:12 <dalley> #idea Proposed for #3093: accept and add to sprint
14:35:12 <pulpbot> dalley: Proposed for #3093: accept and add to sprint
14:35:35 <mhrivnak> +1
14:36:16 <dalley> !accept
14:36:16 <dalley> #agreed accept and add to sprint
14:36:16 <pulpbot> dalley: Current proposal accepted: accept and add to sprint
14:36:17 <pulpbot> dalley: 4 issues left to triage: 3098, 3100, 3101, 3103
14:36:18 <dalley> #topic Docker publish may fail with "OSError: [Errno 17] File exists" if two publishes triggered at same time - http://pulp.plan.io/issues/3098
14:36:18 <pulpbot> Issue #3098 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:36:19 <pulpbot> Docker publish may fail with "OSError: [Errno 17] File exists" if two publishes triggered at same time - http://pulp.plan.io/issues/3098
14:38:05 <mhrivnak> interesting.
14:38:16 <asmacdo> :*(
14:38:20 <mhrivnak> Behavior shows in pulp_docker, but looks like the problem is in platform.
14:38:53 <mhrivnak> In any case, I suspect this will be relatively easy to solve.
14:39:11 <asmacdo> yeah, if it exists, problem solved, keep going
14:39:30 <asmacdo> jortel: is this the problem you were working on in pulp3?
14:39:46 * jortel looks
14:40:08 <asmacdo> we might be able to steal some of pulp3 code :)
14:40:17 <mhrivnak> !propose triage high medium
14:40:17 <mhrivnak> #idea Proposed for #3098: Priority: High, Severity: Medium
14:40:17 <pulpbot> mhrivnak: Proposed for #3098: Priority: High, Severity: Medium
14:41:23 <asmacdo> sounds reasonable to me
14:41:56 <jortel> asmacdo: hard to say.  which pulp3 problem do you mean?
14:42:27 <asmacdo> the general filesystem race condition
14:42:40 <mhrivnak> I suggest continuing that discussion later unless it's relevant to triaging?
14:43:16 <asmacdo> i'm fine with that, mostly wanted jortel to have a glance before we triage
14:43:17 <jortel> agreed
14:43:45 <dalley> !accept
14:43:45 <dalley> #agreed Priority: High, Severity: Medium
14:43:45 <pulpbot> dalley: Current proposal accepted: Priority: High, Severity: Medium
14:43:47 <pulpbot> dalley: 3 issues left to triage: 3100, 3101, 3103
14:43:47 <dalley> #topic Removal of existing iso units doesn't work if there are multiple iso files - http://pulp.plan.io/issues/3100
14:43:48 <pulpbot> Issue #3100 [POST] (daviddavis@redhat.com) - Priority: Normal | Severity: Medium
14:43:49 <pulpbot> Removal of existing iso units doesn't work if there are multiple iso files - http://pulp.plan.io/issues/3100
14:44:22 <asmacdo> POST
14:44:26 <asmacdo> #idea Proposed for #3100: Leave the issue as-is, accepting its current state.
14:44:26 <asmacdo> !propose accept
14:44:26 <pulpbot> asmacdo: Proposed for #3100: Leave the issue as-is, accepting its current state.
14:44:32 <mhrivnak> !propose other accept and add to sprint
14:44:32 <mhrivnak> #idea Proposed for #3100: accept and add to sprint
14:44:32 <pulpbot> mhrivnak: Proposed for #3100: accept and add to sprint
14:44:45 <asmacdo> daviddavis++
14:44:45 <pulpbot> asmacdo: daviddavis's karma is now 17
14:44:48 <dalley> !accept
14:44:48 <dalley> #agreed accept and add to sprint
14:44:48 <pulpbot> dalley: Current proposal accepted: accept and add to sprint
14:44:49 <pulpbot> dalley: 2 issues left to triage: 3101, 3103
14:44:50 <dalley> #topic Changing a repository's name changes its URI - http://pulp.plan.io/issues/3101
14:44:50 <pulpbot> Issue #3101 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:44:51 <pulpbot> Changing a repository's name changes its URI - http://pulp.plan.io/issues/3101
14:45:38 <asmacdo> i'm tempted to add this one to the sprint too
14:46:06 <bmbouter> +1
14:46:27 <asmacdo> I think we ought to groom it though
14:46:31 <mhrivnak> Should we expand the scope of this to all natural keys?
14:46:34 <jortel> +1
14:46:39 <asmacdo> I dont think we do mhrivnak
14:46:56 <mhrivnak> All natural keys when used to form URL paths? :)
14:46:56 <dalley> !propose other accept, groom, add to sprint
14:46:56 <dalley> #idea Proposed for #3101: accept, groom, add to sprint
14:46:56 <pulpbot> dalley: Proposed for #3101: accept, groom, add to sprint
14:47:01 <asmacdo> some resources need to change their name
14:47:06 <asmacdo> wait dalley
14:47:07 <bmbouter> yes we should
14:47:19 <bmbouter> if we want more discussion we could skip
14:47:37 <bmbouter> or continue discussion now b/c I do want it on the sprint soon
14:48:03 <mhrivnak> asmacdo if a name needs to change, then perhaps the name is not the natural key?
14:48:20 <asmacdo> I guess we could just do this for all natural keys, and fix it later if there is an exception
14:48:28 <asmacdo> +1 accept
14:48:32 <bmbouter> we should have no natural keys in urls
14:48:34 <bmbouter> +1
14:48:52 <bizhang> +1
14:49:08 <mhrivnak> +1 accept, and let's discuss natural keys in URLs separately.
14:49:30 <asmacdo> sorry to hold up
14:49:30 <dalley> just accept, or accept & add to sprint?
14:49:36 <asmacdo> but that is different than i was thinking
14:49:41 <asmacdo> i just noticed that last comment
14:49:55 <asmacdo> i was thinking that the natural keys would be used in urls
14:49:59 <asmacdo> but be immutable
14:50:36 <mhrivnak> That is the current intent. There's a suggestion to change that, but it needs discussion.
14:50:40 <bmbouter> agreed
14:51:15 <asmacdo> ok, then i'm ok to move on
14:51:35 <dalley> !accept
14:51:35 <dalley> #agreed accept, groom, add to sprint
14:51:35 <pulpbot> dalley: Current proposal accepted: accept, groom, add to sprint
14:51:36 <pulpbot> dalley: 1 issues left to triage: 3103
14:51:36 <dalley> #topic Missing representation of spawned_tasks in response - http://pulp.plan.io/issues/3103
14:51:37 <pulpbot> Issue #3103 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:51:38 <pulpbot> Missing representation of spawned_tasks in response - http://pulp.plan.io/issues/3103
14:52:14 <bmbouter> kersom discovered this while implementing the "follow a task and all of its children" code in pulp smash
14:52:29 <bmbouter> I think the viewset is just not including that field for some reason
14:52:59 <mhrivnak> I'm +1 on accepting this, but I'm not sure it's worth adding to the current sprint.
14:53:00 <asmacdo> s/viewset/serializer/
14:53:22 <kersom> based on what we talked yesterday, the same concept is applied for workers as well. but I did not find a good example to file an issue. it is on my todo list.
14:54:04 <bmbouter> for them to port that code I think they need this field which is the sprint motivation
14:54:17 <bmbouter> kersom another option is to make the following of child tasks a separate issue
14:54:19 <asmacdo> if this is blocking QE +1 add t osprint
14:54:31 <mhrivnak> Ah. If it's blocking QE I'm good for adding it to the sprint.
14:54:31 <bmbouter> in practice there should be few of those since pulp3 doesn't even have auto publish
14:54:44 <bmbouter> it is blocking QE if they continue to port the way they planned to
14:54:56 <bmbouter> kersom are you +1 to add this to the sprint or?
14:54:58 <dalley> !propose other accept and add to sprint
14:54:58 <dalley> #idea Proposed for #3103: accept and add to sprint
14:54:58 <pulpbot> dalley: Proposed for #3103: accept and add to sprint
14:55:10 <bmbouter> I'm +1 on adding it to the sprint (I think)
14:55:20 <kersom> it could very helpful for QE
14:55:22 <kersom> +1
14:55:30 <kersom> be*
14:56:48 <kersom> then we do not need to create a code that will be changed in a near future, and it will be very close to what we have in place for pulp2, and it has been used for a while.
14:58:09 <dalley> any objections?
14:58:10 <bmbouter> +1
14:58:22 <asmacdo> +1
14:58:25 <dalley> !accept
14:58:25 <dalley> #agreed accept and add to sprint
14:58:25 <pulpbot> dalley: Current proposal accepted: accept and add to sprint
14:58:27 <pulpbot> dalley: No issues to triage.
14:58:35 <bmbouter> \o/
14:59:16 <dalley> asmacdo, you mentioned that you thought 3101 should be groomed before putting it on the sprint
14:59:27 <dalley> should we let the person who grooms it add to the sprint?
15:00:05 <asmacdo> i was still talking about 3100
15:00:34 <asmacdo> oh. no sorry
15:00:52 <asmacdo> no, we don't need to groom. I think we should make all natural  keys immutable, at least for now.
15:00:53 <dalley> 3100 was the one already in POST
15:01:03 <dalley> ack
15:01:19 <dalley> !end
15:01:19 <dalley> #endmeeting