15:34:08 <dalley> #startmeeting Pulp Triage 2017-11-07
15:34:08 <dalley> !start
15:34:08 <dalley> #info dalley has joined triage
15:34:08 <pulpbot> Meeting started Tue Nov  7 15:34:08 2017 UTC and is due to finish in 60 minutes.  The chair is dalley. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:34:08 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:34:08 <pulpbot> The meeting name has been set to 'pulp_triage_2017_11_07'
15:34:08 <pulpbot> dalley: dalley has joined triage
15:34:12 <dkliban> !here
15:34:12 <dkliban> #info dkliban has joined triage
15:34:12 <pulpbot> dkliban: dkliban has joined triage
15:34:13 <ttereshc> !here
15:34:13 <ttereshc> #info ttereshc has joined triage
15:34:13 <pulpbot> ttereshc: ttereshc has joined triage
15:34:13 <bmbouter> #info bmbouter has joined triage
15:34:13 <bmbouter> !here
15:34:14 <pulpbot> bmbouter: bmbouter has joined triage
15:34:16 <daviddavis> !here
15:34:16 <daviddavis> #info daviddavis has joined triage
15:34:16 <pulpbot> daviddavis: daviddavis has joined triage
15:34:16 <bmbouter> long live pulpbot!
15:34:24 <dalley> bizhang++
15:34:26 <pulpbot> dalley: bizhang's karma is now 30
15:34:26 <dalley> :)
15:34:49 <bizhang> !here
15:34:49 <bizhang> #info bizhang has joined triage
15:34:50 <pulpbot> bizhang: bizhang has joined triage
15:34:53 <dalley> !next
15:34:54 <pulpbot> dalley: 3 issues left to triage: 3117, 3118, 3120
15:34:54 <dalley> #topic jwt_secret field in the API is confusing - http://pulp.plan.io/issues/3117
15:34:55 <pulpbot> Issue #3117 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:34:56 <pulpbot> jwt_secret field in the API is confusing - http://pulp.plan.io/issues/3117
15:35:23 <mhrivnak> !here
15:35:23 <mhrivnak> #info mhrivnak has joined triage
15:35:23 <pulpbot> mhrivnak: mhrivnak has joined triage
15:35:38 <mhrivnak> I agree it's confusing. :)
15:35:39 <daviddavis> this came up during a pr review. not sure how to proceed on this
15:35:53 <dkliban> it's a bug
15:35:55 <mhrivnak> Do we want to expose that field at all?
15:36:10 <daviddavis> probably not. I'm all for just dropping the DEBUG behavior
15:36:39 <daviddavis> by expose, do you mean just read or read AND write?
15:36:39 <dkliban> let's accept as is and continue discussion on the issue
15:36:51 <dalley> !propose triage accept
15:36:51 <pulpbot> dalley: (propose triage <priority> <severity> [target_release]) -- Propose triage values including priority, severity, and an optional target release.
15:36:56 <dalley> !propose accept
15:36:56 <dalley> #idea Proposed for #3117: Leave the issue as-is, accepting its current state.
15:36:56 <pulpbot> dalley: Proposed for #3117: Leave the issue as-is, accepting its current state.
15:36:56 <mhrivnak> works for me.
15:37:02 <bizhang> +1
15:37:08 <ttereshc> +1
15:37:27 <dalley> !accept
15:37:27 <dalley> #agreed Leave the issue as-is, accepting its current state.
15:37:27 <pulpbot> dalley: Current proposal accepted: Leave the issue as-is, accepting its current state.
15:37:28 <pulpbot> dalley: 2 issues left to triage: 3118, 3120
15:37:28 <dalley> #topic cannot create docker repository with  repo-registry-id containing "--" or "__" - http://pulp.plan.io/issues/3118
15:37:29 <pulpbot> Issue #3118 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:37:30 <pulpbot> cannot create docker repository with  repo-registry-id containing "--" or "__" - http://pulp.plan.io/issues/3118
15:37:49 <dkliban> ipanova: any thoughts on this?
15:38:41 <ttereshc> dkliban, she is not participating in triage today
15:38:45 <mhrivnak> Maybe just a bug in the regex.
15:38:47 <dkliban> ah ok
15:38:58 <dkliban> is this a regression or a new feature?
15:39:02 <dkliban> or both
15:39:20 <mhrivnak> regression I think.
15:39:32 <thomasmckay> i spoke w/ jsherrill about this yesterday and commented on the issue
15:40:01 <dkliban> should we add it to the sprint?
15:40:06 <thomasmckay> it's difficult for me to decide if -- should or shouldn't be allowed strictly from docker docs
15:40:27 <mhrivnak> dkliban I think yes.
15:40:32 <dkliban> thomasmckay: in what cases would ou want to use -- ?
15:40:56 <mhrivnak> !propose other high medium add to sprint
15:40:56 <mhrivnak> #idea Proposed for #3118: high medium add to sprint
15:40:56 <pulpbot> mhrivnak: Proposed for #3118: high medium add to sprint
15:40:58 <thomasmckay> dkliban: never, really. issue is that foreman is auto-creating labels with those chars in it
15:41:06 <dkliban> oh
15:41:18 <dkliban> +1
15:41:23 <thomasmckay> and since we have existing names with that, an upgrade would not work
15:41:31 <dkliban> makes sense
15:41:57 <mhrivnak> thomasmckay can you add any info to the issue about the origin of that regex?
15:42:09 <thomasmckay> it may make most sense to allow config to not check names and rely on foreman to validate
15:43:00 <thomasmckay> mhrivnak: if you click through the pr you'll reach https://pulp.plan.io/issues/2368
15:43:25 <thomasmckay> that's the pr i did to update the regexp to match docker docs (referenced there)
15:43:25 <dalley> !accept
15:43:25 <dalley> #agreed high medium add to sprint
15:43:25 <pulpbot> dalley: Current proposal accepted: high medium add to sprint
15:43:26 <pulpbot> dalley: 1 issues left to triage: 3120
15:43:27 <dalley> #topic Race condition on saving a distribution unit during "smart proxy" sync - http://pulp.plan.io/issues/3120
15:43:27 <pulpbot> Issue #3120 [POST] (ttereshc) - Priority: High | Severity: Medium
15:43:28 <pulpbot> Race condition on saving a distribution unit during "smart proxy" sync - http://pulp.plan.io/issues/3120
15:43:47 <dalley> sorry, didn't mean to cut you off
15:44:00 <daviddavis> accept and add to sprint
15:44:03 <asmacdo> thomasmckay [a-z0-9]+(?:[._-][a-z0-9]+)*.   (for each component, with / between components)  according to https://docs.docker.com/registry/spec/api/#overview
15:44:34 <dalley> !propose other accept and add to sprint
15:44:34 <dalley> #idea Proposed for #3120: accept and add to sprint
15:44:34 <pulpbot> dalley: Proposed for #3120: accept and add to sprint
15:44:40 <ttereshc> +1
15:44:46 <mhrivnak> +1
15:44:59 <dalley> !accept
15:44:59 <dalley> #agreed accept and add to sprint
15:44:59 <pulpbot> dalley: Current proposal accepted: accept and add to sprint
15:45:01 <pulpbot> dalley: No issues to triage.
15:45:05 <dalley> #endmeeting
15:45:05 <dalley> !end