15:30:25 <dalley> #startmeeting Pulp Triage 2017-11-28
15:30:25 <dalley> #info dalley has joined triage
15:30:26 <pulpbot> Meeting started Tue Nov 28 15:30:25 2017 UTC and is due to finish in 60 minutes.  The chair is dalley. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:30:26 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:30:26 <pulpbot> The meeting name has been set to 'pulp_triage_2017_11_28'
15:30:26 <pulpbot> dalley: dalley has joined triage
15:31:21 <ttereshc> !here
15:31:21 <ttereshc> #info ttereshc has joined triage
15:31:21 <pulpbot> ttereshc: ttereshc has joined triage
15:31:25 <bmbouter> !here
15:31:25 <bmbouter> #info bmbouter has joined triage
15:31:25 <pulpbot> bmbouter: bmbouter has joined triage
15:31:29 <mhrivnak> #info mhrivnak has joined triage
15:31:29 <mhrivnak> !here
15:31:29 <pulpbot> mhrivnak: mhrivnak has joined triage
15:31:57 <dkliban> !here
15:31:57 <dkliban> #info dkliban has joined triage
15:31:57 <pulpbot> dkliban: dkliban has joined triage
15:32:00 <dalley> !next
15:32:02 <dalley> #topic Clarify image tagging vs. image naming - http://pulp.plan.io/issues/3128
15:32:02 <pulpbot> dalley: 4 issues left to triage: 3128, 3146, 3148, 3149
15:32:03 <pulpbot> Issue #3128 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:32:04 <pulpbot> Clarify image tagging vs. image naming - http://pulp.plan.io/issues/3128
15:32:21 <mhrivnak> oops, I dropped this one.
15:32:42 <mhrivnak> How about ipanova and I move this forward this week?
15:32:42 <jortel> !here
15:32:42 <jortel> #info jortel has joined triage
15:32:42 <pulpbot> jortel: jortel has joined triage
15:32:50 <ttereshc> !propose skip
15:32:50 <ttereshc> #idea Proposed for #3128: Skip this issue for this triage session.
15:32:50 <pulpbot> ttereshc: Proposed for #3128: Skip this issue for this triage session.
15:33:57 <mhrivnak> +1
15:33:58 <dkliban> +1
15:34:02 <jortel> +1
15:34:22 <dalley> !accept
15:34:22 <dalley> #agreed Skip this issue for this triage session.
15:34:22 <pulpbot> dalley: Current proposal accepted: Skip this issue for this triage session.
15:34:23 <pulpbot> dalley: 3 issues left to triage: 3146, 3148, 3149
15:34:23 <dalley> #topic Add repoview support to the RPM rsync distributor - http://pulp.plan.io/issues/3146
15:34:24 <pulpbot> Issue #3146 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:34:25 <pulpbot> Add repoview support to the RPM rsync distributor - http://pulp.plan.io/issues/3146
15:34:27 <daviddavis> !here
15:34:27 <daviddavis> #info daviddavis has joined triage
15:34:27 <pulpbot> daviddavis: daviddavis has joined triage
15:34:38 <dkliban> this should be a story
15:34:47 <ttereshc> +1
15:34:50 <dalley> !propose other convert to story
15:34:50 <dalley> #idea Proposed for #3146: convert to story
15:34:50 <pulpbot> dalley: Proposed for #3146: convert to story
15:34:53 <jortel> y
15:36:11 <dalley> ?
15:36:30 <ttereshc> I think we are in agreement to convert to story
15:36:31 <mhrivnak> y not
15:36:51 <dalley> oh, y=yes :)
15:36:54 <dalley> !accept
15:36:54 <dalley> #agreed convert to story
15:36:54 <pulpbot> dalley: Current proposal accepted: convert to story
15:36:55 <pulpbot> dalley: 2 issues left to triage: 3148, 3149
15:36:55 <dalley> #topic dupicate key error on task_status collection with mongoengine 0.14  - http://pulp.plan.io/issues/3148
15:36:56 <pulpbot> Issue #3148 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:36:57 <pulpbot> dupicate key error on task_status collection with mongoengine 0.14  - http://pulp.plan.io/issues/3148
15:37:06 <dalley> I thought y=why
15:37:34 <ipanova> !here
15:37:34 <ipanova> #info ipanova has joined triage
15:37:34 <pulpbot> ipanova: ipanova has joined triage
15:37:36 <bmbouter> me too
15:37:50 <jortel> dalley: heh.  I meant (y)es but I can see y that would be confusing ;)
15:38:05 <jortel> I wont do it again.
15:38:47 <dalley> np
15:38:59 <daviddavis> what version of mongoengine do we ship?
15:39:05 <ttereshc> I think we need to reproduce this on fedora and check compatibility with 0.14 in general
15:39:08 <ttereshc> 0.11 I think
15:39:30 <bmbouter> this suggests 0.10.5-1  https://github.com/pulp/pulp/blob/master/deps/external_deps.json#L64
15:40:20 <ttereshc> bmbouter, then you're right
15:40:34 <dalley> this may be related?  same traceback https://pulp.plan.io/issues/2990
15:41:23 <daviddavis> I'm thinking we should create a task to support mongoengine 0.14 and then attach this bug
15:42:15 <daviddavis> or maybe turn this issue into that task
15:42:23 <bmbouter> we can just test against the deps on F27 which ships 0.14
15:42:26 <bmbouter> https://apps.fedoraproject.org/packages/python-mongoengine
15:42:44 <bmbouter> iirc, pcreech said he was testing F27 and pulp?
15:42:53 <dkliban> i think so
15:43:15 <dalley> yup
15:44:42 <daviddavis> how do we triage this then
15:45:00 <mhrivnak> Someone needs to just !propose something specific. :)
15:45:11 <dkliban> it's a bug ... accept as is
15:45:17 <ttereshc> create a task to test pulp on F27 and mark this one as related?
15:45:35 <daviddavis> +1 to ttereshc
15:45:41 <dalley> +1
15:45:41 <bmbouter> I think that testing is already happening though
15:45:45 <bmbouter> isn't there already a ticket
15:46:08 <mhrivnak> +1 testing is a good idea, but it's independent from this bug report.
15:46:15 <ttereshc> !propose other create a task to test pulp on F27 if it doesn't exist and mark this one as related
15:46:15 <ttereshc> #idea Proposed for #3148: create a task to test pulp on F27 if it doesn't exist and mark this one as related
15:46:15 <pulpbot> ttereshc: Proposed for #3148: create a task to test pulp on F27 if it doesn't exist and mark this one as related
15:46:26 <daviddavis> perfect
15:46:35 <dalley> !accept
15:46:35 <dalley> #agreed create a task to test pulp on F27 if it doesn't exist and mark this one as related
15:46:35 <pulpbot> dalley: Current proposal accepted: create a task to test pulp on F27 if it doesn't exist and mark this one as related
15:46:37 <dalley> #topic pulpcore.plugin.download.asyncio has surprising timeout handling - http://pulp.plan.io/issues/3149
15:46:37 <pulpbot> dalley: 1 issues left to triage: 3149
15:46:38 <pulpbot> Issue #3149 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:46:39 <pulpbot> pulpcore.plugin.download.asyncio has surprising timeout handling - http://pulp.plan.io/issues/3149
15:47:13 <bmbouter> oh interesting!
15:48:32 <bmbouter> !propose accept as is and add to sprint
15:48:32 <pulpbot> bmbouter: propose accept Propose accepting the current issue in its current state.
15:49:12 <dalley> !propose other accept and add to sprint
15:49:12 <dalley> #idea Proposed for #3149: accept and add to sprint
15:49:12 <pulpbot> dalley: Proposed for #3149: accept and add to sprint
15:50:17 <dkliban> +1
15:50:20 <jortel> is this a pulp issue?
15:50:25 <jortel> or aio.http issue?
15:50:33 <dkliban> it's how we are using it i think
15:50:54 <ttereshc> yeah, that's my understanding as well
15:51:36 <bmbouter> yeah it's how we are using it
15:51:54 <bmbouter> the user is identifying two levels of timeouts and we are only handling one
15:52:20 <dalley> !accept
15:52:20 <dalley> #agreed accept and add to sprint
15:52:20 <pulpbot> dalley: Current proposal accepted: accept and add to sprint
15:52:21 <pulpbot> dalley: No issues to triage.
15:52:27 <dalley> !end
15:52:27 <dalley> #endmeeting