15:30:31 <dalley> #startmeeting Pulp Triage 2018-01-09
15:30:31 <dalley> #info dalley has joined triage
15:30:31 <dalley> !start
15:30:31 <pulpbot> Meeting started Tue Jan 9 15:30:31 2018 UTC and is due to finish in 60 minutes. The chair is dalley. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:30:31 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:30:31 <pulpbot> The meeting name has been set to 'pulp_triage_2018_01_09'
15:30:31 <pulpbot> dalley: dalley has joined triage
15:31:06 <ipanova|sick> !here
15:31:06 <ipanova|sick> #info ipanova|sick has joined triage
15:31:06 <pulpbot> ipanova|sick: ipanova|sick has joined triage
15:31:33 <dkliban> !here
15:31:33 <dkliban> #info dkliban has joined triage
15:31:33 <pulpbot> dkliban: dkliban has joined triage
15:31:42 <daviddavis> !here
15:31:42 <daviddavis> #info daviddavis has joined triage
15:31:42 <pulpbot> daviddavis: daviddavis has joined triage
15:32:15 <asmacdo> !here
15:32:15 <asmacdo> #info asmacdo has joined triage
15:32:15 <pulpbot> asmacdo: asmacdo has joined triage
15:32:17 <dalley> !next
15:32:18 <pulpbot> dalley: 8 issues left to triage: 3250, 3251, 3254, 3255, 3256, 3257, 3258, 3259
15:32:18 <dalley> #topic docker tag creation: inconsistent field names - http://pulp.plan.io/issues/3250
15:32:19 <pulpbot> Issue #3250 [POST] (unassigned) - Priority: Normal | Severity: High
15:32:20 <pulpbot> docker tag creation: inconsistent field names - http://pulp.plan.io/issues/3250
15:33:11 <milan> rchan, sry, was afk having a snack O:-)
15:33:23 <asmacdo> lets accept manifest_digest or digest, and deprecate digest
15:33:27 <asmacdo> !propose accept
15:33:27 <asmacdo> #idea Proposed for #3250: Leave the issue as-is, accepting its current state.
15:33:27 <pulpbot> asmacdo: Proposed for #3250: Leave the issue as-is, accepting its current state.
15:33:32 <ttereshc> !here
15:33:32 <ttereshc> #info ttereshc has joined triage
15:33:32 <pulpbot> ttereshc: ttereshc has joined triage
15:34:21 <ipanova|sick> asmacdo: we'd need then to add one more option to the cli
15:34:37 <asmacdo> ipanova|sick: we could, but we don't have to
15:34:38 <ipanova|sick> if we want to be consistent if we plan to deprecate digest
15:35:09 <asmacdo> thats fine, or we could update the cli to use --digest but add a manifest_digest over the REST API
15:35:18 <ttereshc> maybe discuss it on the issue?
15:35:26 <dkliban> yeah ... let's accept and discuss on issue
15:35:28 <ipanova|sick> yes ttereshc
15:35:29 <asmacdo> either way, i think we can accept
15:35:42 <bmbouter> !here
15:35:42 <bmbouter> #info bmbouter has joined triage
15:35:42 <pulpbot> bmbouter: bmbouter has joined triage
15:35:49 <ttereshc> +1
15:36:07 * ttereshc +1 that bmbouter joined :)
15:36:15 <dalley> !accept
15:36:15 <dalley> #agreed Leave the issue as-is, accepting its current state.
15:36:15 <pulpbot> dalley: Current proposal accepted: Leave the issue as-is, accepting its current state.
15:36:16 <pulpbot> dalley: 7 issues left to triage: 3251, 3254, 3255, 3256, 3257, 3258, 3259
15:36:17 <dalley> #topic Uploading a docker tag with pulp_user_metadata specified - http://pulp.plan.io/issues/3251
15:36:17 <pulpbot> Issue #3251 [NEW] (unassigned) - Priority: Normal | Severity: High
15:36:18 <pulpbot> Uploading a docker tag with pulp_user_metadata specified - http://pulp.plan.io/issues/3251
15:36:35 <asmacdo> !propose accept
15:36:35 <asmacdo> #idea Proposed for #3251: Leave the issue as-is, accepting its current state.
15:36:35 <pulpbot> asmacdo: Proposed for #3251: Leave the issue as-is, accepting its current state.
15:36:38 <bmbouter> +1
15:36:51 <ipanova|sick> hold on
15:37:15 <asmacdo> this is an additive change, and if we implement it, we can easily include the pulp_user_metadata when we copy a tag
15:37:15 <ipanova|sick> can someone then explain me why we created a special API endpoint for user metadata creation?
15:37:28 <bmbouter> I don't know why/where that came from
15:37:32 <bmbouter> this is the first I've heard of it
15:37:35 <ipanova|sick> lol
15:37:48 <asmacdo> i dont know why we did, but it makes sense to add user metadata after creation or during creation
15:37:50 <misa> asmacdo: that's exactly what happens for all other units
15:38:04 <bmbouter> I thought it was a dict attribute stored like that, yes
15:38:07 <ipanova|sick> misa: you mentioned just package group
15:38:11 <ipanova|sick> did you try other units?
15:38:23 <misa> no
15:38:39 <bmbouter> we should look at the models
15:38:52 <milan> ... OT: dkliban, thx, I noticed the same having bumped Fedora version 25->26; more debugging I guess
15:38:53 <bmbouter> b/c I think it's on one of the models high up in the inheritance
15:39:02 <misa> bmbouter: correct
15:39:05 <misa> it's part of ContentUnit
15:39:10 <ipanova|sick> bmbouter: yes
15:39:20 <ipanova|sick> but then why we made that endpoint
15:39:29 <misa> to set it after the fact
15:39:31 <ipanova|sick> if we could do it the way misa tried
15:39:39 <ipanova|sick> ok
15:39:58 <misa> and it's nice that, being part of the core, plugin developers can't f it up
15:40:04 <ipanova|sick> well i have no enough of info figuring out where this comes from and why we have it
15:40:11 <ipanova|sick> so let's accept then :)
15:40:20 <misa> it was a big push I think in pulp 2.10
15:40:28 <dalley> or, we could skip and discuss this deeper later
15:40:41 <dalley> either way, meeting at 11 so we should move on
15:40:43 <misa> a PR is coming forthwith
15:40:44 <asmacdo> i think we should accept, and continue discussion on the issue
15:40:51 <dkliban> accept
15:40:56 <dalley> sounds good
15:40:59 <dalley> !accept
15:40:59 <dalley> #agreed Leave the issue as-is, accepting its current state.
15:40:59 <pulpbot> dalley: Current proposal accepted: Leave the issue as-is, accepting its current state.
15:41:00 <ipanova|sick> fine both ways
15:41:00 <dalley> #topic Documentation - Repository Authentication - http://pulp.plan.io/issues/3254
15:41:01 <pulpbot> dalley: 6 issues left to triage: 3254, 3255, 3256, 3257, 3258, 3259
15:41:02 <pulpbot> Issue #3254 [NEW] (unassigned) - Priority: Normal | Severity: Low
15:41:03 <pulpbot> Documentation - Repository Authentication - http://pulp.plan.io/issues/3254
15:41:36 <asmacdo> !propose other high high and and to the sprint
15:41:36 <asmacdo> #idea Proposed for #3254: high high and and to the sprint
15:41:36 <pulpbot> asmacdo: Proposed for #3254: high high and and to the sprint
15:42:03 <bmbouter> what about asking them for a PR?
15:42:17 <asmacdo> sounds like a plan
15:42:33 <bmbouter> I can comment inviting that if that helps
15:42:41 <asmacdo> +1
15:42:48 <ipanova|sick> +1
15:42:53 <daviddavis> +i^2
15:43:01 <asmacdo> lol -1?
15:43:10 <ttereshc> +1 but why is it high high?
15:43:12 <daviddavis> ha
15:43:16 <dalley> this is +1 to accepting? which is not exclusive with asking for a PR
15:43:18 <daviddavis> i^4 rather
15:43:29 <ipanova|sick> accept as it is and ask for a PR
15:43:37 <ipanova|sick> no need for h/h
15:43:45 <asmacdo> high high because our cli is lying
15:43:56 <asmacdo> or high med
15:44:21 <asmacdo> but im fine with accepting as is, if thats what everyone prefers
15:44:45 <asmacdo> sorry, this is a docs bug, not a CLI bug
15:44:53 <dalley> !accept
15:44:53 <dalley> #agreed high high and and to the sprint
15:44:53 <pulpbot> dalley: Current proposal accepted: high high and and to the sprint
15:44:54 <pulpbot> dalley: 5 issues left to triage: 3255, 3256, 3257, 3258, 3259
15:44:55 <dalley> #topic pulp-consumer does not remove binding if repo is no longer available on server - http://pulp.plan.io/issues/3255
15:44:55 <pulpbot> Issue #3255 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:44:56 <pulpbot> pulp-consumer does not remove binding if repo is no longer available on server - http://pulp.plan.io/issues/3255
15:45:32 <ipanova|sick> hold on
15:45:35 <ipanova|sick> can we go back
15:45:49 <dalley> I think so, but I forget the command
15:45:54 <ipanova|sick> the options he was optioning are w/r to the consumer auth
15:45:55 <asmacdo> !issue 3254
15:46:06 <dalley> !issue 3254
15:46:07 <dalley> #topic Documentation - Repository Authentication - http://pulp.plan.io/issues/3254
15:46:07 <pulpbot> Issue #3254 [NEW] (unassigned) - Priority: Normal | Severity: Low
15:46:08 <pulpbot> Documentation - Repository Authentication - http://pulp.plan.io/issues/3254
15:46:48 <ipanova|sick> https://paste.fedoraproject.org/paste/9PZlsMcpVstFRnhF-tQ~UQ
15:46:51 <ipanova|sick> asmacdo: ^
15:47:14 <asmacdo> oh, nice catch ipanova|sick
15:47:17 <bmbouter> ipanova|sick: nice
15:47:20 <bmbouter> I see what you are saying
15:47:36 <bmbouter> I'm removing my comment
15:47:51 <ipanova|sick> yup, i think he got confused
15:48:00 <dalley> any action on my part, or should we move on?
15:48:04 <dalley> 12 minutes to meeting
15:48:09 <bmbouter> we need to not accept
15:48:13 <asmacdo> #idea Proposed for #3254: Skip this issue for this triage session.
15:48:13 <asmacdo> !propose skip
15:48:13 <pulpbot> asmacdo: Proposed for #3254: Skip this issue for this triage session.
15:48:16 <bmbouter> it should be closed - NOT A BUG
15:48:26 <ipanova|sick> dalley: yo, don't hurry up, this way we do the trige in a bad way
15:48:29 <asmacdo> thats better
15:48:45 <ipanova|sick> if we don't manage that's ok we can leave that for next triage, but let's not lower the quality
15:48:46 <bmbouter> and a comment added helping with a bit of explanation
15:48:51 <asmacdo> +1 close with comment
15:49:00 <bmbouter> can someone take the AA for the comment?
15:49:06 <ipanova|sick> bmbouter: yes i will
15:49:10 <ipanova|sick> i will comment
15:49:13 <dalley> !propose close - notabug
15:49:13 <pulpbot> dalley: Error: "propose" is not a valid command.
15:49:22 <dalley> !propose close
15:49:22 <pulpbot> dalley: Error: "propose" is not a valid command.
15:49:26 <asmacdo> !propose triage close
15:49:26 <pulpbot> asmacdo: (propose triage <priority> <severity> [target_release]) -- Propose triage values including priority, severity, and an optional target release.
15:49:37 <dalley> !propose other close-notabug
15:49:37 <dalley> #idea Proposed for #3254: close-notabug
15:49:37 <pulpbot> dalley: Proposed for #3254: close-notabug
15:49:41 <asmacdo> lol
15:49:42 <ipanova|sick> +1
15:49:48 <asmacdo> we should apparently close more :)
15:50:15 <ttereshc> +1
15:50:35 <dalley> !accept
15:50:35 <dalley> #agreed close-notabug
15:50:35 <pulpbot> dalley: Current proposal accepted: close-notabug
15:50:37 <dalley> #topic pulp-consumer does not remove binding if repo is no longer available on server - http://pulp.plan.io/issues/3255
15:50:37 <pulpbot> dalley: 5 issues left to triage: 3255, 3256, 3257, 3258, 3259
15:50:38 <pulpbot> Issue #3255 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:50:39 <pulpbot> pulp-consumer does not remove binding if repo is no longer available on server - http://pulp.plan.io/issues/3255
15:51:29 <asmacdo> !propose accept
15:51:29 <asmacdo> #idea Proposed for #3255: Leave the issue as-is, accepting its current state.
15:51:29 <pulpbot> asmacdo: Proposed for #3255: Leave the issue as-is, accepting its current state.
15:51:42 <ipanova|sick> +1
15:51:49 <asmacdo> does anyone know of a workaround other than creating the repo, unbinding, then deleting it?
15:51:59 <ttereshc> I'm not sure, maybe bindings are gone after repo removal...
15:52:17 <ipanova|sick> i don't think so
15:52:23 <ipanova|sick> ttereshc:
15:52:28 <asmacdo> they cant be cleaned up at delete time, the consumer isnt connected then
15:52:34 <bmbouter> I think we have one of these open already
15:52:36 <bmbouter> iirc
15:52:48 <ipanova|sick> that;s possible
15:53:09 <bmbouter> oh wait no it's slightly different
15:53:10 <ipanova|sick> let's skip for now and try to find already opened one for the next triage session
15:53:23 <dalley> !propose skip
15:53:23 <dalley> #idea Proposed for #3255: Skip this issue for this triage session.
15:53:23 <pulpbot> dalley: Proposed for #3255: Skip this issue for this triage session.
15:53:28 <bmbouter> that is fine w/ me
15:53:48 <asmacdo> +1
15:53:51 <ipanova|sick> actually i think the workaround is to set the force to true
15:53:53 <ipanova|sick> :)
15:54:23 <asmacdo> he set force=true in the issue
15:54:23 <ttereshc> !propose skip and ipanova|sick will take a look :P
15:54:23 <pulpbot> ttereshc: propose skip Propose skipping the current issue for this triage session.
15:54:57 <asmacdo> +1
15:55:22 <ttereshc> asmacdo, I don't see it {"force": false}
15:55:27 <dalley> !accept
15:55:27 <dalley> #agreed Skip this issue for this triage session.
15:55:27 <pulpbot> dalley: Current proposal accepted: Skip this issue for this triage session.
15:55:28 <pulpbot> dalley: 4 issues left to triage: 3256, 3257, 3258, 3259
15:55:28 <dalley> #topic all sslclientcert in pulp.repo are called client.crt - http://pulp.plan.io/issues/3256
15:55:29 <milan> ipanova|sick may be right; there's some discrepancy between issue short description and the steps; btw reporter gone from users
15:55:29 <pulpbot> Issue #3256 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:55:30 <pulpbot> all sslclientcert in pulp.repo are called client.crt - http://pulp.plan.io/issues/3256
15:55:32 <ipanova|sick> he lies asmacdo
15:55:34 <ipanova|sick> asmacdo: INFO - DELETE request to /pulp/api/v2/consumers/pulpserver/bindings/foobar/yum_distributor/ with parameters {"force": false}
15:55:44 <asmacdo> :)
15:56:25 <ipanova|sick> ttereshc: i will take a look as ttereshc sweetheart suggested :-P
15:56:48 <ttereshc> (:
15:57:43 <daviddavis> !dance
15:57:43 <pulpbot> ♪┏(°.°)┛┗(°.°)┓┗(°.°)┛┏(°.°)┓ ♪
15:57:51 <ipanova|sick> !kirby
15:57:51 <pulpbot> (>'-')> <('-'<) ^('-')^ v('-')v(>'-')> (^-^)
15:58:02 <daviddavis> :D
15:58:13 <ttereshc> so user suggests to preserve a cert name?
15:59:38 <ipanova|sick> !propose skip
15:59:38 <ipanova|sick> #idea Proposed for #3256: Skip this issue for this triage session.
15:59:38 <pulpbot> ipanova|sick: Proposed for #3256: Skip this issue for this triage session.
16:00:07 <dkliban> skip
16:00:10 <dkliban> +1
16:00:11 <asmacdo> +1
16:00:13 <ttereshc> skip the rest till Friday triage
16:00:19 <ipanova|sick> +1
16:00:23 <dkliban> +1
16:00:25 <dalley> !accept
16:00:25 <dalley> #agreed Skip this issue for this triage session.
16:00:25 <pulpbot> dalley: Current proposal accepted: Skip this issue for this triage session.
16:00:26 <pulpbot> dalley: 3 issues left to triage: 3257, 3258, 3259
16:00:26 <dalley> #topic pulp does not ask, provide or configure entitlement certificate key - http://pulp.plan.io/issues/3257
16:00:27 <pulpbot> Issue #3257 [NEW] (unassigned) - Priority: Normal | Severity: Medium
16:00:28 <pulpbot> pulp does not ask, provide or configure entitlement certificate key - http://pulp.plan.io/issues/3257
16:00:29 <dalley> !end
16:00:29 <dalley> #endmeeting