15:30:25 <dalley> #startmeeting Pulp Triage 2018-01-16
15:30:25 <dalley> #info dalley has joined triage
15:30:26 <pulpbot> Meeting started Tue Jan 16 15:30:25 2018 UTC and is due to finish in 60 minutes. The chair is dalley. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:30:26 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:30:26 <pulpbot> The meeting name has been set to 'pulp_triage_2018_01_16'
15:30:26 <pulpbot> dalley: dalley has joined triage
15:30:47 <bizhang> !here
15:30:47 <bizhang> #info bizhang has joined triage
15:30:47 <pulpbot> bizhang: bizhang has joined triage
15:31:01 <daviddavis> #info daviddavis has joined triage
15:31:01 <daviddavis> !here
15:31:01 <pulpbot> daviddavis: daviddavis has joined triage
15:31:05 <preethi> !here
15:31:05 <preethi> #info preethi has joined triage
15:31:05 <pulpbot> preethi: preethi has joined triage
15:31:07 <milan> !here
15:31:07 <milan> #info milan has joined triage
15:31:07 <pulpbot> milan: milan has joined triage
15:31:38 <ttereshc> #info ttereshc has joined triage
15:31:38 <ttereshc> !here
15:31:38 <pulpbot> ttereshc: ttereshc has joined triage
15:31:43 <dalley> !next
15:31:44 <pulpbot> dalley: 5 issues left to triage: 3255, 3278, 3281, 3282, 3283
15:31:44 <dalley> #topic pulp-consumer does not remove binding if repo is no longer available on server - http://pulp.plan.io/issues/3255
15:31:45 <pulpbot> Issue #3255 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:31:46 <pulpbot> pulp-consumer does not remove binding if repo is no longer available on server - http://pulp.plan.io/issues/3255
15:31:49 <bmbouter> #info bmbouter has joined triage
15:31:49 <bmbouter> !here
15:31:49 <pulpbot> bmbouter: bmbouter has joined triage
15:32:37 <ipanova> !here
15:32:37 <ipanova> #info ipanova has joined triage
15:32:37 <pulpbot> ipanova: ipanova has joined triage
15:32:48 <ipanova> #idea Proposed for #3255: Skip this issue for this triage session.
15:32:48 <ipanova> !propose skip
15:32:48 <pulpbot> ipanova: Proposed for #3255: Skip this issue for this triage session.
15:33:34 <daviddavis> +1
15:34:05 <dkliban> !HERER
15:34:05 <pulpbot> dkliban: Error: "HERER" is not a valid command.
15:34:09 <ttereshc> +1
15:34:10 <dkliban> !here
15:34:10 <dkliban> #info dkliban has joined triage
15:34:10 <pulpbot> dkliban: dkliban has joined triage
15:34:15 <daviddavis> lol dkliban
15:34:30 <ipanova> this is what i call enthusiasm
15:34:36 <dkliban> LOL
15:34:44 <ttereshc> dkliban, you sound Deutsch
15:35:03 <ipanova> dalley: my furer please accept
15:35:21 <dkliban> are we skipping?
15:35:23 <dalley> !accept
15:35:23 <dalley> #agreed Skip this issue for this triage session.
15:35:23 <pulpbot> dalley: Current proposal accepted: Skip this issue for this triage session.
15:35:24 <pulpbot> dalley: 4 issues left to triage: 3278, 3281, 3282, 3283
15:35:24 <dalley> #topic Pulp Installation Docs does not recommend additional steps user should take to set up a secure Pulp server - http://pulp.plan.io/issues/3278
15:35:26 <pulpbot> Issue #3278 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:35:27 <pulpbot> Pulp Installation Docs does not recommend additional steps user should take to set up a secure Pulp server - http://pulp.plan.io/issues/3278
15:35:46 <ipanova> dkliban: we are, no info from reporter yet
15:35:49 <dalley> was waiting on someone else to ++, but I guess nobody had an opinion :P
15:35:59 <ipanova> dalley++
15:35:59 <pulpbot> ipanova: dalley's karma is now 23
15:36:36 <daviddavis> accept and maybe add to sprint
15:37:02 <dkliban> accept as is
15:37:37 <ttereshc> !propose accept
15:37:37 <ttereshc> #idea Proposed for #3278: Leave the issue as-is, accepting its current state.
15:37:37 <pulpbot> ttereshc: Proposed for #3278: Leave the issue as-is, accepting its current state.
15:39:10 <bizhang> +1
15:39:15 <dalley> !accept
15:39:15 <dalley> #agreed Leave the issue as-is, accepting its current state.
15:39:15 <pulpbot> dalley: Current proposal accepted: Leave the issue as-is, accepting its current state.
15:39:16 <pulpbot> dalley: 3 issues left to triage: 3281, 3282, 3283
15:39:17 <dalley> #topic Several active resource managers in "celery status" - http://pulp.plan.io/issues/3281
15:39:17 <pulpbot> Issue #3281 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:39:18 <pulpbot> Several active resource managers in "celery status" - http://pulp.plan.io/issues/3281
15:40:32 <dkliban> this is an interesting bug
15:41:16 <dkliban> we should accept as is. i don't think we need to add it to the sprint quite yet
15:41:31 <dkliban> bmbouter: dalley: what do you think?
15:41:49 <dalley> I think I agree
15:42:09 <dalley> !propose accept
15:42:09 <dalley> #idea Proposed for #3281: Leave the issue as-is, accepting its current state.
15:42:09 <pulpbot> dalley: Proposed for #3281: Leave the issue as-is, accepting its current state.
15:42:53 <daviddavis> +1
15:43:13 <dkliban> +1
15:44:34 <dalley> bmbouter?
15:45:02 <dalley> !accept
15:45:02 <dalley> #agreed Leave the issue as-is, accepting its current state.
15:45:02 <pulpbot> dalley: Current proposal accepted: Leave the issue as-is, accepting its current state.
15:45:03 <dalley> #topic As a user, I know which Linux distributions are supported - http://pulp.plan.io/issues/3282
15:45:04 <pulpbot> dalley: 2 issues left to triage: 3282, 3283
15:45:05 <pulpbot> Issue #3282 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:45:06 <pulpbot> As a user, I know which Linux distributions are supported - http://pulp.plan.io/issues/3282
15:45:43 <bmbouter> I agree
15:45:48 <asmacdo> !propose other switch to story
15:45:48 <asmacdo> #idea Proposed for #3282: switch to story
15:45:48 <asmacdo> #info asmacdo has joined triage
15:45:49 <pulpbot> asmacdo: asmacdo has joined triage
15:45:50 <pulpbot> asmacdo: Proposed for #3282: switch to story
15:45:52 <bmbouter> re: 3281
15:45:55 <dkliban> accept and add to sprint for 3281
15:46:36 <bmbouter> re: 3281, it shows just accept, not on sprint
15:46:46 <dalley> switch to story, add to sprint?
15:47:06 <bmbouter> dalley +1
15:47:27 <dalley> !propose other accept, convert to story, add to sprint
15:47:27 <dalley> #idea Proposed for #3282: accept, convert to story, add to sprint
15:47:28 <pulpbot> dalley: Proposed for #3282: accept, convert to story, add to sprint
15:47:49 <asmacdo> they are talking about 3282, not 3281 dalley
15:47:51 <dkliban> sorry for the confusion ... i meant add 3282. not 3281
15:48:03 <bmbouter> haha
15:48:13 <dalley> ah, k
15:48:15 <bmbouter> +1 3282, convert to story, add to sprint
15:48:16 <dkliban> :(
15:48:29 <dkliban> +1
15:48:49 <asmacdo> lol !propose foreach(3281, 3282) convert to story add to sprint
15:48:52 <bmbouter> actually
15:48:59 <bmbouter> I don't think Pulp cares
15:49:11 <dkliban> we should state taht
15:49:11 <bmbouter> Pulp doesn't support oses
15:49:36 <dkliban> bmbouter: we need to state teh requirements
15:49:52 <bmbouter> yeah but this story is asking not for requirements but a statement of distro support
15:50:06 <bmbouter> I understand the need and motivation though
15:50:21 <bmbouter> if this is a statement about our installers I think that makes a lot of sense
15:51:07 <bmbouter> because that means it's been packaged for a specific distro
15:51:49 <bmbouter> what do others think?
15:52:09 <asmacdo> well, we dont package for a specific distro because we always install on a vm of fedora
15:52:58 * milan might run on OS X? ;)
15:53:06 <bmbouter> it probably would easily
15:53:29 <bmbouter> I thikn the ansible playbooks need to be clear which OSes they support
15:53:41 <bmbouter> but Pulp can run anywhere there is the necessary deps and runtime environments
15:53:43 <dkliban> bmbouter: yes ... it's a statement about the installer
15:53:59 <asmacdo> +1, but we should also state ^ somewhere early on in our docs
15:54:08 <bmbouter> agreed to both
15:54:16 <bmbouter> can we update this issue in these waysand then add it?
15:54:27 <asmacdo> +1
15:54:48 <dalley> !propose other edit the issue to specify the ansible installers and accept
15:54:48 <dalley> #idea Proposed for #3282: edit the issue to specify the ansible installers and accept
15:54:49 <pulpbot> dalley: Proposed for #3282: edit the issue to specify the ansible installers and accept
15:54:56 <bizhang> +1
15:55:28 <dkliban> +1
15:56:01 <bmbouter> +1 but who can take the AI?
15:56:13 * milan can
15:56:20 <dalley> +1
15:56:21 <dkliban> milan: ty
15:56:25 <milan> np
15:56:30 <dalley> milan++
15:56:30 <pulpbot> dalley: milan's karma is now 1
15:56:36 <dalley> first karma :)
15:56:44 <milan> heh :)
15:56:54 <dalley> !accept
15:56:54 <dalley> #agreed edit the issue to specify the ansible installers and accept
15:56:54 <pulpbot> dalley: Current proposal accepted: edit the issue to specify the ansible installers and accept
15:56:55 <dalley> #topic Descriptions for actions are hard to parse and expose internal implementation - http://pulp.plan.io/issues/3283
15:56:56 <pulpbot> dalley: 1 issues left to triage: 3283
15:56:57 <pulpbot> Issue #3283 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:56:58 <pulpbot> Descriptions for actions are hard to parse and expose internal implementation - http://pulp.plan.io/issues/3283
15:57:04 <bmbouter> ty milan
15:57:06 <dalley> well, perhaps first karma after pulpbot crashed
15:58:05 <asmacdo> this sounds like a DRF RFE
15:58:13 <asmacdo> !propose other convert to story
15:58:13 <asmacdo> #idea Proposed for #3283: convert to story
15:58:13 <pulpbot> asmacdo: Proposed for #3283: convert to story
15:58:48 <daviddavis> what's the thought process behind making it a story?
15:59:15 <asmacdo> As a user, I can easily parse the API schema
15:59:41 <daviddavis> to me, that should be a given
15:59:44 <daviddavis> not a story
16:00:30 <bmbouter> if it's correcting already merged code then I'm +1 to issue
16:00:57 <asmacdo> i think this would be adding a 3rd party library, and that might mess with our autodocs generation
16:01:19 <daviddavis> what 3rd party library?
16:02:04 <asmacdo> dont know, but AFAIK, this is all upstream code. we just use it
16:02:15 <daviddavis> yea but we use it incorrectly
16:02:26 <daviddavis> it might be worth considering whether we should use it as intended?
16:02:29 <daviddavis> at least for the mvp
16:02:42 <dkliban> so let's make this a story
16:02:56 <daviddavis> I say keep it an issue until we have some direction
16:03:14 <dkliban> daviddavis: do you mind skipping for now?
16:03:21 <dkliban> i want to discuss more on the issue
16:03:24 <bmbouter> I just reread this and I think we need some discussion about a solution
16:03:26 <daviddavis> +1
16:03:34 <bmbouter> but I'm glad this is brought up
16:03:36 <asmacdo> +1 accept as an issue, we can continue discussion on the issue
16:03:46 <asmacdo> no need to retriage
16:03:57 <bmbouter> or skip?
16:04:09 <daviddavis> either works for me
16:04:18 <dkliban> let's skip
16:04:35 <dalley> #idea Proposed for #3283: Skip this issue for this triage session.
16:04:35 <dalley> !propose skip
16:04:35 <pulpbot> dalley: Proposed for #3283: Skip this issue for this triage session.
16:04:45 <asmacdo> thats fine
16:04:46 <dkliban> +1
16:05:18 <ttereshc> +1
16:05:45 <dalley> !skip
16:05:46 <pulpbot> dalley: No issues to triage.
16:05:51 <dalley> !end
16:05:51 <dalley> #endmeeting