15:30:09 <dalley> #startmeeting Pulp Triage 2018-01-26
15:30:09 <dalley> #info dalley has joined triage
15:30:10 <pulpbot> Meeting started Fri Jan 26 15:30:09 2018 UTC and is due to finish in 60 minutes. The chair is dalley. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:30:10 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:30:10 <pulpbot> The meeting name has been set to 'pulp_triage_2018_01_26'
15:30:10 <pulpbot> dalley: dalley has joined triage
15:30:29 <ichimonji10> pcreech, I think so, yes.
15:30:43 <daviddavis> #info daviddavis has joined triage
15:30:43 <daviddavis> !here
15:30:43 <pulpbot> daviddavis: daviddavis has joined triage
15:30:51 <pcreech> ichimonji10: let's move to #pulp so we don't interrupt triage
15:30:59 <elyezer> ichimonji10++
15:30:59 <pulpbot> elyezer: ichimonji10's karma is now 57
15:31:03 <bizhang> !here
15:31:03 <bizhang> #info bizhang has joined triage
15:31:03 <pulpbot> bizhang: bizhang has joined triage
15:31:08 <mansari> !here
15:31:08 <mansari> #info mansari has joined triage
15:31:08 <pulpbot> mansari: mansari has joined triage
15:31:08 <elyezer> excellent bug report
15:31:12 <dalley> daviddavis, I thought you were on PTO?
15:31:21 <daviddavis> I am :)
15:31:27 <dalley> ah :)
15:31:32 <daviddavis> just was checking some emails and decided to attend triage
15:31:50 <dalley> daviddavis, kk, fyi, someone was asking for you on the internal #pulp earlier
15:32:04 <dalley> 30 min ago
15:32:07 <dalley> !next
15:32:08 <pulpbot> dalley: 6 issues left to triage: 3313, 3314, 3317, 3318, 3319, 3322
15:32:08 <dalley> #topic rsync distributor broken on Fedora 27 due to SELinux denials - http://pulp.plan.io/issues/3313
15:32:09 <pulpbot> Issue #3313 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:32:10 <pulpbot> rsync distributor broken on Fedora 27 due to SELinux denials - http://pulp.plan.io/issues/3313
15:32:41 <bizhang> I think this cleared up on the last batch of smash jobs
15:33:10 <bizhang> I can comment and close
15:33:47 <dalley> !propose other bizhang will comment and close
15:33:47 <dalley> #idea Proposed for #3313: bizhang will comment and close
15:33:47 <pulpbot> dalley: Proposed for #3313: bizhang will comment and close
15:33:54 <dalley> !propose other bizhang will double-check, comment and close
15:33:54 <dalley> #idea Proposed for #3313: bizhang will double-check, comment and close
15:33:54 <pulpbot> dalley: Proposed for #3313: bizhang will double-check, comment and close
15:34:17 <bizhang> +1
15:34:19 <mansari> +1
15:34:50 <dalley> !accept
15:34:50 <dalley> #agreed bizhang will double-check, comment and close
15:34:50 <pulpbot> dalley: Current proposal accepted: bizhang will double-check, comment and close
15:34:52 <dalley> #topic puppet install distributor broken on F27 due to SELinux denials - http://pulp.plan.io/issues/3314
15:34:52 <pulpbot> dalley: 5 issues left to triage: 3314, 3317, 3318, 3319, 3322
15:34:53 <pulpbot> Issue #3314 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:34:54 <pulpbot> puppet install distributor broken on F27 due to SELinux denials - http://pulp.plan.io/issues/3314
15:35:32 <bizhang> !propose accept and add to sprint
15:35:32 <pulpbot> bizhang: propose accept Propose accepting the current issue in its current state.
15:36:14 <bizhang> we should fix these before tuesday if the 2.15.1 release is targeting f27
15:36:38 <dalley> +1
15:37:31 <mansari> +1
15:37:46 <dalley> !accept
15:37:46 <pulpbot> dalley: No action proposed, nothing to accept.
15:37:56 <dalley> !propose other accept and add to sprint
15:37:56 <dalley> #idea Proposed for #3314: accept and add to sprint
15:37:56 <pulpbot> dalley: Proposed for #3314: accept and add to sprint
15:37:57 <dalley> #agreed accept and add to sprint
15:37:57 <dalley> !accept
15:37:57 <pulpbot> dalley: Current proposal accepted: accept and add to sprint
15:37:58 <pulpbot> dalley: 4 issues left to triage: 3317, 3318, 3319, 3322
15:37:59 <dalley> #topic rsync_distributors: 'rsync_extra_args' not used in all calls to rsync - http://pulp.plan.io/issues/3317
15:37:59 <pulpbot> Issue #3317 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:38:00 <pulpbot> rsync_distributors: 'rsync_extra_args' not used in all calls to rsync - http://pulp.plan.io/issues/3317
15:38:02 <ichimonji10> bizhang, I think 3313 and 3314 are still active and biting us
15:38:17 <ichimonji10> The issues aren't failing in jenkins, because I added some logic that's causing the tests to skip
15:38:46 <bizhang> ahh I see
15:39:02 <dalley> !issue 3313
15:39:03 <dalley> #topic rsync distributor broken on Fedora 27 due to SELinux denials - http://pulp.plan.io/issues/3313
15:39:03 <pulpbot> Issue #3313 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:39:04 <pulpbot> rsync distributor broken on Fedora 27 due to SELinux denials - http://pulp.plan.io/issues/3313
15:39:07 <ichimonji10> I can check today and get back to you.
15:39:12 <bizhang> !propose other accept and add to spring
15:39:12 <bizhang> #idea Proposed for #3313: accept and add to spring
15:39:13 <pulpbot> bizhang: Proposed for #3313: accept and add to spring
15:39:14 <dalley> !propose other accept and add to sprint
15:39:14 <dalley> #idea Proposed for #3313: accept and add to sprint
15:39:14 <pulpbot> dalley: Proposed for #3313: accept and add to sprint
15:39:25 <bizhang> +1
15:39:29 <dalley> !accept
15:39:29 <dalley> #agreed accept and add to sprint
15:39:29 <pulpbot> dalley: Current proposal accepted: accept and add to sprint
15:39:30 <pulpbot> dalley: 4 issues left to triage: 3317, 3318, 3319, 3322
15:39:31 <dalley> #topic rsync_distributors: 'rsync_extra_args' not used in all calls to rsync - http://pulp.plan.io/issues/3317
15:39:31 <pulpbot> Issue #3317 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:39:32 <pulpbot> rsync_distributors: 'rsync_extra_args' not used in all calls to rsync - http://pulp.plan.io/issues/3317
15:39:46 <mansari> Should be in POST...can see a PR
15:40:31 <dalley> correct
15:40:41 <dalley> !propose other accept and move to post
15:40:41 <dalley> #idea Proposed for #3317: accept and move to post
15:40:41 <pulpbot> dalley: Proposed for #3317: accept and move to post
15:40:47 <mansari> +1
15:41:17 <bizhang> should we assign it to someone to move it forward and get it merged?
15:41:56 <dalley> we should assign it to the author and then ping Dennis to review I think
15:42:13 <bizhang> +1
15:42:33 <daviddavis> +1
15:43:17 <dalley> !accept
15:43:17 <dalley> #agreed accept and move to post
15:43:17 <pulpbot> dalley: Current proposal accepted: accept and move to post
15:43:19 <dalley> #topic Can't set up Pulp 3 dev environment on non-Vagrant hosts - http://pulp.plan.io/issues/3318
15:43:19 <pulpbot> dalley: 3 issues left to triage: 3318, 3319, 3322
15:43:20 <pulpbot> Issue #3318 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:43:21 <pulpbot> Can't set up Pulp 3 dev environment on non-Vagrant hosts - http://pulp.plan.io/issues/3318
15:43:30 <ichimonji10> I'm happy to do the actual work on this one.
15:44:24 <bizhang> !propose accept
15:44:24 <bizhang> #idea Proposed for #3318: Leave the issue as-is, accepting its current state.
15:44:24 <pulpbot> bizhang: Proposed for #3318: Leave the issue as-is, accepting its current state.
15:44:47 <dalley> works for me
15:45:27 <dalley> !accept
15:45:27 <dalley> #agreed Leave the issue as-is, accepting its current state.
15:45:27 <pulpbot> dalley: Current proposal accepted: Leave the issue as-is, accepting its current state.
15:45:29 <dalley> #topic Certificates used in unit testing are expired - http://pulp.plan.io/issues/3319
15:45:29 <pulpbot> dalley: 2 issues left to triage: 3319, 3322
15:45:30 <pulpbot> Issue #3319 [POST] (dalley) - Priority: Normal | Severity: Medium
15:45:31 <pulpbot> Certificates used in unit testing are expired - http://pulp.plan.io/issues/3319
15:47:40 <dalley> daviddavis, could you look into whether we need to change the certificate generation script?
15:48:07 <daviddavis> dalley: so I looked briefly at the PR and I am not sure I understand what the problem is or what to fix
15:48:11 <daviddavis> I am not an expert in this area
15:49:12 <dalley> well, the immediate problem is that the certificates we're using as part of unittests are expired
15:49:24 <daviddavis> where do you see that they're expired?
15:49:26 <daviddavis> dalley: ^
15:49:59 <dalley> "notBefore=<Jan 26 18:25:17 2015 GMT>, notAfter=<Jan 25 18:25:17 2018 GMT"
15:50:44 <daviddavis> ah ok, I was looking at the PR
15:50:59 <daviddavis> accept and add to sprint?
15:51:52 <dalley> yes but we need to figure out if we need to do something about #2733 which I marked as relevant
15:52:37 <daviddavis> dalley: how is 2733 relevant?
15:52:37 <dalley> I noticed that 7 months ago you replaced the certs because candlepin didn't like them, and that the new certs I generated look like the ones with the formatting that candlepin doesn't like
15:52:51 <daviddavis> let me look
15:54:04 <daviddavis> dalley: the formatting is not a problem I don't think. the main fix was the addition of some fields (e.g. https://git.io/vNXDh )
15:54:38 <daviddavis> not sure why the formatting changed
15:54:55 <daviddavis> but I don't think it matters
15:56:26 <dalley> alright
15:56:37 <dalley> !propose accept and add to sprint
15:56:37 <pulpbot> dalley: propose accept Propose accepting the current issue in its current state.
15:56:46 <dalley> !propose accept and add to sprint, move to POSt
15:56:46 <pulpbot> dalley: propose accept Propose accepting the current issue in its current state.
15:56:49 <dalley> !propose accept and add to sprint, move to POST
15:56:49 <pulpbot> dalley: propose accept Propose accepting the current issue in its current state.
15:56:59 <dalley> !propose other accept and add to sprint, move to POST
15:56:59 <dalley> #idea Proposed for #3319: accept and add to sprint, move to POST
15:56:59 <pulpbot> dalley: Proposed for #3319: accept and add to sprint, move to POST
15:57:05 <dalley> sigh
15:57:21 <bizhang> +1
15:58:01 <dalley> !accept
15:58:01 <dalley> #agreed accept and add to sprint, move to POST
15:58:01 <pulpbot> dalley: Current proposal accepted: accept and add to sprint, move to POST
15:58:02 <dalley> #topic Add --bg flag to "rpm repo copy" - http://pulp.plan.io/issues/3322
15:58:03 <pulpbot> dalley: 1 issues left to triage: 3322
15:58:04 <pulpbot> Issue #3322 [NEW] (unassigned) - Priority: Normal | Severity: Low
15:58:05 <pulpbot> Add --bg flag to "rpm repo copy" - http://pulp.plan.io/issues/3322
15:58:44 <daviddavis> convert to story?
15:59:07 <dalley> agreed
15:59:55 <dalley> !propose other convert to story
15:59:55 <dalley> #idea Proposed for #3322: convert to story
15:59:56 <pulpbot> dalley: Proposed for #3322: convert to story
16:00:26 <bizhang> +1
16:01:33 <dalley> !accept
16:01:33 <dalley> #agreed convert to story
16:01:33 <pulpbot> dalley: Current proposal accepted: convert to story
16:01:34 <pulpbot> dalley: No issues to triage.
16:01:38 <dalley> !end
16:01:38 <dalley> #endmeeting