15:30:13 <dalley> #startmeeting Pulp Triage 2018-02-13
15:30:13 <pulpbot> Meeting started Tue Feb 13 15:30:13 2018 UTC and is due to finish in 60 minutes. The chair is dalley. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:30:13 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:30:13 <pulpbot> The meeting name has been set to 'pulp_triage_2018_02_13'
15:30:13 <dalley> #info dalley has joined triage
15:30:13 <pulpbot> dalley: dalley has joined triage
15:30:34 <daviddavis> !here
15:30:34 <daviddavis> #info daviddavis has joined triage
15:30:34 <pulpbot> daviddavis: daviddavis has joined triage
15:30:37 <milan_> !here
15:30:37 <milan_> #info milan_ has joined triage
15:30:38 <pulpbot> milan_: milan_ has joined triage
15:30:39 <dkliban> !here
15:30:39 <dkliban> #info dkliban has joined triage
15:30:39 <pulpbot> dkliban: dkliban has joined triage
15:30:40 <ttereshc> !here
15:30:40 <ttereshc> #info ttereshc has joined triage
15:30:41 <pulpbot> ttereshc: ttereshc has joined triage
15:31:04 <dalley> !next
15:31:05 <dalley> #topic Can't delete a publication - http://pulp.plan.io/issues/3354
15:31:06 <pulpbot> dalley: 7 issues left to triage: 3354, 3355, 3357, 3358, 3362, 3365, 3366
15:31:07 <pulpbot> Issue #3354 [POST] (daviddavis@redhat.com) - Priority: Normal | Severity: Medium
15:31:08 <pulpbot> Can't delete a publication - http://pulp.plan.io/issues/3354
15:31:15 <bizhang> !here
15:31:15 <bizhang> #info bizhang has joined triage
15:31:15 <pulpbot> bizhang: bizhang has joined triage
15:31:19 <dalley> already in POST. accept & add to sprint?
15:31:30 <bizhang> +1
15:31:35 <dalley> !propose other accept and add to sprint
15:31:35 <dalley> #idea Proposed for #3354: accept and add to sprint
15:31:35 <pulpbot> dalley: Proposed for #3354: accept and add to sprint
15:31:54 <daviddavis> +1
15:31:57 <dkliban> +1
15:32:00 <dalley> !accept
15:32:00 <dalley> #agreed accept and add to sprint
15:32:00 <pulpbot> dalley: Current proposal accepted: accept and add to sprint
15:32:02 <dalley> #topic Getting an error building docs with Sphinx 1.7 - http://pulp.plan.io/issues/3355
15:32:02 <pulpbot> dalley: 6 issues left to triage: 3355, 3357, 3358, 3362, 3365, 3366
15:32:03 <pulpbot> Issue #3355 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:32:04 <pulpbot> Getting an error building docs with Sphinx 1.7 - http://pulp.plan.io/issues/3355
15:32:41 <dkliban> add to sprint
15:32:45 <ttereshc> +1
15:32:50 <daviddavis> +1
15:32:59 <dalley> !propose other accept and add to sprint
15:32:59 <dalley> #idea Proposed for #3355: accept and add to sprint
15:32:59 <pulpbot> dalley: Proposed for #3355: accept and add to sprint
15:33:03 <dalley> !accept
15:33:03 <dalley> #agreed accept and add to sprint
15:33:03 <pulpbot> dalley: Current proposal accepted: accept and add to sprint
15:33:04 <pulpbot> dalley: 5 issues left to triage: 3357, 3358, 3362, 3365, 3366
15:33:04 <dalley> #topic docker_distributor_web is racy, not atomic - http://pulp.plan.io/issues/3357
15:33:05 <pulpbot> Issue #3357 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:33:06 <pulpbot> docker_distributor_web is racy, not atomic - http://pulp.plan.io/issues/3357
15:34:39 <dalley> !propose other high / normal add to sprint
15:34:39 <dalley> #idea Proposed for #3357: high / normal add to sprint
15:34:40 <pulpbot> dalley: Proposed for #3357: high / normal add to sprint
15:36:48 <ttereshc> it seems like a bad issue though it's not that urgent I think...
15:36:56 <ttereshc> and we have sprint planning this week
15:37:15 <dkliban> let's discuss at sprint planning?
15:37:37 <ttereshc> !propose triage h n
15:37:37 <pulpbot> ttereshc: Error: Unknown Severity
15:37:42 <ttereshc> !propose triage h m
15:37:42 <ttereshc> #idea Proposed for #3357: Priority: High, Severity: Medium
15:37:42 <pulpbot> ttereshc: Proposed for #3357: Priority: High, Severity: Medium
15:37:45 <dalley> just accept for now then and evaluate at planning?
15:37:56 <dkliban> yeah
15:38:19 <dalley> h/m works for me
15:38:31 <dkliban> +1
15:38:37 <dalley> !accept
15:38:37 <dalley> #agreed Priority: High, Severity: Medium
15:38:37 <pulpbot> dalley: Current proposal accepted: Priority: High, Severity: Medium
15:38:38 <pulpbot> dalley: 4 issues left to triage: 3358, 3362, 3365, 3366
15:38:39 <dalley> #topic Very occasionally, a task will be processed and have a 'worker_name' of None - http://pulp.plan.io/issues/3358
15:38:39 <pulpbot> Issue #3358 [NEW] (unassigned) - Priority: Normal | Severity: High
15:38:40 <pulpbot> Very occasionally, a task will be processed and have a 'worker_name' of None - http://pulp.plan.io/issues/3358
15:38:58 <dalley> I suspect this is another race condition
15:39:00 <ttereshc> dalley, maybe add sprint candidate flag to rm #3357?
15:39:08 <dalley> ttereshc, ack
15:41:19 <dalley> seems like it happens quite infrequently but it caused a random task failure and a bunch of others without a record of what worker processed them
15:41:32 <ttereshc> why update throws dup key error? if index is only by task id? (if I understood the traceback correctly)
15:42:02 <ttereshc> here https://pulp.plan.io/issues/3358#note-3
15:42:29 <dkliban> hm
15:45:00 <ttereshc> for triage purposes I think we can accept it
15:45:00 <dkliban> should we add to the sprint?
15:46:20 <dalley> we can accept it for now and then discuss it at sprint planning perhaps. but I will probably spend some time looking at it today anyways
15:46:28 <dkliban> sounds good
15:46:34 <dkliban> let's accept and go to next issue
15:46:34 * milan_ cofeee sry, falling asleep triaging O:-)
15:46:54 <ttereshc> dalley, do you still have this installation and DB data?
15:47:00 <dalley> ttereshc, yes
15:47:13 <ttereshc> cool
15:47:19 <ttereshc> !propose accept
15:47:19 <ttereshc> #idea Proposed for #3358: Leave the issue as-is, accepting its current state.
15:47:19 <pulpbot> ttereshc: Proposed for #3358: Leave the issue as-is, accepting its current state.
15:47:36 <dalley> I just checked and it happened again about 20 minutes ago
15:48:10 <dalley> +1 accept
15:48:18 <dkliban> +1
15:48:38 <dalley> !accept
15:48:38 <dalley> #agreed Leave the issue as-is, accepting its current state.
15:48:38 <pulpbot> dalley: Current proposal accepted: Leave the issue as-is, accepting its current state.
15:48:39 <dalley> #topic Pypi install commands are missing the migrations and they produce broken installations - http://pulp.plan.io/issues/3362
15:48:40 <pulpbot> dalley: 3 issues left to triage: 3362, 3365, 3366
15:48:41 <pulpbot> Issue #3362 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:48:42 <pulpbot> Pypi install commands are missing the migrations and they produce broken installations - http://pulp.plan.io/issues/3362
15:50:05 <daviddavis> is this because we're not shipping migrations with the pypi packages and we need to generate them?
15:50:14 <dkliban> i think so
15:50:29 <daviddavis> accept and make sprint candidate for next sprint?
15:50:34 <dalley> that's what Brian's email said
15:50:39 <dkliban> yeah
15:51:20 <bizhang> I think migrations should be shipped with pypi when they're commited to github
15:51:46 <dkliban> bizhang: let's discuss on the ticket
15:51:54 <bizhang> dkliban, will do
15:51:57 <ttereshc> yeah, I think we had this discussion somewhere, /me is trying to find it
15:53:12 <daviddavis> there was a discussion last year on pulp-dev: Is it time to commit our migrations?
15:53:28 <dalley> !propose accept and make candidate
15:53:28 <pulpbot> dalley: propose accept Propose accepting the current issue in its current state.
15:53:37 <dalley> !propose other accept and make candidate
15:53:37 <dalley> #idea Proposed for #3362: accept and make candidate
15:53:37 <pulpbot> dalley: Proposed for #3362: accept and make candidate
15:54:43 <dalley> !propose skip
15:54:43 <dalley> #idea Proposed for #3362: Skip this issue for this triage session.
15:54:43 <pulpbot> dalley: Proposed for #3362: Skip this issue for this triage session.
15:54:53 <dalley> if we are discussing on the ticket
15:55:10 <daviddavis> works for me
15:55:20 <dkliban> +1
15:55:22 <jortel> +1
15:55:40 <dalley> !skip
15:55:41 <pulpbot> dalley: 2 issues left to triage: 3365, 3366
15:55:42 <dalley> #topic @id@ on the inherited content unit conflicts with a content unit which also uses @id@ - http://pulp.plan.io/issues/3365
15:55:42 <pulpbot> Issue #3365 [NEW] (unassigned) - Priority: Normal | Severity: Low
15:55:43 <pulpbot> @id@ on the inherited content unit conflicts with a content unit which also uses @id@ - http://pulp.plan.io/issues/3365
15:56:27 <daviddavis> not sure I understand the conflict?
15:57:06 <daviddavis> oh, plugin writers are trying to add 'id' columns to their content units?
15:57:22 <ttereshc> I guess more information on the issue will be helpful
15:57:36 <daviddavis> I can comment
15:57:38 <dkliban> let's skip
15:58:05 <ttereshc> +1
15:58:08 <jortel> +1, skip. need for info
15:58:17 <dalley> +1
15:58:20 <dalley> !skip
15:58:21 <pulpbot> dalley: 1 issues left to triage: 3366
15:58:22 <dalley> #topic settings.yaml states the default broker to be Qpid but settings.py requires Rabbitmq - http://pulp.plan.io/issues/3366
15:58:22 <pulpbot> Issue #3366 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:58:24 <pulpbot> settings.yaml states the default broker to be Qpid but settings.py requires Rabbitmq - http://pulp.plan.io/issues/3366
15:58:59 <dalley> !propose accept + add to sprint + easy fix flag
15:58:59 <pulpbot> dalley: propose accept Propose accepting the current issue in its current state.
15:59:11 <jortel> +1
15:59:18 <daviddavis> +1
15:59:34 <bizhang> +1
15:59:40 <dalley> !accept
15:59:40 <dalley> #agreed Skip this issue for this triage session.
15:59:40 <pulpbot> dalley: Current proposal accepted: Skip this issue for this triage session.
15:59:42 <pulpbot> dalley: No issues to triage.
15:59:44 <dalley> !end
15:59:44 <dalley> #endmeeting