14:30:58 <dalley> #startmeeting Pulp Triage 2018-04-03
14:30:58 <dalley> #info dalley has joined triage
14:30:59 <pulpbot> Meeting started Tue Apr 3 14:30:58 2018 UTC and is due to finish in 60 minutes. The chair is dalley. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:30:59 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:30:59 <pulpbot> The meeting name has been set to 'pulp_triage_2018_04_03'
14:30:59 <pulpbot> dalley: dalley has joined triage
14:31:01 * daviddavis puts his shirt back on
14:31:02 <asmacdo> !here
14:31:02 <asmacdo> #info asmacdo has joined triage
14:31:02 <pulpbot> asmacdo: asmacdo has joined triage
14:31:04 <daviddavis> !here
14:31:04 <daviddavis> #info daviddavis has joined triage
14:31:04 <pulpbot> daviddavis: daviddavis has joined triage
14:31:10 <dkliban> !here
14:31:10 <dkliban> #info dkliban has joined triage
14:31:10 <pulpbot> dkliban: dkliban has joined triage
14:31:12 <dawalker> !here
14:31:12 <dawalker> #info dawalker has joined triage
14:31:12 <pulpbot> dawalker: dawalker has joined triage
14:31:15 <dalley> !next
14:31:17 <dalley> #topic /api/v3/ and /content/ could collide with a Live API - http://pulp.plan.io/issues/3532
14:31:17 <pulpbot> dalley: 9 issues left to triage: 3532, 3534, 3535, 3536, 3537, 3539, 3540, 3541, 3546
14:31:17 <asmacdo> daviddavis: so thats why no video :)
14:31:18 <pulpbot> Issue #3532 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:31:19 <pulpbot> /api/v3/ and /content/ could collide with a Live API - http://pulp.plan.io/issues/3532
14:31:24 <daviddavis> lol
14:31:27 <bmbouter> !here
14:31:27 <bmbouter> #info bmbouter has joined triage
14:31:27 <pulpbot> bmbouter: bmbouter has joined triage
14:31:58 <dalley> lol
14:32:08 <bmbouter> I'm recommending we put this on the sprint because it's a significant but easy change
14:32:09 <asmacdo> just occurred to me that this one would need some changes to pulp/devel also
14:32:12 <bmbouter> yup
14:32:21 <asmacdo> +1 add to sprint
14:32:23 <dalley> I thought we dropped pulp/ from the url for some reason w/r/t live apis to begin with
14:32:26 <daviddavis> I don't think it's easy but +1 to add to sprint
14:32:34 <daviddavis> we'll need to update pulp-smash, docs, etc
14:32:48 <asmacdo> a lot of easy work
14:32:56 <dalley> !propose other accept and add to sprint
14:32:56 <dalley> #idea Proposed for #3532: accept and add to sprint
14:32:56 <pulpbot> dalley: Proposed for #3532: accept and add to sprint
14:32:59 <bmbouter> it's true. low complexity but not wasy
14:33:03 <bmbouter> easy
14:33:10 <dawalker> wasy?
14:33:17 <daviddavis> somewhat easy = wasy
14:33:38 <asmacdo> +1 new tag: wasy
14:33:46 <dalley> can someone comment on the issue w/ all of the projects that need changes?
14:33:51 <dalley> checklist, probably
14:34:10 <asmacdo> they are all different projects, so ill file issues and relate them to this one
14:34:18 <dalley> asmacdo++
14:34:18 <pulpbot> dalley: asmacdo's karma is now 39
14:34:24 <dalley> !accept
14:34:24 <dalley> #agreed accept and add to sprint
14:34:24 <pulpbot> dalley: Current proposal accepted: accept and add to sprint
14:34:26 <dalley> #topic Error syncing OSTree Repository - http://pulp.plan.io/issues/3534
14:34:26 <pulpbot> dalley: 8 issues left to triage: 3534, 3535, 3536, 3537, 3539, 3540, 3541, 3546
14:34:27 <pulpbot> Issue #3534 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:34:28 <pulpbot> Error syncing OSTree Repository - http://pulp.plan.io/issues/3534
14:34:59 <dkliban> jortel: ^
14:35:16 <asmacdo> !propose skip
14:35:16 <asmacdo> #idea Proposed for #3534: Skip this issue for this triage session.
14:35:16 <pulpbot> asmacdo: Proposed for #3534: Skip this issue for this triage session.
14:35:19 <daviddavis> who else is on the ostree team?
14:35:20 <asmacdo> hes in scrum of scrums
14:35:23 <daviddavis> ah
14:35:27 <dalley> that's still going on?
14:35:31 <daviddavis> lol
14:35:32 <dalley> jeez, long one today
14:35:33 <asmacdo> maybe not
14:35:40 * asmacdo is making things up
14:35:47 <dkliban> +1 to skppign
14:35:58 <dalley> !skip
14:36:00 <dalley> #topic Error syncing Oracle EPEL repository - http://pulp.plan.io/issues/3535
14:36:00 <pulpbot> dalley: 7 issues left to triage: 3535, 3536, 3537, 3539, 3540, 3541, 3546
14:36:01 <pulpbot> Issue #3535 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:36:01 <dkliban> i'll ping jortel about it later
14:36:02 <pulpbot> Error syncing Oracle EPEL repository - http://pulp.plan.io/issues/3535
14:36:12 <dalley> we can come back to it if jortel materializes
14:37:18 <dkliban> we should look into this issue
14:37:39 <dkliban> at least try to reproduce. i would say that it's worth adding to the sprint to at least try reproducing
14:37:46 <asmacdo> the Oracle answers in its own way
14:38:30 <daviddavis> ...
14:38:35 <dawalker> heh
14:38:37 <daviddavis> accept and add to sprint?
14:38:46 <dalley> !propose accept and add to sprint
14:38:46 <pulpbot> dalley: propose accept Propose accepting the current issue in its current state.
14:38:46 <dkliban> +1
14:38:50 <dawalker> +1
14:38:54 <dalley> #agreed Skip this issue for this triage session.
14:38:54 <dalley> !accept
14:38:54 <pulpbot> dalley: Current proposal accepted: Skip this issue for this triage session.
14:38:55 <dalley> #topic Can't get date filters to work - http://pulp.plan.io/issues/3536
14:38:56 <pulpbot> dalley: 6 issues left to triage: 3536, 3537, 3539, 3540, 3541, 3546
14:38:57 <pulpbot> Issue #3536 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:38:58 <pulpbot> Can't get date filters to work - http://pulp.plan.io/issues/3536
14:39:11 <bmbouter> ?
14:39:21 <bmbouter> current proposal accepted skip?
14:39:47 <daviddavis> bmbouter: not sure I understand
14:39:48 <asmacdo> nice catch bmbouter
14:40:00 <asmacdo> dalley> !accept
14:40:00 <asmacdo>
10:39 <pulpbot> dalley: Current proposal accepted: Skip this issue for this triage session.
14:40:00 <dalley> lol
14:40:00 <daviddavis> oh
14:40:19 <dalley> well, I did the right thing anyway
14:40:24 <dalley> moving on :P
14:40:30 <asmacdo> for #3536 lets skip for now
14:40:34 <dalley> (marked accept and added)
14:40:45 <asmacdo> ill take an AI to check it and comment
14:40:47 <bmbouter> cool thx
14:41:21 <dalley> with this one, I'm working on filtering lately anyway so i can check it, it would take 30 seconds
14:41:35 <daviddavis> I think asmacdo beat you
14:41:46 * asmacdo hands the torch to dalley
14:41:50 <jortel> !here
14:41:50 <jortel> #info jortel has joined triage
14:41:50 <pulpbot> jortel: jortel has joined triage
14:42:12 <dalley> !propose other dalley will comment on the issue after investigation
14:42:12 <dalley> #idea Proposed for #3536: dalley will comment on the issue after investigation
14:42:13 <pulpbot> dalley: Proposed for #3536: dalley will comment on the issue after investigation
14:42:24 <dalley> accept or skip, as far as triage goes?
14:42:30 <asmacdo> dalley: im curious so ping me when you finish
14:42:39 <asmacdo> skip
14:42:45 <dalley> !skip
14:42:46 <dalley> #topic Filters should not exist for /api/v3/repositories/<uuid>/versions/<version>/ - http://pulp.plan.io/issues/3537
14:42:47 <pulpbot> dalley: 5 issues left to triage: 3537, 3539, 3540, 3541, 3546
14:42:48 <pulpbot> Issue #3537 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:42:49 <pulpbot> Filters should not exist for /api/v3/repositories/<uuid>/versions/<version>/ - http://pulp.plan.io/issues/3537
14:43:03 <dalley> asmacdo, date filtering worked for me with worker.last_heartbeat
14:43:08 <dalley> fwiw
14:43:13 <asmacdo> interesting
14:43:18 <daviddavis> dalley: it might just be a doc bug in that case
14:43:22 <asmacdo> so this is that same issue right?
14:43:31 <asmacdo> that all params/filters exist for a whole viewset?
14:43:41 <asmacdo> whether list or detail
14:43:49 <daviddavis> yea
14:44:20 <daviddavis> I don't think this exists outside repo versions though
14:44:21 <daviddavis> not sure
14:44:31 <dkliban> i don't think so eitehr
14:45:01 <daviddavis> I forgot to tag this issue
14:45:24 <daviddavis> I think our api schema is a mess and we should address these ASAP. I vote to add this to the sprint.
14:45:38 <dalley> !propose other accept and add to sprint
14:45:38 <dalley> #idea Proposed for #3537: accept and add to sprint
14:45:38 <pulpbot> dalley: Proposed for #3537: accept and add to sprint
14:46:02 <asmacdo> seems reasonable. lets make sure this isnt widespread
14:46:18 <daviddavis> I'll take an AI to add a note
14:46:24 <dkliban> +1
14:46:28 <dalley> +1
14:46:43 <dawalker> +1
14:46:50 <dalley> !accept
14:46:50 <dalley> #agreed accept and add to sprint
14:46:50 <pulpbot> dalley: Current proposal accepted: accept and add to sprint
14:46:52 <pulpbot> dalley: 4 issues left to triage: 3539, 3540, 3541, 3546
14:46:52 <dalley> #topic Install drf_openapi when installing pulp3 - http://pulp.plan.io/issues/3539
14:46:53 <pulpbot> Issue #3539 [NEW] (unassigned) - Priority: Normal | Severity: Low
14:46:54 <pulpbot> Install drf_openapi when installing pulp3 - http://pulp.plan.io/issues/3539
14:47:14 <dkliban> i asked kersom to file this issue
14:47:35 <dkliban> i was hoping that he would add a test that makes sure that the /api/v3/docs/ endpoint is working
14:47:44 <daviddavis> +1
14:47:46 <dalley> !propose other accept, add to sprint, easy fix
14:47:46 <dalley> #idea Proposed for #3539: accept, add to sprint, easy fix
14:47:46 <pulpbot> dalley: Proposed for #3539: accept, add to sprint, easy fix
14:47:51 <daviddavis> +1
14:47:53 <dkliban> but it's hard to add a test like that because drf_openapi is an optional dependency
14:48:06 <daviddavis> yea, I like bizhang's solution
14:48:16 <bmbouter> I also do that is what other projects do too
14:48:18 <bmbouter> optional deps
14:48:19 <asmacdo> +1 bizhang's solution
14:48:32 <bmbouter> should we not include it in 100% of installs?
14:48:44 <bmbouter> I think that is the only question still
14:48:57 <asmacdo> i dont think its necessary
14:49:03 <dkliban> i think it is
14:49:10 <dkliban> every Foreman install comes with the docs
14:49:18 <dkliban> and i like that about Foreman a lot
14:49:27 <daviddavis> that's true
14:49:28 <asmacdo> core API is documented in core docs, plugin API is documented in plugin docs
14:49:37 <bmbouter> everything serves with this package though
14:49:47 <bmbouter> and even if plugins don't core would
14:49:57 <asmacdo> yeah, but i bet a lot of users will use the hosted docs
14:50:06 <asmacdo> so they won't care about that extra dep
14:50:22 <bmbouter> ok so diverse opinions, let's skip and comment on the issue
14:50:24 <bmbouter> I'll post the question
14:50:29 <dalley> !propose skip
14:50:29 <dalley> #idea Proposed for #3539: Skip this issue for this triage session.
14:50:29 <pulpbot> dalley: Proposed for #3539: Skip this issue for this triage session.
14:50:29 <daviddavis> ok
14:50:48 <asmacdo> im ok to add it, -0
14:51:02 <asmacdo> if everyone else agrees, lets not spend more time on it
14:51:05 <dalley> well, for the purposes of triage,moving on
14:51:19 <daviddavis> sounds good
14:51:26 <asmacdo> k
14:51:31 <dalley> adding it or discussion?
14:51:43 <daviddavis> moving on
14:51:50 <dalley> !accept
14:51:50 <dalley> #agreed Skip this issue for this triage session.
14:51:50 <pulpbot> dalley: Current proposal accepted: Skip this issue for this triage session.
14:51:51 <pulpbot> dalley: 3 issues left to triage: 3540, 3541, 3546
14:51:51 <dalley> #topic When pulp_workers are restarted, /etc/default/pulp_workers might be ignored - http://pulp.plan.io/issues/3540
14:51:52 <pulpbot> Issue #3540 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:51:53 <pulpbot> When pulp_workers are restarted, /etc/default/pulp_workers might be ignored - http://pulp.plan.io/issues/3540
14:51:53 <dalley> !issue 3534
14:51:53 <dalley> #topic Error syncing OSTree Repository - http://pulp.plan.io/issues/3534
14:51:54 <pulpbot> Issue #3534 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:51:55 <pulpbot> Error syncing OSTree Repository - http://pulp.plan.io/issues/3534
14:52:03 <dalley> switching back to the ostree one
14:52:06 <dalley> jortel?
14:52:36 <jortel> I think #3534 should be high prio and sev but not added to the sprint since no bz.
14:52:54 <daviddavis> I'm not sure this is ostree specific
14:53:00 <dalley> !propose triage high high
14:53:00 <dalley> #idea Proposed for #3534: Priority: High, Severity: High
14:53:00 <pulpbot> dalley: Proposed for #3534: Priority: High, Severity: High
14:53:14 <daviddavis> the code seems to be in pulp/server/controllers/repository.py
14:53:20 <dkliban> jortel: i told thomasmckay that we will try to reproduce ... if it reproduces he will open a BZ
14:53:40 <jortel> okay. that sounds good.
14:53:54 <dalley> !propose other accept and add to sprint, high/high
14:53:54 <dalley> #idea Proposed for #3534: accept and add to sprint, high/high
14:53:54 <pulpbot> dalley: Proposed for #3534: accept and add to sprint, high/high
14:54:10 <dalley> if we're trying to reproduce it
14:54:42 <dalley> objections?
14:55:15 <dalley> or just leave it off the sprint still
14:55:18 <dalley> ?
14:55:44 <jortel> on the sprint is fine.
14:55:54 <dalley> !accept
14:55:54 <dalley> #agreed accept and add to sprint, high/high
14:55:54 <pulpbot> dalley: Current proposal accepted: accept and add to sprint, high/high
14:55:56 * daviddavis does the 4 min warning dance
14:55:56 <pulpbot> dalley: 3 issues left to triage: 3540, 3541, 3546
14:55:56 <dalley> #topic When pulp_workers are restarted, /etc/default/pulp_workers might be ignored - http://pulp.plan.io/issues/3540
14:55:57 <pulpbot> Issue #3540 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:55:58 <pulpbot> When pulp_workers are restarted, /etc/default/pulp_workers might be ignored - http://pulp.plan.io/issues/3540
14:56:02 <jortel> but thinking it could be deferred til after the beta
14:58:42 <bmbouter> yeah the processes fail to restart
14:58:47 <jortel> dkliban: I'd be glad to reproduce #3534 as well. lemme know.
14:58:51 <bmbouter> so the settings don't take effect
14:59:29 <dkliban> jortel: let's talk to thomasmckay and see how urgent tthis is
14:59:57 <dalley> alright it's 11:00
15:00:07 <dalley> should we cut it off?
15:00:34 <bmbouter> yes we have another meeting...
15:00:44 * bmbouter does the marathon meeting dance
15:00:46 <dalley> !end
15:00:46 <dalley> #endmeeting