14:29:31 <dalley> #startmeeting Pulp Triage 2018-04-20
14:29:31 <pulpbot> Meeting started Fri Apr 20 14:29:31 2018 UTC and is due to finish in 60 minutes.  The chair is dalley. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:29:31 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:29:31 <pulpbot> The meeting name has been set to 'pulp_triage_2018_04_20'
14:29:31 <dalley> #info dalley has joined triage
14:29:31 <pulpbot> dalley: dalley has joined triage
14:29:37 <dawalker> !here
14:29:37 <dawalker> #info dawalker has joined triage
14:29:38 <pulpbot> dawalker: dawalker has joined triage
14:30:21 <asmacdo> !here
14:30:21 <asmacdo> #info asmacdo has joined triage
14:30:22 <pulpbot> asmacdo: asmacdo has joined triage
14:30:49 <dalley> !next
14:30:50 <pulpbot> dalley: 6 issues left to triage: 3574, 3575, 3577, 3578, 3583, 3585
14:30:51 <dalley> #topic Checksum issue after copy a repo - http://pulp.plan.io/issues/3574
14:30:51 <pulpbot> Issue #3574 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:30:52 <pulpbot> Checksum issue after copy a repo - http://pulp.plan.io/issues/3574
14:31:18 <daviddavis> #info daviddavis has joined triage
14:31:18 <daviddavis> !here
14:31:18 <pulpbot> daviddavis: daviddavis has joined triage
14:32:18 <asmacdo> i think this looks like an rpm plugin bug
14:32:39 <asmacdo> rpm team, want to triage this in your meeting?
14:33:26 <dkliban> !here
14:33:26 <dkliban> #info dkliban has joined triage
14:33:26 <pulpbot> dkliban: dkliban has joined triage
14:33:59 <dkliban> i think we can just accept
14:34:04 <dkliban> someone will need to investigate it
14:34:12 <dkliban> it's a matter of trying to reproduce the issue
14:34:22 <dalley> !propose accept
14:34:22 <dalley> #idea Proposed for #3574: Leave the issue as-is, accepting its current state.
14:34:22 <pulpbot> dalley: Proposed for #3574: Leave the issue as-is, accepting its current state.
14:34:31 <asmacdo> !propose other accept and change project to pulp_rom
14:34:31 <asmacdo> #idea Proposed for #3574: accept and change project to pulp_rom
14:34:31 <pulpbot> asmacdo: Proposed for #3574: accept and change project to pulp_rom
14:34:32 <ttereshc> !here
14:34:32 <ttereshc> #info ttereshc has joined triage
14:34:32 <pulpbot> ttereshc: ttereshc has joined triage
14:34:55 <daviddavis> +1
14:35:01 <ttereshc> +1
14:35:05 <dkliban> +1
14:35:08 <dalley> !accept
14:35:08 <dalley> #agreed accept and change project to pulp_rom
14:35:08 <pulpbot> dalley: Current proposal accepted: accept and change project to pulp_rom
14:35:10 <dalley> #topic Dev requirements installed outside of the pulp virtualenv - http://pulp.plan.io/issues/3575
14:35:10 <pulpbot> dalley: 5 issues left to triage: 3575, 3577, 3578, 3583, 3585
14:35:11 <pulpbot> Issue #3575 [NEW] (unassigned) - Priority: Normal | Severity: Low
14:35:12 <pulpbot> Dev requirements installed outside of the pulp virtualenv - http://pulp.plan.io/issues/3575
14:35:27 <dkliban> also accept and probably add to sprint
14:35:58 <dalley> !propose other accept and add to sprint
14:35:58 <dalley> #idea Proposed for #3575: accept and add to sprint
14:35:58 <pulpbot> dalley: Proposed for #3575: accept and add to sprint
14:36:03 <daviddavis> I'm not sure I understand
14:36:05 <dawalker> It's a minor thing in the whole scope, but would be very helpful.
14:36:09 <daviddavis> are these python packages?
14:36:16 <dkliban> yes they are
14:36:32 <asmacdo> the "extra packages" mentioned in the comment are rpms
14:36:52 <daviddavis> ah ok
14:37:11 <dkliban> asmacdo: there is 2 sets mentioned
14:37:23 <asmacdo> right, some are python, some are rpm
14:37:25 <dkliban> the second set is pointing to a pip install step
14:37:29 <daviddavis> +1 to accept and add to sprint
14:37:35 <dkliban> +1
14:37:39 <dawalker> +1
14:38:00 <dalley> !accept
14:38:00 <dalley> #agreed accept and add to sprint
14:38:00 <pulpbot> dalley: Current proposal accepted: accept and add to sprint
14:38:01 <dalley> #topic DATA_UPLOAD_MAX_MEMORY_SIZE - http://pulp.plan.io/issues/3577
14:38:02 <pulpbot> dalley: 4 issues left to triage: 3577, 3578, 3583, 3585
14:38:03 <pulpbot> Issue #3577 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:38:04 <pulpbot> DATA_UPLOAD_MAX_MEMORY_SIZE - http://pulp.plan.io/issues/3577
14:38:21 <daviddavis> accept and ask reporter for patch :)
14:38:30 <dkliban> daviddavis: that sounds good to me
14:38:39 <daviddavis> also, probably a story
14:38:42 <dkliban> yeah
14:38:58 <dalley> !propose other, accept, convert to story, ask reporter for patch
14:38:58 <pulpbot> dalley: Error: "propose" is not a valid command.
14:39:19 * daviddavis does the pulpbot error dance
14:39:24 <dkliban> lol
14:39:30 <dawalker> lol
14:39:40 <dalley> !propose other accept, convert to story, ask reporter for patch
14:39:40 <dalley> #idea Proposed for #3577: accept, convert to story, ask reporter for patch
14:39:40 <pulpbot> dalley: Proposed for #3577: accept, convert to story, ask reporter for patch
14:39:51 <ttereshc> :)
14:39:54 <dawalker> +1
14:39:55 <ttereshc> +1
14:40:06 <dkliban> +1
14:40:14 <asmacdo> note to self and anyone: maybe we can give better guidelines for bug subjects
14:40:41 <dalley> does anyone in particular want to comment asking for the patch?  otherwise I will
14:40:54 <dkliban> dalley: i'll comment. i spoke with the user on IRC already
14:40:54 <asmacdo> dalley++
14:40:55 <pulpbot> asmacdo: dalley's karma is now 51
14:41:01 <dalley> !accept
14:41:01 <dalley> #agreed accept, convert to story, ask reporter for patch
14:41:01 <pulpbot> dalley: Current proposal accepted: accept, convert to story, ask reporter for patch
14:41:03 <dalley> #topic pulp-python wrong path to pypi - http://pulp.plan.io/issues/3578
14:41:03 <pulpbot> dalley: 3 issues left to triage: 3578, 3583, 3585
14:41:04 <pulpbot> Issue #3578 [POST] (bizhang) - Priority: Normal | Severity: High
14:41:05 <pulpbot> pulp-python wrong path to pypi - http://pulp.plan.io/issues/3578
14:41:12 <asmacdo> !propose accept
14:41:12 <asmacdo> #idea Proposed for #3578: Leave the issue as-is, accepting its current state.
14:41:12 <pulpbot> asmacdo: Proposed for #3578: Leave the issue as-is, accepting its current state.
14:41:14 <asmacdo> its at post
14:41:23 <dalley> !propose other accept and add to sprint
14:41:23 <dalley> #idea Proposed for #3578: accept and add to sprint
14:41:23 <pulpbot> dalley: Proposed for #3578: accept and add to sprint
14:41:29 <asmacdo> this fixes the pypi -> warehouse transition
14:41:38 <asmacdo> +1
14:41:38 <ttereshc> +1
14:42:02 <dalley> !accept
14:42:02 <dalley> #agreed accept and add to sprint
14:42:02 <pulpbot> dalley: Current proposal accepted: accept and add to sprint
14:42:03 <pulpbot> dalley: 2 issues left to triage: 3583, 3585
14:42:04 <dalley> #topic 500 when publishing a repository without any versions - http://pulp.plan.io/issues/3583
14:42:04 <pulpbot> Issue #3583 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:42:05 <pulpbot> 500 when publishing a repository without any versions - http://pulp.plan.io/issues/3583
14:42:29 <dkliban> fun
14:42:31 <dalley> !propose other accept and add to sprint
14:42:31 <dalley> #idea Proposed for #3583: accept and add to sprint
14:42:31 <pulpbot> dalley: Proposed for #3583: accept and add to sprint
14:42:33 <dkliban> +1
14:42:37 <asmacdo> + easyfix
14:42:38 <ttereshc> +1
14:42:45 <bmbouter> !here
14:42:45 <bmbouter> #info bmbouter has joined triage
14:42:45 <pulpbot> bmbouter: bmbouter has joined triage
14:43:12 <dalley> #agreed accept and add to sprint
14:43:12 <dalley> !accept
14:43:12 <pulpbot> dalley: Current proposal accepted: accept and add to sprint
14:43:13 <pulpbot> dalley: 1 issues left to triage: 3585
14:43:13 <dalley> #topic Pulp sync/publish relies on unique filenames per repo, corrupting repository - http://pulp.plan.io/issues/3585
14:43:14 <pulpbot> Issue #3585 [NEW] (unassigned) - Priority: Normal | Severity: High
14:43:15 <pulpbot> Pulp sync/publish relies on unique filenames per repo, corrupting repository - http://pulp.plan.io/issues/3585
14:43:49 <asmacdo> bizhang ^
14:44:29 <asmacdo> (not that you would know about this, but that you should check this out re: your python upload issue)
14:45:02 <dkliban> i thnk we should accept this bug
14:45:05 <asmacdo> unless the rpm team wants to do differently, i think WONTFIX
14:45:08 <dkliban> but i dont'know that we can fix it
14:45:29 <dkliban> bmbouter: any thoughts?
14:45:50 <dkliban> ttereshc: ?
14:45:59 <ttereshc> so they have nevra in a package  which is different from the nevra specified in a filename?
14:46:06 <dkliban> ttereshc: exactly
14:46:16 <dekimsey> The filename is not nevra. it's $name-$version.rhel5.$arch.rpm
14:46:43 <daviddavis> and the packages differ by epoch?
14:46:50 <dekimsey> No, differ by release
14:47:37 <ttereshc> +1 to accept and look closer
14:47:40 <dekimsey> You'll notice the repoquery at the end gives the full nevra. It looks good between packages (terrible example since it cannot show two releases of the same version, but alas).
14:47:41 <dkliban> +1
14:48:03 <dalley> !propose accept
14:48:03 <dalley> #idea Proposed for #3585: Leave the issue as-is, accepting its current state.
14:48:03 <pulpbot> dalley: Proposed for #3585: Leave the issue as-is, accepting its current state.
14:48:11 <dkliban> +1
14:48:11 <asmacdo> +1
14:48:22 <ttereshc> dekimsey, do you have url for the repo to reproduce?
14:48:28 <dkliban> ttereshc: it's private
14:48:33 <ttereshc> ah ok
14:48:39 <dekimsey> ttereshc: Unforutnately not, it's a vendor one that's auth'd
14:48:51 <ttereshc> sure, just didn't notice that
14:49:14 <dekimsey> ttereshc: I haven't tested, but I imagine if I got the problem described correctly should be easy to just publish with re-used filenames to demo.
14:49:15 <dkliban> dekimsey: keep an eye on updates from plan.io in your email. we'll post comments on the issue if we need more info
14:49:26 <dekimsey> dkliban: Will do. Thank you all.
14:50:10 <ttereshc> dekimsey, also feel free to suggest a solution via PR if you're familiar with Python :)
14:50:11 <dalley> !accept
14:50:11 <dalley> #agreed Leave the issue as-is, accepting its current state.
14:50:11 <pulpbot> dalley: Current proposal accepted: Leave the issue as-is, accepting its current state.
14:50:12 <pulpbot> dalley: No issues to triage.
14:50:16 <dalley> !end
14:50:16 <dalley> #endmeeting