14:30:21 <asmacdo> #startmeeting Pulp Triage 2018-04-24
14:30:22 <asmacdo> #info asmacdo has joined triage
14:30:22 <pulpbot> Meeting started Tue Apr 24 14:30:21 2018 UTC and is due to finish in 60 minutes. The chair is asmacdo. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:30:22 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:30:22 <pulpbot> The meeting name has been set to 'pulp_triage_2018_04_24'
14:30:22 <pulpbot> asmacdo: asmacdo has joined triage
14:30:29 <dawalker> !here
14:30:29 <dawalker> #info dawalker has joined triage
14:30:29 <pulpbot> dawalker: dawalker has joined triage
14:30:36 <dkliban> !here
14:30:36 <dkliban> #info dkliban has joined triage
14:30:36 <pulpbot> dkliban: dkliban has joined triage
14:30:42 <daviddavis> !here
14:30:42 <daviddavis> #info daviddavis has joined triage
14:30:43 <pulpbot> daviddavis: daviddavis has joined triage
14:31:25 <asmacdo> !next
14:31:26 <pulpbot> asmacdo: 7 issues left to triage: 3586, 3587, 3589, 3594, 3595, 3596, 3598
14:31:27 <asmacdo> #topic Filtering workers is indetermanistic - http://pulp.plan.io/issues/3586
14:31:27 <pulpbot> Issue #3586 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:31:28 <pulpbot> Filtering workers is indetermanistic - http://pulp.plan.io/issues/3586
14:32:00 <daviddavis> triage, add to sprint
14:32:06 <asmacdo> #idea Proposed for #3586: accept and add to sprint
14:32:06 <asmacdo> !propose other accept and add to sprint
14:32:06 <pulpbot> asmacdo: Proposed for #3586: accept and add to sprint
14:32:10 <ttereshc> !here
14:32:10 <ttereshc> #info ttereshc has joined triage
14:32:10 <pulpbot> ttereshc: ttereshc has joined triage
14:32:26 <ipanova|gone> !here
14:32:26 <ipanova|gone> #info ipanova|gone has joined triage
14:32:26 <pulpbot> ipanova|gone: ipanova|gone has joined triage
14:32:32 <asmacdo> do we have a plan of attack for this? it would be nice to add a little more info to the bug, I'm not sure how I'd begin
14:32:33 <dkliban> +!
14:32:44 <ttereshc> asmacdo, +1
14:32:50 <asmacdo> dkliban: proposed: !!!!!!!!!!!!
14:33:06 <dkliban> asmacdo: we need to find a good reproducer outside of travis
14:33:18 <daviddavis> reproduce locally and debug
14:33:39 <daviddavis> although I had trouble for the former but my python 3.5 version wasn't the same z version
14:34:01 <asmacdo> ok. would one of you mind adding some comments, marking it triaged and add to sprint?
14:34:06 <bmbouter> !here
14:34:06 <bmbouter> #info bmbouter has joined triage
14:34:06 <pulpbot> bmbouter: bmbouter has joined triage
14:34:35 <asmacdo> im going to accept unless there are objections. T -10, 9
14:35:03 <asmacdo> !accept
14:35:03 <asmacdo> #agreed accept and add to sprint
14:35:03 <pulpbot> asmacdo: Current proposal accepted: accept and add to sprint
14:35:04 <pulpbot> asmacdo: 6 issues left to triage: 3587, 3589, 3594, 3595, 3596, 3598
14:35:05 <asmacdo> #topic Multiple serializers doesn't work for detail viewsets types - http://pulp.plan.io/issues/3587
14:35:05 <pulpbot> Issue #3587 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:35:06 <pulpbot> Multiple serializers doesn't work for detail viewsets types - http://pulp.plan.io/issues/3587
14:35:13 <daviddavis> yea I can do that
14:35:20 <asmacdo> thanks daviddavis
14:35:40 <asmacdo> !propose triage accept and add to sprint
14:35:40 <pulpbot> asmacdo: (propose triage <priority> <severity> [target_release]) -- Propose triage values including priority, severity, and an optional target release.
14:35:48 <asmacdo> !propose triage other accept and add to sprint
14:35:48 <pulpbot> asmacdo: (propose triage <priority> <severity> [target_release]) -- Propose triage values including priority, severity, and an optional target release.
14:35:53 <asmacdo> !propose tother accept and add to sprint
14:35:53 <pulpbot> asmacdo: Error: "propose" is not a valid command.
14:35:59 <asmacdo> !propose other accept and add to sprint
14:35:59 <asmacdo> #idea Proposed for #3587: accept and add to sprint
14:35:59 <pulpbot> asmacdo: Proposed for #3587: accept and add to sprint
14:36:15 * asmacdo needs to calm down :)
14:36:45 <daviddavis> +1
14:37:05 <dawalker> lol
14:37:11 <dawalker> +1
14:37:19 <ttereshc> daviddavis, +1 for asmacdo to calm down?
14:37:24 <daviddavis> haha
14:37:29 <daviddavis> +1 to everything
14:37:34 <asmacdo> lol
14:37:34 <ttereshc> good :)
14:37:36 <ttereshc> +1
14:37:37 <rchan> asmacdo definitely had his caffeine dosage this morning.
14:37:52 <asmacdo> ^ thats the truth
14:38:01 <asmacdo> #agreed accept and add to sprint
14:38:01 <asmacdo> !accept
14:38:01 <pulpbot> asmacdo: Current proposal accepted: accept and add to sprint
14:38:02 <pulpbot> asmacdo: 5 issues left to triage: 3589, 3594, 3595, 3596, 3598
14:38:03 <asmacdo> #topic Settings in server.yaml have inconsistent names - http://pulp.plan.io/issues/3589
14:38:03 <pulpbot> Issue #3589 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:38:04 <pulpbot> Settings in server.yaml have inconsistent names - http://pulp.plan.io/issues/3589
14:38:17 <dkliban> accept and add to sprint
14:38:21 <daviddavis> +1
14:38:32 <asmacdo> !propose triage other accept and add to sprint
14:38:32 <pulpbot> asmacdo: (propose triage <priority> <severity> [target_release]) -- Propose triage values including priority, severity, and an optional target release.
14:38:33 <ipanova> +1
14:38:38 <asmacdo> !propose other accept and add to sprint
14:38:38 <asmacdo> #idea Proposed for #3589: accept and add to sprint
14:38:39 <pulpbot> asmacdo: Proposed for #3589: accept and add to sprint
14:38:44 <ipanova> do we want all upper or lowercase btw?
14:39:02 <ttereshc> it's probably a refactor, not a bug?
14:39:13 <asmacdo> refactor means that it isn't user facing, but this is
14:39:20 <daviddavis> +1
14:39:41 <daviddavis> I'd go with all lowercase but ultimately as long as it's consistent
14:39:59 <dkliban> django has uppsercase settings
14:40:04 * dkliban thinks
14:40:32 <daviddavis> it does but it's a python file IIRC
14:40:35 <asmacdo> dkliban: django settings are in .py though. this is .yaml. We should go with the standard for yaml
14:40:36 <ttereshc> I meant that everything works (so not a bug), just names are inconsistent... not important, just a thought
14:40:40 <dawalker> I generally prefer lowercase, but agree that django's settings are kept upper. Might be nice to follow suit.
14:41:09 <dkliban> let's accept and discuss on issue
14:41:17 <daviddavis> +1
14:41:22 <ttereshc> +1 to add to the sprint and discuss later
14:41:23 <asmacdo> +1
14:41:30 <ipanova> +1
14:41:41 <asmacdo> someone who wants to comment, accept and add to sprint while you comment?
14:42:35 <asmacdo> ttereshc: i'd be ok to call it a task if you prefer?
14:42:40 <dawalker> +1
14:42:56 <dawalker> Looks like it's typically lowercase_with_underscores for a yaml
14:43:03 <asmacdo> !propose other move to task, accept, and add to sprint
14:43:03 <asmacdo> #idea Proposed for #3589: move to task, accept, and add to sprint
14:43:03 <pulpbot> asmacdo: Proposed for #3589: move to task, accept, and add to sprint
14:43:07 <daviddavis> -1 to task. tasks aren't part of releases
14:43:22 <asmacdo> !propose other accept and add to sprint
14:43:22 <asmacdo> #idea Proposed for #3589: accept and add to sprint
14:43:22 <pulpbot> asmacdo: Proposed for #3589: accept and add to sprint
14:43:39 <ipanova> dawalker: +1
14:43:48 <ttereshc> I'm ok not to complicate things and leave it as is, just my understanding of what the bug is was different
14:43:48 <dkliban> +1
14:44:03 <asmacdo> dawalker: would you comment, add to sprint and mark triaged?
14:44:37 <asmacdo> !accept
14:44:37 <asmacdo> #agreed accept and add to sprint
14:44:37 <pulpbot> asmacdo: Current proposal accepted: accept and add to sprint
14:44:39 <asmacdo> #topic Remove sync_mode and download_policy from docs - http://pulp.plan.io/issues/3594
14:44:39 <pulpbot> asmacdo: 4 issues left to triage: 3594, 3595, 3596, 3598
14:44:40 <pulpbot> Issue #3594 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:44:41 <pulpbot> Remove sync_mode and download_policy from docs - http://pulp.plan.io/issues/3594
14:44:49 <asmacdo> the next 3 are the same
14:45:13 <asmacdo> i propose ForEach(accept, add to sprint)
14:45:21 <daviddavis> that's fine. these are 5 min fixes.
14:45:34 <daviddavis> and we should have good docs for the beta
14:45:35 <asmacdo> it be great if these were done before the beta
14:45:39 <asmacdo> lol +1
14:45:43 <asmacdo> !propose accept
14:45:43 <asmacdo> #idea Proposed for #3594: Leave the issue as-is, accepting its current state.
14:45:43 <pulpbot> asmacdo: Proposed for #3594: Leave the issue as-is, accepting its current state.
14:45:50 <ttereshc> +1
14:45:51 <asmacdo> (they are already on the sprint)
14:46:00 <asmacdo> !accept
14:46:00 <asmacdo> #agreed Leave the issue as-is, accepting its current state.
14:46:00 <pulpbot> asmacdo: Current proposal accepted: Leave the issue as-is, accepting its current state.
14:46:00 <daviddavis> nice
14:46:02 <asmacdo> #topic Remove sync_mode and download_policy from docs - http://pulp.plan.io/issues/3595
14:46:02 <pulpbot> asmacdo: 3 issues left to triage: 3595, 3596, 3598
14:46:03 <pulpbot> Issue #3595 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:46:04 <pulpbot> Remove sync_mode and download_policy from docs - http://pulp.plan.io/issues/3595
14:46:07 <asmacdo> !accept
14:46:07 <pulpbot> asmacdo: No action proposed, nothing to accept.
14:46:15 <asmacdo> !propose accept
14:46:15 <asmacdo> #idea Proposed for #3595: Leave the issue as-is, accepting its current state.
14:46:15 <pulpbot> asmacdo: Proposed for #3595: Leave the issue as-is, accepting its current state.
14:46:17 <asmacdo> !accept
14:46:17 <asmacdo> #agreed Leave the issue as-is, accepting its current state.
14:46:17 <pulpbot> asmacdo: Current proposal accepted: Leave the issue as-is, accepting its current state.
14:46:18 <pulpbot> asmacdo: 2 issues left to triage: 3596, 3598
14:46:18 <asmacdo> #topic Remove sync_mode and download_policy from docs - http://pulp.plan.io/issues/3596
14:46:19 <pulpbot> Issue #3596 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:46:20 <pulpbot> Remove sync_mode and download_policy from docs - http://pulp.plan.io/issues/3596
14:46:22 <asmacdo> !propose accept
14:46:22 <asmacdo> #idea Proposed for #3596: Leave the issue as-is, accepting its current state.
14:46:22 <pulpbot> asmacdo: Proposed for #3596: Leave the issue as-is, accepting its current state.
14:46:26 <asmacdo> !accept
14:46:26 <asmacdo> #agreed Leave the issue as-is, accepting its current state.
14:46:26 <pulpbot> asmacdo: Current proposal accepted: Leave the issue as-is, accepting its current state.
14:46:27 <pulpbot> asmacdo: 1 issues left to triage: 3598
14:46:27 <asmacdo> #topic During sync, tar.gz files are being saved as .tar files - http://pulp.plan.io/issues/3598
14:46:28 <pulpbot> Issue #3598 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:46:29 <pulpbot> During sync, tar.gz files are being saved as .tar files - http://pulp.plan.io/issues/3598
14:47:52 <asmacdo> daviddavis: I don't have permission to edit https://pulp.plan.io/issues/3595, would you accept that one?
14:48:14 <daviddavis> yea should probably give you perms
14:48:22 <asmacdo> +1
14:48:29 <asmacdo> ansible folks, do you want to triage this one here or skip?
14:48:39 <daviddavis> is bmbouter here?
14:48:44 <bmbouter> yup
14:48:54 <bmbouter> let's skip
14:49:01 <daviddavis> any reason?
14:49:09 <asmacdo> #idea Proposed for #3598: Skip this issue for this triage session.
14:49:09 <asmacdo> !propose skip
14:49:09 <pulpbot> asmacdo: Proposed for #3598: Skip this issue for this triage session.
14:49:17 <bmbouter> just figured not everyone was interested in plugin bugs
14:49:21 <daviddavis> ah
14:49:33 <bmbouter> accept, add to sprint, any of that is fine
14:49:35 <bmbouter> we need to fix
14:49:36 <dkliban> +1 to skip
14:49:41 <bmbouter> yeah skip
14:49:48 <asmacdo> !accept
14:49:48 <asmacdo> #agreed Skip this issue for this triage session.
14:49:48 <pulpbot> asmacdo: Current proposal accepted: Skip this issue for this triage session.
14:49:49 <pulpbot> asmacdo: No issues to triage.
14:49:56 <asmacdo> gg ez
14:50:00 <daviddavis> :)
14:50:03 <asmacdo> !end
14:50:03 <asmacdo> #endmeeting