14:30:15 <dalley> #startmeeting Pulp Triage 2018-05-01
14:30:15 <dalley> #info dalley has joined triage
14:30:16 <pulpbot> Meeting started Tue May 1 14:30:15 2018 UTC and is due to finish in 60 minutes. The chair is dalley. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:30:16 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:30:16 <pulpbot> The meeting name has been set to 'pulp_triage_2018_05_01'
14:30:16 <pulpbot> dalley: dalley has joined triage
14:30:30 <daviddavis> !here
14:30:30 <daviddavis> #info daviddavis has joined triage
14:30:30 <pulpbot> daviddavis: daviddavis has joined triage
14:30:58 <bmbouter> !here
14:30:58 <bmbouter> #info bmbouter has joined triage
14:30:58 <pulpbot> bmbouter: bmbouter has joined triage
14:31:08 <asmacdo> !here
14:31:08 <asmacdo> #info asmacdo has joined triage
14:31:08 <pulpbot> asmacdo: asmacdo has joined triage
14:31:29 <dalley> !next
14:31:30 <pulpbot> dalley: 9 issues left to triage: 3610, 3611, 3618, 3620, 3621, 3622, 3623, 3632, 3635
14:31:31 <dalley> #topic 500 when publishing a repository without any versions - http://pulp.plan.io/issues/3610
14:31:31 <pulpbot> Issue #3610 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:31:32 <pulpbot> 500 when publishing a repository without any versions - http://pulp.plan.io/issues/3610
14:31:46 <jortel> !here
14:31:46 <jortel> #info jortel has joined triage
14:31:46 <pulpbot> jortel: jortel has joined triage
14:31:51 <dalley> !propose other accept and add to sprint
14:31:51 <dalley> #idea Proposed for #3610: accept and add to sprint
14:31:52 <pulpbot> dalley: Proposed for #3610: accept and add to sprint
14:32:03 <daviddavis> this will be fixed I think by https://pulp.plan.io/issues/3617
14:32:08 <daviddavis> also it's ansible
14:32:14 <daviddavis> let's skip?
14:32:16 <bmbouter> yup
14:32:27 <dalley> !skip
14:32:28 <pulpbot> dalley: 8 issues left to triage: 3611, 3618, 3620, 3621, 3622, 3623, 3632, 3635
14:32:29 <dalley> #topic Pulp Data Migrated but failed to access through URL - http://pulp.plan.io/issues/3611
14:32:29 <pulpbot> Issue #3611 [NEW] (unassigned) - Priority: Normal | Severity: Urgent
14:32:31 <pulpbot> Pulp Data Migrated but failed to access through URL - http://pulp.plan.io/issues/3611
14:32:33 <asmacdo> daviddavis: you are right about 3617
14:32:41 <daviddavis> cool
14:32:42 <bmbouter> I'm only prepared to traige core issues really
14:32:49 <daviddavis> and pulp_file?
14:33:00 <dalley> daviddavis, it's already fixed in pulp_file
14:33:01 <bmbouter> yes pulp_file ( I thikn of it really as part of core )
14:33:07 <dalley> oh nvm
14:33:10 <daviddavis> ha
14:33:25 <dalley> misunderstood
14:33:39 <daviddavis> I'm like 99% sure this issue is environmental
14:33:55 <jortel> agreed
14:34:14 <asmacdo> seems likely. they might also consider using a later version since they are new to pulp
14:34:27 <dalley> skip and continue conversation with them?
14:34:31 <daviddavis> also the docs say that XSendFilePath must be setup properly
14:34:34 <daviddavis> works for me
14:34:43 <jortel> +1
14:34:54 <asmacdo> +1 skip
14:34:55 <dalley> !skip
14:34:56 <pulpbot> dalley: 7 issues left to triage: 3618, 3620, 3621, 3622, 3623, 3632, 3635
14:34:57 <dalley> #topic database configuration docs are confusing - http://pulp.plan.io/issues/3618
14:34:57 <pulpbot> Issue #3618 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:34:58 <pulpbot> database configuration docs are confusing - http://pulp.plan.io/issues/3618
14:35:14 <daviddavis> accept and add to sprint
14:35:50 <asmacdo> +1
14:35:53 <jortel> +1
14:35:54 <dalley> +1
14:36:00 <bmbouter> what is the remedy?
14:36:06 <dalley> !propose other accept and add to sprint
14:36:06 <dalley> #idea Proposed for #3618: accept and add to sprint
14:36:06 <pulpbot> dalley: Proposed for #3618: accept and add to sprint
14:36:07 <bmbouter> I agree it's an issue
14:36:15 <dalley> also tag docs
14:36:44 <jortel> let's discuss remedies on the issue
14:36:54 <dalley> !accept
14:36:54 <dalley> #agreed accept and add to sprint
14:36:54 <pulpbot> dalley: Current proposal accepted: accept and add to sprint
14:36:55 <pulpbot> dalley: 6 issues left to triage: 3620, 3621, 3622, 3623, 3632, 3635
14:36:56 <dalley> #topic Static content not available from pip install - http://pulp.plan.io/issues/3620
14:36:56 <pulpbot> Issue #3620 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:36:57 <pulpbot> Static content not available from pip install - http://pulp.plan.io/issues/3620
14:37:01 <bmbouter> can we keep off sprint untiil it's agreed?
14:37:11 <bmbouter> it's fine I can click watch
14:37:14 <dalley> sure
14:37:15 <bmbouter> to ensure I can follow
14:37:18 <dalley> I can take it back off
14:37:40 <dalley> this one I think is notabug
14:38:01 <daviddavis> sounds like it. maybe skip for now and give jsherrill a chance to confirm
14:38:23 <asmacdo> +1 skip. hopefully not a bug, but lets wait on confirmation
14:38:34 <jortel> +1
14:38:57 <dkliban> asmacdo: i think it is a bug and he just had a typo in the ticket
14:39:01 <dkliban> i've seen the same problem
14:39:05 <bmbouter> this is real
14:39:08 <jortel> ah
14:39:15 <bmbouter> we hit this in ghent like first install
14:39:19 <dkliban> yeah
14:39:20 <asmacdo> dang
14:39:21 <bmbouter> which speaks to how our dev environment works against us
14:39:36 <jsherrill> +1 yes i see it even against /pulp/api/v3/docs/
14:39:49 <jsherrill> it was a typo in the issue
14:39:49 <daviddavis> jsherrill: thank you
14:39:55 <daviddavis> in that case, accept and add to sprint
14:39:59 <asmacdo> i dont think we mention in the instalation instructions to make html
14:40:00 <bmbouter> +1
14:40:02 <jortel> +1
14:40:07 <asmacdo> jsherrill: did you build the docs?
14:40:12 <dalley> !propose other accept and add to sprint
14:40:12 <dalley> #idea Proposed for #3620: accept and add to sprint
14:40:12 <pulpbot> dalley: Proposed for #3620: accept and add to sprint
14:40:12 <asmacdo> its not automatic
14:40:29 <dkliban> asmacdo: comment on the issue
14:40:29 <jsherrill> asmacdo: probably not, is it documented in the install instructions ?
14:40:37 <bmbouter> yeah it's on us no matter what
14:40:38 <dalley> asmacdo, for the live docs, you don't have to build them
14:40:47 <bmbouter> that is also my understanding
14:40:49 <asmacdo> oh, no way. ive been wasting my life :)
14:40:51 <dkliban> can we go on to the next issue please?
14:40:54 <jsherrill> html seems to be there, i'm missing assets it seems
14:41:01 <asmacdo> sure lets move on
14:41:10 <dalley> !accept
14:41:10 <dalley> #agreed accept and add to sprint
14:41:10 <pulpbot> dalley: Current proposal accepted: accept and add to sprint
14:41:12 <dalley> #topic /repositories/ api docs includes no parameter documentation - http://pulp.plan.io/issues/3621
14:41:12 <pulpbot> dalley: 5 issues left to triage: 3621, 3622, 3623, 3632, 3635
14:41:13 <pulpbot> Issue #3621 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:41:14 <pulpbot> /repositories/ api docs includes no parameter documentation - http://pulp.plan.io/issues/3621
14:41:44 <dalley> I assume this is talking about name and description?
14:41:56 <asmacdo> none of the fields are documented
14:41:59 <dkliban> yeah
14:42:01 <dkliban> major bug
14:42:12 <asmacdo> not sure how thats possible, they have help text
14:42:21 <dkliban> it's a bug :)
14:42:22 <asmacdo> but sure enough they arent in the nightly docs
14:42:38 <dalley> I think I know the reason for that fyi
14:42:41 <asmacdo> ill comment on the issue, we should see if this is just for built docs or if its for the autodocs
14:42:52 <dalley> well, maybe not
14:42:53 <daviddavis> I think it's because the docs document serializers separately
14:42:57 <daviddavis> as schemas
14:42:59 <dkliban> accept and add to sprint
14:43:03 <daviddavis> +1
14:43:06 <asmacdo> +1
14:43:09 <dalley> +1
14:43:17 <dalley> !propose other accept and add to sprint
14:43:17 <dalley> #idea Proposed for #3621: accept and add to sprint
14:43:17 <pulpbot> dalley: Proposed for #3621: accept and add to sprint
14:43:19 <dalley> !accept
14:43:19 <dalley> #agreed accept and add to sprint
14:43:19 <pulpbot> dalley: Current proposal accepted: accept and add to sprint
14:43:20 <pulpbot> dalley: 4 issues left to triage: 3622, 3623, 3632, 3635
14:43:20 <dalley> #topic swagger docs include semantic error - http://pulp.plan.io/issues/3622
14:43:21 <pulpbot> Issue #3622 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:43:22 <pulpbot> swagger docs include semantic error - http://pulp.plan.io/issues/3622
14:43:33 <dkliban> i saw this also
14:43:41 <dkliban> accept and add to sprint
14:43:47 <daviddavis> dkliban: does it come up when you run this from the command line
14:44:02 <daviddavis> just curious
14:44:09 <daviddavis> anyway, accept and add to sprint
14:44:19 <bmbouter> +1
14:44:22 <jortel> +1
14:44:34 <dalley> +!
14:44:36 <dalley> +!
14:44:36 <asmacdo> do we want to make it not read only or not required?
14:44:47 <dalley> !propose other accept and add to sprint
14:44:47 <dalley> #idea Proposed for #3622: accept and add to sprint
14:44:47 <pulpbot> dalley: Proposed for #3622: accept and add to sprint
14:45:05 <asmacdo> ill ask on the issue, keep going
14:45:13 <dalley> #agreed accept and add to sprint
14:45:13 <dalley> !accept
14:45:13 <pulpbot> dalley: Current proposal accepted: accept and add to sprint
14:45:14 <dalley> #topic As a user I can sync a registry by whitelisting tags ( Filtered Sync) - http://pulp.plan.io/issues/3623
14:45:15 <pulpbot> dalley: 3 issues left to triage: 3623, 3632, 3635
14:45:16 <pulpbot> Issue #3623 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:45:17 <pulpbot> As a user I can sync a registry by whitelisting tags ( Filtered Sync) - http://pulp.plan.io/issues/3623
14:45:33 <daviddavis> user story
14:45:42 <dkliban> yeah ... it's also a duplicate
14:45:46 <dkliban> i'll update this ticket
14:45:52 <dalley> cool
14:45:58 <dalley> !skip
14:45:59 <pulpbot> dalley: 2 issues left to triage: 3632, 3635
14:46:00 <dalley> #topic Pulp_python does not normalize project name before publish - http://pulp.plan.io/issues/3632
14:46:00 <pulpbot> Issue #3632 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:46:01 <pulpbot> Pulp_python does not normalize project name before publish - http://pulp.plan.io/issues/3632
14:46:15 <dalley> !skip
14:46:16 <pulpbot> dalley: 1 issues left to triage: 3635
14:46:16 <dalley> #topic Improve filter documentation - http://pulp.plan.io/issues/3635
14:46:17 <pulpbot> Issue #3635 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:46:18 <pulpbot> Improve filter documentation - http://pulp.plan.io/issues/3635
14:48:08 <asmacdo> I'd like to have this on the sprint
14:48:15 <dalley> +!
14:48:25 <dalley> !propose other accept and add to sprint
14:48:25 <dalley> #idea Proposed for #3635: accept and add to sprint
14:48:25 <pulpbot> dalley: Proposed for #3635: accept and add to sprint
14:48:35 <asmacdo> dalley s/Shift//
14:48:54 <asmacdo> not sure how this can be done though.
14:49:37 <jortel> perhaps just link to django/drf docs since we're directly exposing django model query syntax?
14:50:03 <dalley> I think it can, forget the details but I'm pretty sure you can provide help text on filters
14:50:45 <asmacdo> jortel, thats a good last resort. it would be awesome if users could see what they need to do directly.
14:50:59 <jortel> true
14:52:31 <asmacdo> +1 accept
14:52:48 <jortel> +1
14:52:53 <dkliban> +1
14:53:40 <dalley> !accept
14:53:40 <dalley> #agreed accept and add to sprint
14:53:40 <pulpbot> dalley: Current proposal accepted: accept and add to sprint
14:53:42 <pulpbot> dalley: No issues to triage.
14:53:44 <dalley> !end
14:53:44 <dalley> #endmeeting