14:33:15 <dawalker> #startmeeting Pulp Triage 2018-10-12
14:33:15 <dawalker> #info dawalker has joined triage
14:33:16 <pulpbot> Meeting started Fri Oct 12 14:33:15 2018 UTC and is due to finish in 60 minutes. The chair is dawalker. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:33:16 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:33:16 <pulpbot> The meeting name has been set to 'pulp_triage_2018_10_12'
14:33:16 <pulpbot> dawalker: dawalker has joined triage
14:33:30 <daviddavis> #info daviddavis has joined triage
14:33:30 <daviddavis> !here
14:33:30 <pulpbot> daviddavis: daviddavis has joined triage
14:34:32 <ttereshc> #info ttereshc has joined triage
14:34:32 <ttereshc> !here
14:34:33 <pulpbot> ttereshc: ttereshc has joined triage
14:34:36 <bmbouter> #info bmbouter has joined triage
14:34:36 <bmbouter> !here
14:34:36 <pulpbot> bmbouter: bmbouter has joined triage
14:34:48 * ttereshc is looking for an example of a profile daviddavis
14:35:17 <dalley> #info dalley has joined triage
14:35:17 <dalley> !here
14:35:17 <pulpbot> dalley: dalley has joined triage
14:35:25 <jortel> #info jortel has joined triage
14:35:25 <jortel> !here
14:35:25 <pulpbot> jortel: jortel has joined triage
14:35:36 <dawalker> !next
14:35:38 <pulpbot> dawalker: 5 issues left to triage: 4075, 4076, 4077, 4079, 4080
14:35:38 <dawalker> #topic ArtifactDownloader stage does not reduce traffic when Downloaders receive 429 status code - http://pulp.plan.io/issues/4075
14:35:39 <pulpbot> Issue #4075 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:35:40 <pulpbot> ArtifactDownloader stage does not reduce traffic when Downloaders receive 429 status code - http://pulp.plan.io/issues/4075
14:35:57 <bmbouter> we can accept or skip
14:36:01 <bmbouter> I'm supposed to look at this
14:36:10 <dawalker> #idea Proposed for #4075: Leave the issue as-is, accepting its current state.
14:36:10 <dawalker> !propose accept
14:36:10 <pulpbot> dawalker: Proposed for #4075: Leave the issue as-is, accepting its current state.
14:36:37 <daviddavis> +1
14:36:47 <ttereshc> bmbouter, is it the concern raised in the comment? and now it's a separate issue
14:37:07 <bmbouter> yes
14:37:09 <bmbouter> ttereshc: exactly
14:37:15 <ttereshc> ok, thx
14:37:25 <ttereshc> +1
14:37:29 <dawalker> #agreed Leave the issue as-is, accepting its current state.
14:37:29 <dawalker> !accept
14:37:29 <pulpbot> dawalker: Current proposal accepted: Leave the issue as-is, accepting its current state.
14:37:31 <dawalker> #topic Last override config doesn't show force_full - http://pulp.plan.io/issues/4076
14:37:31 <pulpbot> dawalker: 4 issues left to triage: 4076, 4077, 4079, 4080
14:37:32 <pulpbot> Issue #4076 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:37:33 <pulpbot> Last override config doesn't show force_full - http://pulp.plan.io/issues/4076
14:38:05 <daviddavis> accept
14:38:09 <dawalker> !propose accept
14:38:09 <dawalker> #idea Proposed for #4076: Leave the issue as-is, accepting its current state.
14:38:09 <pulpbot> dawalker: Proposed for #4076: Leave the issue as-is, accepting its current state.
14:38:23 <ttereshc> I'm not sure if it was done onpurpose or not
14:38:39 <daviddavis> I don't think it was
14:38:43 <ttereshc> last_override configs are compared
14:38:48 <ttereshc> iirc
14:39:10 <daviddavis> yea, we purposefully don't compare force_full because it would trigger another force_full sync
14:39:18 <daviddavis> at least according to the comments in the code
14:39:48 <daviddavis> https://git.io/fxWtR
14:39:52 <ttereshc> yeah exactly
14:40:08 <daviddavis> the problem is we use this same comparison to store last_override_config which gets shown to the user
14:40:29 <daviddavis> so when you run a force_full sync and then check the field in the CLI, it looks like it didn't get saved
14:40:37 <ttereshc> I see
14:40:46 <ttereshc> thanks for clarification
14:40:49 <ttereshc> +1
14:40:50 <daviddavis> yea
14:40:55 <dawalker> Cool
14:40:57 <dawalker> #agreed Leave the issue as-is, accepting its current state.
14:40:57 <dawalker> !accept
14:40:57 <pulpbot> dawalker: Current proposal accepted: Leave the issue as-is, accepting its current state.
14:40:58 <pulpbot> dawalker: 3 issues left to triage: 4077, 4079, 4080
14:40:58 <dawalker> #topic pulpcore can't be installed in a Django site that also ships a a custom User object - http://pulp.plan.io/issues/4077
14:40:59 <pulpbot> Issue #4077 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:41:00 <pulpbot> pulpcore can't be installed in a Django site that also ships a a custom User object - http://pulp.plan.io/issues/4077
14:42:37 <dawalker> bmbouter, is this related to that person you were working with yesterday before my meeting with you?
14:42:58 <ttereshc> we should do something with it
14:43:05 <dawalker> #idea Proposed for #4077: Leave the issue as-is, accepting its current state.
14:43:05 <dawalker> !propose accept
14:43:06 <pulpbot> dawalker: Proposed for #4077: Leave the issue as-is, accepting its current state.
14:43:21 <daviddavis> +1 to accept
14:43:24 <ttereshc> is it a bugfix or a story?
14:43:28 <jortel> +1 accept
14:43:34 <dawalker> It feels more like a story?
14:43:42 <dalley> story
14:43:44 <ttereshc> it does to me as well
14:44:00 <daviddavis> +1
14:44:12 <ttereshc> !propose other convert to story
14:44:12 <ttereshc> #idea Proposed for #4077: convert to story
14:44:12 <pulpbot> ttereshc: Proposed for #4077: convert to story
14:44:24 <ttereshc> bmbouter, ^ ?
14:44:56 <daviddavis> bmbouter left for the weekend
14:45:02 <daviddavis> he's out enjoying the nice weather
14:45:20 <ttereshc> is he in Brno?
14:45:27 <dawalker> ok, let's accept ttereshc proposal of convert to story for now.
14:45:31 * bmbouter is back!
14:45:31 <dawalker> #agreed convert to story
14:45:31 <dawalker> !accept
14:45:31 <pulpbot> dawalker: Current proposal accepted: convert to story
14:45:33 <dawalker> #topic field manifest had null=True even manifest cannot never be null - http://pulp.plan.io/issues/4079
14:45:33 <pulpbot> dawalker: 2 issues left to triage: 4079, 4080
14:45:34 <pulpbot> Issue #4079 [NEW] (ppicka) - Priority: Normal | Severity: Medium
14:45:35 <bmbouter> +1
14:45:36 <pulpbot> field manifest had null=True even manifest cannot never be null - http://pulp.plan.io/issues/4079
14:45:47 <daviddavis> accept
14:45:53 <dalley> ttereshc, daviddavis also re the last issue (wasn't paying enough attention), I think the last_override_config doesn't show *anything* anymore because it was a security issue and a way to see creds used for a one-time op
14:45:59 <jortel> accept
14:46:06 <dawalker> !propose accdept
14:46:06 <pulpbot> dawalker: Error: "propose" is not a valid command.
14:46:09 <dawalker> #idea Proposed for #4079: Leave the issue as-is, accepting its current state.
14:46:09 <dawalker> !propose accept
14:46:10 <pulpbot> dawalker: Proposed for #4079: Leave the issue as-is, accepting its current state.
14:46:19 <ttereshc> dalley, I think we excluded sensitive info only
14:46:29 <ttereshc> dalley, but I might recall it wrongly
14:46:29 <daviddavis> dalley: I think this is true--unless somewhere else in the code is explicitly writing to it before it gets passed back from the API
14:46:34 <dalley> my understanding was that we made it always return {} but I could also be wrong
14:46:44 <daviddavis> yea, it gets set to {}
14:46:45 <bmbouter> yes
14:47:05 <daviddavis> https://github.com/pulp/pulp/pull/3513
14:47:22 <dawalker> Ok, just making sure--we're good with convert to story on 4077, and we're good with accepting as is 4079?
14:47:31 <ttereshc> +1 to accept 4079
14:47:36 <daviddavis> +1
14:47:41 <dawalker> #agreed Leave the issue as-is, accepting its current state.
14:47:41 <dawalker> !accept
14:47:41 <pulpbot> dawalker: Current proposal accepted: Leave the issue as-is, accepting its current state.
14:47:42 <pulpbot> dawalker: 1 issues left to triage: 4080
14:47:42 <dawalker> #topic Licensing Options fo Plugin Writers - http://pulp.plan.io/issues/4080
14:47:43 <pulpbot> Issue #4080 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:47:44 <pulpbot> Licensing Options fo Plugin Writers - http://pulp.plan.io/issues/4080
14:47:44 <bmbouter> +1
14:48:10 <bmbouter> I asked legal for comment on this, probably skip for now
14:48:17 <ttereshc> +1
14:48:21 <ttereshc> ty
14:48:23 <dawalker> !propose skip
14:48:23 <dawalker> #idea Proposed for #4080: Skip this issue for this triage session.
14:48:23 <pulpbot> dawalker: Proposed for #4080: Skip this issue for this triage session.
14:48:35 <daviddavis> +1
14:48:42 <dawalker> !accept
14:48:42 <dawalker> #agreed Skip this issue for this triage session.
14:48:42 <pulpbot> dawalker: Current proposal accepted: Skip this issue for this triage session.
14:48:43 <pulpbot> dawalker: No issues to triage.
14:48:45 <ttereshc> re Last override config doesn't show force_full - http://pulp.plan.io/issues/4076
14:48:54 <ttereshc> should we make it more general then?
14:49:06 <bmbouter> re 4077 (removal of custom user object) this PR is ready for review, it works https://github.com/pulp/pulp/pull/3711
14:49:07 <ttereshc> add all non-sensetive info back?
14:49:31 <ttereshc> *non-sensitive
14:49:38 <daviddavis> we should probably open a separate bug as force_full isn't being set in the database
14:49:44 <daviddavis> but yea, I think you're right
14:50:11 <daviddavis> my thought is that even if we add the non-sensitive info back, force_full won't display properly
14:50:16 <dalley> ttereshc, I agree it should be more general
14:50:36 <ttereshc> daviddavis, I see
14:50:38 <dalley> daviddavis, it's not being set in the db?
14:50:42 <daviddavis> dalley: no
14:50:54 <dalley> oh, then that is a separate issue
14:51:08 <dalley> didn't know that
14:51:30 <dawalker> Is it ok to let it stand at convert to story, end triage, and continue any discussion of opening a possible separate issue?
14:51:40 <daviddavis> dawalker: yes
14:51:43 <dawalker> !end
14:51:43 <dawalker> #endmeeting