15:32:17 <dawalker> #startmeeting Pulp Triage 2019-01-11
15:32:17 <dawalker> #info dawalker has joined triage
15:32:18 <pulpbot> Meeting started Fri Jan 11 15:32:17 2019 UTC and is due to finish in 60 minutes.  The chair is dawalker. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:32:18 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:32:18 <pulpbot> The meeting name has been set to 'pulp_triage_2019_01_11'
15:32:18 <pulpbot> dawalker: dawalker has joined triage
15:32:46 <ttereshc> !here
15:32:46 <ttereshc> #info ttereshc has joined triage
15:32:47 <pulpbot> ttereshc: ttereshc has joined triage
15:32:50 <ipanova> #info ipanova has joined triage
15:32:50 <ipanova> !here
15:32:50 <pulpbot> ipanova: ipanova has joined triage
15:32:58 <bmbouter> !here
15:32:58 <bmbouter> #info bmbouter has joined triage
15:32:59 <pulpbot> bmbouter: bmbouter has joined triage
15:33:06 <asmacdo> #info asmacdo has joined triage
15:33:06 <asmacdo> !here
15:33:07 <pulpbot> asmacdo: asmacdo has joined triage
15:33:11 <dkliban> !here
15:33:11 <dkliban> #info dkliban has joined triage
15:33:12 <pulpbot> dkliban: dkliban has joined triage
15:33:59 <dawalker> !next
15:34:01 <pulpbot> dawalker: 7 issues left to triage: 4289, 4303, 4305, 4307, 4308, 4313, 4314
15:34:01 <dawalker> #topic Content delivery breaks if remote is deleted - http://pulp.plan.io/issues/4289
15:34:02 <pulpbot> Issue #4289 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:34:03 <pulpbot> Content delivery breaks if remote is deleted - http://pulp.plan.io/issues/4289
15:34:13 <dalley> !here
15:34:13 <dalley> #info dalley has joined triage
15:34:14 <pulpbot> dalley: dalley has joined triage
15:34:18 <dawalker> bmbouter ^
15:34:25 <dawalker> did you speak with gmbnomis?
15:34:28 <ttereshc> heh I read it as CDT breaks :)
15:34:33 <dkliban> lol
15:34:40 <dawalker> :)
15:34:56 <bmbouter> skip one more time please
15:34:58 <ipanova> ttereshc: i read it like this for the past 3 triages :d
15:35:23 <dawalker> I see jortel added a comment
15:35:32 <jortel> #info jortel has joined triage
15:35:32 <jortel> !here
15:35:32 <pulpbot> jortel: jortel has joined triage
15:35:36 <dawalker> #idea Proposed for #4289: Skip this issue for this triage session.
15:35:36 <dawalker> !propose skip
15:35:37 <pulpbot> dawalker: Proposed for #4289: Skip this issue for this triage session.
15:35:48 <bmbouter> I know but we haven't had the time so what else could we do
15:36:19 <asmacdo> skip is ok with me, bmbouter should this have RC blocker tag?
15:36:23 <dawalker> been a busy week :)
15:36:52 <bmbouter> I think the tag should stay because it would be significant for correctness to not have it
15:37:12 <asmacdo> it doesnt have rc blocker tag
15:37:18 <asmacdo> i was suggesting we add it
15:37:19 <bmbouter> ttereshc: I am not honoring what I said I would do though. I keep saying I'm going to take action and I haven't so I want to also acknowledge that
15:37:31 <bmbouter> +1 to the blocker tag for this issue
15:37:40 <jortel> +1 blocker
15:37:49 <asmacdo> !propose other skip and add rc blocker tag
15:37:49 <asmacdo> #idea Proposed for #4289: skip and add rc blocker tag
15:37:50 <pulpbot> asmacdo: Proposed for #4289: skip and add rc blocker tag
15:38:01 <dawalker> +1
15:38:05 <dkliban> +1
15:38:15 <dawalker> !accept
15:38:15 <dawalker> #agreed skip and add rc blocker tag
15:38:15 <pulpbot> dawalker: Current proposal accepted: skip and add rc blocker tag
15:38:16 <dawalker> #topic Pulp upgrade from 2.7 to 2.17 - http://pulp.plan.io/issues/4303
15:38:17 <pulpbot> dawalker: 6 issues left to triage: 4303, 4305, 4307, 4308, 4313, 4314
15:38:18 <pulpbot> Issue #4303 [NEW] (unassigned) - Priority: Normal | Severity: High
15:38:19 <pulpbot> Pulp upgrade from 2.7 to 2.17 - http://pulp.plan.io/issues/4303
15:40:03 <dkliban> let's skip and i'll leave a question for the user
15:40:10 <asmacdo> +1
15:40:14 <dkliban> i don't think thee is a bug here
15:40:26 <dawalker> agreed
15:40:29 <dawalker> !propose skip
15:40:29 <dawalker> #idea Proposed for #4303: Skip this issue for this triage session.
15:40:29 <pulpbot> dawalker: Proposed for #4303: Skip this issue for this triage session.
15:40:33 <ttereshc> +1
15:40:41 <ipanova> +1
15:40:50 <dawalker> #agreed Skip this issue for this triage session.
15:40:50 <dawalker> !accept
15:40:50 <pulpbot> dawalker: Current proposal accepted: Skip this issue for this triage session.
15:40:52 <dawalker> #topic Issue #4303:<Pulp upgrade from 2.7 to 2.17> - http://pulp.plan.io/issues/4305
15:40:52 <pulpbot> dawalker: 5 issues left to triage: 4305, 4307, 4308, 4313, 4314
15:40:53 <pulpbot> Issue #4305 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:40:54 <pulpbot> Issue #4303:<Pulp upgrade from 2.7 to 2.17> - http://pulp.plan.io/issues/4305
15:41:00 <dkliban> duplicate of previous one
15:41:17 <asmacdo> +1
15:41:33 <dalley> +1
15:41:37 <dawalker> !propose skip
15:41:37 <dawalker> #idea Proposed for #4305: Skip this issue for this triage session.
15:41:38 <pulpbot> dawalker: Proposed for #4305: Skip this issue for this triage session.
15:41:39 <jortel> +1
15:41:45 <asmacdo> not skip
15:41:47 <dawalker> or should we close as duplicate
15:41:50 <dawalker> ok
15:41:51 <asmacdo> #idea Proposed for #4305: close as dupe
15:41:51 <asmacdo> !propose other close as dupe
15:41:51 <pulpbot> asmacdo: Proposed for #4305: close as dupe
15:41:57 <dawalker> +1
15:42:04 <ipanova> close as dupe +1
15:42:06 <ttereshc> +1
15:42:08 <dawalker> cleaner that way
15:42:11 <dawalker> #agreed close as dupe
15:42:11 <dawalker> !accept
15:42:12 <pulpbot> dawalker: Current proposal accepted: close as dupe
15:42:14 <dawalker> #topic Schema shows pulp_file content endpoints instead of all pulp api endpoints - http://pulp.plan.io/issues/4307
15:42:14 <pulpbot> dawalker: 4 issues left to triage: 4307, 4308, 4313, 4314
15:42:15 <pulpbot> Issue #4307 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:42:16 <pulpbot> Schema shows pulp_file content endpoints instead of all pulp api endpoints - http://pulp.plan.io/issues/4307
15:43:36 <ttereshc> it would be helpful if someone can test it
15:43:43 <ttereshc> try to reproduce it I meant
15:44:07 <ttereshc> I have it on my system but I'm on pulp2 now, I didn't get a chance to retest this one
15:44:21 <ttereshc> if it's a bug than it's a blocker in my opinion
15:44:27 <asmacdo> ooh:/pulp/api/v3/{_id}/ being the viewset for FileContent seems wrong too
15:44:43 <ttereshc> asmacdo, do you have it as well?
15:45:18 <asmacdo> ttereshc: nope i see pulp schema
15:45:36 <asmacdo> but i have pulp_file and pulp_docker installed
15:45:56 <ttereshc> asmacdo, do you have a fresh checkout
15:46:08 <asmacdo> yesterday fresh
15:46:19 <asmacdo> oh interesting, i don't see any pulp_file schema though
15:46:20 <ttereshc> let's skip and I'll try with the fresh install
15:46:26 <asmacdo> +1 skip
15:46:28 <dkliban> +1
15:46:31 <dawalker> !propose skip
15:46:31 <dawalker> #idea Proposed for #4307: Skip this issue for this triage session.
15:46:31 <pulpbot> dawalker: Proposed for #4307: Skip this issue for this triage session.
15:46:42 <dawalker> +1
15:46:48 <dawalker> #agreed Skip this issue for this triage session.
15:46:48 <dawalker> !accept
15:46:49 <pulpbot> dawalker: Current proposal accepted: Skip this issue for this triage session.
15:46:50 <pulpbot> dawalker: 3 issues left to triage: 4308, 4313, 4314
15:46:50 <dawalker> #topic Stages should not blindly trust the correct state of DeclarativeContent - http://pulp.plan.io/issues/4308
15:46:51 <pulpbot> Issue #4308 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:46:52 <pulpbot> Stages should not blindly trust the correct state of DeclarativeContent - http://pulp.plan.io/issues/4308
15:46:56 <bmbouter> ttereshc: I'm getting a fresh install just now I can test
15:47:25 <ttereshc> bmbouter, perfect, thank you. Let us know which plugins you have and if you see schema for everything
15:47:40 <bmbouter> will do
15:48:20 <bmbouter> this is an interesting file we should post some discussion on it
15:48:29 <bmbouter> strong validation would be good
15:48:36 <ttereshc> +1 to discuss
15:48:48 <ipanova> +1
15:48:48 <bmbouter> there are some cases to talk through because it also could stop some use cases
15:48:49 <ttereshc> sounds like a story as well
15:48:54 <bmbouter> agreed
15:49:04 <bmbouter> +1 convert to story and invite discussion maybe through pulp-dev?
15:49:16 <bmbouter> invite to discuss on the issue
15:49:27 <asmacdo> sure-- ill send an email to pulp-dev
15:49:28 <dawalker> #idea Proposed for #4308: convert to story and discuss
15:49:28 <dawalker> !propose other convert to story and discuss
15:49:28 <pulpbot> dawalker: Proposed for #4308: convert to story and discuss
15:49:33 <ttereshc> +!
15:49:35 <ttereshc> +1
15:49:53 <dawalker> #agreed convert to story and discuss
15:49:53 <dawalker> !accept
15:49:53 <pulpbot> dawalker: Current proposal accepted: convert to story and discuss
15:49:54 <dawalker> #topic Username is mutable and can be updated/changed via REST API - http://pulp.plan.io/issues/4313
15:49:55 <pulpbot> dawalker: 2 issues left to triage: 4313, 4314
15:49:56 <pulpbot> Issue #4313 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:49:57 <pulpbot> Username is mutable and can be updated/changed via REST API - http://pulp.plan.io/issues/4313
15:50:50 <dawalker> accept or do we want more discussion?
15:51:04 <dkliban> bmbouter: ttereshc  was asking about this earlier and i did not think we intended for user names to be mutable ... though i am up for debate on that
15:51:14 <asmacdo> #idea Proposed for #4313: accept +easy fix +rc_blocker + sprint
15:51:14 <asmacdo> !propose other accept +easy fix +rc_blocker + sprint
15:51:14 <pulpbot> asmacdo: Proposed for #4313: accept +easy fix +rc_blocker + sprint
15:51:17 <bmbouter> so really crazy idea time I think we shoiuld remove users entirely
15:51:22 <bmbouter> actually a user told me this lol
15:51:22 <dkliban> lol
15:51:26 <ttereshc> :D
15:51:27 <dawalker> I liked ttereshc point that it's easier to go from immutable->mutable than the other way, so perhaps default to this change for now
15:51:49 <dalley> agreed
15:51:49 <bmbouter> but +1 to accept to make it immutable, I need to raise this should we have users at all on pulp-dev separately
15:51:57 <dkliban> sounds good
15:52:00 <dkliban> +1 to accept
15:52:02 <asmacdo> we don't need to completely remove users, we could just remove the Create mixin from the viewset
15:52:15 <dawalker> +1
15:52:16 <asmacdo> that would leave 1 user, the admin
15:52:36 <bmbouter> that sounds good too
15:52:38 <dawalker> #agreed accept +easy fix +rc_blocker + sprint
15:52:38 <dawalker> !accept
15:52:38 <pulpbot> dawalker: Current proposal accepted: accept +easy fix +rc_blocker + sprint
15:52:40 <dawalker> #topic accept_headers should be checked when docker pull is performed by digest - http://pulp.plan.io/issues/4314
15:52:40 <pulpbot> dawalker: 1 issues left to triage: 4314
15:52:41 <pulpbot> Issue #4314 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:52:42 <pulpbot> accept_headers should be checked when docker pull is performed by digest - http://pulp.plan.io/issues/4314
15:52:46 <asmacdo> i guess we could also remove the update mixin so you couldnt s/admin/whateva/
15:53:02 <asmacdo> #idea Proposed for #4314: Leave the issue as-is, accepting its current state.
15:53:02 <asmacdo> !propose accept
15:53:02 <pulpbot> asmacdo: Proposed for #4314: Leave the issue as-is, accepting its current state.
15:53:04 <dkliban> accept this one
15:53:16 <ttereshc> asmacdo, you may want to change password though
15:53:44 <dkliban> ttereshc: no ... everyone gets the same password ... it'll be easier for them to remember
15:54:01 <dkliban> :)
15:54:02 <bmbouter> also write it on a sticky note and put it on the pulp box itself that way we always have it
15:54:10 <dkliban> lol
15:54:11 <ttereshc> (:
15:54:12 <bmbouter> also use my birthday
15:54:16 <dawalker> heh
15:54:22 <ipanova> better :password
15:54:25 <ipanova> as password
15:54:27 <dkliban> lol
15:54:30 <dawalker> yep
15:54:34 <ipanova> !end
15:54:36 <bmbouter> applesandpears
15:54:41 <dalley> hunter2
15:54:42 <dkliban> dawalker: let's accept this docker issue
15:54:44 <ttereshc> +1 to accept the docker issue we are supposed to triage :)
15:54:55 <dawalker> #agreed Leave the issue as-is, accepting its current state.
15:54:55 <dawalker> !accept
15:54:55 <pulpbot> dawalker: Current proposal accepted: Leave the issue as-is, accepting its current state.
15:54:56 <pulpbot> dawalker: No issues to triage.
15:55:01 <dawalker> !end
15:55:01 <dawalker> #endmeeting