14:30:42 <asmacdo> #startmeeting Pulp Triage 2019-04-26
14:30:42 <asmacdo> #info asmacdo has joined triage
14:30:42 <asmacdo> !start
14:30:42 <pulpbot> Meeting started Fri Apr 26 14:30:42 2019 UTC.  The chair is asmacdo. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:30:42 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:30:42 <pulpbot> The meeting name has been set to 'pulp_triage_2019-04-26'
14:30:42 <pulpbot> asmacdo: asmacdo has joined triage
14:30:45 <daviddavis> #info daviddavis has joined triage
14:30:45 <daviddavis> !here
14:30:45 <pulpbot> daviddavis: daviddavis has joined triage
14:30:50 <asmacdo> arg-- not having my cal on my phone is killing me
14:31:03 <daviddavis> why don't you put your cal on your phone?
14:31:23 <asmacdo> it was, but theres all that fancy redhat security required now
14:31:36 <ttereshc> #info ttereshc has joined triage
14:31:36 <ttereshc> !here
14:31:37 <pulpbot> ttereshc: ttereshc has joined triage
14:31:41 <ipanova> #info ipanova has joined triage
14:31:41 <ipanova> !here
14:31:41 <pulpbot> ipanova: ipanova has joined triage
14:31:50 <dalley> #info dalley has joined triage
14:31:50 <dalley> !here
14:31:50 <pulpbot> dalley: dalley has joined triage
14:32:04 <asmacdo> !next
14:32:05 <pulpbot> asmacdo: 7 issues left to triage: 4725, 4726, 4731, 4733, 4734, 4741, 4742
14:32:05 <asmacdo> #topic https://pulp.plan.io/issues/4725
14:32:06 <pulpbot> RM 4725 - bmbouter - POST - Debian lazy sync virt-install fails w/ a 404 error, yet it's on the remote's CDN
14:32:07 <pulpbot> https://pulp.plan.io/issues/4725
14:32:47 <asmacdo> i took a look at this pr but i don't have time to fully understand what was going on
14:32:54 <asmacdo> anyway since there is a PR lets accept
14:32:58 <asmacdo> #idea Proposed for #4725: Leave the issue as-is, accepting its current state.
14:32:58 <asmacdo> !propose accept
14:32:58 <pulpbot> asmacdo: Proposed for #4725: Leave the issue as-is, accepting its current state.
14:33:03 <ttereshc> +1 in POST
14:33:03 <dkliban> #info dkliban has joined triage
14:33:03 <dkliban> !here
14:33:03 <pulpbot> dkliban: dkliban has joined triage
14:33:08 <ipanova> we should accept this
14:33:14 <daviddavis> +1
14:33:14 <dkliban> +1
14:33:23 <asmacdo> #agreed Leave the issue as-is, accepting its current state.
14:33:23 <asmacdo> !accept
14:33:23 <pulpbot> asmacdo: Current proposal accepted: Leave the issue as-is, accepting its current state.
14:33:24 <pulpbot> asmacdo: 6 issues left to triage: 4726, 4731, 4733, 4734, 4741, 4742
14:33:24 <asmacdo> #topic https://pulp.plan.io/issues/4726
14:33:25 <pulpbot> RM 4726 - bmbouter - NEW - Starting Pulp shows errors while all processes start up
14:33:26 <pulpbot> https://pulp.plan.io/issues/4726
14:33:35 <daviddavis> accept
14:33:54 <dkliban> +1
14:33:58 <asmacdo> #idea Proposed for #4726: Leave the issue as-is, accepting its current state.
14:33:58 <asmacdo> !propose accept
14:33:58 <pulpbot> asmacdo: Proposed for #4726: Leave the issue as-is, accepting its current state.
14:34:25 <asmacdo> #agreed Leave the issue as-is, accepting its current state.
14:34:25 <asmacdo> !accept
14:34:25 <pulpbot> asmacdo: Current proposal accepted: Leave the issue as-is, accepting its current state.
14:34:26 <pulpbot> asmacdo: 5 issues left to triage: 4731, 4733, 4734, 4741, 4742
14:34:26 <asmacdo> #topic https://pulp.plan.io/issues/4731
14:34:27 <pulpbot> RM 4731 - kersom - NEW - Order of data in PULP_MANIFEST returned by Pulp is different from feed url
14:34:28 <pulpbot> https://pulp.plan.io/issues/4731
14:34:44 <daviddavis> closed wontfix
14:34:52 <dkliban> this may be a docs issue
14:35:14 <ttereshc> dkliban, for every plugin then
14:35:17 <dkliban> we want to make it clear in the docs that pulp does not preserve the metadata and generates it new
14:35:21 <dkliban> yes, for sure
14:35:29 <dkliban> so in this case it's for the file plugin
14:35:51 <kersom> a note about this in the docs it could be helpful
14:35:58 <ttereshc> I'm not sure where the balance is
14:36:14 <ttereshc> if we put too much info in the docs, no one will read it
14:36:14 <ipanova> i would close this
14:36:15 <ttereshc> imo
14:36:33 <daviddavis> kersom will but I agree
14:36:45 <ttereshc> +1 to close it
14:36:49 <daviddavis> +1 from me
14:36:59 <ipanova> we mention that we generate metadata but  that does not imply that we do it exactly as it incomes
14:37:10 <kersom> what about the "I agree that the space after commas should be fixed"?
14:37:20 <kersom> in the comments
14:37:26 <kersom> https://pulp.plan.io/issues/4731#note-5
14:37:33 <daviddavis> we should open an issue for that
14:37:35 <ipanova> kersom: does this impact funcionality?
14:37:39 <kersom> no
14:37:57 <kersom> I was not sure if it was a bug, I just would like to make you aware of it
14:38:17 <asmacdo> even though looks like we are going to close, i think this was a good thing to write up
14:38:29 <ttereshc> maybe we should have optionally an extended version of docs  - "version for developers and QE"
14:38:29 <asmacdo> at least now, if others are surprised they will see  this
14:38:39 <ipanova> kersom: https://en.wikipedia.org/wiki/Comma-separated_values basic rules section
14:39:03 <asmacdo> i think this is actually an isolated problem
14:39:13 <asmacdo> all other plugins implement a previously existing API
14:39:20 <kersom> ipanova, thanks
14:39:34 <asmacdo> pulp_file makes up its own API, which probably ought to be documented
14:39:51 <dkliban> yep
14:39:58 <asmacdo> a section in the docs about PULP_MANIFEST, the format of it, the lack of order of it, etc
14:40:03 <dkliban> asmacdo: that is a good observation
14:40:05 <asmacdo> i think we should accept this
14:40:09 <dkliban> +1
14:40:25 <asmacdo> #idea Proposed for #4731: Leave the issue as-is, accepting its current state.
14:40:25 <asmacdo> !propose accept
14:40:25 <pulpbot> asmacdo: Proposed for #4731: Leave the issue as-is, accepting its current state.
14:40:43 <asmacdo> ill add that stuff as a comment on this
14:40:48 <dkliban> asmacdo: thank you
14:40:59 <ttereshc> +1
14:41:02 <asmacdo> #agreed Leave the issue as-is, accepting its current state.
14:41:02 <asmacdo> !accept
14:41:02 <pulpbot> asmacdo: Current proposal accepted: Leave the issue as-is, accepting its current state.
14:41:03 <pulpbot> asmacdo: 4 issues left to triage: 4733, 4734, 4741, 4742
14:41:04 <asmacdo> #topic https://pulp.plan.io/issues/4733
14:41:04 <pulpbot> RM 4733 - bmbouter - NEW - Pulp configured with S3 doesn't give users the Content-Disposition header
14:41:06 <pulpbot> https://pulp.plan.io/issues/4733
14:41:32 <dkliban> accept
14:41:49 <dkliban> we have the same problem with docker
14:41:53 <ttereshc> #idea Proposed for #4733: Leave the issue as-is, accepting its current state.
14:41:53 <ttereshc> !propose accept
14:41:53 <pulpbot> ttereshc: Proposed for #4733: Leave the issue as-is, accepting its current state.
14:42:11 <daviddavis> +1
14:42:17 <ipanova> +1
14:43:12 <asmacdo> #agreed Leave the issue as-is, accepting its current state.
14:43:12 <asmacdo> !accept
14:43:12 <pulpbot> asmacdo: Current proposal accepted: Leave the issue as-is, accepting its current state.
14:43:13 <asmacdo> #topic https://pulp.plan.io/issues/4734
14:43:13 <pulpbot> asmacdo: 3 issues left to triage: 4734, 4741, 4742
14:43:14 <pulpbot> RM 4734 - bmbouter - NEW - Downloading content with virt-install causes exceptions in the pulp-content app
14:43:15 <pulpbot> https://pulp.plan.io/issues/4734
14:43:28 <dkliban> accept
14:43:42 <asmacdo> is this a pulp_deb issue?
14:43:47 <dkliban> no
14:43:53 <dkliban> we have similar issue with docker pull
14:44:06 <asmacdo> ok
14:44:08 <ipanova> dkliban: do we?
14:44:10 <asmacdo> #idea Proposed for #4734: Leave the issue as-is, accepting its current state.
14:44:10 <asmacdo> !propose accept
14:44:10 <pulpbot> asmacdo: Proposed for #4734: Leave the issue as-is, accepting its current state.
14:44:46 <dkliban> ipanova: yes, it's not quite the same, but when the client tries to connect over ssl the pulp-content-app logs a traceback
14:44:55 <ipanova> dkliban: gotcha
14:45:04 <asmacdo> shoudl we add this to the sprint?
14:45:07 <dkliban> yeah
14:45:17 <asmacdo> and 3.0 milestone
14:45:33 <asmacdo> #idea Proposed for #4734: accept, add to sprint, add 3.0 milestone
14:45:33 <asmacdo> !propose other accept, add to sprint, add 3.0 milestone
14:45:34 <pulpbot> asmacdo: Proposed for #4734: accept, add to sprint, add 3.0 milestone
14:45:38 <dkliban> +1
14:46:04 <asmacdo> #agreed accept, add to sprint, add 3.0 milestone
14:46:04 <asmacdo> !accept
14:46:04 <pulpbot> asmacdo: Current proposal accepted: accept, add to sprint, add 3.0 milestone
14:46:05 <asmacdo> #topic https://pulp.plan.io/issues/4741
14:46:05 <pulpbot> asmacdo: 2 issues left to triage: 4741, 4742
14:46:06 <pulpbot> RM 4741 - ttereshc - NEW - Migration of modular content fails for very old Fedora repos (upgrade from <=2.16 to 2.17+)
14:46:07 <pulpbot> https://pulp.plan.io/issues/4741
14:46:10 <daviddavis> skip
14:46:24 <asmacdo> !skip
14:46:25 <pulpbot> asmacdo: 1 issues left to triage: 4742
14:46:25 <asmacdo> #topic https://pulp.plan.io/issues/4742
14:46:26 <pulpbot> RM 4742 - ipanova@redhat.com - NEW - /var/cache/pulp is not cleaned after task succeds
14:46:27 <pulpbot> https://pulp.plan.io/issues/4742
14:46:31 <daviddavis> is this pulp 2?
14:47:03 <ipanova> yes sorry forgot to add the tag
14:47:18 <daviddavis> cool
14:47:26 <asmacdo> #idea Proposed for #4742: accept, add pulp2 tag
14:47:26 <asmacdo> !propose other accept, add pulp2 tag
14:47:26 <pulpbot> asmacdo: Proposed for #4742: accept, add pulp2 tag
14:47:26 <daviddavis> accept? accept and add to sprint?
14:47:29 <ipanova> this is a long story ticket, but i cannot reproduce this myself even i fail the repo sync task cache gets cleaned
14:47:37 <daviddavis> weird
14:47:38 <ipanova> but customer seems to be very upset
14:47:47 <daviddavis> uh oh
14:48:06 <dkliban> accept and add to sprin
14:48:09 <daviddavis> "Customer have multiple capsules and this is happening only on one of them.
14:48:12 <ipanova> i attached the bz, maybe we should wait for pm score, dunno
14:48:20 <ipanova> daviddavis: yes exactly
14:48:23 <ttereshc> it sounds very familiar
14:48:37 <ttereshc> I think we had a bug report about not cleaning isos
14:48:45 <dkliban> yeah we did
14:49:01 <asmacdo> #idea Proposed for #4742: accept, +pulp2 +add to sprint
14:49:01 <asmacdo> !propose other accept, +pulp2 +add to sprint
14:49:01 <pulpbot> asmacdo: Proposed for #4742: accept, +pulp2 +add to sprint
14:49:04 <dkliban> i'll take a look at this one next week
14:49:30 <asmacdo> #agreed accept, +pulp2 +add to sprint
14:49:30 <asmacdo> !accept
14:49:30 <pulpbot> asmacdo: Current proposal accepted: accept, +pulp2 +add to sprint
14:49:31 <pulpbot> asmacdo: No issues to triage.
14:49:39 <ttereshc> let's not add to the sprint and wait for the pmscore
14:49:39 <mikedep333> #info mikedep333 has joined triage
14:49:39 <mikedep333> !here
14:49:39 <pulpbot> mikedep333: mikedep333 has joined triage
14:49:45 <dkliban> sure
14:50:00 <asmacdo> !issue 4742
14:50:01 <asmacdo> #topic https://pulp.plan.io/issues/4742
14:50:01 <pulpbot> RM 4742 - ipanova@redhat.com - NEW - /var/cache/pulp is not cleaned after task succeds
14:50:02 <pulpbot> https://pulp.plan.io/issues/4742
14:50:14 <asmacdo> !propose accept +pulp2, wait on pm
14:50:14 <pulpbot> asmacdo: propose accept Propose accepting the current issue in its current state.
14:50:31 <asmacdo> !accept
14:50:31 <pulpbot> asmacdo: No action proposed, nothing to accept.
14:50:37 <asmacdo> open floor anyone?
14:51:34 <ipanova> dkliban: ttereshc i will add a comment with my testing and that i could not reproduce this
14:52:05 <asmacdo> i shared this with pulp_python yesterday, but i bet all yall will get a kick https://xkcd.com/2140/
14:52:10 <dkliban> ipanova: thank you
14:52:40 <asmacdo> #endmeeting
14:52:40 <asmacdo> !end