14:30:41 <asmacdo> #startmeeting Pulp Triage 2019-06-25
14:30:41 <asmacdo> #info asmacdo has joined triage
14:30:41 <asmacdo> !start
14:30:41 <pulpbot> Meeting started Tue Jun 25 14:30:41 2019 UTC. The chair is asmacdo. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:30:41 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:30:41 <pulpbot> The meeting name has been set to 'pulp_triage_2019-06-25'
14:30:41 <pulpbot> asmacdo: asmacdo has joined triage
14:30:42 <ppicka> !here
14:30:42 <ppicka> #info ppicka has joined triage
14:30:43 <pulpbot> ppicka: ppicka has joined triage
14:30:44 <daviddavis> #info daviddavis has joined triage
14:30:44 <daviddavis> !here
14:30:44 <pulpbot> daviddavis: daviddavis has joined triage
14:30:47 <bmbouter> asmacdo: the names I made are epic confusing. more after triage
14:30:50 <bmbouter> #info bmbouter has joined triage
14:30:50 <bmbouter> !here
14:30:50 <pulpbot> bmbouter: bmbouter has joined triage
14:30:52 <ttereshc> #info ttereshc has joined triage
14:30:52 <ttereshc> !here
14:30:52 <pulpbot> ttereshc: ttereshc has joined triage
14:31:03 <dawalker> #info dawalker has joined triage
14:31:03 <dawalker> !here
14:31:04 <pulpbot> dawalker: dawalker has joined triage
14:31:25 <asmacdo> #info asmacdo has joined triage
14:31:25 <asmacdo> !start
14:31:25 <pulpbot> asmacdo: Error: Can't start another meeting, one is in progress.
14:31:26 <pulpbot> asmacdo: asmacdo has joined triage
14:31:30 <asmacdo> !next
14:31:31 <pulpbot> asmacdo: 20 issues left to triage: 4939, 4947, 4959, 4970, 4979, 4989, 4990, 4992, 4994, 4996, 4998, 5001, 5002, 5005, 5006, 5008, 5009, 5010, 5012, 5028
14:31:31 <asmacdo> #topic https://pulp.plan.io/issues/4939
14:31:32 <pulpbot> RM 4939 - kersom - NEW - Docs - Collections upload workflows is using role endpoints
14:31:33 <pulpbot> https://pulp.plan.io/issues/4939
14:31:36 <daviddavis> skip
14:31:40 <asmacdo> !skip
14:31:41 <pulpbot> asmacdo: 19 issues left to triage: 4947, 4959, 4970, 4979, 4989, 4990, 4992, 4994, 4996, 4998, 5001, 5002, 5005, 5006, 5008, 5009, 5010, 5012, 5028
14:31:41 <asmacdo> #topic https://pulp.plan.io/issues/4947
14:31:42 <pulpbot> RM 4947 - amacdona@redhat.com - NEW - As a user I can add tags to a repository by name.
14:31:43 <pulpbot> https://pulp.plan.io/issues/4947
14:31:46 <daviddavis> skip
14:31:48 <asmacdo> !skip
14:31:49 <pulpbot> asmacdo: 18 issues left to triage: 4959, 4970, 4979, 4989, 4990, 4992, 4994, 4996, 4998, 5001, 5002, 5005, 5006, 5008, 5009, 5010, 5012, 5028
14:31:49 <asmacdo> #topic https://pulp.plan.io/issues/4959
14:31:50 <pulpbot> RM 4959 - amacdona@redhat.com - NEW - Do not log that a download fails with 401 (INFO) unless it fails again after token refresh
14:31:51 <pulpbot> https://pulp.plan.io/issues/4959
14:32:00 <bmbouter> this is so confusing
14:32:08 <daviddavis> skip
14:32:15 <asmacdo> yeah pulpbot is struggling
14:32:24 <asmacdo> dkliban: lets chat after
14:32:27 <asmacdo> !skip
14:32:28 <pulpbot> asmacdo: 17 issues left to triage: 4970, 4979, 4989, 4990, 4992, 4994, 4996, 4998, 5001, 5002, 5005, 5006, 5008, 5009, 5010, 5012, 5028
14:32:28 <asmacdo> #topic https://pulp.plan.io/issues/4970
14:32:29 <pulpbot> RM 4970 - kersom - NEW - Collection - RepositoryDistribution does not provide url to consume to cosume content from Pulp
14:32:30 <pulpbot> https://pulp.plan.io/issues/4970
14:32:37 <daviddavis> one solution is to switch queries
14:32:44 <daviddavis> skip
14:32:45 <asmacdo> we did, but it didnt take?
14:32:46 <bmbouter> daviddavis: that sounds so easy
14:32:48 <asmacdo> !skip
14:32:49 <pulpbot> asmacdo: 16 issues left to triage: 4979, 4989, 4990, 4992, 4994, 4996, 4998, 5001, 5002, 5005, 5006, 5008, 5009, 5010, 5012, 5028
14:32:49 <asmacdo> #topic https://pulp.plan.io/issues/4979
14:32:50 <pulpbot> RM 4979 - dgoetz - NEW - Katello complains during reposync about being unable to update existing errate
14:32:51 <pulpbot> https://pulp.plan.io/issues/4979
14:33:04 <asmacdo> !skip
14:33:05 <pulpbot> asmacdo: 15 issues left to triage: 4989, 4990, 4992, 4994, 4996, 4998, 5001, 5002, 5005, 5006, 5008, 5009, 5010, 5012, 5028
14:33:05 <asmacdo> #topic https://pulp.plan.io/issues/4989
14:33:06 <pulpbot> RM 4989 - mdellweg - ASSIGNED - Api bindings for python use unnecessary verbose action names
14:33:07 <pulpbot> https://pulp.plan.io/issues/4989
14:33:15 <daviddavis> dkliban: add this to the sprint?
14:33:30 <daviddavis> I think this work is done
14:33:34 <asmacdo> this has an associated revision, MODIFIED?
14:33:41 <bmbouter> I think so also
14:33:47 <daviddavis> let's ask dkliban to update it
14:33:48 <dalley> #info dalley has joined triage
14:33:48 <dalley> !here
14:33:48 <pulpbot> dalley: dalley has joined triage
14:33:53 <bmbouter> +1
14:33:58 <ggainey> and add to sprint, yeah?
14:34:04 <daviddavis> +1
14:34:13 <asmacdo> #idea Proposed for #4989: dkliban will update, and add to sprint
14:34:13 <asmacdo> !propose other dkliban will update, and add to sprint
14:34:13 <pulpbot> asmacdo: Proposed for #4989: dkliban will update, and add to sprint
14:34:29 <asmacdo> #agreed dkliban will update, and add to sprint
14:34:29 <asmacdo> !accept
14:34:29 <pulpbot> asmacdo: Current proposal accepted: dkliban will update, and add to sprint
14:34:30 <pulpbot> asmacdo: 14 issues left to triage: 4990, 4992, 4994, 4996, 4998, 5001, 5002, 5005, 5006, 5008, 5009, 5010, 5012, 5028
14:34:30 <asmacdo> #topic https://pulp.plan.io/issues/4990
14:34:31 <pulpbot> RM 4990 - kersom - NEW - Core's serializer should only validate when policy='immediate' (the default)
14:34:32 <pulpbot> https://pulp.plan.io/issues/4990
14:34:39 <daviddavis> this is on the sprint
14:34:51 <ggainey> yupper
14:34:57 <asmacdo> #idea Proposed for #4990: Leave the issue as-is, accepting its current state.
14:34:57 <asmacdo> !propose accept
14:34:57 <pulpbot> asmacdo: Proposed for #4990: Leave the issue as-is, accepting its current state.
14:35:43 <bherring> #info bherring has joined triage
14:35:43 <bherring> !here
14:35:43 <pulpbot> bherring: bherring has joined triage
14:35:50 <asmacdo> #agreed Leave the issue as-is, accepting its current state.
14:35:50 <asmacdo> !accept
14:35:50 <pulpbot> asmacdo: Current proposal accepted: Leave the issue as-is, accepting its current state.
14:35:51 <pulpbot> asmacdo: 13 issues left to triage: 4992, 4994, 4996, 4998, 5001, 5002, 5005, 5006, 5008, 5009, 5010, 5012, 5028
14:35:52 <asmacdo> #topic https://pulp.plan.io/issues/4992
14:35:52 <pulpbot> RM 4992 - jsherril@redhat.com - NEW - 'fields' parameter is not available in api docs/bindings
14:35:53 <pulpbot> https://pulp.plan.io/issues/4992
14:36:27 <bmbouter> this will be an issue w/ pulp's openAPI schema
14:36:36 <daviddavis> yea
14:36:54 <daviddavis> there's no P tag on it so hard to know the priority
14:36:54 <ttereshc> yeah, I thought we triaged this one
14:36:57 <daviddavis> me too
14:37:20 <bmbouter> I'm asking katello devs to set them so we can bring that up at tomorrow's integration meeting also
14:37:27 <daviddavis> +1
14:37:28 <bmbouter> s/them/the P tags/
14:37:29 <ggainey> freenode-#pulp-dev.log:Jun 21
10:40:19 <pulpbot> ttereshc: Proposed for #4992: accept, add to sprint, add bindings tag
14:37:32 <dkliban> this is a P1
14:37:38 <ttereshc> heh
14:37:49 <jsherrill> sorry, i will set that, for that one its a p3 i'd say
14:38:03 <daviddavis> accept and add to 3.0 milestone then
14:38:08 <ggainey> +1
14:38:15 <bmbouter> +1
14:38:17 <ttereshc> and + bindings tag
14:38:20 <daviddavis> +1
14:38:25 <asmacdo> #idea Proposed for #4992: accept, add to sprint, +3.0 miletone, +bindings tag, +p3, remind austin to hit save this time
14:38:25 <asmacdo> !propose other accept, add to sprint, +3.0 miletone, +bindings tag, +p3, remind austin to hit save this time
14:38:25 <pulpbot> asmacdo: Proposed for #4992: accept, add to sprint, +3.0 miletone, +bindings tag, +p3, remind austin to hit save this time
14:38:31 <ggainey> heh
14:38:32 <daviddavis> heh
14:38:45 <ggainey> asmacdo: hit save :)
14:38:49 <dawalker> +1
14:39:11 <asmacdo> #agreed accept, add to sprint, +3.0 miletone, +bindings tag, +p3, remind austin to hit save this time
14:39:11 <asmacdo> !accept
14:39:11 <pulpbot> asmacdo: Current proposal accepted: accept, add to sprint, +3.0 miletone, +bindings tag, +p3, remind austin to hit save this time
14:39:12 <pulpbot> asmacdo: 12 issues left to triage: 4994, 4996, 4998, 5001, 5002, 5005, 5006, 5008, 5009, 5010, 5012, 5028
14:39:12 <asmacdo> #topic https://pulp.plan.io/issues/4994
14:39:13 <pulpbot> RM 4994 - iballou - POST - Combine manifest-list-tag and manifest-tag models in Docker plugin
14:39:14 <pulpbot> https://pulp.plan.io/issues/4994
14:39:18 <daviddavis> skip
14:39:22 <asmacdo> !skip
14:39:23 <pulpbot> asmacdo: 11 issues left to triage: 4996, 4998, 5001, 5002, 5005, 5006, 5008, 5009, 5010, 5012, 5028
14:39:23 <asmacdo> #topic https://pulp.plan.io/issues/4996
14:39:24 <pulpbot> RM 4996 - sajha - NEW - Asible collection remote doesn't handle trailing / in sync url
14:39:25 <pulpbot> https://pulp.plan.io/issues/4996
14:39:28 <daviddavis> skip
14:39:35 <daviddavis> man we got to get this fixed
14:39:40 <asmacdo> !skip
14:39:41 <pulpbot> asmacdo: 10 issues left to triage: 4998, 5001, 5002, 5005, 5006, 5008, 5009, 5010, 5012, 5028
14:39:41 <asmacdo> #topic https://pulp.plan.io/issues/4998
14:39:42 <pulpbot> RM 4998 - daviddavis - NEW - Artifact size is limited to 2 GB
14:39:43 <pulpbot> https://pulp.plan.io/issues/4998
14:40:07 <daviddavis> we discussed this before but I don't remember what the outcome was? did we triage it already?
14:40:08 <asmacdo> hmm did i miss this one too?
14:40:15 <daviddavis> maybe I was suppose to triage it
14:40:24 <daviddavis> I'll handle it
14:40:31 <daviddavis> it's a one line fix
14:40:39 <ggainey> we talked about it on the 21st
14:40:41 <ggainey> yeah
14:40:59 <ggainey> Integer to BigInteger, yeah?
14:41:06 <asmacdo> #idea Proposed for #4998: Leave the issue as-is, accepting its current state.
14:41:06 <asmacdo> !propose accept
14:41:06 <pulpbot> asmacdo: Proposed for #4998: Leave the issue as-is, accepting its current state.
14:41:08 <daviddavis> yea
14:41:13 <dawalker> I tried to keep a list of AI's after each triage and follow up with that person before the next triage to make sure they remembered.
14:41:38 <daviddavis> that's a good idea
14:41:52 <asmacdo> keeping up with the wrong query is distracting me
14:41:58 <daviddavis> ha yea
14:41:59 <ttereshc> +1 to accept
14:42:03 <ggainey> +1
14:42:08 <asmacdo> #agreed Leave the issue as-is, accepting its current state.
14:42:08 <asmacdo> !accept
14:42:08 <pulpbot> asmacdo: Current proposal accepted: Leave the issue as-is, accepting its current state.
14:42:10 <asmacdo> #topic https://pulp.plan.io/issues/5001
14:42:10 <pulpbot> asmacdo: 9 issues left to triage: 5001, 5002, 5005, 5006, 5008, 5009, 5010, 5012, 5028
14:42:12 <pulpbot> RM 5001 - sajha - NEW - Provide content_ansible_collection_read method for ansible collections
14:42:12 <ggainey> dawalker++
14:42:13 <pulpbot> https://pulp.plan.io/issues/5001
14:42:14 <pulpbot> ggainey: dawalker's karma is now 41
14:42:26 <daviddavis> skip
14:42:32 <asmacdo> dawalker: pulpbot proposals can be used for that
14:42:38 <asmacdo> !skip
14:42:39 <pulpbot> asmacdo: 8 issues left to triage: 5002, 5005, 5006, 5008, 5009, 5010, 5012, 5028
14:42:40 <asmacdo> #topic https://pulp.plan.io/issues/5002
14:42:40 <pulpbot> RM 5002 - horakmar - NEW - rpm_remote ignores proxy_url
14:42:41 <pulpbot> https://pulp.plan.io/issues/5002
14:42:48 <ttereshc> skip
14:42:54 <dkliban> it's fixe dalready
14:42:57 <dalley> are the rest all plugin issues?
14:43:03 * daviddavis skips to my lou
14:43:11 <asmacdo> !skip
14:43:11 <daviddavis> I think I filed some non-plugin issues
14:43:12 <ttereshc> dkliban, I commented on the one which I was sure that is pulp 3
14:43:12 <asmacdo> #topic https://pulp.plan.io/issues/5005
14:43:13 <pulpbot> asmacdo: 7 issues left to triage: 5005, 5006, 5008, 5009, 5010, 5012, 5028
14:43:14 <pulpbot> RM 5005 - horakmar - NEW - RPM remote sync ignores "proxy_url" settings
14:43:15 <pulpbot> https://pulp.plan.io/issues/5005
14:43:27 <ttereshc> skip
14:43:34 <asmacdo> !skip
14:43:35 <pulpbot> asmacdo: 6 issues left to triage: 5006, 5008, 5009, 5010, 5012, 5028
14:43:36 <asmacdo> #topic https://pulp.plan.io/issues/5006
14:43:36 <pulpbot> RM 5006 - ttereshc - NEW - A publication can't be created immediately after kicking off a sync task
14:43:37 <pulpbot> https://pulp.plan.io/issues/5006
14:43:47 <dawalker> daviddavis, so help me if I have skip to my lou stuck in my head the rest of the day...
14:43:57 <daviddavis> lol
14:44:04 <asmacdo> !skiptomylou
14:44:04 <pulpbot> asmacdo: Error: "skiptomylou" is not a valid command.
14:44:07 <asmacdo> !skip
14:44:08 <pulpbot> asmacdo: 5 issues left to triage: 5008, 5009, 5010, 5012, 5028
14:44:08 <asmacdo> #topic https://pulp.plan.io/issues/5008
14:44:09 <pulpbot> RM 5008 - ttereshc - NEW - No way to enforce content specific uniqueness constaints in a repo version
14:44:09 <ggainey> dawalker: we'll all just call daviddavis "Mah Darlin'" :)
14:44:10 <pulpbot> https://pulp.plan.io/issues/5008
14:44:28 <mikedep333> #info mikedep333 has joined triage
14:44:28 <mikedep333> !here
14:44:28 <pulpbot> mikedep333: mikedep333 has joined triage
14:44:31 <daviddavis> do we have support for auto-publish in pulp 3?
14:44:52 <asmacdo> daviddavis: do you want to go back to 5006?
14:45:03 <daviddavis> oh
14:45:12 <daviddavis> no I am good
14:45:22 <daviddavis> sorry
14:45:34 <bmbouter> daviddavis: we don't have auto-publish we do have distributions that can serve the 'latest' publicaiton automatically
14:45:48 <daviddavis> I see
14:45:49 <bmbouter> which is effectively auto-publish only without waiting for an operation to occur
14:45:58 <bmbouter> same for auto-distribute of a repo version
14:45:59 <dawalker> ggainey, *snort*
14:46:07 <daviddavis> 5008 = story?
14:46:21 <daviddavis> or task
14:46:32 <asmacdo> lets skip 5008. ive got a proposal on the list, and bmbouter is working up another idea
14:46:44 <daviddavis> +1
14:46:49 <ttereshc> +1 to skip
14:46:56 <asmacdo> actually, can we just triage it
14:47:14 <asmacdo> 1 less to skip again :(
14:47:40 <asmacdo> its a real issue, without an agreed upon solution, which "triaged" is ok for
14:47:40 <daviddavis> sure
14:47:53 <bmbouter> I think I can reply on that thread today
14:47:56 <asmacdo> #idea Proposed for #5008: Leave the issue as-is, accepting its current state.
14:47:56 <asmacdo> !propose accept
14:47:56 <pulpbot> asmacdo: Proposed for #5008: Leave the issue as-is, accepting its current state.
14:47:58 <asmacdo> #agreed Leave the issue as-is, accepting its current state.
14:47:58 <asmacdo> !accept
14:47:59 <pulpbot> asmacdo: Current proposal accepted: Leave the issue as-is, accepting its current state.
14:47:59 <asmacdo> #topic https://pulp.plan.io/issues/5009
14:48:00 <pulpbot> asmacdo: 4 issues left to triage: 5009, 5010, 5012, 5028
14:48:01 <pulpbot> RM 5009 - daviddavis - NEW - HTML in our json api schema
14:48:02 <pulpbot> https://pulp.plan.io/issues/5009
14:48:14 <dkliban> i can fix this one
14:48:17 <daviddavis> this one is a blocker for me as a pulp user
14:48:33 <dkliban> daviddavis: which aspect is the blocker for you?
14:48:38 <asmacdo> dkliban: how do you propose fixing it?
14:48:57 <bmbouter> I thought html was normal as it provides docs content about the calls
14:48:57 <daviddavis> the pulp schema is difficult to read in json/yml/etc
14:49:27 <dkliban> oh ... i don't think it is meant to be viewed as JSON by a human
14:49:28 <asmacdo> dkliban: IIRC you said something about being able to strip the html from those alternate formats?
14:49:29 <bmbouter> that's true but it will make the html rendering plaintext
14:49:47 <dkliban> we can render it without HTML in the bindings
14:49:57 <asmacdo> we already established that daviddavis is a machine
14:50:02 <daviddavis> :)
14:50:04 <dkliban> lol
14:50:08 <daviddavis> json and yaml are human readable formats!
14:50:27 <bmbouter> that's just what a machine would say!
14:50:31 <dkliban> lol
14:50:34 <daviddavis> haha
14:50:36 <asmacdo> LOLOL
14:50:51 <ggainey> :)
14:50:58 <dkliban> but in all seriousness, where would you like to find the JSON schema without HTML?
14:51:15 <daviddavis> in my command line
14:51:30 <dkliban> what about a query argument 'strip_html'
14:51:41 <daviddavis> I think some pulp users like me will want to read the docs from the command line and not have to render them to html, open a browser, etc
14:51:44 <dkliban> and if you pass it in, html is stripped out of the schema
14:52:04 <asmacdo> how about query argument include_html instead
14:52:04 <daviddavis> sure
14:52:09 <daviddavis> asmacdo: +1
14:52:33 <dkliban> yeah ... i can try that
14:52:43 <asmacdo> if that doesnt work skip is cool too
14:53:01 <asmacdo> dkliban: do you mind updating the issue?
14:53:04 <dkliban> yeah ... but i understand why skipping by default would be desired
14:53:09 <dkliban> i'll update it
14:53:19 <asmacdo> #idea Proposed for #5009: dkliban will update, accept and add to sprint
14:53:19 <asmacdo> !propose other dkliban will update, accept and add to sprint
14:53:19 <pulpbot> asmacdo: Proposed for #5009: dkliban will update, accept and add to sprint
14:53:27 <daviddavis> thanks
14:53:34 <asmacdo> #agreed dkliban will update, accept and add to sprint
14:53:34 <asmacdo> !accept
14:53:34 <pulpbot> asmacdo: Current proposal accepted: dkliban will update, accept and add to sprint
14:53:36 <asmacdo> #topic https://pulp.plan.io/issues/5010
14:53:36 <pulpbot> asmacdo: 3 issues left to triage: 5010, 5012, 5028
14:53:37 <pulpbot> RM 5010 - daviddavis - NEW - Travis fails when PRs are rebased and merged
14:53:38 <pulpbot> https://pulp.plan.io/issues/5010
14:53:57 <daviddavis> this is not urgent. it just causes our tests to fail sometimes.
14:54:03 <asmacdo> i wouldnt mind this so much if rebase and merge werent the default button on pulp3
14:54:04 <bmbouter> I think this is best resolved in the Travis Configuration tool
14:54:33 <dkliban> https://pulp.plan.io/issues/5009#note-5
14:54:33 <asmacdo> +1 bmbouter
14:54:51 <asmacdo> dkliban++
14:54:51 <pulpbot> asmacdo: dkliban's karma is now 299
14:55:07 <bmbouter> here comes that perfect game!
14:55:18 <daviddavis> I don't think we can fix it in the travis config tool along
14:55:21 <daviddavis> alone
14:55:22 <asmacdo> and after that, moved permanently
14:55:53 <bmbouter> daviddavis: for each repo theTravis Config tool would be up to date w/ how that repo merges and if the repo changes their approach they need to update the tool so future deployers will get it correctly
14:55:56 <bmbouter> is what I imagined
14:56:02 <asmacdo> same
14:56:18 <daviddavis> bmbouter: some repos have pre_before_install.sh that check out code. we need to confirm that they aren't using HEAD^2
14:56:29 <ttereshc> dkliban, is 5009 still an issue or more like a story?
14:56:51 <bmbouter> daviddavis: true. I figure we would converge at some point on a steady state where those behaviors are reflected in the travis config tool
14:57:05 * bmbouter has a meeting in 4 minutes and wants to highlight https://pulp.plan.io/issues/5031
14:57:18 <dkliban> ttereshc: it's a story
14:57:50 <bmbouter> I can highlight https://pulp.plan.io/issues/5031 on pulp-dev actually
14:57:54 <asmacdo> #idea Proposed for #5010: switch to template, change to story
14:57:54 <asmacdo> !propose other switch to template, change to story
14:57:54 <pulpbot> asmacdo: Proposed for #5010: switch to template, change to story
14:58:19 <asmacdo> +1 5031 to the list
14:58:26 <daviddavis> 5010 is a story?
14:58:50 <daviddavis> I agree moving it to template but not sure about it being a story
14:59:13 <ggainey> daviddavis: thought 5009 was the subject of "template and story"?
14:59:27 <daviddavis> ggainey: look at the last pulpbot output
14:59:50 <ggainey> oooh, I see - sorry, clearly havin trouble keeping up today, thanks :)
14:59:54 <asmacdo> "as a commiter, I can rebase and merge a PR"
15:00:03 <daviddavis> eh
15:00:07 <asmacdo> but i dont feel strongly about it
15:00:12 <asmacdo> would you prefer a task?
15:00:18 <daviddavis> +1
15:00:21 <asmacdo> #idea Proposed for #5010: switch to template, change to task
15:00:21 <asmacdo> !propose other switch to template, change to task
15:00:21 <pulpbot> asmacdo: Proposed for #5010: switch to template, change to task
15:00:23 <daviddavis> I gotta meeting
15:00:30 <asmacdo> #agreed switch to template, change to task
15:00:30 <asmacdo> !accept
15:00:31 <pulpbot> asmacdo: Current proposal accepted: switch to template, change to task
15:00:31 <asmacdo> #topic https://pulp.plan.io/issues/5012
15:00:32 <pulpbot> asmacdo: 2 issues left to triage: 5012, 5028
15:00:33 <pulpbot> RM 5012 - dkliban@redhat.com - NEW - ssl_client_key printed in the logs
15:00:34 <pulpbot> https://pulp.plan.io/issues/5012
15:00:49 <ggainey> ew
15:00:53 <ttereshc> ha! daviddavis has a meeting with bmbouter :P
15:01:12 <daviddavis> I do :)
15:01:18 <ggainey> logging keys is Bad - let's fix this please
15:01:27 <dkliban> let's add to the sprint
15:01:30 <ggainey> +1
15:01:48 <ttereshc> #idea Proposed for #5012: accept, add to the sprint set to 3.0
15:01:48 <ttereshc> #info ttereshc has joined triage
15:01:48 <ttereshc> !propose other accept, add to the sprint set to 3.0
15:01:48 <pulpbot> ttereshc: ttereshc has joined triage
15:01:49 <pulpbot> ttereshc: Proposed for #5012: accept, add to the sprint set to 3.0
15:01:56 <asmacdo> +1
15:02:08 <dkliban> +1
15:02:17 <asmacdo> #agreed accept, add to the sprint set to 3.0
15:02:17 <asmacdo> !accept
15:02:17 <pulpbot> asmacdo: Current proposal accepted: accept, add to the sprint set to 3.0
15:02:18 <asmacdo> #topic https://pulp.plan.io/issues/5028
15:02:19 <pulpbot> asmacdo: 1 issues left to triage: 5028
15:02:20 <pulpbot> RM 5028 - dkliban@redhat.com - NEW - RepositoryVersion.create() can't be called outside of a task
15:02:21 <pulpbot> https://pulp.plan.io/issues/5028
15:02:30 <asmacdo> dkliban: this is necessary
15:02:38 <dkliban> yeah ... we need it for docker
15:02:45 <asmacdo> no i mean the current behavior
15:02:57 <dkliban> and i have a PR ready if the proposed solution is acceptable
15:03:09 <asmacdo> docker push cant be modifying repos that should be locked because they are currently syncing
15:03:36 <ttereshc> it looks like a story to me
15:04:11 <dkliban> it's a story from the plugin writer's perspective
15:04:49 <dkliban> asmacdo: if a task has to be dispatched to create a repository version, then docker push is not going to work
15:05:12 <asmacdo> :(
15:05:13 <daviddavis> dkliban: this story sounds good to me. what about using current() though https://git.io/fjr0a
15:05:17 <dkliban> so it's really up to the user to not sync repos that they use for pushing to
15:06:25 <dkliban> daviddavis: can't use it ... it will return None
15:06:42 <daviddavis> dkliban: right but can you check it before creating a created resource?
15:06:43 <dkliban> and the DB doesn't let you create a CreatedResource with task=None
15:07:02 <dkliban> daviddavis: you can, but i want the plugin writer to make this decision intentionally
15:07:23 <daviddavis> I see. in that case, an optional parameter works for me.
15:07:56 <dkliban> asmacdo: we should discuss this tomorrow in our docker meeting
15:08:05 <partha> dkliban: I was trying to sync a pulp3 file repo from pulp2
15:08:27 <asmacdo> yes, lets do that. i'm really concerned that we've made a lot of assumptions about adding/removing only ever taking place in tasks
15:08:42 <daviddavis> yup
15:08:54 <asmacdo> #idea Proposed for #5028: Skip this issue for this triage session.
15:08:54 <asmacdo> !propose skip
15:08:54 <pulpbot> asmacdo: Proposed for #5028: Skip this issue for this triage session.
15:09:06 <daviddavis> s/only ever taking place in tasks//
15:09:12 <partha> dkliban: and hit upon the following error -> https://paste.fedoraproject.org/paste/IRBej9cICuj3ovqSUMG74w
15:09:38 <partha> "Downloading <3.iso> failed checksum validation. The manifest specified the checksum to be 1d7e85343d88da30fa418c129b8bb50eb2ef9d386c425ed005ded01c0c1197da, but it was 1d7e85343d88da30fa418c129b8bb50eb2ef9d386c425ed005ded01c0c1197da."
15:09:43 <partha> does it ring a bell
15:09:53 <asmacdo> !skip
15:09:54 <pulpbot> asmacdo: No issues to triage.
15:09:58 <asmacdo> #endmeeting
15:09:58 <asmacdo> !end