14:33:07 <asmacdo> #startmeeting Pulp Triage 2019-07-26
14:33:07 <asmacdo> #info asmacdo has joined triage
14:33:07 <asmacdo> !start
14:33:07 <pulpbot> Meeting started Fri Jul 26 14:33:07 2019 UTC.  The chair is asmacdo. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:33:07 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:33:07 <pulpbot> The meeting name has been set to 'pulp_triage_2019-07-26'
14:33:07 <pulpbot> asmacdo: asmacdo has joined triage
14:33:11 <ipanova> #info ipanova has joined triage
14:33:11 <ipanova> !here
14:33:12 <pulpbot> ipanova: ipanova has joined triage
14:33:15 <ttereshc> #info ttereshc has joined triage
14:33:15 <ttereshc> !here
14:33:15 <pulpbot> ttereshc: ttereshc has joined triage
14:33:56 <asmacdo> !next
14:33:57 <asmacdo> #topic https://pulp.plan.io/issues/5185
14:33:57 <pulpbot> asmacdo: 4 issues left to triage: 5185, 5184, 5182, 5177
14:33:58 <pulpbot> RM 5185 - jsherril@redhat.com - NEW - installer does not overwrite settings.py
14:33:59 <pulpbot> https://pulp.plan.io/issues/5185
14:34:47 <asmacdo> bmbouter: at one point we discussed that hte user should be able to provide their own settings.py and we shouldnt clobber that
14:35:22 <daviddavis> I feel like if they provide their own settings.py, they shouldn't rerun the installer?
14:35:37 <asmacdo> what if they want to add another plugin
14:35:42 <fabricioo0> #info fabricioo0 has joined triage
14:35:42 <fabricioo0> !here
14:35:43 <pulpbot> fabricioo0: fabricioo0 has joined triage
14:35:46 <dkliban> #info dkliban has joined triage
14:35:46 <dkliban> !here
14:35:46 <pulpbot> dkliban: dkliban has joined triage
14:35:56 <daviddavis> you can use the installer for that?
14:35:58 <bmbouter> when ansible manages files it is the thing that manages files
14:36:09 <bmbouter> it has to be updating it every run
14:36:32 <dkliban> yeah
14:36:33 <dawalker> this isn't fundamentally different than the dev-config.yml being custom vs overwritten right?
14:36:51 <asmacdo> this is different
14:36:58 <bmbouter> it is because in that case a defaults is provided here it isn't
14:37:04 <dawalker> ok
14:37:12 <daviddavis> can we put a warning in settings.py when it's generated by the installer?
14:37:29 <dkliban> the installer should always updae the settings beased on what user asked for
14:37:36 <dkliban> we should accept and add to sprint
14:37:43 <kersom__> +1 to this one
14:37:47 <daviddavis> +1
14:37:52 <bmbouter> +1
14:38:08 <asmacdo> thats fine with me-- but we are now going to clobber any settings.py provided by the user
14:38:32 <bmbouter> not if they provide it through pulp_settings
14:38:35 <dkliban> asmacdo: let's discuss on the issue how to best ipmlement this
14:38:48 <ttereshc> and ensure that it's documented
14:38:50 <dkliban> asmacdo: we want the user to be in control
14:38:58 <ggainey> +1 to all of the above
14:39:14 <asmacdo> bmbouter: thats fair. now that the user has full control via pulp_settings, there is no need to provide their own settings.py
14:39:20 <dkliban> yep
14:39:28 <asmacdo> #idea Proposed for #5185: accept and add to sprint
14:39:28 <asmacdo> !propose other accept and add to sprint
14:39:28 <pulpbot> asmacdo: Proposed for #5185: accept and add to sprint
14:39:33 <dkliban> +1
14:39:37 <ggainey> +1
14:39:54 <dawalker> +1
14:40:34 <asmacdo> #agreed accept and add to sprint
14:40:34 <asmacdo> !accept
14:40:34 <pulpbot> asmacdo: Current proposal accepted: accept and add to sprint
14:40:35 <asmacdo> #topic https://pulp.plan.io/issues/5184
14:40:35 <pulpbot> asmacdo: 3 issues left to triage: 5184, 5182, 5177
14:40:36 <pulpbot> RM 5184 - jsherril@redhat.com - NEW - provide identifier within sync task progress_reports
14:40:37 <pulpbot> https://pulp.plan.io/issues/5184
14:40:55 <bmbouter> yeah this was an interesting problem
14:41:06 <bmbouter> it could be retitled to be a bug, or just as easily made a story
14:41:16 <dkliban> it's a story
14:41:23 <bmbouter> but integrators are dependant on language settings is the claim
14:41:37 <daviddavis> yup
14:41:50 <bmbouter> I think they get uuids
14:42:00 <daviddavis> is this a 3.0 issue?
14:42:04 <dkliban> yes
14:42:08 <asmacdo> i think "message" should stay, but a new machine readable field should be added, so +1 story
14:42:26 <dkliban> who is going to champion this story?
14:42:32 <dkliban> we need more planning around it
14:42:33 <ggainey> concur - we def want something programs can rely on, and dealing with human-readable-text is suboptimal
14:42:58 <bmbouter> I can help
14:43:28 <asmacdo> #idea Proposed for #5184: convert to story
14:43:28 <asmacdo> !propose other convert to story
14:43:28 <pulpbot> asmacdo: Proposed for #5184: convert to story
14:43:30 <daviddavis> this sounds easy enough for someone newer
14:43:34 <daviddavis> like lmjachky or fabricioo0
14:43:37 <bmbouter> daviddavis: I agree
14:43:42 <ggainey> concur
14:43:50 <bmbouter> I'd like to write some on the story as my part of it
14:43:55 <bmbouter> I can do that right after this chat
14:44:06 <daviddavis> ok, maybe bmbouter you can check with them to see who's free to champion it next
14:44:07 <daviddavis> week
14:44:11 <asmacdo> bmbouter: ill leave it as is, please change to story
14:44:26 <bmbouter> daviddavis and asmacdo will do
14:44:29 <bmbouter> ty
14:44:30 <asmacdo> #agreed convert to story
14:44:30 <asmacdo> !accept
14:44:30 <pulpbot> asmacdo: Current proposal accepted: convert to story
14:44:31 <pulpbot> asmacdo: 2 issues left to triage: 5182, 5177
14:44:31 <asmacdo> #topic https://pulp.plan.io/issues/5182
14:44:32 <pulpbot> RM 5182 - ipanova@redhat.com - NEW - As a user I can filter char fields by multiple values
14:44:33 <pulpbot> https://pulp.plan.io/issues/5182
14:44:45 <ttereshc> story?
14:44:50 <daviddavis> I think this is supposed to be in POST too
14:44:52 <dkliban> yes
14:45:01 <dkliban> no ... it's not in post
14:45:02 <asmacdo> no
14:45:11 <asmacdo> maybe a story though
14:45:16 <dkliban> this is a story
14:45:20 <ggainey> concur
14:45:26 <daviddavis> it's not supposed to be in post?
14:45:31 <asmacdo> #idea Proposed for #5182: convert to story-- then lets talk about it in open floor
14:45:31 <asmacdo> !propose other convert to story-- then lets talk about it in open floor
14:45:33 <pulpbot> asmacdo: Proposed for #5182: convert to story-- then lets talk about it in open floor
14:45:39 <daviddavis> ok
14:46:06 <asmacdo> ipanova?
14:46:24 <ipanova> my wifi disconnected
14:46:32 <ipanova> asmacdo: yes?
14:46:42 <dkliban> ipanova: we are discussing your story about in filter
14:46:47 <dkliban> ipanova: and that it is indeed a story
14:46:50 <asmacdo> #5182 will be converted to story, and we can chat about it during open floor
14:46:57 <ipanova> #5182 currently we have no way to filter by multiple values
14:47:26 <ipanova> so i created a CharInFilter but  maybe there is a better way
14:47:53 <ipanova> dkliban: i agree it is a story
14:48:03 <dkliban> let's discuss it after triage
14:48:13 <bmbouter> yes we can link to some code then
14:48:33 <dkliban> asmacdo: let's propose converting to story
14:48:40 <asmacdo> i did
14:48:53 <ipanova> +1
14:48:56 <asmacdo> #agreed convert to story-- then lets talk about it in open floor
14:48:56 <asmacdo> !accept
14:48:56 <pulpbot> asmacdo: Current proposal accepted: convert to story-- then lets talk about it in open floor
14:48:57 <asmacdo> #topic https://pulp.plan.io/issues/5177
14:48:57 <pulpbot> asmacdo: 1 issues left to triage: 5177
14:48:58 <pulpbot> RM 5177 - aishapaal - NEW - service
14:48:59 <pulpbot> https://pulp.plan.io/issues/5177
14:49:03 <dkliban> spam
14:49:03 <ttereshc> spam
14:49:09 <daviddavis> damn, I wanted to work on this one
14:49:16 <dawalker> lol
14:49:20 <dawalker> you can!
14:49:21 <bmbouter> I can cleanup I'm quick at it
14:49:24 <ipanova> haha
14:49:28 <ggainey> :D
14:49:35 <asmacdo> #idea Proposed for #5177: bmbouter will smack that spammer directly in the face
14:49:35 <asmacdo> !propose other bmbouter will smack that spammer directly in the face
14:49:36 <pulpbot> asmacdo: Proposed for #5177: bmbouter will smack that spammer directly in the face
14:49:41 <ggainey> +1
14:49:48 <asmacdo> #agreed bmbouter will smack that spammer directly in the face
14:49:48 <asmacdo> !accept
14:49:48 <pulpbot> asmacdo: Current proposal accepted: bmbouter will smack that spammer directly in the face
14:49:49 <pulpbot> asmacdo: No issues to triage.
14:50:00 <asmacdo> open flooooor
14:50:23 <dkliban> 5183
14:50:23 <asmacdo> !issue 5182
14:50:24 <asmacdo> #topic https://pulp.plan.io/issues/5182
14:50:24 <ggainey> so I have a thing I tripped over 10 min before this mtg
14:50:24 <pulpbot> RM 5182 - ipanova@redhat.com - NEW - As a user I can filter char fields by multiple values
14:50:25 <pulpbot> https://pulp.plan.io/issues/5182
14:50:31 <dkliban> that one!
14:50:41 * ggainey waits :)
14:50:50 * asmacdo collides with everyone
14:50:52 <dkliban> it would be nice if users could filter based on a list of strings
14:51:11 <dkliban> right now are char fields have filters for exact matches
14:51:11 <asmacdo> there is a simple enough way to do this-- which ipanova has done in the linked PRs
14:52:19 <ipanova> dkliban: you suggesting /?name__in = [a,c,b,]
14:53:00 <bmbouter> I thought maybe drf provided something like that yeah
14:53:08 <bmbouter> and we could put it into the base filterset
14:53:26 <daviddavis> what do we do for add_content and remove_content
14:53:40 <dkliban> those are post params
14:53:43 <bmbouter> https://github.com/pulp/pulpcore/blob/f621a30e2e8e92c60d0b37586f1e04324cc8fcbb/pulpcore/app/viewsets/base.py#L396
14:54:13 <asmacdo> bmbouter: yes https://github.com/pulp/pulpcore/pull/231/files
14:55:00 <asmacdo> oh i see, nm
14:55:24 <dkliban> bmbouter: do yo uhave an example of where it is used?
14:55:28 <ipanova> bmbouter: from what i read we need to write a custom filter
14:55:54 <asmacdo> ipanova: i think this was done after i wrote that filtering research
14:56:23 <dkliban> oh yeah ... here https://docs.pulpproject.org/en/3.0/nightly/restapi.html#operation/repositories_list
14:56:49 <dkliban> ipanova: https://github.com/pulp/pulpcore/blob/master/pulpcore/app/viewsets/repository.py#L47
14:57:10 <dkliban> https://github.com/pulp/pulpcore/blob/master/pulpcore/app/viewsets/base.py#L21
14:57:13 <asmacdo> nice!
14:57:58 <dkliban> ipanova: so it looks like we already have this functionality
14:59:03 <asmacdo> i guess all thats left to do is add NAME_FILTER_OPTIONS to the plugin api
14:59:04 <ipanova> ah cool, so we need to define for each field  this
14:59:47 <asmacdo> ipanova: think we are good to move on?
15:00:09 <ipanova> asmacdo: well that would work only for name, so we will add this for every field we want to enable the filter __in to work
15:00:14 <ipanova> asmacdo: yes
15:00:29 <asmacdo> cool
15:00:44 <asmacdo> issue !5183
15:00:51 <asmacdo> !issue 5183
15:00:52 <daviddavis> hehe
15:00:52 <asmacdo> #topic https://pulp.plan.io/issues/5183
15:00:53 <pulpbot> RM 5183 - jsherril@redhat.com - MODIFIED - docker ruby bindings remote list ignores arguments
15:00:54 <pulpbot> https://pulp.plan.io/issues/5183
15:01:02 <asmacdo> dkliban?
15:02:43 <asmacdo> maybe we can come back to this one
15:02:47 <asmacdo> ggainey: you had something?
15:02:51 <ggainey> yessir
15:02:55 <ggainey> !issue 5189
15:03:01 <asmacdo> !issue 5189
15:03:02 <asmacdo> #topic https://pulp.plan.io/issues/5189
15:03:03 <pulpbot> RM 5189 - ggainey - NEW - 2-master Travis builds failing, need to pin distro in .travis.yml
15:03:04 <pulpbot> https://pulp.plan.io/issues/5189
15:03:04 <ggainey> heh
15:03:09 <asmacdo> backseat driver!
15:03:11 <ggainey> so, tripped over this right before the mtg
15:03:20 <daviddavis> so xenial doesn't support python 2.6
15:03:40 <daviddavis> and sometimes travis jobs get routed to vms with xenial
15:03:41 <ggainey> travis' default-dist switched from trusty to xenial at the end of June, and xenial can't find py2.6
15:03:44 <ggainey> yus
15:04:02 <daviddavis> solution is to pin dist to trusty
15:04:08 <ggainey> correct
15:04:15 <daviddavis> not sure if pulp/pulp also has this problem?
15:04:22 <ggainey> lemme check
15:04:58 <daviddavis> we're using python 3.6 to run travis jobs in pulp 2
15:05:01 <daviddavis> interesting
15:05:04 <asmacdo> too bad xenial is not a friendly host ;)
15:05:06 <ggainey> yeah, just seeing that
15:05:16 <daviddavis> hehe
15:05:26 <daviddavis> asmacdo++
15:05:26 <pulpbot> daviddavis: asmacdo's karma is now 125
15:05:30 <daviddavis> bad.puns++
15:05:30 <pulpbot> daviddavis: bad.puns's karma is now 1
15:05:50 <bmbouter> haha
15:05:54 <dawalker> :D
15:06:04 <daviddavis> ok, I think we should accept and add to sprint
15:06:06 <ggainey> ok, I'm now (more) confused - pulp_rpm builds on py2.6/7, but pulp on py3.6?
15:06:08 <ggainey> in 2-master
15:06:18 <daviddavis> ggainey: yea, it's just building the docs and stuff
15:06:24 <daviddavis> it's not running the code against python 3.6
15:06:27 <ggainey> ahhhhhhh, ok
15:06:46 <daviddavis> you may want to check the other pulp 2 plugins if you can
15:07:04 <ggainey> so should we pin the dist to trusty, or consolidate on 'build on py3'?
15:08:24 <daviddavis> in pulp_rpm at least, we're just running flake8
15:08:28 <daviddavis> https://github.com/pulp/pulp_rpm/blob/2-master/.travis.yml#L6
15:08:35 <daviddavis> I don't see why we couldn't just drop 2.6
15:09:37 * daviddavis feels like he's talking to himself
15:09:37 <ggainey> pulp_python has the prob, but is only running flake3 and pep257
15:09:46 <ggainey> daviddavis: sorry, looking at projects
15:09:53 <daviddavis> ah no worries
15:10:11 <daviddavis> yea, I'm cool with either pinning the dist or dropping 2.6
15:10:12 <ggainey> but I'm good with "drop 2.6 from .travis.yml wherever it appears", yeah?
15:10:18 <daviddavis> +1
15:10:25 <ggainey> I'd rather drop 2.6, since trusty is EOL 'soon'
15:10:36 <daviddavis> yea
15:10:41 <bmbouter> yup
15:10:44 <bmbouter> +1
15:10:48 * bmbouter appears
15:10:53 <ttereshc> daviddavis, I think we haven't dropped 2.6 support because we agreed that for katello users we'll try to be 2.6 compatible if we can
15:11:05 <ttereshc> and if we don't run into any show stoppers
15:11:14 <ttereshc> we officially don't support it
15:11:15 <mikedep333> Keep in mind that trusty has canonical's paid extended support.
15:11:20 <ttereshc> but we try our best
15:11:22 <daviddavis> ttereshc: right but the context here is travis and we're only using travis for flake8 and building docs
15:11:30 <daviddavis> I'm not saying we should drop 2.6 support in pulp
15:11:33 <daviddavis> just in travis
15:11:44 <ggainey> aye
15:11:45 <mikedep333> And if we use the unpatched free version in CI without accessing the internet, I don't think there's any security issue.
15:11:49 <ttereshc> daviddavis, ah ok, thanks for pointing to the contest
15:11:50 <asmacdo> does running flake8 with python 2.6 catch things like non-allowed dict comprehensions?
15:11:53 <ttereshc> *context
15:12:44 <daviddavis> asmacdo: o so there are flake8 rules specific to 2.6?
15:13:00 <asmacdo> i dont know, but i assumed there was a reason for running flake8 twice
15:13:22 <daviddavis> "It is very important to install Flake8 on the correct version of Python for your needs."
15:13:24 <ttereshc> it should be version specific
15:13:52 <daviddavis> yea, so I guess pinning dist is the way to go for now
15:14:04 <ggainey> yeah, makes sense to me
15:14:18 <ggainey> and reading https://blog.travis-ci.com/2019-04-15-xenial-default-build-environment suggests that trusty isn't going to disappear - it's just not the default
15:14:34 <ggainey> kk - i'm happy to add commentary to the issue
15:14:44 <asmacdo> woot
15:14:54 <asmacdo> anyone else got a thing?
15:15:00 <bmbouter> yes one
15:15:02 <asmacdo> dkliban, did you want to talk about ruby binding
15:15:12 <bmbouter> I want to update pulplift with this  https://github.com/pulp/pulplift/pull/40
15:15:19 <bmbouter> tha's the postgreSQL 9.6 change
15:15:38 <asmacdo> guess the ansible PR has already been merged?
15:15:43 <daviddavis> yes
15:15:48 <bmbouter> yes it passed once RC4 was released
15:15:51 <bmbouter> and merged
15:16:14 <asmacdo> approved
15:16:19 <bmbouter> sweet!
15:16:41 <daviddavis> !friday
15:16:41 <pulpbot> ♪ It's Friday, Friday, gotta get down on Friday ♪
15:16:47 <asmacdo> #endmeeting
15:16:47 <asmacdo> !end