15:30:51 <fao89> #startmeeting Pulp Triage 2020-03-03
15:30:51 <fao89> !start
15:30:51 <pulpbot> Meeting started Tue Mar  3 15:30:51 2020 UTC.  The chair is fao89. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:30:51 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:30:51 <pulpbot> The meeting name has been set to 'pulp_triage_2020-03-03'
15:30:51 <fao89> #info fao89 has joined triage
15:30:51 <pulpbot> fao89: fao89 has joined triage
15:30:52 <dawalker> !here
15:30:53 <dawalker> #info dawalker has joined triage
15:30:53 <pulpbot> dawalker: dawalker has joined triage
15:30:59 <ppicka> #info ppicka has joined triage
15:30:59 <ppicka> !here
15:30:59 <pulpbot> ppicka: ppicka has joined triage
15:31:01 <fao89> !next
15:31:03 <fao89> #topic https://pulp.plan.io/issues/6270
15:31:03 <dkliban> #info dkliban has joined triage
15:31:03 <dkliban> !here
15:31:03 <pulpbot> fao89: 12 issues left to triage: 6270, 6263, 6258, 6255, 6254, 6253, 6252, 6249, 6246, 6244, 6243, 6221
15:31:04 <pulpbot> RM 6270 - bmbouter - NEW - Cannot dispatch a task from within a task
15:31:06 <pulpbot> https://pulp.plan.io/issues/6270
15:31:07 <pulpbot> dkliban: dkliban has joined triage
15:31:17 <fao89> #idea Proposed for #6270: Leave the issue as-is, accepting its current state.
15:31:17 <fao89> !propose accept
15:31:17 <pulpbot> fao89: Proposed for #6270: Leave the issue as-is, accepting its current state.
15:31:30 <dkliban> accept and add to sprint?
15:31:31 <ggainey> #info ggainey has joined triage
15:31:31 <ggainey> !here
15:31:31 <pulpbot> ggainey: ggainey has joined triage
15:31:49 <fao89> #idea Proposed for #6270: accept and add to sprint
15:31:49 <fao89> !propose other accept and add to sprint
15:31:49 <pulpbot> fao89: Proposed for #6270: accept and add to sprint
15:32:16 <fao89> #agreed accept and add to sprint
15:32:16 <fao89> !accept
15:32:16 <pulpbot> fao89: Current proposal accepted: accept and add to sprint
15:32:17 <fao89> #topic https://pulp.plan.io/issues/6263
15:32:17 <pulpbot> fao89: 11 issues left to triage: 6263, 6258, 6255, 6254, 6253, 6252, 6249, 6246, 6244, 6243, 6221
15:32:18 <pulpbot> RM 6263 - bmbouter - NEW - User installation makes non-pulp user hard to use
15:32:19 <pulpbot> https://pulp.plan.io/issues/6263
15:32:40 <daviddavis> #info daviddavis has joined triage
15:32:40 <daviddavis> !here
15:32:40 <pulpbot> daviddavis: daviddavis has joined triage
15:32:48 <fao89> #idea Proposed for #6263: Leave the issue as-is, accepting its current state.
15:32:48 <fao89> !propose accept
15:32:48 <pulpbot> fao89: Proposed for #6263: Leave the issue as-is, accepting its current state.
15:33:16 <dkliban> +1
15:33:24 <ppicka> +1
15:33:27 <dawalker> +1
15:33:37 <fao89> #agreed Leave the issue as-is, accepting its current state.
15:33:37 <fao89> !accept
15:33:37 <pulpbot> fao89: Current proposal accepted: Leave the issue as-is, accepting its current state.
15:33:38 <fao89> #topic https://pulp.plan.io/issues/6258
15:33:39 <pulpbot> fao89: 10 issues left to triage: 6258, 6255, 6254, 6253, 6252, 6249, 6246, 6244, 6243, 6221
15:33:40 <pulpbot> RM 6258 - bmbouter - NEW - pip error says a future version of pip will fail
15:33:41 <pulpbot> https://pulp.plan.io/issues/6258
15:34:07 <dkliban> accept
15:34:10 <dawalker> +1
15:34:11 <fao89> #idea Proposed for #6258: Leave the issue as-is, accepting its current state.
15:34:11 <fao89> !propose accept
15:34:11 <pulpbot> fao89: Proposed for #6258: Leave the issue as-is, accepting its current state.
15:34:14 <fao89> #agreed Leave the issue as-is, accepting its current state.
15:34:15 <fao89> !accept
15:34:15 <pulpbot> fao89: Current proposal accepted: Leave the issue as-is, accepting its current state.
15:34:16 <pulpbot> fao89: 9 issues left to triage: 6255, 6254, 6253, 6252, 6249, 6246, 6244, 6243, 6221
15:34:16 <fao89> #topic https://pulp.plan.io/issues/6255
15:34:17 <pulpbot> RM 6255 - dkliban@redhat.com - NEW - changes from pulp 2 docs don't state that pulp 3 doesn't manage consumers
15:34:18 <pulpbot> https://pulp.plan.io/issues/6255
15:34:39 <dkliban> we had an email on the mailing list asking about this and i wanted to link to docs and we don't have any
15:34:41 <ppicka> +1
15:34:41 <bmbouter> #info bmbouter has joined triage
15:34:41 <bmbouter> !here
15:34:41 <pulpbot> bmbouter: bmbouter has joined triage
15:34:54 <fao89> #idea Proposed for #6255: accept and add to sprint
15:34:54 <fao89> !propose other accept and add to sprint
15:34:54 <pulpbot> fao89: Proposed for #6255: accept and add to sprint
15:34:57 <daviddavis> needs docs tag too
15:34:57 <dawalker> +1
15:35:00 <ggainey> concur
15:35:11 <bmbouter> +1
15:35:15 <fao89> #agreed accept and add to sprint
15:35:15 <fao89> !accept
15:35:15 <pulpbot> fao89: Current proposal accepted: accept and add to sprint
15:35:16 <pulpbot> fao89: 8 issues left to triage: 6254, 6253, 6252, 6249, 6246, 6244, 6243, 6221
15:35:16 <fao89> #topic https://pulp.plan.io/issues/6254
15:35:17 <pulpbot> RM 6254 - bmbouter - POST - Incorrect `Environment` in systemd files made by the installer
15:35:18 <pulpbot> https://pulp.plan.io/issues/6254
15:35:24 <bmbouter> at post already
15:35:26 <ttereshc> #info ttereshc has joined triage
15:35:26 <ttereshc> !here
15:35:26 <pulpbot> ttereshc: ttereshc has joined triage
15:35:26 <bmbouter> accept
15:35:31 <bmbouter> ty fao89 for fixing!
15:35:35 <ggainey> heh
15:35:45 <ggainey> accept-and-add then? :)
15:35:48 <fao89> actually it is not fixed
15:35:49 <daviddavis> +1
15:35:52 <daviddavis> oh
15:36:07 <bmbouter> fao89: how do you want to triage?
15:36:24 <fao89> https://github.com/pulp/ansible-pulp/pull/245#discussion_r386684103
15:36:47 <fao89> I propose to accept, as it depends on other issue
15:36:58 <ggainey> yeah, just read the conversation in PR
15:37:08 <fao89> #idea Proposed for #6254: Leave the issue as-is, accepting its current state.
15:37:08 <fao89> !propose accept
15:37:08 <pulpbot> fao89: Proposed for #6254: Leave the issue as-is, accepting its current state.
15:37:32 <daviddavis> works for me
15:37:35 <ttereshc> +1
15:37:37 <dkliban> +1
15:37:39 <ppicka> +1
15:37:41 <fao89> #agreed Leave the issue as-is, accepting its current state.
15:37:41 <fao89> !accept
15:37:41 <pulpbot> fao89: Current proposal accepted: Leave the issue as-is, accepting its current state.
15:37:42 <pulpbot> fao89: 7 issues left to triage: 6253, 6252, 6249, 6246, 6244, 6243, 6221
15:37:42 <fao89> #topic https://pulp.plan.io/issues/6253
15:37:43 <pulpbot> RM 6253 - daviddavis - NEW - Chunked uploads don't work against S3
15:37:44 <pulpbot> https://pulp.plan.io/issues/6253
15:38:01 <bmbouter> accept add to sprint?
15:38:03 <fao89> !propose accept and add to sprint
15:38:03 <pulpbot> fao89: propose accept Propose accepting the current issue in its current state.
15:38:06 <dawalker> +1
15:38:11 <dkliban> +1
15:38:15 <ppicka> +1
15:38:21 <ggainey> +1
15:38:22 <fao89> !accept
15:38:22 <pulpbot> fao89: No action proposed, nothing to accept.
15:38:44 <fao89> #idea Proposed for #6253: accept and add to sprint
15:38:44 <fao89> !propose other accept and add to sprint
15:38:44 <pulpbot> fao89: Proposed for #6253: accept and add to sprint
15:38:46 <fao89> #agreed accept and add to sprint
15:38:46 <fao89> !accept
15:38:46 <pulpbot> fao89: Current proposal accepted: accept and add to sprint
15:38:47 <pulpbot> fao89: 6 issues left to triage: 6252, 6249, 6246, 6244, 6243, 6221
15:38:47 <fao89> #topic https://pulp.plan.io/issues/6252
15:38:48 <pulpbot> RM 6252 - pimsierhuis - NEW - Pulp-streamer serves corrupt content when upstream connection breaks in the middle
15:38:49 <pulpbot> https://pulp.plan.io/issues/6252
15:39:06 <fao89> #idea Proposed for #6252: Leave the issue as-is, accepting its current state.
15:39:06 <fao89> !propose accept
15:39:06 <pulpbot> fao89: Proposed for #6252: Leave the issue as-is, accepting its current state.
15:39:48 <daviddavis> this needs a pulp 2 tag. I'm hesitant to accept since the chances of us fixing this are low.
15:40:10 <bmbouter> yeah is it pulp2?
15:40:14 <ttereshc> yeah, it;s pulp 2
15:40:25 <bmbouter> then yes tag pulp2 and we should ask him to try pulp3?
15:40:28 <ttereshc> at least the reporter points to 2-master
15:40:48 <ttereshc> maybe it's worth asking anyway
15:41:11 <fao89> #idea Proposed for #6252: add pulp2 tag and ...
15:41:11 <fao89> !propose other add pulp2 tag and ...
15:41:12 <pulpbot> fao89: Proposed for #6252: add pulp2 tag and ...
15:42:07 <ttereshc> ... and ask if he uses pulp2 and that he should consider trying pulp3
15:42:08 <daviddavis> my proposal would be to confirm it's pulp 2 and if so, point the user to pulp 3
15:42:12 <daviddavis> +1
15:42:43 <fao89> #idea Proposed for #6252: add pulp2 tag and ask if he uses pulp2 and that he should consider trying pulp3
15:42:43 <fao89> !propose other add pulp2 tag and ask if he uses pulp2 and that he should consider trying pulp3
15:42:43 <pulpbot> fao89: Proposed for #6252: add pulp2 tag and ask if he uses pulp2 and that he should consider trying pulp3
15:42:47 <fao89> #agreed add pulp2 tag and ask if he uses pulp2 and that he should consider trying pulp3
15:42:47 <fao89> !accept
15:42:47 <pulpbot> fao89: Current proposal accepted: add pulp2 tag and ask if he uses pulp2 and that he should consider trying pulp3
15:42:48 <pulpbot> fao89: 5 issues left to triage: 6249, 6246, 6244, 6243, 6221
15:42:48 <fao89> #topic https://pulp.plan.io/issues/6249
15:42:49 <pulpbot> RM 6249 - bmbouter - NEW - Plugin snippet docs for pugin writers don't mention adding them to MANIFEST.in
15:42:50 <pulpbot> https://pulp.plan.io/issues/6249
15:42:58 <ggainey> it's def pulp2, he's looknig at 2-master server.py
15:43:12 <bmbouter> I want to add 6249 to sprint
15:43:19 <bmbouter> it's a small but important docs fix
15:43:20 <daviddavis> yea also he uses 'pulp-streamer' which is pulp 2 only
15:43:22 <daviddavis> bmbouter: +1
15:43:23 <bmbouter> ipanova: btw ^
15:43:34 <fao89> #idea Proposed for #6249: accept and add to sprint
15:43:34 <fao89> !propose other accept and add to sprint
15:43:35 <pulpbot> fao89: Proposed for #6249: accept and add to sprint
15:43:38 <ggainey> +1
15:43:43 <fao89> #agreed accept and add to sprint
15:43:43 <fao89> !accept
15:43:44 <pulpbot> fao89: Current proposal accepted: accept and add to sprint
15:43:45 <pulpbot> fao89: 4 issues left to triage: 6246, 6244, 6243, 6221
15:43:45 <fao89> #topic https://pulp.plan.io/issues/6246
15:43:46 <pulpbot> RM 6246 - dkliban@redhat.com - NEW - ruby bindings seem to always set Authorization header
15:43:47 <pulpbot> https://pulp.plan.io/issues/6246
15:44:09 <fao89> #idea Proposed for #6246: Leave the issue as-is, accepting its current state.
15:44:09 <fao89> !propose accept
15:44:09 <pulpbot> fao89: Proposed for #6246: Leave the issue as-is, accepting its current state.
15:44:18 <ggainey> +1
15:44:37 <daviddavis> needs 'api bindings' tag
15:44:45 <ttereshc> +1 +1
15:44:53 <fao89> dkliban, does it blocks katello in some way?
15:45:00 <daviddavis> good question
15:45:53 <jsherrill> it blocks us from upgrading to 3.1 or 3.2
15:46:14 <daviddavis> add to sprint then
15:46:20 <fao89> #idea Proposed for #6246: accept and add to sprint
15:46:20 <fao89> !propose other accept and add to sprint
15:46:20 <pulpbot> fao89: Proposed for #6246: accept and add to sprint
15:46:25 <ttereshc> +1
15:46:29 <fao89> #agreed accept and add to sprint
15:46:29 <fao89> !accept
15:46:29 <pulpbot> fao89: Current proposal accepted: accept and add to sprint
15:46:30 <pulpbot> fao89: 3 issues left to triage: 6244, 6243, 6221
15:46:30 <fao89> #topic https://pulp.plan.io/issues/6244
15:46:31 <pulpbot> RM 6244 - sajha - NEW - in settings.py , REST_FRAMEWORK__DEFAULT_AUTHENTICATION_CLASSES , instead of the replacing the list, adds values to the existing list.
15:46:32 <pulpbot> https://pulp.plan.io/issues/6244
15:46:34 <fao89> thank you jsherrill
15:47:09 <daviddavis> accept and add to sprint
15:47:26 <fao89> #idea Proposed for #6244: accept and add to sprint
15:47:26 <fao89> !propose other accept and add to sprint
15:47:26 <pulpbot> fao89: Proposed for #6244: accept and add to sprint
15:47:46 <dkliban> +1
15:47:53 <fao89> #agreed accept and add to sprint
15:47:53 <fao89> !accept
15:47:53 <pulpbot> fao89: Current proposal accepted: accept and add to sprint
15:47:54 <fao89> #topic https://pulp.plan.io/issues/6243
15:47:55 <pulpbot> fao89: 2 issues left to triage: 6243, 6221
15:47:56 <pulpbot> RM 6243 - ttereshc - NEW - When pip_version_specifier is set to null, broken config is generated
15:47:57 <pulpbot> https://pulp.plan.io/issues/6243
15:48:07 <dkliban> accept and add to sprit
15:48:18 <fao89> #idea Proposed for #6243: accept and add to sprint
15:48:18 <fao89> !propose other accept and add to sprint
15:48:18 <pulpbot> fao89: Proposed for #6243: accept and add to sprint
15:48:21 <ttereshc> I thought mikedep333 solved that ^
15:48:37 <fao89> #agreed accept and add to sprint
15:48:37 <fao89> !accept
15:48:37 <pulpbot> fao89: Current proposal accepted: accept and add to sprint
15:48:38 <fao89> #topic https://pulp.plan.io/issues/6221
15:48:38 <pulpbot> fao89: 1 issues left to triage: 6221
15:48:39 <pulpbot> RM 6221 - CodeHeeler - NEW - Bindings Issues at Install, Undocumented Fix
15:48:40 <pulpbot> https://pulp.plan.io/issues/6221
15:49:07 <dawalker> daviddavis, what do you think now?
15:49:17 <ttereshc> add a docs tag?
15:49:18 <dawalker> docs issue, add note about pbindings?
15:49:51 <daviddavis> the issue was that you didn't have bindings?
15:50:12 <dawalker> or they were all the version 0.0.0.0 or something
15:50:17 <daviddavis> hmm
15:50:29 <dawalker> but nowhere is pbindings mentioned in our docs
15:50:34 <fao89> version 0.0.0 == generated by ansible-pulp
15:50:36 <dawalker> so there was no way to know how to generate them
15:51:05 <daviddavis> we should def document pbindings so +1 to me. I just want to make sure there isn't a problem generating the bindings during vagrant up.
15:51:08 <dawalker> if no one else is getting it in this state, we can let it go, but I think it should be documented
15:51:23 <fao89> #idea Proposed for #6221: accept and add to sprint
15:51:23 <fao89> !propose other accept and add to sprint
15:51:23 <pulpbot> fao89: Proposed for #6221: accept and add to sprint
15:51:34 <daviddavis> +1 from me
15:51:39 <ttereshc> +1 docs tag
15:51:49 <daviddavis> +1 to that too
15:51:50 <fao89> #agreed accept and add to sprint
15:51:50 <fao89> !accept
15:51:50 <pulpbot> fao89: Current proposal accepted: accept and add to sprint
15:51:51 <pulpbot> fao89: No issues to triage.
15:51:51 <ppicka> +1 for doc
15:52:38 <fao89> Open floor!
15:53:20 <bmbouter> we merged the major performance increase from @lubos an hour ago
15:53:25 <bmbouter> and I need this reviewed https://github.com/pulp/pulpcore/pull/569
15:53:26 * ggainey cheers
15:53:40 <dawalker> yay performance!
15:53:44 <dawalker> !kirby
15:53:44 <pulpbot> (>'-')> <('-'<) ^('-')^ v('-')v(>'-')> (^-^)
15:53:45 <bmbouter> I'm going to retest some on the scale box with the zillion units on it
15:55:48 <fao89> did someone vagrant up today? I'm experience problems with that, and it seems is from galaxy side, as it could not reach https://galaxy.ansible.com/v1/roles/?owner__username=geerlingguy&name=postgresql
15:56:42 <dkliban> oh shit
15:56:49 <dkliban> looks like a 404
15:57:32 <fao89> yep, I've been looking ansible repos to see if they released something recently, but I couldn't find anything
15:58:56 <daviddavis> hmm seems to exist https://galaxy.ansible.com/geerlingguy/postgresql
15:59:25 <fao89> it is the error I get: https://paste.centos.org/view/b3af85f5
16:00:05 <daviddavis> it should be https://galaxy.ansible.com/api/v1/
16:00:06 <fao89> it renders a 404 page instead of download the role
16:00:34 <daviddavis> this link works fine https://galaxy.ansible.com/api/v1/roles/?owner__username=geerlingguy&name=postgresql
16:01:10 <dkliban> i see a difference in the two links
16:01:19 <dkliban> on is /v1/ and the other is /api/v1/
16:01:31 <fao89> as we don't explicitly declare the url, maybe ansible-galaxy need an update
16:01:42 <daviddavis> hmm possibly
16:03:03 <fao89> I'll look more into it, as it is blocking me, good to know the right url
16:03:18 <fao89> any more issues for open floor?
16:05:14 <fao89> #endmeeting
16:05:14 <fao89> !end