14:30:09 <fao89> #startmeeting Pulp Triage 2020-03-31
14:30:09 <fao89> !start
14:30:09 <fao89> #info fao89 has joined triage
14:30:09 <pulpbot> Meeting started Tue Mar 31 14:30:09 2020 UTC. The chair is fao89. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:30:09 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:30:09 <pulpbot> The meeting name has been set to 'pulp_triage_2020-03-31'
14:30:09 <pulpbot> fao89: fao89 has joined triage
14:30:15 <fao89> !next
14:30:15 <ppicka> !here
14:30:16 <pulpbot> fao89: 3 issues left to triage: 6420, 6415, 6413
14:30:17 <fao89> #topic https://pulp.plan.io/issues/6420
14:30:17 <ppicka> #info ppicka has joined triage
14:30:17 <pulpbot> RM 6420 - mdepaulo@redhat.com - POST - Pulp containers do not allow commands like "/bin/bash" to be run, only "bash"
14:30:19 <pulpbot> https://pulp.plan.io/issues/6420
14:30:20 <pulpbot> ppicka: ppicka has joined triage
14:30:31 <fao89> #idea Proposed for #6420: Leave the issue as-is, accepting its current state.
14:30:31 <fao89> !propose accept
14:30:31 <pulpbot> fao89: Proposed for #6420: Leave the issue as-is, accepting its current state.
14:30:38 <ttereshc> #info ttereshc has joined triage
14:30:38 <ttereshc> !here
14:30:38 <pulpbot> ttereshc: ttereshc has joined triage
14:30:46 <fao89> #idea Proposed for #6420: accept and add to sprint
14:30:46 <fao89> !propose other accept and add to sprint
14:30:46 <pulpbot> fao89: Proposed for #6420: accept and add to sprint
14:30:49 <ipanova> #info ipanova has joined triage
14:30:49 <ipanova> !here
14:30:49 <pulpbot> ipanova: ipanova has joined triage
14:30:52 <fao89> as it is already in post
14:30:58 <ttereshc> shouldn't we wait for at least 3 people?
14:31:07 <ttereshc> ah we have them already, ok
14:31:16 <ppicka> +1 when it is in post already
14:31:26 <ipanova> +1
14:31:37 <fao89> #agreed accept and add to sprint
14:31:37 <fao89> !accept
14:31:37 <pulpbot> fao89: Current proposal accepted: accept and add to sprint
14:31:38 <ttereshc> +!
14:31:39 <fao89> #topic https://pulp.plan.io/issues/6415
14:31:39 <pulpbot> fao89: 2 issues left to triage: 6415, 6413
14:31:40 <pulpbot> RM 6415 - daviddavis - NEW - Document how users can figure out the type for a given href
14:31:41 <pulpbot> https://pulp.plan.io/issues/6415
14:31:58 <fao89> #idea Proposed for #6415: Leave the issue as-is, accepting its current state.
14:31:58 <fao89> !propose accept
14:31:58 <pulpbot> fao89: Proposed for #6415: Leave the issue as-is, accepting its current state.
14:31:59 <daviddavis> #info daviddavis has joined triage
14:31:59 <daviddavis> !here
14:31:59 <pulpbot> daviddavis: daviddavis has joined triage
14:32:02 <ipanova> +1
14:32:03 <daviddavis> probably a task
14:32:13 <ttereshc> +1 to a task
14:32:26 <fao89> #idea Proposed for #6415: convert to a task
14:32:26 <fao89> !propose other convert to a task
14:32:26 <pulpbot> fao89: Proposed for #6415: convert to a task
14:32:34 <daviddavis> +1
14:32:42 <fao89> #agreed convert to a task
14:32:42 <fao89> !accept
14:32:42 <pulpbot> fao89: Current proposal accepted: convert to a task
14:32:43 <pulpbot> fao89: 1 issues left to triage: 6413
14:32:44 <fao89> #topic https://pulp.plan.io/issues/6413
14:32:44 <pulpbot> RM 6413 - ttereshc - NEW - Sync timeouts when retrying in case of HTTP 407
14:32:45 <pulpbot> https://pulp.plan.io/issues/6413
14:32:58 <ggainey> #info ggainey has joined triage
14:32:58 <ggainey> !here
14:32:58 <pulpbot> ggainey: ggainey has joined triage
14:33:00 <ttereshc> #idea Proposed for #6413: Leave the issue as-is, accepting its current state.
14:33:00 <ttereshc> !propose accept
14:33:01 <pulpbot> ttereshc: Proposed for #6413: Leave the issue as-is, accepting its current state.
14:33:01 <ipanova> we should add pulp2 tag
14:33:14 <ttereshc> +1 ipanova
14:33:18 <daviddavis> +1
14:33:24 <fao89> #agreed Leave the issue as-is, accepting its current state.
14:33:24 <fao89> !accept
14:33:24 <pulpbot> fao89: Current proposal accepted: Leave the issue as-is, accepting its current state.
14:33:25 <pulpbot> fao89: No issues to triage.
14:33:30 <ipanova> \0/
14:33:50 <fao89> Open floor!
14:34:00 <daviddavis> I was hoping to get feedback on the pr processor. no one's said anything about it.
14:34:08 <dkliban> it's awesome!
14:34:18 <daviddavis> ok cool
14:34:35 <daviddavis> I'll look at rolling it out to a couple more projects
14:35:02 <ttereshc> yes, it's great
14:36:01 <dalley> daviddavis++
14:36:01 <pulpbot> dalley: daviddavis's karma is now 302
14:36:33 <dalley> I ran across this project over the weekend https://github.com/jakedeichert/mask
14:37:16 <daviddavis> interesting
14:37:17 <dalley> it would be kinda nice if we could just have a context-sensitive command to run all the unit tests in this project, all the functional tests, etc without needing to paste the incantation
14:37:29 <dalley> all the performance tests
14:37:52 <bmbouter> #info bmbouter has joined triage
14:37:52 <bmbouter> !here
14:37:52 <pulpbot> bmbouter: bmbouter has joined triage
14:38:13 <bmbouter> dalley: PR processor is great
14:38:26 <fao89> not sure if open floor is the place for it, but I'm starting to get confused with context switching (mainly galaxy x rpm tests), advice will be highly appreciated
14:38:56 <dkliban> welcome to my world fao89
14:39:00 <daviddavis> ha
14:39:01 <bmbouter> yuuuuup
14:39:17 <dkliban> fao89: i don't have any advice though
14:39:28 <dkliban> cause i am failing at the context switching right now
14:39:43 <fao89> I imagined that, that's why I'm curious how people are handling it
14:39:46 <daviddavis> yea, lack of sleep and general dread is hampering my ability right now to do so
14:40:09 <bmbouter> fao89: one thing I do is use different boxes for different areas of work I'm actively doing
14:40:15 <ggainey> fao89: the only thing that has worked for me, is to break your day up into separate blocks
14:40:32 <ggainey> like, "4 hours in the AM for ONLY GALAXY, and then 3 hours for ONLY TESTS"
14:40:37 <bmbouter> yup
14:40:38 <ggainey> or even separate days
14:40:43 <bmbouter> yup
14:40:54 <ggainey> and then just try really hard not to cross the streams (which is my personal failure-point)
14:41:01 <fao89> good advice!
14:41:06 <fao89> bmbouter++
14:41:06 <pulpbot> fao89: bmbouter's karma is now 237
14:41:11 <fao89> ggainey++
14:41:11 <pulpbot> fao89: ggainey's karma is now 17
14:41:13 <bmbouter> also at the beginning of my day I try to write down a short (like 1 or two things) I will complete today and I ignore the rest
14:41:23 <bmbouter> well I try to ignore, I'm not good at ignoring
14:41:38 <bmbouter> once I'm into the business of the day it's harder for me to see what is important
14:41:39 <ggainey> fao89: bmbouter : also, if I know I'm gonna be in this spot for a while, I try to bang together scripts/aliases that handle the grunt cmd-work of switching gears
14:41:59 <bmbouter> I also make a list at the end of the day as my starter list for tomorrow
14:42:12 <bmbouter> fao89: also take breaks
14:42:14 <ggainey> bmbouter: yeah - I havea general tasklist that can get large, but every day gets a ":today list" that is no more then 4/5 things
14:42:31 <ggainey> fao89: listen to bmbouter , for bmbouter is Wise in the Ways of the Code
14:42:34 <ggainey> bmbouter++
14:42:34 <pulpbot> ggainey: bmbouter's karma is now 238
14:42:50 <bmbouter> pshhhh, everyone here is a master in the art I think
14:43:09 <bmbouter> a break can go a looooong way towards improving productivity
14:43:14 <ggainey> bmbouter: well..we've certainly all had a lot of *practice* at it, that's for sure :)
14:43:19 <bmbouter> :)
14:43:24 <fao89> I think you both have a really good set of advice, thank you!
14:43:25 <bmbouter> I love orking w/ this team
14:43:38 <daviddavis> hey can I ask for the status on https://github.com/pulp/pulpcore/pull/613
14:43:47 <daviddavis> not sure what the next steps are?
14:43:52 <ggainey> Re breaks - it's amazing what a 30 min lunch + 30 min power-nap can accomplish
14:44:20 <ggainey> (assuming you're someone who *can* nap, I know a number of folk who just can't)
14:44:28 <bmbouter> daviddavis: yeah I think me, you, and dkliban need to reach a conclusion and advise fao on which option we're going with
14:44:32 <fao89> daviddavis, for me it is matter of a vote which PR is better 600 or 613, one will be closed and the other will be merged
14:44:37 <bmbouter> well all of us together
14:44:49 <bmbouter> daviddavis, dkliban, fao89, and myself
14:44:56 <dkliban> daviddavis: we need to figure out how we are actually using these write_only fields
14:45:22 <dkliban> daviddavis: bmbouter: fao89: i am in particular interested in https://github.com/pulp/pulpcore/blob/master/pulpcore/app/serializers/content.py#L29
14:46:06 <dkliban> this serializer is used by pulp_deb and pulp_container only ... though i might be wrong
14:46:41 <dkliban> and last week we were discussing that any serializer that has write_only fields should probably be only used for POST and not GET requests
14:46:51 <dkliban> and thus does not need to have wrtie_only=True set on it
14:47:12 <fao89> dkliban, all the other plugins use a variation of that serializer
14:47:31 <dkliban> fao89: can you link to an example of a variation?
14:47:49 <daviddavis> dkliban: it's used by pretty much all plugins via the upload serializer which extends it https://git.io/Jv5r5
14:48:07 <dkliban> daviddavis: thank you
14:48:10 <fao89> dkliban, https://github.com/pulp/pulpcore/blob/master/pulpcore/plugin/serializers/content.py#L16
14:48:30 <dkliban> daviddavis: fao89: so do we actually need to set write_only=True there?
14:48:41 <dkliban> it doesn't seem like we use that serializer for GET requests ... or do we?
14:49:27 <daviddavis> I believe it does get used for GET requests. FileContentSerializer extends it for example https://git.io/Jv5rN
14:50:28 <dkliban> is tehre a practical way to change that?
14:50:34 <fao89> on RPM it is used for packages: https://github.com/pulp/pulp_rpm/blob/master/pulp_rpm/app/serializers.py#L514-L520
14:51:02 <daviddavis> dkliban: if we don't support write_only, I think the only practical way to change it is to break the serializer into two separate serializers
14:51:31 <dkliban> daviddavis: would we be duplicating code ?
14:52:07 <dkliban> i am torn between keeping thing DRY and not having to have special handling to write_only fields
14:53:09 <daviddavis> me too. we could have the write_only serializer extend the readonly serializer. it'd be a PITA for plugins though because they'd have to now setup their viewset to use two serializers.
14:53:34 <bmbouter> I am having difficulty follow all the aspects here on chat
14:53:55 <bmbouter> but if you all are then certainly let's continue
14:54:03 <daviddavis> I can set up a video meeting at 1?
14:54:08 <bmbouter> having a dedicated convo/call I believe would help
14:54:10 <bmbouter> +1
14:54:17 <dkliban> let's do it
14:54:22 <daviddavis> ok
14:54:51 <daviddavis> I'm going to do a little more research too
14:54:57 <fao89> definitely we need a meeting
14:54:59 <fao89> +1
14:55:12 <fao89> #endmeeting
14:55:12 <fao89> !end