#pulp-dev: Pulp Triage 2016-05-06

Meeting started by dkliban at 14:30:11 UTC (full logs).

Meeting summary

    1. dkliban has joined triage (dkliban, 14:30:11)
    2. ttereshc has joined triage (ttereshc, 14:30:20)
    3. bowlofeggs has joined triage (bowlofeggs, 14:30:25)
    4. preethi has joined triage (preethi, 14:30:28)
    5. smyers has joined triage (smyers, 14:30:32)
    6. ipanova has joined triage (ipanova, 14:30:34)
    7. jcline has joined triage (jcline, 14:30:39)

  1. No "unprotected/http" option available for ostree repos - http://pulp.plan.io/issues/1773 (dkliban, 14:31:22)
    1. pcreech has joined triage (pcreech, 14:32:05)
    2. IDEA: Proposed for #1773: Skip this issue for this triage session. (smyers, 14:32:19)
    3. AGREED: Skip this issue for this triage session. (dkliban, 14:32:37)

  2. Error searching rpm repositories by fields using dot notation - http://pulp.plan.io/issues/1865 (dkliban, 14:32:39)
    1. IDEA: Proposed for #1865: Priority: High, Severity: High (bowlofeggs, 14:34:25)
    2. IDEA: Proposed for #1865: Priority: High, Severity: High, Target Platform Release: 2.8.4 (smyers, 14:35:25)

  3. The Pulp Python bindings don't use requests and fail to retry - http://pulp.plan.io/issues/1866 (dkliban, 14:36:03)
    1. mhrivnak has joined triage (mhrivnak, 14:36:08)

  4. pulp-admin fails to display the erratum if not all metadata is present - http://pulp.plan.io/issues/1881 (dkliban, 14:38:41)
    1. IDEA: Proposed for #1881: Priority: Normal, Severity: High, Target Platform Release: 2.8.4 (smyers, 14:39:42)
    2. AGREED: Priority: Normal, Severity: High, Target Platform Release: 2.8.4 (dkliban, 14:40:46)

  5. As a user, I can sync and publish all package types - http://pulp.plan.io/issues/1883 (dkliban, 14:40:48)
    1. IDEA: Proposed for #1883: Leave the issue as-is, accepting its current state. (smyers, 14:41:26)

  6. Lazy integration - http://pulp.plan.io/issues/1884 (dkliban, 14:42:07)
    1. IDEA: Proposed for #1884: Leave the issue as-is, accepting its current state. (bowlofeggs, 14:42:15)
    2. IDEA: Proposed for #1884: Skip this issue for this triage session. (smyers, 14:43:25)
    3. AGREED: Skip this issue for this triage session. (dkliban, 14:43:32)

  7. Pulp uploads are failing with "too many open files" error - http://pulp.plan.io/issues/1885 (dkliban, 14:43:34)
    1. IDEA: Proposed for #1885: Priority: Normal, Severity: High, Target Platform Release: 2.8.4 (bowlofeggs, 14:43:48)
    2. IDEA: Proposed for #1885: Leave the issue as-is, accepting its current state. (ipanova, 14:45:11)
    3. ACTION: bmbouter Update #1885 to note that this might be an environmental problem, not a pulp-specific problem. (smyers, 14:46:27)
    4. ACTION: bmbouter ask for reproduction steps (bowlofeggs, 14:46:49)
    5. IDEA: Proposed for #1885: Skip this issue for this triage session. (bowlofeggs, 14:47:04)
    6. AGREED: Skip this issue for this triage session. (dkliban, 14:47:11)

  8. Removal of the unit fails if criteria contains unknown fields - http://pulp.plan.io/issues/1886 (dkliban, 14:47:13)
    1. IDEA: Proposed for #1886: Priority: Normal, Severity: Medium, Target Platform Release: 2.8.4 (bowlofeggs, 14:47:59)
    2. IDEA: Proposed for #1886: Priority: Normal, Severity: Medium (smyers, 14:49:28)
    3. AGREED: Priority: Normal, Severity: Medium (dkliban, 14:49:57)

  9. pulp-qpid-ssl-cfg echoes the NSS DB password - http://pulp.plan.io/issues/1890 (dkliban, 14:50:00)
    1. IDEA: Proposed for #1890: Priority: Normal, Severity: Medium, Target Platform Release: 2.8.4 (bowlofeggs, 14:51:28)
    2. IDEA: also add the easy fix tag (smyers, 14:51:44)
    3. AGREED: Priority: Normal, Severity: Medium, Target Platform Release: 2.8.4 (dkliban, 14:52:02)

  10. pulp_docker does not support Docker < 1.10 with manifests that were published from Docker >= 1.10 - http://pulp.plan.io/issues/1893 (dkliban, 14:52:04)
    1. ACTION: bowlofeggs add the easy tag (bowlofeggs, 14:52:04)
    2. IDEA: Proposed for #1893: Skip this issue for this triage session. (ipanova, 14:53:03)
    3. AGREED: Skip this issue for this triage session. (dkliban, 14:53:46)

  11. unassociate rpms API request using unit_ids removes all rpm from repo - http://pulp.plan.io/issues/1894 (dkliban, 14:53:48)
    1. IDEA: Proposed for #1894: Priority: High, Severity: High, Target Platform Release: 2.8.4 (smyers, 14:55:02)
    2. ACTION: pulp unbreak pulp (bowlofeggs, 14:55:41)
    3. IDEA: Proposed for #1894: Leave the issue as-is, accepting its current state. (bowlofeggs, 14:57:27)
    4. AGREED: Leave the issue as-is, accepting its current state. (dkliban, 14:57:32)

  12. Recursive RPM unit copies are not recursive - http://pulp.plan.io/issues/1895 (dkliban, 14:57:34)
    1. IDEA: Proposed for #1895: Priority: High, Severity: High, Target Platform Release: 2.8.4 (mhrivnak, 14:57:46)
    2. AGREED: Priority: High, Severity: High, Target Platform Release: 2.8.4 (dkliban, 14:58:44)

  13. catalog entries not created for pre-existing units - http://pulp.plan.io/issues/1897 (dkliban, 14:58:45)
    1. IDEA: Proposed for #1897: Priority: High, Severity: High, Target Platform Release: 2.8.4 (ipanova, 15:00:01)
    2. ACTION: jcline needs to paint a picture of the 404 devastation that occurs as a result of #1897 (smyers, 15:00:45)
    3. AGREED: Priority: High, Severity: High, Target Platform Release: 2.8.4 (dkliban, 15:01:29)

  14. Errata search does not filter packages that are not in repo - http://pulp.plan.io/issues/1898 (dkliban, 15:01:31)
    1. IDEA: Proposed for #1898: Priority: Normal, Severity: Medium (bowlofeggs, 15:03:01)
    2. AGREED: Priority: Normal, Severity: Medium (dkliban, 15:04:30)

  15. Repo sync failure with "time data '' does not match format '%Y-%m-%d %H:%M:%S'" - http://pulp.plan.io/issues/1899 (dkliban, 15:04:31)
    1. IDEA: Proposed for #1899: Skip this issue for this triage session. (smyers, 15:06:03)
    2. IDEA: Proposed for #1899: Close as NOTABUG (smyers, 15:07:23)
    3. IDEA: Proposed for #1899: keep it as a bad error message bug (bowlofeggs, 15:07:49)
    4. IDEA: Proposed for #1899: Close as NOTABUG, open a new issue to track the validation error (smyers, 15:08:27)
    5. IDEA: Proposed for #1899: Close as NOTABUG (ipanova, 15:13:07)
    6. IDEA: Proposed for #1899: Close as NOTABUG, open a new issue to track the validation error (bowlofeggs, 15:14:34)
    7. IDEA: Proposed for #1899: Leave the issue as-is, accepting its current state. (bowlofeggs, 15:15:16)
    8. IDEA: Proposed for #1899: Close as NOTABUG, open a new issue to track the validation error (bowlofeggs, 15:15:24)

  16. RFE: Please enable/support Redis as a celery broker transport in pulp - http://pulp.plan.io/issues/1900 (dkliban, 15:16:00)
    1. IDEA: resolution for #1899 should have been Close as NOTABUG, open a new issue to track the validation error (smyers, 15:16:41)
    2. IDEA: Proposed for #1900: Convert to task: Test pulp with redis as a kombu backend (smyers, 15:18:23)
    3. AGREED: Convert to task: Test pulp with redis as a kombu backend (dkliban, 15:18:39)

  17. Repo sync failure with "time data '' does not match format '%Y-%m-%d %H:%M:%S'" - http://pulp.plan.io/issues/1899 (dkliban, 15:20:26)
    1. IDEA: Proposed for #1899: Close as NOTABUG, open a new issue to track the validation error (smyers, 15:21:41)
    2. AGREED: Close as NOTABUG, open a new issue to track the validation error (dkliban, 15:36:34)


Meeting ended at 15:36:35 UTC (full logs).

Action items

  1. bmbouter Update #1885 to note that this might be an environmental problem, not a pulp-specific problem.
  2. bmbouter ask for reproduction steps
  3. bowlofeggs add the easy tag
  4. pulp unbreak pulp
  5. jcline needs to paint a picture of the 404 devastation that occurs as a result of #1897


Action items, by person

  1. bmbouter
    1. bmbouter Update #1885 to note that this might be an environmental problem, not a pulp-specific problem.
    2. bmbouter ask for reproduction steps
  2. bowlofeggs
    1. bowlofeggs add the easy tag
  3. jcline
    1. jcline needs to paint a picture of the 404 devastation that occurs as a result of #1897


People present (lines said)

  1. bowlofeggs (152)
  2. pulpbot (125)
  3. smyers (124)
  4. dkliban (90)
  5. mhrivnak (59)
  6. ipanova (37)
  7. ttereshc (35)
  8. jcline (29)
  9. bmbouter (11)
  10. preethi (9)
  11. jalbertson (9)
  12. pcreech (3)
  13. asmacdo (2)


Generated by MeetBot 0.1.4.